Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gdm und gimp lassen sich nicht bauen [solved]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
tazinblack
Veteran
Veteran


Joined: 23 Jan 2005
Posts: 1126
Location: Baden / Germany

PostPosted: Wed May 09, 2012 7:43 pm    Post subject: gdm und gimp lassen sich nicht bauen [solved] Reply with quote

Hallo zusammen,

ich hab hier was merkwürdiges.

Beim bauen von gdm:
Code:
(process:5481): GdkPixbuf-WARNING **: Bug! gdk-pixbuf loader 'png' didn't set an error on failure.
failed to load "./preferences-desktop-locale.png": Failed to load image './preferences-desktop-locale.png': reason not known, probably a corrupt image file
make[3]: *** [inlines.h] Fehler 1
make[3]: Leaving directory `/var/tmp/portage/gnome-base/gdm-2.20.11-r1/work/gdm-2.20.11/pixmaps/24x24'
make[2]: *** [all-recursive] Fehler 1
make[2]: Leaving directory `/var/tmp/portage/gnome-base/gdm-2.20.11-r1/work/gdm-2.20.11/pixmaps'
make[1]: *** [all-recursive] Fehler 1
make[1]: Leaving directory `/var/tmp/portage/gnome-base/gdm-2.20.11-r1/work/gdm-2.20.11'
make: *** [all] Fehler 2
 * ERROR: gnome-base/gdm-2.20.11-r1 failed (compile phase):
 *   emake failed


und gimp:
Code:
(process:17424): GdkPixbuf-WARNING **: Bug! gdk-pixbuf loader 'png' didn't set an error on failure.
failed to load "./cursor-bad.png": Failed to load image './cursor-bad.png': reason not known, probably a corrupt image file
make[2]: *** [gimp-tool-cursors.h] Fehler 1
make[2]: Leaving directory `/var/tmp/portage/media-gfx/gimp-2.6.12/work/gimp-2.6.12/cursors'
make[1]: *** [all-recursive] Fehler 1
make[1]: Leaving directory `/var/tmp/portage/media-gfx/gimp-2.6.12/work/gimp-2.6.12'
make: *** [all] Fehler 2
emake failed
 * ERROR: media-gfx/gimp-2.6.12 failed (compile phase):
 *   compile failure


Irgendwas verhindert das Laden von png Dateien?!?
Wenn ich die zwei distfiles lösche und er sie neu runterlädt passiert das Gleiche wieder.
Ich versuch mal die libpng neu zu bauen.

Irgend welche Ideen?
Wie immer sind jegliche Tipps willkommen!
_________________
Gruß / Regards
tazinblack
_______________________________________________________
what's the point in being grown up if you can't be childish sometimes


Last edited by tazinblack on Wed May 09, 2012 8:54 pm; edited 1 time in total
Back to top
View user's profile Send private message
tazinblack
Veteran
Veteran


Joined: 23 Jan 2005
Posts: 1126
Location: Baden / Germany

PostPosted: Wed May 09, 2012 8:07 pm    Post subject: Reply with quote

also die libpngs neu bauen bringt nix. Wenn ich auch noch ne alte /usr/lib64/libpng14.so.14 gefunden hab, welche ein revdep-rebuild --library '/usr/lib64/libpng14.so.14' mit anschließendem rm '/usr/lib64/libpng14.so.14' beseitigt hat.

Leider ändert das nix. Meine Gnome Schnellstarticons in der Leiste sind übrigens auch alle kaputt.
Was das wohl wieder ist?
_________________
Gruß / Regards
tazinblack
_______________________________________________________
what's the point in being grown up if you can't be childish sometimes
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3674
Location: Germany

PostPosted: Wed May 09, 2012 8:13 pm    Post subject: Reply with quote

War da vor Monaten nicht mal ne Gentoo News zum libpng15 Update, mit Hinweisen wie am besten vorzugehen ist?! (Wurde die eventuell übersehen/nicht beachtet)
Schau doch mal in deinen News
Back to top
View user's profile Send private message
tazinblack
Veteran
Veteran


Joined: 23 Jan 2005
Posts: 1126
Location: Baden / Germany

PostPosted: Wed May 09, 2012 8:18 pm    Post subject: Reply with quote

Bin ich eigentlich der Meinung dass ich das damals gemacht hab.

Ich schau mir das aber trotzdem nochmal an eben!
Danke für den Tipp!


Edit:

Das wars leider nicht.

Ein
Code:
find /usr/ -name '*.la' -exec grep png14 {} +
findet kein altes Zeugs.
Und
Code:
revdep-rebuild --library libpng14.so.14 -- --keep-going
läuft jetzt auch fehlerfrei durch.
_________________
Gruß / Regards
tazinblack
_______________________________________________________
what's the point in being grown up if you can't be childish sometimes
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6293

PostPosted: Wed May 09, 2012 8:35 pm    Post subject: Reply with quote

distfiles löschen und neu herunterladen bring nie etwas (außer, man erhielt Fehlermeldungen bzgl. der Checksummen von distfiles): Der Punkt von Checksummen ist ja, zu garantierne, dass man ein fehlerfreies File hat.

Zum eigentlichen Problem: Hilft es x11-libs/gdk-pixbuf neu zu bauen? Möglicherweise zusätzlich gtk+?
Back to top
View user's profile Send private message
tazinblack
Veteran
Veteran


Joined: 23 Jan 2005
Posts: 1126
Location: Baden / Germany

PostPosted: Wed May 09, 2012 8:44 pm    Post subject: Reply with quote

mv wrote:
distfiles löschen und neu herunterladen bring nie etwas (außer, man erhielt Fehlermeldungen bzgl. der Checksummen von distfiles): Der Punkt von Checksummen ist ja, zu garantierne, dass man ein fehlerfreies File hat.

Da hast Du natürlich recht, aber in der Not greift man nach jedem Strohhalm.

Quote:
Zum eigentlichen Problem: Hilft es x11-libs/gdk-pixbuf neu zu bauen? Möglicherweise zusätzlich gtk+?

Siehst Du, und deswegen bist Du advocate und wir nur normale User.
Neubau von x11-libs/gdk-pixbuf und gdm und gimp compilieren wieder.
Mal schauen, ob auch die Icons wieder da sind.

Danke!
_________________
Gruß / Regards
tazinblack
_______________________________________________________
what's the point in being grown up if you can't be childish sometimes
Back to top
View user's profile Send private message
tazinblack
Veteran
Veteran


Joined: 23 Jan 2005
Posts: 1126
Location: Baden / Germany

PostPosted: Wed May 09, 2012 8:54 pm    Post subject: Reply with quote

jap, das wars. Jetzt sind auch die Icons wieder da.

Danke für die schnelle Hilfe!
_________________
Gruß / Regards
tazinblack
_______________________________________________________
what's the point in being grown up if you can't be childish sometimes
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3674
Location: Germany

PostPosted: Wed May 09, 2012 8:59 pm    Post subject: Reply with quote

tazinblack wrote:
Neubau von x11-libs/gdk-pixbuf und gdm und gimp compilieren wieder.

Wenn ich mich nicht irre stand das doch auch in der libpng15 News? (ich hab die News leider aktuell nicht zur Hand)

Aus einem anderen Thread kopiert:
Quote:
2011-10-15-libpng15
Title Upgrade to libpng15
Author Samuli Suominen <ssuominen@gentoo.org>
Posted 2011-10-15
Revision 1

After upgrading from libpng14 to libpng15 it's important that you rebuild
cairo and gdk-pixbuf as soon as possible if they are installed.

Then you can proceed with rebuilding the rest of the software against the new
library:

# revdep-rebuild --library libpng14.so.14 -- --keep-going
Back to top
View user's profile Send private message
tazinblack
Veteran
Veteran


Joined: 23 Jan 2005
Posts: 1126
Location: Baden / Germany

PostPosted: Thu May 10, 2012 10:53 am    Post subject: Reply with quote

Der News Artikel war

Code:
2011-10-15-libpng15
  Title                     Upgrade to libpng15
  Author                    Samuli Suominen <ssuominen@gentoo.org>
  Posted                    2011-10-15
  Revision                  1

After upgrading from libpng14 to libpng15 it's important that you rebuild
cairo and gdk-pixbuf as soon as possible if they are installed.

Then you can proceed with rebuilding the rest of the software against the new
library:

# revdep-rebuild --library libpng14.so.14 -- --keep-going

Note: It might be necessary to run the previous command more than once.

If you find packages not building with the message "ld: cannot find -lpng14",
they are likely caused by broken libtool archives (.la) in your system.

You can identify those files with following one-liner:

# find /usr/ -name '*.la' -exec grep png14 {} +

Once you have identified the broken files, you can either delete them,
edit them in place and replace png14 with png15, or re-emerge the packages
they belong to.

More information and help is available at the following forum post:

http://forums.gentoo.org/viewtopic-t-894950.html


Im verlinikten Forenthread stand das auch nicht explizit drin.
Hätte ich gestern erahnt, dass das mit der Umstellung auf libpng15 vor nem halben Jahr zusammenhängt, hätte ich wohl auch eher danach gesucht.
Aber bisher lief mein System ja ohne erkennbare Mängel.
_________________
Gruß / Regards
tazinblack
_______________________________________________________
what's the point in being grown up if you can't be childish sometimes
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum