Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xorg startet einfach nicht mit Intel i865...
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
jschw
n00b
n00b


Joined: 13 Jul 2012
Posts: 3

PostPosted: Fri Jul 13, 2012 6:41 pm    Post subject: xorg startet einfach nicht mit Intel i865... Reply with quote

Hallo Leute,

ich bin gerade dabei, mich in Gentoo einzuarbeiten.
Die Installation des Basissystems und das Kompilieren des Kerbels mit genkernel hat auch einwandfrei geklappt.
Dann habe ich sorg-x11 installiert , als VIDEO_CARD habe ich "intel" angegeben. Ein
"X -configure" sagt
Code:
Number of created screens dös not match number of detected devices. Configuration failed.

Dann habe ich den Treiber "nv" hinzugefügt - das gleiche. Mit "vesa" flackerte der Bildschirm nach der Eingabe von startx kurz und es kam folgende Meldung:
Code:
waiting for X server to shut down error setting MTRR (base = 0xf0000000, size = 0x007d0000, type = 1 Invalid argument (22)
Server terminated successfully (0). Closing log file.


lspci -k sagt
Code:
00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)

Ein Kernelmodul ist nicht angegeben.

lsmod sagt aber, dass intel_agp, intel_gtt und agpgart geladen sind. Das System ist übrigens ein P4 mit (wie an der GPU zu erkennen ist) 865er-Chipsatz.

Dann habe ich versucht, hal und dbus zu installieren, da diese von xorg ja anscheinend benötigt werden(?), aber emerge findet "hal" nicht (?).
Wie mache ich jetzt weiter, ich gerade total ratlos, und das Buch, mit welchem ich arbeite hält die Installation von sorg viel zu knapp und ist vllt auch nicht mehr ganz aktuell...

Viele Grüße
Julian
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2050
Location: My own world! I and Gentoo!

PostPosted: Sat Jul 14, 2012 7:34 am    Post subject: Reply with quote

Du hast Recht, dein Buch ist leider längst nicht mehr aktuell, "hal" ist bereits seid über 1 Jahr rausgeworfen worden und durch udev ersetzt worden.
Siehe dazu auch am einfachsten das Online-Handbuch ---> http://www.gentoo.org/doc/en/handbook/handbook-amd64.xml

(Die englische Doku ist leider deutlich aktueller und auch schneller aktualisiert als die deutsche Fassung.)
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3674
Location: Germany

PostPosted: Sat Jul 14, 2012 9:37 am    Post subject: Reply with quote

Auch crossposting in mehreren Foren gleichzeitig ersetzt den Blick in die Gentoo Dokumentation nicht.
Nutze am besten http://www.gentoo.org/doc/en/list.xml?desc=1

Zur einrichtung von Xorg siehe zb im X Server Configuration HOWTO
Back to top
View user's profile Send private message
jschw
n00b
n00b


Joined: 13 Jul 2012
Posts: 3

PostPosted: Sat Jul 14, 2012 9:46 am    Post subject: Reply with quote

Vielen Dank für das Stichwort "udev".
Das Buch ist aus der Hochschulbibliothek und wohl leider für die Tonne (zumindest für einige Bereiche) - das Erscheinungsjahr ist 2008... :oops:

Mittlerweile bin ich auch etwas weitergekommen:
Ich habe unter VIDEO_CARDS nur noch "vesa" drin, und habe mesa und xorg-drivers neu kompiliert und einen emerge --autoclean durchgeführt. Danach lief "X -configure" durch, und ich konnte mit "X" den x-server starten, bzw. bekam ich einfach einen schwarzen Bildschirm. Das scheint laut Forenbeiträgen auch normal zu sein (?).

Jetzt kompiliert KDE im Moment, mal schauen, ob sich das starten lässt... ;)

Wie kann ich denn aussagekräftig testen, ob xorg jetzt mit Maus, Tastatur und allem drum und dran funktioniert? Ein schwarzer bzw. weißer Bildschirm ist ja nicht sonderlich hilfreich...

Sorry für das crossposting, ich hatte ja schon einen Blick in die Doku reingeworfen... evtl. habe ich auch vergessen, das Intel-Modul zu aktivieren, das werde ich wenn KDE durch ist noch nachholen!
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2050
Location: My own world! I and Gentoo!

PostPosted: Sat Jul 14, 2012 10:08 am    Post subject: Reply with quote

als root:
X -retro :1 &
DISPLAY=:1 xterm oder DISPLAY=:1 eterm oder DISPLAY=:1 konsole
oder DISPLAY=:1 vlc
oder DISPLAY=:1 mplayer /pfad/zu/datei/deiner/solange/es/ein/video/ist/datei

Such dir was aus ;)

Für deine Grafikkarte müsste auch irgendwo eine brauchbare Anleitung rumfliegen.
Evtl auch auf wiki.gentoo.org oder gentoo-wiki.com
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Sat Jul 14, 2012 10:40 am    Post subject: Re: xorg startet einfach nicht mit Intel i865... Reply with quote

jschw wrote:
"X -configure" sagt
Code:
Number of created screens dös not match number of detected devices. Configuration failed.

1) X -configure wirst du nicht brauchen. Einfach die Doku lesen
http://www.gentoo.org/doc/en/xorg-config.xml
dann klappt das out-of-the-box. (Hab ne intel HD 3000, unterscheidet sich aber in der Konfiguration überhaupt nicht von deiner).
2) Kommt der Output echt so? Also mit dem "dös" statt "does"? Wäre schon relativ ulkig :D
Back to top
View user's profile Send private message
jschw
n00b
n00b


Joined: 13 Jul 2012
Posts: 3

PostPosted: Sat Jul 14, 2012 1:22 pm    Post subject: Reply with quote

@Max Steel: Super, vielen Dank! :)
Es gibt viele Anleitungen, das stimmt! Nur sind alle, die ich finden konnte, so alt wie der Chipsatz und daher genauso hilfreich wie mein Buch von 2008. Zum Glück heißen wenigstens die betreffenden Kernel-Module anscheinend noch gleich und ich kann sie wenigstens zum Anpassen des Kernels verwenden - oder hat sich in dieser Zeit auch was Grundlegendes geändert???

@franzf: Nein, leider ist Gentoo nicht so lustig! :D
Ich hab's kurzerhand abgetippt, da ich auf der Konsole noch nicht fit genug bin, das von dort aus zu posten. Und die Rechtschreibkorrektur von OS X hat seltsamerweise "does" zu "dös" und "xorg" zu "sorg" gemacht.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3674
Location: Germany

PostPosted: Sat Jul 14, 2012 2:54 pm    Post subject: Reply with quote

jschw wrote:
Es gibt viele Anleitungen, das stimmt! Nur sind alle, die ich finden konnte, so alt wie der Chipsatz und daher genauso hilfreich wie mein Buch von 2008. Zum Glück heißen wenigstens die betreffenden Kernel-Module anscheinend noch gleich und ich kann sie wenigstens zum Anpassen des Kernels verwenden - oder hat sich in dieser Zeit auch was Grundlegendes geändert???

Naja, es ist unverständlich warum du nicht einfach die aktuelle Gentoo-Dokumentationen nutzt ;)
Im schon mehrfach erwähnten X Server Configuration HOWTO sollte doch alles notwendige zu finden sein - auch die für deinen Chipsatz nötigen Kernel Settings sind dort aufgelistet, desweiteren wie man Xorg einrichtet und auch deren Funktion testen kann.
Wenn es dann immer noch Unklarheiten gibt wird man dir hier sicherlich gern weiterhelfen.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum