Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
systemd-udevd used greatest stack depth
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
onevision
n00b
n00b


Joined: 06 Sep 2011
Posts: 32
Location: Draper, Utah

PostPosted: Wed Nov 13, 2013 9:09 pm    Post subject: systemd-udevd used greatest stack depth Reply with quote

I'm no stranger to Gentoo, and have happily been using it for over a decade. I recently installed a new machine for work, which went smooth enough. I accidentally enabled some packages that were Gnome 3.0, which cascaded a pile of dependencies, but corrected the problem and all was happy again. My machine was running just fine. I compiled a new kernel and when rebooting now I get the error:

[ 10.258837] systemd-udevd (1760) used greatest stack depth: 3672 bytest left

I do get a command line prompt to login and can login just fine. I run rc-status to see that every service is stopped. If I try to start a service it gives me the message:

* You are attempting to run an openrc service on a
* system which openrc did not boot.
...

I'm not entirely clear on all the details of systemd, but know that it was a new addition to this install. I know the problem however is not related to the new kernel, but rather some setting I have for the boot process, as I've tried booting from the old kernel and get the same response. I did follow the guide at http://wiki.gentoo.org/wiki/Systemd but i'm missing something somewhere. Not being entirely familiar with this area, I'm not sure where to even begin looking. Anyone have any tips or a bone you could chuck my way?
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1428

PostPosted: Wed Nov 13, 2013 9:33 pm    Post subject: Reply with quote

First of All, what init service would you like to run :?:
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
onevision
n00b
n00b


Joined: 06 Sep 2011
Posts: 32
Location: Draper, Utah

PostPosted: Thu Nov 14, 2013 4:59 pm    Post subject: Reply with quote

Well, at this point any service would be nice, although ultimately I need to get my xdm (gdm) running to get my desktop. As I mentioned though, when I do an 'rc-status --all' I can see that every service is stopped. Doesn't matter which one I pick, I can't get status, stop, or start any of them.

I know this has to be some simple configuration settings somewhere that is set wrong, but I just can't seem to find where that is or why. As it stands right now, I have the command prompt and can login. The directory structure all seems to be there, include everything in /dev and there is even the /run directory present and populated with directories (only udev and systemd seems to have anything though).

I believe the problem is related to something with either openrc, systemd, or udev - but I'm not just familiar enough with these areas to know which takes precedence or how well they play well with each other. When I do a revdep-rebuild everything comes out perfect and nothing is needed - same goes for emerge -uDv world, so I would assume that all the correct programs are present - just not being very happy playing with each other. Good thing too, since can't start the network service or anything else for that matter. Does that help clarify any? I'd be happy to provide any output for anything - I'm just a little lost on where to start with this.
Back to top
View user's profile Send private message
wuzzerd
Guru
Guru


Joined: 05 Jan 2005
Posts: 454
Location: New Mexico

PostPosted: Thu Nov 14, 2013 5:29 pm    Post subject: Reply with quote

onevision:

Gnome now needs systemd :( This is NOT gentoo's fault. There are many interesting flamewars going on about it.

Ok to start networking:

Code:

# systemctl enable dhcpcd.service
# systemctl start dhcpcd.service


for gdm:

Code:

#systemctl enable gdm.service
#systemctl  start   gdm.service


Both services should automatically start when you reboot.

Note: I'm not a systemd/gnome expert although I made a simple gentoo install without gnome to learn a bit about it.

Good Luck
Back to top
View user's profile Send private message
onevision
n00b
n00b


Joined: 06 Sep 2011
Posts: 32
Location: Draper, Utah

PostPosted: Thu Nov 14, 2013 8:35 pm    Post subject: Reply with quote

Interesting. Yeah I quickly browsed through a bit of the discord, which I don't blame Gentoo and honestly don't have a preference. I thought that I went through the wiki posting pretty well, but apparently not. I know I verified the correct kernel modules were set, as well as verified mtab was set with a symlink, and adjusted the /etc/default/grub setting as specified. I even did the following:

/usr/lib/systemd/systemd-localed &
/usr/lib/systemd/systemd-timedated &
/usr/lib/systemd/systemd-hostnamed &
hostnamectl set-hostname <HOSTNAME>
localectl set-locale LANG=<LOCALE>

but skipped:

localectl set-keymap <KEYMAP>
localectl set-x11-keymap <LAYOUT>
localectl set-x11-keymap <LAYOUT> <MODEL> <VARIANT> <OPTIONS>

As I wasn't entirely sure what that was set to, although I do know I'm using the Microsoft ergo 4000 keyboard.

So I did as you suggested, and the first one immediately brought up my network connection perfectly. I didn't seem to have gdm available, so enabled xdm (which should be pointing to gdm), which also worked. The wiki also mentioned a bunch of other services, which I believed were all set correctly, but apparently they may not have been. So am I correct in assuming that rc-status and rc-update are downgraded in favor of using systemctl? Also, I'm almost embarrassed to say this, but I seem to have locked myself in a corner. While xdm started, it won't let me login (I'm guessing authentication isn't working), but it's also the bare bones default, which I can't stop or get a terminal. I've tried alt+f keys to pop open a new display, but no luck. ctrl+alt+backspace to kill the x window didn't work either. The 3 finger salute is disabled, but doesn't matter anyway, since it starts up automatically now. I'm also assuming that I need to verify at least those default services and make sure they are active, but without a console that becomes impossible. Any trick for killing xdm so I can check on those other services?
Back to top
View user's profile Send private message
onevision
n00b
n00b


Joined: 06 Sep 2011
Posts: 32
Location: Draper, Utah

PostPosted: Thu Nov 14, 2013 8:44 pm    Post subject: Reply with quote

Scratch that - I got back to command line. I just booted from the install CD, mounted the root partition and then disabled xdm - then rebooted, which worked just fine. I'll verify the other services now and let you know where that leads me. Thanks so much for the help - with any luck, I'll be back in business in a bit.
Back to top
View user's profile Send private message
wuzzerd
Guru
Guru


Joined: 05 Jan 2005
Posts: 454
Location: New Mexico

PostPosted: Thu Nov 14, 2013 8:52 pm    Post subject: Reply with quote

If you use a rescue/livecd do:
Code:
rm /etc/systemd/system/display-manager.service

Then you should be able to reboot to a terminal.

Systemd seems to have symbolic links all over the place and propaganda for man pages. Googling the Arch forums will sometimes find a answer to a problem.
Back to top
View user's profile Send private message
onevision
n00b
n00b


Joined: 06 Sep 2011
Posts: 32
Location: Draper, Utah

PostPosted: Thu Nov 14, 2013 9:31 pm    Post subject: Reply with quote

Okay, so here's where I'm at. It looks like it was missing some of the key services on startup, which are starting now and I can see them successfully start during the boot sequence. I verified the key services as being active using 'systemctl status xxx.service', which showed it as being 'active' and 'loaded'. Still can't get the network interface to come up though. I can start the dhcpcd service, but it does not seem to be bringing up the interface - either that or it's setting it the same as the loopback (I have an 'lo' and a 'sit0' both set for 127.0.0.1). I also tried starting the NetworkManager service, and while that did start both the NIC and the wifi interfaces, it got set with an invalid IPv6. Not having the network interface up would explain the other services not coming up.

Here's the main problem though. If I start the xdm service, I'm taken to that same generic and non-functioning xsession login. I don't have a gdm service, so that's not an option. Any ideas on how I can get my x session to start correctly? I think I can figure out the rest if I could get to the desktop - which is really sad, considering I learned linux/unix on headless machines all from the command line. LOL Is it that it's just not picking up the config? Also, using this systemd method, does it still read config settings from /etc/conf.d? I did notice that I can't really start services using a call to /etc/init.d/xxx anymore, as that's apparently the method used by openrc, correct? And I assume rc-status and rc-update are also tied to openrc, correct? I should use systemctl moving forward then?
Back to top
View user's profile Send private message
onevision
n00b
n00b


Joined: 06 Sep 2011
Posts: 32
Location: Draper, Utah

PostPosted: Thu Nov 14, 2013 10:02 pm    Post subject: Reply with quote

Did explore into some interesting things, which that systemctl command is pretty handy. Played around with various calls that is capable of, like '--all' and 'list-unit-files' - among others. Everything seemed to look pretty good, so I decided to try the no brainer and just login as my user account and execute a 'startx', which surprisingly worked just fine. So that at least got me into the x desktop.

Still seem to be having some issues with establishing a network connection. It seems to think the ethernet cable is disconnected, which it isn't and I have the kernel module loaded for it. I try to start the wifi connection, and it says I don't have permissions, which I did previously - unless it's using a new group. Progress at any rate. 8-)
Back to top
View user's profile Send private message
onevision
n00b
n00b


Joined: 06 Sep 2011
Posts: 32
Location: Draper, Utah

PostPosted: Thu Nov 14, 2013 10:10 pm    Post subject: Reply with quote

Got the network service figured out. Looks like the dhcpcd and NetworkManager were fighting to see who was top dog. Any ideas on how to get the gdm windows manager working though? I'm not finding anything too obvious.
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1379

PostPosted: Thu Nov 14, 2013 10:16 pm    Post subject: Reply with quote

@onevision, to get one vision you have to answer yourself:
eyoung100 wrote:
First of All, what init service would you like to run :?:

Output of this shows your usage:
cat /proc/cmdline

If there isn't
init=/usr/lib/systemd/systemd (or init=/lib/systemd/systemd ?)
your are using openrc.
onevision wrote:
/usr/lib/systemd/systemd-localed &
/usr/lib/systemd/systemd-timedated &
/usr/lib/systemd/systemd-hostnamed &

Trying to use internal subcommands of systemd is not possible for you.
_________________
fun2gen2
Back to top
View user's profile Send private message
wuzzerd
Guru
Guru


Joined: 05 Jan 2005
Posts: 454
Location: New Mexico

PostPosted: Thu Nov 14, 2013 10:27 pm    Post subject: Reply with quote

Great you figured out a lot while I was buying groceries, lol. It should be as simple as
Code:
systemctl enable gdm.service
Back to top
View user's profile Send private message
wuzzerd
Guru
Guru


Joined: 05 Jan 2005
Posts: 454
Location: New Mexico

PostPosted: Thu Nov 14, 2013 10:31 pm    Post subject: Reply with quote

I'm not paying attention. You forgot to
Code:
emerge gdm
heh.
Back to top
View user's profile Send private message
onevision
n00b
n00b


Joined: 06 Sep 2011
Posts: 32
Location: Draper, Utah

PostPosted: Thu Nov 14, 2013 11:04 pm    Post subject: Reply with quote

The response to cat /proc/cmdline returns:

BOOT_IMAGE=/vmlinuz-3.10.17-gentoo root=/dev/sda3 ro init=/usr/lib/systemd/systemd

Which I assume this is why everything is now wanting systemd way of doing this, and I believe is the result of adding the line in /etc/default/grub of GRUB_CMDLINE_LINUX="init=/usr/lib/systemd/systemd" Does that sound right?

Actually, I had already had gdm installed and working perfectly before all this. I did check however just to make sure that I wasn't missing any compile flags or anything, and it's all still there. Also did an equery check on gdm just to make sure, which everything looked good - other than the custom.conf which I changed. If I do a systemctl status gdm.service it returns no such file or directory. Damn gremlins always stealing my files! At least everything seems to be working now - using startx anyway, so at least I have a paddle and boat. Any ideas on why gdm seems to be lost in the void? I'll try re-emerging it just to be certain.
Back to top
View user's profile Send private message
wuzzerd
Guru
Guru


Joined: 05 Jan 2005
Posts: 454
Location: New Mexico

PostPosted: Thu Nov 14, 2013 11:23 pm    Post subject: Reply with quote

Did you look in /usr/lib/systemd/system for gdm.service?
Back to top
View user's profile Send private message
onevision
n00b
n00b


Joined: 06 Sep 2011
Posts: 32
Location: Draper, Utah

PostPosted: Thu Nov 14, 2013 11:28 pm    Post subject: Reply with quote

There is also one other service that I'm having trouble with - but was having issues with it before all this. My sound card seems to be working fine - and did at one point (just before all this). Now it looks like it's working, but nothing comes out any of the output jacks. I've check volume control which looks good. The systemctl command won't let me do anything with alsa, so I'm not sure what to do with that?
Back to top
View user's profile Send private message
onevision
n00b
n00b


Joined: 06 Sep 2011
Posts: 32
Location: Draper, Utah

PostPosted: Thu Nov 14, 2013 11:29 pm    Post subject: Reply with quote

Yeah, it did not have the service listed in that directory. Do I need to manually add or link it?
Back to top
View user's profile Send private message
wuzzerd
Guru
Guru


Joined: 05 Jan 2005
Posts: 454
Location: New Mexico

PostPosted: Thu Nov 14, 2013 11:44 pm    Post subject: Reply with quote

No. It should be a service file which should look something like this:
Code:
[Unit]
Description=X-Window Display Manager
After=systemd-user-sessions.service

[Service]
ExecStart=/usr/bin/gdm -nodaemon

[Install]
Alias=display-manager.service


I think enabling it ( I'm getting a bit over my head here ) generates the link.

Stolen from Arch Wiki
Quote:
Loading the display manager

To enable graphical login, run your preferred Display Manager daemon (e.g. KDM). At the moment, service files exist for GDM, KDM, SLiM, XDM, LXDM, LightDM, and SDDM.

# systemctl enable kdm

This should work out of the box. If not, you might have a default.target set manually or from an older install:

# ls -l /etc/systemd/system/default.target

/etc/systemd/system/default.target -> /usr/lib/systemd/system/graphical.target

Simply delete the symlink and systemd will use its stock default.target (i.e. graphical.target).

# rm /etc/systemd/system/default.target

After enabling kdm a symlink "display-manager.service" should be set in /etc/systemd/system/

# ls -l /etc/systemd/system/display-manager.service

/etc/systemd/system/display-manager.service -> /usr/lib/systemd/system/kdm.service

Back to top
View user's profile Send private message
onevision
n00b
n00b


Joined: 06 Sep 2011
Posts: 32
Location: Draper, Utah

PostPosted: Thu Nov 14, 2013 11:58 pm    Post subject: Reply with quote

Hum, interesting. When I try to do that command to add it, this is the outcome

systemctl enable gdm
Failed to issue method call: No such file or directory

Checking things in the overall system however I did notice that it's not very happy with the display manager:

systemctl --all
...
display-manager.service error inactive dead display-manager.service

It would seem that I would need to create a manual symlink, although I'm just not sure on what I'm suppose to be linking it to exactly. LOL Which also sort of makes it harder to do. 8-) Still you've helped me learn miles upon miles with using systemd, so I can't thank you enough for all your help with this. Your the only reason why I'm actually able to get any work done right now. LOL It's greatly appreciated.
Back to top
View user's profile Send private message
wuzzerd
Guru
Guru


Joined: 05 Jan 2005
Posts: 454
Location: New Mexico

PostPosted: Fri Nov 15, 2013 12:14 am    Post subject: Reply with quote

onevision wrote:

It would seem that I would need to create a manual symlink, although I'm just not sure on what I'm suppose to be linking it to exactly. LOL Which also sort of makes it harder to do. 8-) Still you've helped me learn miles upon miles with using systemd, so I can't thank you enough for all your help with this. Your the only reason why I'm actually able to get any work done right now. LOL It's greatly appreciated.


You seem to going through a lot of the same stuff I did three weeks ago, this gives me an opportunity to try to remember what I did. Actually I started with an Arch install to see what a friend was talking about. Out of frustration I typed dhcpcd and networking started. It seems every simple thing you want to do takes a (umm) ton of work and about an hours worth of research. All we are trying to do here is:
Code:
#rc-update add net.eth0 default
#rc-update add gdm default
I'm sure glad I didn't try to install gnome. I hope you have a real important reason to want to install it.

I'm off for the night, keep plugging...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum