Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] no kernel compile, 32 v 64 bit problem?
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Tux's lil' helper
Tux's lil' helper

Joined: 04 May 2005
Posts: 146

PostPosted: Mon Mar 24, 2014 8:09 pm    Post subject: [SOLVED] no kernel compile, 32 v 64 bit problem? Reply with quote

hey good folks, when i try to compile my kernel i get an error indicating that the cpu i selected does not support x86-64 instruction sets... im a bit confused

here is emerge --info followed by my error

emerge --info
Portage 2.2.8-r1 (default/linux/x86/13.0/desktop/gnome/systemd, gcc-4.7.3, glibc-2.17, 3.6.8-gentoo i686)
System uname: Linux-3.6.8-gentoo-i686-Intel-R-_Core-TM-_i5_CPU_650_@_3.20GHz-with-gentoo-2.2
KiB Mem:     3596992 total,    829692 free
KiB Swap:     976892 total,    976892 free
Timestamp of tree: Sat, 22 Mar 2014 02:15:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
app-shells/bash:          4.2_p45
dev-lang/python:          2.7.5-r3, 3.3.3
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo
CFLAGS="-O2 -march=i686 -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /usr/share/polkit-1/actions /usr/share/themes/oxygen-gtk/gt
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned
sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -march=i686 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --tim
eout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac aalib acl acpi aim alsa ao apache2 audiofile bash-completion bcmath berkdb bluetooth branding bzip2 cairo calendar cdda cddb cdinstall cdparan
oia cdr cgi cli colord cracklib crypt cscope css ctype cups curl curlwrappers cvs cxx dbus debug dedicated directfb dri dts dvb dvd dvdr eds emboss encode ev
o examples exif expat fam fastcgi fbcon ffmpeg firefox flac fontconfig fortran ftp gcj gd gdbm geoip ggi gif gimp gnome gnome-keyring gnome-online-accounts g
nutils gpm gstreamer gtk gtkhtml gzip handbook hddtemp iconv icq imagemagick imap imlib introspection ipv6 jabber jack java javascript jbig jingle jit jpeg j
peg2k kerberos lame lash latex lcms ldap libcaca libedit libnotify libsecret libwww lm_sensors lzma lzo mad matroska mhash mime mms mng modules motif mp3 mp4
 mpeg mpi mplayer msn mtp nas nautilus ncurses networkmanager nls nntp nocd nptl offensive ogg openal openexr opengl openmp osc oscar oss pam pango pcre pdf
perl php plotutilspng png policykit portaudio ppds pulseaudio python qt3support qt4 quicktime raw rdesktop readline recode roby samba sdl session shorten sim
plexml slang slp smp sndfile snmp socialweb sockets socks5 sound source sox speex spell ssl startup-notification subversion svg svga symlink syslog systemd s
zip tcmalloc tcpd theora tidy tiff timidity tokenizer truetype udev udisks unicode upnp upnp-av upower usb v4l videos vim-syntax vorbis wavpack wayland win32
codecs wmf wxwidgets x264 x86 xattr xcb xine xinerama xml xv xvid yaz zlib" ABI_X86="32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci
emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="a
uthn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_gro
upfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers
 include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATUR
ES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog
" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore r
tcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz6
33 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice"
ETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel
 mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p
 iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

(CHROOT) Gentoo-20121221 linux # make && make modules_install
make[1]: Nothing to be done for `all'.
make[1]: Nothing to be done for `relocs'.
  CHK     include/generated/uapi/linux/version.h
  CHK     include/generated/utsrelease.h
  CALL    scripts/
  CC      scripts/mod/devicetable-offsets.s
  GEN     scripts/mod/devicetable-offsets.h
  HOSTCC  scripts/mod/file2alias.o
  HOSTLD  scripts/mod/modpost
  CHK     include/generated/compile.h
  AS      usr/initramfs_data.o
usr/initramfs_data.S:1:0: error: CPU you selected does not support x86-64 instruction set
make[1]: *** [usr/initramfs_data.o] Error 1
make: *** [usr] Error 2

much thanks!

Last edited by nosenseofhumor1 on Mon Mar 24, 2014 8:34 pm; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 23 Jul 2004
Posts: 8418
Location: ~Brussels - Belgique

PostPosted: Mon Mar 24, 2014 8:17 pm    Post subject: Reply with quote


Emerge --info shows you are running a 32 bits environment. You won't be able to build any 64 bit executable there, except with cross-compiliation.

I suggest you to restart a fresh install, using a correct amd64 stage, your i5 will be more useful :)
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 04 May 2005
Posts: 146

PostPosted: Mon Mar 24, 2014 8:34 pm    Post subject: Reply with quote


Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum