Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ls /lib/modules/'uname -r' /kernel/drivers/net
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Pinonoir
n00b
n00b


Joined: 12 May 2014
Posts: 4

PostPosted: Wed May 21, 2014 2:40 pm    Post subject: ls /lib/modules/'uname -r' /kernel/drivers/net Reply with quote

No such file or directory
Back to top
View user's profile Send private message
aCOSwt
Bodhisattva
Bodhisattva


Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Wed May 21, 2014 2:53 pm    Post subject: Reply with quote

typo problems everywhere... pino(t)noir ? :wink:

As you posted your command, it appears that you used the Apostrophe ' (ASCII 0x27) for surrounding uname -r.
The correct syntax is to use a Backquote `(AltGr 7 on an azerty keyboard) ASCII 0x60

Moreover there should be no space between the closing backquote and the following /

So, in extenso your command should be
Code:
ls /lib/modules/`uname -r`/kernel/drivers/net


And last... you might legally get no drivers directory if you did not build anything as modules, and no net directory if you did not build any net driver as module when making your kernel.
_________________
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 703

PostPosted: Wed May 21, 2014 6:53 pm    Post subject: Reply with quote

aCOSwt wrote:
typo problems everywhere... pino(t)noir ? :wink:

As you posted your command, it appears that you used the Apostrophe ' (ASCII 0x27) for surrounding uname -r.
The correct syntax is to use a Backquote `(AltGr 7 on an azerty keyboard) ASCII 0x60

Moreover there should be no space between the closing backquote and the following /

So, in extenso your command should be
Code:
ls /lib/modules/`uname -r`/kernel/drivers/net


And last... you might legally get no drivers directory if you did not build anything as modules, and no net directory if you did not build any net driver as module when making your kernel.


or
Code:
# ls /lib/modules/$(uname -r)/kernel/drivers/net


Code:
ls /lib/modules/$(uname -r)/kernel/drivers/net
fddi  hippi  macvlan.ko  phy  plip  ppp  sb1000.ko  slip  tun.ko  veth.ko  wan

_________________
BOINC ed il calcolo distribuito

My LiveRecoverySystem Repo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum