Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Cannot mount ntfs volume
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Aixile
n00b
n00b


Joined: 05 Jul 2014
Posts: 6

PostPosted: Sat Jul 05, 2014 3:43 am    Post subject: [Solved] Cannot mount ntfs volume Reply with quote

I have installed my gentoo dual boot with windows.
i found that i cannot mount other volumes on the same disk.

(sda3 sda4 ,they are ntfs volumes)
when i try to mount them manually
Code:

Mount is denied because the NTFS volume is already exclusively opened.
The volume may be already mounted, or another software may use it which
could be identified for example by the help of the 'fuser' command.


"mount" shows they have been already mounted on boot
Code:

mount
rootfs on / type rootfs (rw)
/dev/sda6 on / type btrfs (rw,noatime,ssd,discard,space_cache)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
tmpfs on /run type tmpfs (rw,nosuid,nodev,relatime,size=1218820k,mode=755)
udev on /dev type devtmpfs (rw,nosuid,relatime,size=10240k,nr_inodes=1523034,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
cgroup_root on /sys/fs/cgroup type tmpfs (rw,nosuid,nodev,noexec,relatime,size=10240k,mode=755)
openrc on /sys/fs/cgroup/openrc type cgroup (rw,nosuid,nodev,noexec,relatime,release_agent=/lib64/rc/sh/cgroup-release-agent.sh,name=openrc)
cpu on /sys/fs/cgroup/cpu type cgroup (rw,nosuid,nodev,noexec,relatime,cpu)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,nodev,noexec,nosuid)
/dev/sda4 on /run/media/root/ã¾ãã type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)
/dev/sda3 on /run/media/root/ã·ã¹ãã ãã type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)


but i cannot visit them,and when i try to unmount them
Code:

umount -f /dev/sda3
umount: /run/media/root/ã·ã¹ãã ãã: not found


1.the volume label name ã·ã¹ãã ãã was wrong encoding of japanese volume label ,
but the strange thing was even i changed the sda3 label into other ascii charactors on windows ,
the error information was remain unchanged , still shows ã·ã¹ãã ãã

2."mount" and "df -kh" shows sda6 is mounted, but my pc doesn't have sda6...and there are only sda5 in my fstab
Code:
# <fs>                  <mountpoint>    <type>          <opts>          <dump/pass>

/dev/sda5       /       btrfs   noatime,discard 0       0       


Code:

ls /dev/sda*
/dev/sda  /dev/sda1  /dev/sda2  /dev/sda3  /dev/sda4  /dev/sda5

Code:

df -kh
df: '/sys/fs/cgroup/openrc': No such file or directory
df: '/run/media/root/\343\201\276\343\201\230\343\202\201': No such file or directory
df: '/run/media/root/\343\202\267\343\202\271\343\203\206\343\203\240\343\201\237\343\202\223': No such file or directory
Filesystem      Size  Used Avail Use% Mounted on
/dev/sda6        37G  9.8G   27G  28% /
tmpfs           5.9G  796K  5.9G   1% /run
udev            5.9G     0  5.9G   0% /dev
cgroup_root     5.9G     0  5.9G   0% /sys/fs/cgroup


i tried recompiling kernel but nothing works, so i think may be i should reinstall some other things.
(my gentoo use systemd)

Thanks!


Last edited by Aixile on Mon Jul 07, 2014 12:29 am; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43985
Location: 56N 3W

PostPosted: Sat Jul 05, 2014 9:09 am    Post subject: Reply with quote

Aixile,

Welcome to Gentoo.

Mount shows you do indeed have a /dev/sda6
Code:
mount
rootfs on / type rootfs (rw)
/dev/sda6 on / type btrfs (rw,noatime,ssd,discard,space_cache)
...


It can exist and be mounted without appearing in /dev as your boot loader setup will contain the entry (real_)root=/dev/sda6.
root is special. The kernel has to moult it before it can read /etc/fstab, since that file is on the root partition.
As /dev/sda6 is missing from /dev, rootfsck cannot have run, so everything will be read only.


mount:
...
/dev/sda4 on /run/media/root/ã¾ãã type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)
/dev/sda3 on /run/media/root/ã·ã¹ãã ãã type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)
...


The filesystem type there should be ntfs, if you use the in kernel ntfs read only driver, or ntfs3g if you use the FUSE based read/write driver.
This implies that your /ect/fstab is incorrect. You may have ntfs-3g missing too.

Please post the output of
Code:
fdisk -l
It sdould show your sda6 and the content of /etc/fstab

Oh root on btrfs is still experimental. When it breaks you may loose you install.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Aixile
n00b
n00b


Joined: 05 Jul 2014
Posts: 6

PostPosted: Sat Jul 05, 2014 11:24 am    Post subject: Reply with quote

Hi NeddySeagoon,

Code:
Disk /dev/sda: 238.5 GiB, 256060514304 bytes, 500118192 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 78CA0451-B780-4023-A562-97A9229A89FA

Device           Start          End   Size Type
/dev/sda1         2048       206847   100M EFI System
/dev/sda2       206848       468991   128M Microsoft reserved
/dev/sda3       468992    254355455 121.1G Microsoft basic data
/dev/sda4    254357504    423825407  80.8G Microsoft basic data
/dev/sda5    423827456    500117503  36.4G Microsoft basic data


fdisk also shows there is no sda6. the true root file system is sda5
I use rEFInd as boot loader, and I dont think I have specified root=/dev/sda6 in refind.conf
(Actually i didn't write any boot configurations , all was done by rEFInd automaticly)
the only thing I did was adding
Code:

root=/dev/sda5 rootfstype=btrfs init=/usr/lib/systemd/systemd net.ifnames=0

to the built-in kernel command line.

I don't have any problems about root file system writing, I can use this system as there is no problems

I use ntfs3g to read ntfs , and there is noting wrong with my ntfs driver, i'm able to mount and read/write ntfs volume on another hard disk sdb.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43985
Location: 56N 3W

PostPosted: Sat Jul 05, 2014 11:31 am    Post subject: Reply with quote

Aixile,

Something has mounted sda3 and sda5 as type fuseblk
Code:
/dev/sda4 on /run/media/root/ã¾ãã type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)
/dev/sda3 on /run/media/root/ã·ã¹ãã ãã type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)

That looks to be wrong as it suggests that ntfs3g is not in use.

What does fstab say?
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Aixile
n00b
n00b


Joined: 05 Jul 2014
Posts: 6

PostPosted: Sat Jul 05, 2014 2:01 pm    Post subject: Reply with quote

NeddySeagoon wrote:
Aixile,

Something has mounted sda3 and sda5 as type fuseblk
Code:
/dev/sda4 on /run/media/root/ã¾ãã type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)
/dev/sda3 on /run/media/root/ã·ã¹ãã ãã type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)

That looks to be wrong as it suggests that ntfs3g is not in use.

What does fstab say?


Code:
cat /etc/fstab
# /etc/fstab: static file system information.
#
# noatime turns off atimes for increased performance (atimes normally aren't
# needed); notail increases performance of ReiserFS (at the expense of storage
# efficiency).  It's safe to drop the noatime options if you want and to
# switch between notail / tail freely.
#
# The root filesystem should have a pass number of either 0 or 1.
# All other filesystems should have a pass number of 0 or greater than 1.
#
# See the manpage fstab(5) for more information.
#

# <fs>                  <mountpoint>    <type>          <opts>          <da;lump/pass>

/dev/sda5       /       btrfs   noatime,discard 0       0

That's all.
There is no sda4 option in fstab, but the system always try to mount it on boot automatically
Back to top
View user's profile Send private message
i4dnf
Apprentice
Apprentice


Joined: 18 Sep 2005
Posts: 266
Location: Bucharest, Romania

PostPosted: Sat Jul 05, 2014 4:22 pm    Post subject: Reply with quote

NeddySeagoon wrote:
Aixile,

Something has mounted sda3 and sda5 as type fuseblk
Code:
/dev/sda4 on /run/media/root/ã¾ãã type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)
/dev/sda3 on /run/media/root/ã·ã¹ãã ãã type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)

That looks to be wrong as it suggests that ntfs3g is not in use.

What does fstab say?


That's how ntfs mounts via ntfs3g look here too (I suppose due to ntfs3g relying on fuse). That mount path and the options suggest udisks trying to (auto)mount those partitions.
Try
Code:

udisksctl info -b /dev/sda4
or
udisksctl info -b /dev/sda3
 

to see what udisks makes of them.
_________________
"The only difference between me and a madman is that I am not MAD" (SALVATOR DALI)
Back to top
View user's profile Send private message
Aixile
n00b
n00b


Joined: 05 Jul 2014
Posts: 6

PostPosted: Sat Jul 05, 2014 9:11 pm    Post subject: Reply with quote

i4dnf wrote:
NeddySeagoon wrote:
Aixile,

Something has mounted sda3 and sda5 as type fuseblk
Code:
/dev/sda4 on /run/media/root/ã¾ãã type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)
/dev/sda3 on /run/media/root/ã·ã¹ãã ãã type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)

That looks to be wrong as it suggests that ntfs3g is not in use.

What does fstab say?


That's how ntfs mounts via ntfs3g look here too (I suppose due to ntfs3g relying on fuse). That mount path and the options suggest udisks trying to (auto)mount those partitions.
Try
Code:

udisksctl info -b /dev/sda4
or
udisksctl info -b /dev/sda3
 

to see what udisks makes of them.


Code:
udisksctl info -b /dev/sda3
/org/freedesktop/UDisks2/block_devices/sda3:
  org.freedesktop.UDisks2.Block:
    Configuration:              []
    CryptoBackingDevice:        '/'
    Device:                     /dev/sda3
    DeviceNumber:               2051
    Drive:                      '/org/freedesktop/UDisks2/drives/PLEXTOR_PX_256M5Pro_P02352102439'
    HintAuto:                   false
    HintIconName:               
    HintIgnore:                 false
    HintName:                   
    HintPartitionable:          true
    HintSymbolicIconName:       
    HintSystem:                 true
    Id:                         by-id-ata-PLEXTOR_PX-256M5Pro_P02352102439-part3
    IdLabel:                    System
    IdType:                     ntfs-3g
    IdUUID:                     7C6E73DE6E738F9E
    IdUsage:                    filesystem
    IdVersion:                 
    MDRaid:                     '/'
    MDRaidMember:               '/'
    PreferredDevice:            /dev/sda3
    ReadOnly:                   false
    Size:                       129989869568
    Symlinks:                   /dev/disk/by-id/ata-PLEXTOR_PX-256M5Pro_P02352102439-part3
                                /dev/disk/by-id/wwn-0x500230310011d717-part3
                                /dev/disk/by-label/System
                                /dev/disk/by-partlabel/Basic\x20data\x20partition
                                /dev/disk/by-partuuid/1f6ce2a4-dbf5-49f4-bedd-a6304d06d880
                                /dev/disk/by-uuid/7C6E73DE6E738F9E
  org.freedesktop.UDisks2.Filesystem:
    MountPoints:       
  org.freedesktop.UDisks2.Partition:
    Flags:              0
    IsContained:        false
    IsContainer:        false
    Name:               Basic data partition
    Number:             3
    Offset:             240123904
    Size:               129989869568
    Table:              '/org/freedesktop/UDisks2/block_devices/sda'
    Type:               ebd0a0a2-b9e5-4433-87c0-68b6b72699c7
    UUID:               1f6ce2a4-dbf5-49f4-bedd-a6304d06d880


when i try to mount/unmount it with udiskctl
Code:
udisksctl mount -b /dev/sda3
Error mounting /dev/sda3: GDBus.Error:org.freedesktop.UDisks2.Error.Failed: Error mounting /dev/sda3 at /run/media/root/System: Command-line `mount -t "ntfs-3g" -o "uhelper=udisks2,nodev,nosuid" "/dev/sda3" "/run/media/root/System"' exited with non-zero exit status 16: Mount is denied because the NTFS volume is already exclusively opened.
The volume may be already mounted, or another software may use it which
could be identified for example by the help of the 'fuser' command.

Code:
udisksctl unmount -b /dev/sda3
Error unmounting /dev/sda3: GDBus.Error:org.freedesktop.UDisks2.Error.NotMounted: Device `/dev/sda3' is not mounted
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43985
Location: 56N 3W

PostPosted: Sun Jul 06, 2014 9:04 am    Post subject: Reply with quote

Aixile,

Add entries to fstab for your NTFS volumes, then auto mounting should leave them alone.

I've never used an auto mounter, going back to the days when DVD+RW at 4.7G was a good thing to use for random access as long as you knew it was anly good for about 1000 +rw mounts.
Anyway, I digress.

The fstab entries are intended for debug only. Automounting is supposed to work.
I have a feeling that root may have access. The problem being that *NIX permissions do not map to NTFS permissions.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Aixile
n00b
n00b


Joined: 05 Jul 2014
Posts: 6

PostPosted: Sun Jul 06, 2014 3:18 pm    Post subject: Reply with quote

NeddySeagoon wrote:
Aixile,

Add entries to fstab for your NTFS volumes, then auto mounting should leave them alone.

I've never used an auto mounter, going back to the days when DVD+RW at 4.7G was a good thing to use for random access as long as you knew it was anly good for about 1000 +rw mounts.
Anyway, I digress.

The fstab entries are intended for debug only. Automounting is supposed to work.
I have a feeling that root may have access. The problem being that *NIX permissions do not map to NTFS permissions.


then i tried adding
Code:

/dev/sda3      /mnt/sda3       ntfs-3g defaults        0       0

to fstab,
but the system failed to mount sda3 on boot and forced me to enter emergency mode.

here is my journalctl log
http://paste.ubuntu.com/7756033/
Back to top
View user's profile Send private message
Aixile
n00b
n00b


Joined: 05 Jul 2014
Posts: 6

PostPosted: Mon Jul 07, 2014 12:10 am    Post subject: Reply with quote

Aixile wrote:
NeddySeagoon wrote:
Aixile,

Add entries to fstab for your NTFS volumes, then auto mounting should leave them alone.

I've never used an auto mounter, going back to the days when DVD+RW at 4.7G was a good thing to use for random access as long as you knew it was anly good for about 1000 +rw mounts.
Anyway, I digress.

The fstab entries are intended for debug only. Automounting is supposed to work.
I have a feeling that root may have access. The problem being that *NIX permissions do not map to NTFS permissions.


then i tried adding
Code:

/dev/sda3      /mnt/sda3       ntfs-3g defaults        0       0

to fstab,
but the system failed to mount sda3 on boot and forced me to enter emergency mode.

here is my journalctl log
http://paste.ubuntu.com/7756033/



I read my journalctl log again and find
Code:

Jul 06 23:53:19 geotia systemd[1]: /etc/mtab is not a symlink or not pointing to /proc/self/mounts. This is not supported anymore. Please make sure to replace this file by a symlink to avoid incorrect or misleading mount(8) output.

then I examined my /etc/mtab and found it was
Code:

rootfs on / type rootfs (rw)
/dev/sda6 on / type btrfs (rw,noatime,ssd,discard,space_cache)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
tmpfs on /run type tmpfs (rw,nosuid,nodev,relatime,size=1218820k,mode=755)
udev on /dev type devtmpfs (rw,nosuid,relatime,size=10240k,nr_inodes=1523034,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
cgroup_root on /sys/fs/cgroup type tmpfs (rw,nosuid,nodev,noexec,relatime,size=10240k,mode=755)
openrc on /sys/fs/cgroup/openrc type cgroup (rw,nosuid,nodev,noexec,relatime,release_agent=/lib64/rc/sh/cgroup-release-agent.sh,name=openrc)
cpu on /sys/fs/cgroup/cpu type cgroup (rw,nosuid,nodev,noexec,relatime,cpu)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,nodev,noexec,nosuid)
/dev/sda4 on /run/media/root/ã¾ãã type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)
/dev/sda3 on /run/media/root/ã·ã¹ãã ãã type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)


just like my mount output.
and my mtab was not a symlink as metioned above in warning, then i deleted it and make it pointing to /proc/self/mounts.
everything works again !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum