Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] Maus geht nach update nicht mehr
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
rogge
Tux's lil' helper
Tux's lil' helper


Joined: 13 Oct 2006
Posts: 98
Location: Erfurt

PostPosted: Wed Jul 16, 2014 1:19 pm    Post subject: [gelöst] Maus geht nach update nicht mehr Reply with quote

Hallo zusammen,

ich habe gestern Abend ein emerge -uDN durchlaufen lassen
und heute, nach dem Shutdown/Neustart, geht die Maus nicht mehr,
weder in der Konsole (gpm) noch unter X.

lsusb zeigt die Maus nach wie vor an. Sie ist auch unter /dev/bus/input und
/dev/input/mice zu finden. Jedoch nicht unter /proc/bus/input/devices, dort ist
nur die Tastatur zu finden (die geht überall).
Wenn ich mir unter XFCE die Mauskonfiguration ansehe, fehlen die Devices, die man
konfigurieren könnte.

Ich habe keinerlei Änderungen an irgendwelchen Configs nach dem Update vorge-
nommen, waren auch nicht verlangt. Die Suche im Netz blieb erfolglos und ein
Downgrade auf udev-212 hat auch nichts gebracht.

Hat irgendjemand eine Idee?


Beste Grüße, rogge


Last edited by rogge on Sun Aug 24, 2014 10:16 am; edited 1 time in total
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Wed Jul 16, 2014 1:49 pm    Post subject: Reply with quote

Gab es ein xorg-server update? Wurden danach die xorg-drivers neu gebaut? Also z.B. xf86-input-mouse oder xf86-input-evdev, jenachdem was du verwendest.
Back to top
View user's profile Send private message
rogge
Tux's lil' helper
Tux's lil' helper


Joined: 13 Oct 2006
Posts: 98
Location: Erfurt

PostPosted: Wed Jul 16, 2014 6:50 pm    Post subject: Reply with quote

Nicht, dass ich mich erinnern könnte. Es gab auf jeden Fall ein
Update von gpm und udev. Den xf86-input-evdev hatte ich aber
auch schon sicherheitshalber neucompiliert.


Grüße, rogge
Back to top
View user's profile Send private message
rogge
Tux's lil' helper
Tux's lil' helper


Joined: 13 Oct 2006
Posts: 98
Location: Erfurt

PostPosted: Thu Jul 17, 2014 9:32 am    Post subject: Reply with quote

Ich habe gestern noch folgendes probiert:

- downgrade relevant erscheinender Pakte (kmod, acl, gpm), alles ohne Erfolg
(in der /var/log/emerge.log lies sich zurückverfolgen, was aktualisiert wurde)

- via einer udev-rule einen symlink der Maus von /dev/bus/usb/008/002 nach /dev/input/mouse0 bzw. /dev/input/event%n
auch ohne Erfolg.


Beste Grüße, rogge
Back to top
View user's profile Send private message
oliver2104
Apprentice
Apprentice


Joined: 27 Jul 2004
Posts: 207
Location: Wien

PostPosted: Fri Jul 18, 2014 12:47 pm    Post subject: Reply with quote

Habe keine Ahnung was dein Update angestellt hat.
Würde das aber so angehen:
Schau zuerst mal ob deine aktuelle Kernelkonfiguration die Maus auch unterstützt.
z.b. die Option:
Code:

Device Drivers ---> Input device support ---> <*> Mouse interface
                                              [*]  Provide legacy /dev/psaux   (kann nicht schaden)
                                              <*> Event Interface
                                              [*]  Mice   ---> hier deine Maus auswählen zb. <*> PS\Mouse

dann schau noch nach:
File Systems ---> Pseudo filesystems, ob proc files system support aktiviert ist

USB Unterstützung muss natürlich auch aktiviert werden.

Kernel Konfiguration speichern und compilieren.
Noch schnell schauen ob die /etc/fstab die Zeile:
Code:

proc         /proc                proc        defaults                     0 0

enthält, dann den neuen Kernel booten.
Back to top
View user's profile Send private message
Jean-Paul
Apprentice
Apprentice


Joined: 13 Apr 2009
Posts: 269

PostPosted: Fri Jul 18, 2014 2:01 pm    Post subject: Reply with quote

oliver2104 wrote:

Noch schnell schauen ob die /etc/fstab die Zeile:
Code:

proc         /proc                proc        defaults                     0 0

enthält, dann den neuen Kernel booten.
Dieser Eintrag ist seit mind. 2011 nicht mehr nötig. Das macht udev von selbst. Die Mausunterstützung im Kernel is drin, sonst hätte er die Einträge in /dev nicht.

@rogge, hast du schon mal eine andere Maus angeschlossen (Kabelbruch) ? Und steht in der Xorg.0.log etwas interessantes ?
_________________
”Everything should be made as simple as possible, but no simpler.” – Albert Einstein
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1379

PostPosted: Sun Jul 20, 2014 8:05 am    Post subject: Reply with quote

xorg-server-1.16.0
braucht vielleicht
x11-drivers/xf86-input-evdev-2.9.0
_________________
fun2gen2
Back to top
View user's profile Send private message
rogge
Tux's lil' helper
Tux's lil' helper


Joined: 13 Oct 2006
Posts: 98
Location: Erfurt

PostPosted: Sun Aug 24, 2014 10:15 am    Post subject: Reply with quote

Danke für die Hilfe und entschuldigt die späte Reaktion.

Nachdem ich jetzt aus dem Urlaub kam, hab ich natürlich noch mal
ein Update durchlaufen lassen. Die Maus ging immernoch nicht. Vor
dem Urlaub hab ich auch eine andere ausprobiert, um eben eine
physischen Defekt ausschließen zu können; den USB-Port hab ich
auch gewechselt, brachte alles nichts.
Sie funktionierte allerdings nach der Aktualisierung des Kernels!
Vorher lief der 3.10.17 und da muss es wohl irgendeinen Konflikt
mit dem damaligen Update gegeben haben. Jetzt mit dem 3.14.14
läuft sie wieder :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum