Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
udev and CONFIG_FHANDLE (SOLVED)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
kdvgent
Guru
Guru


Joined: 29 Sep 2004
Posts: 333
Location: Belgium

PostPosted: Thu Aug 21, 2014 6:45 pm    Post subject: udev and CONFIG_FHANDLE (SOLVED) Reply with quote

Doing a regular update of the packages on my computer, I noticed that udev now wants CONFIG_FHANDLE=y. Looking to the udev upgrade page on the wiki, this is already the case for some time.

So I checked my kernel configuration, saw that CONFIG_FHANDLE=n for my kernel.

Updating the kernel to CONFIG_HANDLE=y and rebooting into the new kernel resulted in my computer no longer finding my keyboard - rather annoying. I use reFind as a boot loader and at that moment I can use the keyboard but once the kernel has come up and the init script have run - no keyboard. udev is at version 216 and my kernel is at version 3.15.10 (gentoo-sources). The system is ~amd64.

Going back to CONFIG_HANDLE=n solves the problem.

I do not understand. Can somebody help? Should I raise a bug (against udev?)?


Last edited by kdvgent on Fri Aug 22, 2014 9:41 am; edited 1 time in total
Back to top
View user's profile Send private message
gerard27
Advocate
Advocate


Joined: 04 Jan 2004
Posts: 2377
Location: Netherlands

PostPosted: Thu Aug 21, 2014 7:23 pm    Post subject: Reply with quote

I'm running ~amd64 too but CONFIG_FHANDLE is enabled,no problem of any kind.
By the way I'm using eudev,don't know if that makes a difference.
Gerard.
_________________
To install Gentoo I use sysrescuecd.Based on Gentoo,has firefox to browse Gentoo docs and mc to browse (and edit) files.
The same disk can be used for 32 and 64 bit installs.
You can follow the Handbook verbatim.
http://www.sysresccd.org/Download
Back to top
View user's profile Send private message
kdvgent
Guru
Guru


Joined: 29 Sep 2004
Posts: 333
Location: Belgium

PostPosted: Thu Aug 21, 2014 8:23 pm    Post subject: eudev vs udev Reply with quote

I would assume changing udev for eudev makes a difference.

Unmerging udev and replacing it by eudev anyhow did not solve the problem - and made me loose my network (I assume the rules sets are not fully compatible).

So I will go back to CONFIG_FHANDLE=n as my system has worked for weeks OK with that (and with recent versions of udev).

But I would like to understand.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13975

PostPosted: Fri Aug 22, 2014 1:32 am    Post subject: Reply with quote

Are you sure that enabling CONFIG_FHANDLE was the only thing you changed? What kind of keyboard is this? What kernel driver handles your keyboard in the working kernel?
Back to top
View user's profile Send private message
kdvgent
Guru
Guru


Joined: 29 Sep 2004
Posts: 333
Location: Belgium

PostPosted: Fri Aug 22, 2014 6:13 am    Post subject: What changed? Reply with quote

I did a large update (monthly update of KDE) but in the kernel configuration, CONFIG_FHANDLE is the only change. Starting with the kernel where CONFIG_FHANDLE=y results in a non working keyboard, starting with the kernel where CONFIG_FHANDLE=n results in a working keyboard. The kernel version is the same so I would assume that there are no changes in the kernel build scripts neither.

Later today, I will build a new kernel with CONFIG_HANDLE=n and check that one so that I am 100% sure that both kernels are build in exactly the same environment.
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1699

PostPosted: Fri Aug 22, 2014 6:57 am    Post subject: Reply with quote

Well, I will mention that I"m also been running ~amd64 on my machines. I'm using udev and checked my configs for all of the kernels I have used (and still have a copy of). Sadly, I only have from 3.15.0-r1 through 3.15.7 for kernels built for my machine. They all have CONFIG_FHANDLE=y set and I haven't encountered any issues on any of them. My system has XFCE instead of KDE, but that shouldn't have any affect on that part. Here's a copy of my config for 3.15.0-r1 that I used. Maybe you'll see something that I have that you don't. Do note, I don't have anything fancy really set in for keyboard input, just the generic support (That I've used for over 10 years). Just in case, here's my use flags for udev.

Code:

[ebuild     U  ] sys-fs/udev-216 [215-r1] USE="acl firmware-loader gudev introspection kmod -doc (-selinux) -static-libs" ABI_X86="(64) -32 (-x32)"


http://pastebin.com/xV66yLLG

Note: My typical update schedule is weekly, on either Saturday or Sunday. However, I have no problem updating earlier upon request. I have no problem risking on breaking my machine, as it just gives me something to do. :) The only thing I usually don't do, is update my kernel too often (don't see much reason to do so, considering how frequent there's a new revision out).
Back to top
View user's profile Send private message
kdvgent
Guru
Guru


Joined: 29 Sep 2004
Posts: 333
Location: Belgium

PostPosted: Fri Aug 22, 2014 9:41 am    Post subject: Proble; solved Reply with quote

ct85711, hu

Thank you very much, you put me on the path to solve my problem.

First I saw that your version of udev (215-r1) is different from mine (216). So I masked version 216 but this was not the solution.

So I did a three way comparison between ct85711's kernel config file, my newest config file and the config file of the most recent working kernel. I then saw that in my newest kernel config file, most special HID device handlers were not set (including HID_MICROSOFT - and I have a Microsoft keyboard). Why? Reconstructing how I did set the FHANDLE, I remembered that I did not find this configuration setting when looking to the General Settings under "make menuconfig". I then saw an EXPERT setting and thought that this maybe would give extra options and indeed, I did found the FHANDLE setting afterwards. Little could I know that this EXPERT setting changed many other settings in my config file, especially the ones about HID device handlers.

So I started again with my latest working kernel config, looked better to the General Setting and found the FHANDLE setting without having set the EXPERT setting. So I did set CONFIG_FHANDLE, checked if the HID device settings were still OK, build a new kernel and voila, problem solved.

Stupid me.

Again, thanks for the help.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum