Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge @preserved-rebuild und dev-lang/ruby:1.8" [solved]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Linubie
Apprentice
Apprentice


Joined: 11 Jun 2004
Posts: 268

PostPosted: Wed Aug 20, 2014 2:52 pm    Post subject: emerge @preserved-rebuild und dev-lang/ruby:1.8" [solv Reply with quote

Moin.

portage bittet mich um ein emerge @preserved-rebuild und meldet dann:

emerge: there are no ebuilds to satisfy "dev-lang/ruby:1.8"


allerdings ist nur eine andere version vorhanden

eix -s ruby


dev-lang/ruby
Available versions:
(1.9) 1.9.3_p484 ~1.9.3_p545 ~1.9.3_p547
(2.0) 2.0.0_p353 ~2.0.0_p481
(2.1) ~2.1.2
{berkdb debug doc examples gdbm ipv6 ncurses +rdoc +readline rubytests socks5 ssl tk xemacs +yaml}
Installed versions: 1.8.7_p374(1.8)(04:34:09 26.11.2013)(berkdb gdbm ipv6 ncurses readline ssl threads -debug -doc -examples -libedit -rubytests -socks5 -tk -xemacs) 1.9.3_p484(1.9)(22:20:42 15.12.2013)(berkdb gdbm ipv6 ncurses rdoc readline ssl yaml -debug -doc -examples -rubytests -socks5 -tk -xemacs) 2.0.0_p353(2.0)(09:03:45 20.08.2014)(berkdb gdbm ipv6 ncurses rdoc readline ssl -debug -doc -examples -rubytests -socks5 -tk -xemacs)
Homepage: http://www.ruby-lang.org/
Description: An object-oriented scripting language


emerge schlägt mir eine andere version vor:

Calculating dependencies... done!
[ebuild R ] dev-lang/ruby-2.0.0_p353:2.0 USE="berkdb gdbm ipv6 ncurses rdoc readline ssl -debug -doc -examples -rubytests -socks5 -tk -xemacs" 0 kB


wie kann ich herausfinden von welchem paket die ruby version benötigt wird, oder wie kann ich das rebuild dazu bringen die vorhanden aktuelle version zu nehmen?


danke
_________________
Mircosoft software is like having sex with a stranger, you always have to be careful not to get infected with something...


Last edited by Linubie on Wed Aug 20, 2014 6:46 pm; edited 1 time in total
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1186

PostPosted: Wed Aug 20, 2014 3:05 pm    Post subject: Reply with quote

das kannst du mit equery (gehört zu gentoolkit) machen:
Code:
equery d dev-lang/ruby:1.8
Back to top
View user's profile Send private message
Linubie
Apprentice
Apprentice


Joined: 11 Jun 2004
Posts: 268

PostPosted: Wed Aug 20, 2014 6:47 pm    Post subject: Reply with quote

Vielen Dank für den Tip, läuft wieder alles wie gewohnt!
_________________
Mircosoft software is like having sex with a stranger, you always have to be careful not to get infected with something...
Back to top
View user's profile Send private message
michael_w
Guru
Guru


Joined: 22 Feb 2006
Posts: 426
Location: 09xxx

PostPosted: Sat Aug 23, 2014 7:37 am    Post subject: Reply with quote

Hallo,

Linubie wrote:
Vielen Dank für den Tip, läuft wieder alles wie gewohnt!


ich stelle mich offenbar etwas doof an, wie hast Du das gelöst?
_________________
Linux ryzen 4.19.57-gentoo #1 SMP Fri Jul 26 10:40:54 CEST 2019 x86_64 AMD Ryzen 7 1800X Eight-Core Processor AuthenticAMD GNU/Linux
Back to top
View user's profile Send private message
Linubie
Apprentice
Apprentice


Joined: 11 Jun 2004
Posts: 268

PostPosted: Sat Aug 23, 2014 3:21 pm    Post subject: Reply with quote

also, wenn ich mich recht erinnere habe ich mit

Code:
equery d dev-lang/ruby:1.8


geguckt welche pakete damit zusammenhängen.

dann habe ich die Version 1.8 gelöscht

Code:
emerge -C dev-lang/ruby:1.8


habe die standard ruby version gesetzt

eselect ruby list
Available Ruby profiles:
[1] ruby19 (with Rubygems) *
[2] ruby20 (with Rubygems)

nun weiß ich nicht mehr so recht

danach habe ich versucht die einzelnen paktet zu compilieren, bei mir waren es glaube ich

emerge libcaca rubygems thin-provisioning-tools -C
emerge libcaca rubygems thin-provisioning-tools -av

und danach einen der folgenden Befehle, oder auch alle 3 führten dann zum Erolg:
Code:


emerge -avuDN --with-bdeps=y @world
emerge @preserved-rebuild
emerge --newuse --deep world -av

_________________
Mircosoft software is like having sex with a stranger, you always have to be careful not to get infected with something...
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3709
Location: Germany

PostPosted: Sat Aug 23, 2014 3:48 pm    Post subject: Reply with quote

Schaut dazu auch in der News die es einst dazu gab :)
/usr/portage/metadata/news/2014-03-16-ruby-1.8-removal/2014-03-16-ruby-1.8-removal.en.txt wrote:
Title: Ruby 1.8 removal; Ruby 1.9/2.0 default
Author: Manuel Rüger <mrueg@gentoo.org>
Content-Type: text/plain
Posted: 2014-03-16
Revision: 1
News-Item-Format: 1.0
Display-If-Installed: dev-lang/ruby

Ruby MRI 1.8 has been retired by upstream in June 2013.[1]
We remove Ruby MRI 1.8 support from the tree now. In parallel Ruby MRI 2.0
support will be activated in base profile's RUBY_TARGETS variable by default
in conjunction with Ruby MRI 1.9.

If your currently eselected Ruby interpreter is ruby18, our recommendation is
to change it to ruby19. At the moment Ruby MRI 1.9 delivers the best possible
support of all Ruby interpreters in tree.

Check the current setting via:

eselect ruby show

Change the current setting to Ruby MRI 1.9 via:

eselect ruby set ruby19

[1] https://www.ruby-lang.org/en/news/2013/06/30/we-retire-1-8-7/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum