Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
World update: Help in understanding which packages to mask
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
muadib25
Tux's lil' helper
Tux's lil' helper


Joined: 08 Aug 2010
Posts: 144
Location: Sweden

PostPosted: Sun Sep 21, 2014 7:46 pm    Post subject: World update: Help in understanding which packages to mask Reply with quote

Hello!

It has been a while since I updated my Desktop/Audio Workstation Gentoo box, and I don't know how to solve this right now. I try to:
Code:
emerge --update --deep --with-bdeps=y --newuse @world

and I get this: http://pastebin.com/Cv0Rd3Rr

Here is my make.conf:
Code:
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.

#ACCEPT_KEYWORDS="~amd64"
CFLAGS="-march=core2 -O2 -pipe"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j5"

# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"

# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="icu xine openal networking sse3 vim-syntax dbus consolekit python threads aalib httpd bluray cpude$

VIDEO_CARDS="nvidia"
ALSA_CARDS="hdsp hdspm"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
#SYNC=rsync://ftp.df.lth.se/pub/gentoo/
PORT_LOGDIR=/var/log/portage/
#ACCEPT_LICENSE="AdobeFlash-10.1 AdobeFlash-11.x"
#ACCEPT_LICENSE="skype-4.0.0.7-copyright"
#ACCEPT_LICENSE="skype-eula"
ACCEPT_LICENSE="dev-java/sun-jdk-1.6.0.37 Oracle-BCLA-JavaSE"
source /var/lib/layman/make.conf
PORTDIR_OVERLAY="/root/overlays/rt-nvidia"
PORTDIR_OVERLAY="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
PORTAGE_ELOG_SYSTEM="save"
PORTAGE_ELOG_CLASSES="warn error info log qa"
PYTHON_SINGLE_TARGET="python2_7 python3_2" ## python3_3"
PYTHON_TARGETS="python2_7 python3_3"

# Set PORTDIR for backward compatibility with various tools:
#   gentoo-bashcomp - bug #478444
#   euse - bug #474574
#   euses and ufed - bug #478318
PORTDIR="/usr/portage"

#GENTOO_MIRRORS="rsync://trumpetti.atm.tut.fi/gentoo/ http://ftp.df.lth.se/pub/gentoo/ rsync://ftp.df.l$
#GENTOO_MIRRORS="rsync://ftp.df.lth.se/pub/gentoo/ ftp://ftp.df.lth.se/pub/gentoo/ rsync://ftp.snt.utwe$



I am pretty lost in semantics at the last bulk of lines portage returns, I mean I don't understand what I need to do when I get this:
Code:
media-libs/libmng:0

  (media-libs/libmng-2.0.2-r1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-libs/libmng-1.0.10-r1::gentoo, installed) pulled in by
    >=media-libs/libmng-1.0.9:0/0= required by (dev-qt/qtgui-4.8.5-r3::gentoo, installed)
Is it the 'libmng-2.0.2-r1' package I have to mask?? Or??

Thank you for your help!
K.
_________________
“What we do for ourselves dies with us. What we do for others and the world remains and is immortal.” -Albert Pine
Back to top
View user's profile Send private message
tryn
Guru
Guru


Joined: 21 Dec 2002
Posts: 320
Location: 39.885° N. -88.913° W.

PostPosted: Sun Sep 21, 2014 9:10 pm    Post subject: Reply with quote

muadib25

Looks like you need to take care of this item. It says that you need a newer gnome-base/gdm then the one that you have.

Quote:
[blocks B ] <gnome-base/gdm-3.8 ("<gnome-base/gdm-3.8" is blocking gnome-base/gsettings-desktop-schemas-3.12.2)


Try upgrading it first with
Code:
emerge -1up gnome-base/gdm

See what it says and if it looks good remove the ( p ) and do it.

Then try the update for the world and see if it removes the problems for you.
Back to top
View user's profile Send private message
muadib25
Tux's lil' helper
Tux's lil' helper


Joined: 08 Aug 2010
Posts: 144
Location: Sweden

PostPosted: Sun Sep 21, 2014 9:35 pm    Post subject: Reply with quote

Hey Tryn! :)

The gdm packages above 3.0 are masked on my system, the reason being that I didn't want to upgrade to Gnome 3.0.

Here is my package.mask file:
Code:
# Atoms that makes me miserable :)

=x11-libs/fltk-2.0_pre6970
=dev-libs/boost-1.42.0-r2
=net-irc/xchat-gnome-0.26.1-r2
=dev-games/physfs-2.0.2-r1
=dev-qt/qtscript-4.8.2-r9999
media-libs/lv2core
=app-pda/libimobiledevice-1.1.4-r4
=media-sound/ardour-3.3-r1
=app-emulation/emul-linux-x86-baselibs-20131008-r2
=app-emulation/emul-linux-x86-baselibs-20131008
=app-emulation/wine-1.7.4
=app-emulation/wine-1.7.3
##=dev-qt/qtcore-4.8.4-r5
##=dev-qt/qt3support-4.8.5
##=dev-qt/qtgui-4.8.5-r1
##=dev-qt/designer-4.8.5
##=net-p2p/retroshare-0.5.5b

##GNOME 3.8 block
>=dev-libs/libgweather-3.0
>=gnome-base/libgnomekbd-3.0
=media-libs/libcanberra-0.28-r4
# Core Applications
>=app-accessibility/orca-3.0
>=gnome-base/gdm-3.0
>=gnome-base/gnome-applets-3.0
>=gnome-base/gnome-keyring-3.0
>=gnome-base/gnome-menus-3.0
>=gnome-base/gnome-panel-3.0
>=gnome-base/gnome-session-3.0
>=gnome-base/gnome-settings-daemon-3.0
>=gnome-base/gnome-control-center-3.0
>=gnome-base/gnome-shell-3.0
>=gnome-base/libgnome-keyring-3.0
>=gnome-base/nautilus-3.0
>=x11-wm/metacity-2.34
>=x11-wm/mutter-3.0
# Extra Applications
>=app-arch/file-roller-3.0
>=app-cdr/brasero-3.0
>=app-crypt/seahorse-3.0
>=app-editors/gedit-3.0
>=app-editors/gedit-plugins-3.0
>=app-text/gtranslator-2.90
>=app-text/evince-3.0
>=dev-util/anjuta-3.0
>=app-pda/gtkpod-2.1.0
>=dev-util/devhelp-3.0
>=gnome-extra/drwright-3.0
>=gnome-extra/evolution-data-server-3.0
>=gnome-extra/evolution-exchange-3.0
>=gnome-extra/gcalctool-6.0
>=gnome-extra/gconf-editor-3.0
>=gnome-extra/gnome-color-manager-3.0
>=gnome-extra/gnome-games-3.0
>=gnome-extra/gnome-games-extra-data-3.0
>=gnome-extra/gnome-media-2.32.0-r300
>=gnome-extra/gnome-packagekit-3.0
>=gnome-extra/gnome-power-manager-3.0
>=gnome-extra/gnome-screensaver-3.0
>=gnome-extra/gnome-system-monitor-3.0
>=gnome-extra/gnome-tweak-tool-3.0
>=gnome-extra/gnome-user-share-3.0
>=gnome-extra/gnome-utils-3.0
#>=gnome-extra/gucharmap-3.0
>=gnome-extra/mousetweaks-3.0
>=gnome-extra/nautilus-sendto-3.0
gnome-extra/office-runner
>=gnome-extra/zenity-3.0
>=mail-client/evolution-3.0
>=media-gfx/eog-3.0
>=media-sound/rhythmbox-2.90
>=media-sound/sound-juicer-2.99
>=media-video/cheese-3.0
##>=media-video/totem-3.0
>=net-analyzer/gnome-nettool-3.0
>=net-im/empathy-3.0
>=net-misc/vinagre-3.0
>=net-misc/vino-3.0
>=net-wireless/gnome-bluetooth-3.0
>=sys-apps/gnome-disk-utility-3.0.2-r300
>=www-client/epiphany-3.0
>=www-client/epiphany-extensions-3.0
>=x11-terms/gnome-terminal-3.0
# Documentation
>=gnome-extra/yelp-3.0
>=dev-util/gnome-devel-docs-3.0
>=gnome-extra/gnome-user-docs-3.0
# NetworkManager
>=net-misc/networkmanager-0.8.99
>=net-misc/networkmanager-pptp-0.8.99
>=net-misc/networkmanager-openconnect-0.8.99
>=net-misc/networkmanager-openvpn-0.8.99
>=net-misc/networkmanager-openswan-0.8.99
>=net-misc/networkmanager-vpnc-0.8.99
>=gnome-extra/nm-applet-0.8.99
# Meta packages
>=gnome-base/gnome-core-apps-3.0
>=gnome-base/gnome-extra-apps-3.0
>=gnome-base/gnome-core-libs-3.0
>=gnome-base/gnome-fallback-3.0
>=gnome-base/gnome-light-3.0
>=gnome-base/gnome-3.0
# Misc applications
>=gnome-extra/nautilus-open-terminal-0.19
>=app-mobilephone/gnome-phone-manager-0.67
>=app-accessibility/caribou-0.4
app-admin/eselect-gnome-shell-extensions
>=app-misc/tracker-0.12
>=dev-libs/folks-0.6
>=dev-libs/libgdata-0.9
>=dev-python/pyatspi-2.2
>=gnome-base/gconf-3.2
>=gnome-extra/at-spi-2.2
gnome-extra/gnome-contacts
gnome-extra/gnome-documents
gnome-extra/gnome-shell-extensions
>=gnome-extra/nautilus-tracker-tags-0.12
gnome-extra/sushi
##>=media-libs/clutter-1.7
##>=media-libs/cogl-1.7
>=net-libs/gnome-online-accounts-3
>=x11-libs/libcryptui-3
>=x11-misc/alacarte-0.13.2-r50
>=app-accessibility/accerciser-3.2
#=app-admin/system-config-printer-common-1.4.3
>gnome-extra/sensors-applet-2.99
=gnome-base/gsettings-desktop-schemas-3.10.1

=gnome-base/gvfs-1.18.3
##>=media-video/totem-2.32.0
##=media-libs/cogl-1.16.2
##=media-video/totem-3.10.1

##=net-libs/webkit-gtk-2.2.6-r200
=net-libs/webkit-gtk-2.2.6-r200
=net-libs/opal-3.10.10
=media-video/x264-encoder-0.0.20111220

=net-im/skype-4.3.0.37
>=gnome-base/gnome-control-center-3.12.1-r1
>=net-libs/gnome-online-accounts-3.12.4
>=dev-libs/libgdata-0.14.3
>=media-plugins/grilo-plugins-0.2.12
>=media-video/totem-3.12.1

... which as I noticed now is a bit messy form previous adjustments... :oops:

I dont really know how gdm popped up in this upgrade, since it's masked.
_________________
“What we do for ourselves dies with us. What we do for others and the world remains and is immortal.” -Albert Pine
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44519
Location: 56N 3W

PostPosted: Sun Sep 21, 2014 9:44 pm    Post subject: Reply with quote

muadib25,

Try
Code:
emerge --update --deep --with-bdeps=y --newuse --ask --verbose @system
first.

Code:
emerge -uDNav --with-bdeps=y @system
is less typing.

You are going to get a perl update to 5.18, so you must run perl-cleaner after the above completes.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 3402
Location: Illinois, USA

PostPosted: Sun Sep 21, 2014 10:44 pm    Post subject: Reply with quote

Quote:
The gdm packages above 3.0 are masked on my system, the reason being that I didn't want to upgrade to Gnome 3.0.


Bite the bullet and move to Mate. Trying to keep Gnome 2.x is only going to get worse.
Back to top
View user's profile Send private message
tryn
Guru
Guru


Joined: 21 Dec 2002
Posts: 320
Location: 39.885° N. -88.913° W.

PostPosted: Mon Sep 22, 2014 1:46 am    Post subject: Reply with quote

muadib25

Sorry about that. I had forgot about the Gnome thing since I don't have Gnome.

I'm glad that I don't have to mess with it. My package.mask only has 4 things in it.
Back to top
View user's profile Send private message
muadib25
Tux's lil' helper
Tux's lil' helper


Joined: 08 Aug 2010
Posts: 144
Location: Sweden

PostPosted: Mon Sep 22, 2014 5:42 pm    Post subject: Reply with quote

I see. How do I uninstall it then?
_________________
“What we do for ourselves dies with us. What we do for others and the world remains and is immortal.” -Albert Pine
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 3402
Location: Illinois, USA

PostPosted: Mon Sep 22, 2014 9:06 pm    Post subject: Reply with quote

So you are running gdm without Gnome. I'd replace gdm. Which desktop are you running?
Back to top
View user's profile Send private message
muadib25
Tux's lil' helper
Tux's lil' helper


Joined: 08 Aug 2010
Posts: 144
Location: Sweden

PostPosted: Tue Sep 23, 2014 6:56 pm    Post subject: Reply with quote

Tony0945 wrote:
So you are running gdm without Gnome. I'd replace gdm. Which desktop are you running?


One moment, I have Gnome 2.x, which I use. I also have fluxbox.
_________________
“What we do for ourselves dies with us. What we do for others and the world remains and is immortal.” -Albert Pine
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 752
Location: S.O. France

PostPosted: Tue Sep 23, 2014 7:21 pm    Post subject: Reply with quote

In your package.mask
Try replacing
Code:
=gnome-base/gsettings-desktop-schemas-3.10.1

by
Code:
>=gnome-base/gsettings-desktop-schemas-3.10.1
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 3402
Location: Illinois, USA

PostPosted: Tue Sep 23, 2014 10:32 pm    Post subject: Reply with quote

If you don't need remote login, I recommend SLiM, http://wiki.gentoo.org/wiki/SLiM. That will give you the chance to choose your desktop at each login.

Personally, I've gone back to vanilla XDM as I run only Mate now and sometimes do remote login with XDMCP.

If you search the forum, you will find several threads on converting to Mate with masks posted. I participated in several of those threads, but on the final machine that I converted, I just removed all the gnome use flags, changed profile from Gnome to plain Desktop (very important), emerge'd -C anything from gnome, --depclean, then unmasked and emerge'd Mate which brought several things back. I don't know if I can really recommend that approach, but it was simple. If you have a lot of customization in Gnome, I'd look for more expert advice than mine.
Back to top
View user's profile Send private message
muadib25
Tux's lil' helper
Tux's lil' helper


Joined: 08 Aug 2010
Posts: 144
Location: Sweden

PostPosted: Wed Sep 24, 2014 5:39 pm    Post subject: Reply with quote

sebB wrote:
In your package.mask
Try replacing
Code:
=gnome-base/gsettings-desktop-schemas-3.10.1

by
Code:
>=gnome-base/gsettings-desktop-schemas-3.10.1


SebB, I think this was it.
With '# emerge --update --deep --with-bdeps=y --newuse @world -p' I get lots of packages for update and in the end this:

Code:
[ebuild     U  ] dev-cpp/libgnomecanvasmm-2.26.0-r1 [2.26.0]
[ebuild   R    ] net-libs/gtk-vnc-0.5.3  PYTHON_TARGETS="(-python2_6%)"
[ebuild     U  ] dev-python/gnome-python-extras-base-2.25.3-r1 [2.25.3]
[ebuild   R    ] x11-libs/vte-0.28.2-r206  PYTHON_TARGETS="(-python2_6%)"
[ebuild   R    ] gnome-extra/hamster-applet-2.32.1-r1  PYTHON_SINGLE_TARGET="(-python2_6%)" PYTHON_TARGETS="(-python2_6%)"
[ebuild   R    ] gnome-base/gconf-2.32.4-r1
[ebuild     U  ] sys-fs/udisks-1.0.5-r1 [1.0.5]
[ebuild     U  ] gnome-base/gnome-vfs-2.24.4-r2 [2.24.4-r1] ABI_X86="(64%*) (-32) (-x32)"
[ebuild   R    ] gnome-base/gnome-desktop-2.32.1-r2  PYTHON_TARGETS="(-python2_6%)"
[ebuild     U  ] media-plugins/gst-plugins-gconf-0.10.31-r1 [0.10.31] ABI_X86="(64%*) (-32) (-x32)"
[ebuild   R    ] app-misc/emelfm2-0.8.1  USE="udisks%* (-udev%*)"
[ebuild     U  ] app-office/libreoffice-4.2.6.3 [4.2.5.2] PYTHON_TARGETS="python3_3*"
[ebuild     U  ] x11-libs/libgksu-2.0.12-r2 [2.0.12-r1]
[ebuild   R    ] media-gfx/inkscape-0.48.4-r1  PYTHON_SINGLE_TARGET="(-python2_6%)" PYTHON_TARGETS="(-python2_6%)"
[ebuild     UD ] media-video/totem-2.32.0-r2 [3.10.1] USE="bluetooth%* youtube%* -iplayer% (-tracker) -upnp-av%"
[ebuild     U ~] media-video/vlc-2.1.5 [2.1.4]
[ebuild   R    ] net-libs/telepathy-glib-0.24.0  PYTHON_TARGETS="(-python2_6%)"
[ebuild  N     ] app-pda/libusbmuxd-1.0.9  USE="-static-libs"
[uninstall     ] app-pda/usbmuxd-1.0.8-r1
[blocks b      ] <app-pda/usbmuxd-1.0.8_p1 ("<app-pda/usbmuxd-1.0.8_p1" is blocking app-pda/libusbmuxd-1.0.9)
[ebuild     U  ] app-pda/libimobiledevice-1.1.6 [1.1.5] USE="-static-libs%" PYTHON_TARGETS="python3_3%* (-python3_2)"
[ebuild  rR    ] sys-power/upower-pm-utils-0.9.23-r2
[ebuild  rR    ] app-pda/ideviceinstaller-1.0.1
[ebuild     U  ] app-pda/ifuse-1.1.3 [1.1.2-r1]
[ebuild     U  ] kde-base/kdelibs-4.12.5-r2 [4.12.5-r1]
[ebuild     U  ] net-im/telepathy-mission-control-5.16.2 [5.14.1] USE="-systemd%"

The following packages are causing rebuilds:

  (media-libs/libmng-2.0.2-r1::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (dev-qt/qtgui-4.8.5-r3::gentoo, ebuild scheduled for merge)
  (dev-lang/perl-5.18.2-r1::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (dev-perl/WWW-RobotRules-6.20.0::gentoo, ebuild scheduled for merge)
    (dev-perl/IO-Socket-SSL-1.953.0::gentoo, ebuild scheduled for merge)
    (dev-perl/libwww-perl-6.50.0::gentoo, ebuild scheduled for merge)
    (perl-core/Digest-SHA-5.820.0::gentoo, ebuild scheduled for merge)
    (dev-perl/Net-SSLeay-1.550::gentoo, ebuild scheduled for merge)
    (dev-perl/HTTP-Cookies-6.0.1-r1::gentoo, ebuild scheduled for merge)
    (dev-perl/Net-HTTP-6.60.0::gentoo, ebuild scheduled for merge)
    (dev-perl/HTTP-Negotiate-6.0.1-r1::gentoo, ebuild scheduled for merge)
    (dev-perl/Error-0.170.210::gentoo, ebuild scheduled for merge)
  (app-pda/libplist-1.11::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (sys-power/upower-pm-utils-0.9.23-r2::gentoo, ebuild scheduled for merge)
    (app-pda/ideviceinstaller-1.0.1::gentoo, ebuild scheduled for merge)

!!! The following installed packages are masked:
- net-im/skype-4.3.0.37::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


 * IMPORTANT: 10 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


I'll let it update tomorrow before I go to work and let you all know.

Tony0945, yeah SliM was cool but I remember I had a problem with it back then when I was setting up this box. I also have the Desktop profile, didnt want it to be Gnome-specific.
I remember I had some problems in getting Fluxbox to work with locale changes (keyboard in other langs) that got me into GNOME again. Regardless of what happens with GNOME tomorrow, I am going to fix this for Fluxbox though...



Thanks! :)
_________________
“What we do for ourselves dies with us. What we do for others and the world remains and is immortal.” -Albert Pine
Back to top
View user's profile Send private message
steveL
Watchman
Watchman


Joined: 13 Sep 2006
Posts: 5153
Location: The Peanut Gallery

PostPosted: Wed Sep 24, 2014 5:54 pm    Post subject: Reply with quote

Nice tip, tony.

Cheers :-)
Back to top
View user's profile Send private message
muadib25
Tux's lil' helper
Tux's lil' helper


Joined: 08 Aug 2010
Posts: 144
Location: Sweden

PostPosted: Thu Sep 25, 2014 8:05 pm    Post subject: Reply with quote

SebB,

yes it worked! Thanks! :)

Now its only totem-2.32.0-r2 that doesn't compile when I do 'emerge --update --newuse --deep --with-bdeps=y @world', I'll make a new post for that.
_________________
“What we do for ourselves dies with us. What we do for others and the world remains and is immortal.” -Albert Pine
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum