Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] partitionen für user-accounts ausblenden
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
oliver2104
Apprentice
Apprentice


Joined: 27 Jul 2004
Posts: 207
Location: Wien

PostPosted: Mon Oct 27, 2014 10:04 am    Post subject: [gelöst] partitionen für user-accounts ausblenden Reply with quote

Habe ein Dualboot-Sytem: Win und gentoo
als ROOT möchte ich auf alle vorhandene Partitionen zugreifen.
meine etc/fstab enthält deswegen ua. zb. folgende Zeile:
Code:
/dev/sdb3    /win4root_only       vfat    nouser,auto        0 0

in der etc/sudoers habe ich meinen user-accounts unbeschränkten Zugriff
auf das Kommando bin/mount gewährt ( für USB-Sticks, CD, etc)
allerdings möchte ich nicht, dass genau die oben genannte partition aus einem
User-Account gemountet werden kann.

Gibt es da eine Lösung ?


Last edited by oliver2104 on Sun Nov 02, 2014 12:17 pm; edited 1 time in total
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1183

PostPosted: Mon Oct 27, 2014 11:05 am    Post subject: Reply with quote

wie wäre es mit udisks?
Code:
udisksctl mount --block-device /dev/sr0
zB für CDs
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Mon Oct 27, 2014 11:34 am    Post subject: Reply with quote

Kann das denn so wie du es jetzt hast, von einem User-Account aus gemountet werden? Der Eintrag nouser ist eigentlich überflüssig, weil das Standard ist. Da musst du nur user eintragen, wenn es der User mounten können darf. Der Knackepunkt bei dir ist das auto. Da wird die Partition beim Booten automatisch eingehängt. Da muss kein User mehr etwas mounten.

Wo ich bei dir aber nicht ganz durchsteige, bei dir gehen die Begriffe mounten und Zugriff durcheinander.

Das Mounten regelst du über die fstab. Und Zugriff hat dann etwas mit den Zugriffsrechten zu tun, die du erteilst. Bei deinen Einstellungen wird das schon mal beim booten gemountet. Das muss dann gar kein User mehr tun. Und der Zugriff ist dann wieder etwas ganz anderes.
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Tue Oct 28, 2014 9:40 am    Post subject: Re: partitionen für user-accounts ausblenden Reply with quote

oliver2104 wrote:
in der etc/sudoers habe ich meinen user-accounts unbeschränkten Zugriff
auf das Kommando bin/mount gewährt ( für USB-Sticks, CD, etc)
allerdings möchte ich nicht, dass genau die oben genannte partition aus einem
User-Account gemountet werden kann.

USB-Sticks und CDs werden doch mittlerweile über udisks automatisch gemountet. Zumindest hab ich beim letzten Mal blöd geguckt, als ich einen Stick nicht mehr selbst mounten konnte, da der offenbar schon gemountet war.

Bei den Mountoptionen kannst du angeben, wer das alles mounten darf.

man mount wrote:
owner Allow an ordinary (i.e., non-root) user to mount the filesystem
if he is the owner of the device. This option implies the
options nosuid and nodev (unless overridden by subsequent
options, as in the option line owner,dev,suid).

Und da Windows-Dateisysteme erst mal keinen Eigentümer haben, setzt du den noch mit uid:

http://wiki.ubuntuusers.de/Windows-Partitionen_einbinden/NTFS-3G
wiki ubuntuusers wrote:
"uid" und "gid"

Mit den Optionen uid=UID und gid=GID werden Benutzer und Gruppe für die Partition simuliert. Für UID und GID kann man wahlweise die numerischen Werte oder die Namen eintragen. Fehlt der Eintrag für gid, so wird die Hauptgruppe des angegebenen Benutzers gewählt. Fehlt hingegen der Eintrag für uid, so erscheint "Root" als Eigentümer.


Die mount-Optionen sollten in der fstab also so ähnlich aussehen (ungetestet):
Code:
/dev/sdb3    /win4root_only       vfat    rw,noauto,owner,nodev,nosuid,noexec,uid=$uid_berechtigter,gid=$gid_berechtigter,file_mode=0644,dir_mode=0755


Korrektur
Code:
file_mode=0600,dir_mode=0700

sollte natürlich so gesetzt sein, sonst können andere User trotzdem auf die gemountete Partition zugreifen.


Last edited by musv on Thu Oct 30, 2014 8:22 pm; edited 1 time in total
Back to top
View user's profile Send private message
oliver2104
Apprentice
Apprentice


Joined: 27 Jul 2004
Posts: 207
Location: Wien

PostPosted: Tue Oct 28, 2014 2:59 pm    Post subject: Reply with quote

Dank Eurer Hilfe und ein wenig selber nachdenken, kann ich das Problem weiter eingrenzen.
denke da gehts um Zugriffsrechte
Code:
cd /
ls -l

liefert eine Liste mit allen Verzeichnissen im root-tree.
Interessant sind dabei folgende Einträge
    drwx------ 51 root root 1720 28. Okt 14:56 root
    drwxr-xr-x 11 root root 16384 1. Jan 1970 win4root_only

das root Verzeichnis mit den Rechten drwx------ macht genau das was ich
mir auch von win4root_only wünsche, nämlich nur von ROOT eingesehen zu werden.
Hab jetzt schon viele fstab-optionen ausprobiert, aber es ist mir noch nicht gelungen
die Zugriffsrechte für win4root_only auf drwx------ zu stellen.
Ausserdem frag ich mich warum da der 1. Jan 1970 im Listing vorkommt.
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1183

PostPosted: Tue Oct 28, 2014 4:14 pm    Post subject: Reply with quote

also, generell stellt man die dateirechte nicht über die mountoptionen, sondern mit chown ein.
Da du aber eine fat partition hast, kann die keine linux dateirechte, sondern du stellst das bei den mountoptionen mit ein, so wie musv es schon gepostet hat.
Back to top
View user's profile Send private message
oliver2104
Apprentice
Apprentice


Joined: 27 Jul 2004
Posts: 207
Location: Wien

PostPosted: Thu Oct 30, 2014 11:37 am    Post subject: Reply with quote

Wie gesagt, hab für die vfat-mountoptionen noch keine geeignete Einstellung gefunden.
Habe natürlich den Rat von musv befolgt und diese Zeile in der /etc/fstab gesetzt:
Code:
/dev/sdb3  /win4root_only  vfat  rw,noauto,owner,nodev,nosuid,noexec,uid=0,gid=0,file_mode=0644,dir_mode=0755  0 0

das sieht zunächts gut aus.
Code:
cd /
ls -l   
zeigt:
    drwx------ 2 root root 48 28. Okt 14:18 win4root_only
also genau wie gewünscht.
Auch erhalten User die Meldung
    Permission denied
beim Zugriff auf /win4root_only
allerdings kann ich mir nicht einmal als ROOT den Inhalt von win4root_only anschauen
Code:
cd win4root_only
ls
ergibt gar nichts bzw. ein leeres Verzeichnis.
Hab auch die fstab-options von noauto zu auto geändert, ändert aber nichts
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Thu Oct 30, 2014 12:10 pm    Post subject: Reply with quote

Aber es ist schon gemountet?
noauto/auto wird nur beim Start genutzt.

Im Betrieb musst du mit "mount -a" oder mit "mount /win4root_only" arbeiten.
Überprüfen kannst Du das mit "mount". Das zeigt dir an, was gerade eingehängt ist.
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
oliver2104
Apprentice
Apprentice


Joined: 27 Jul 2004
Posts: 207
Location: Wien

PostPosted: Fri Oct 31, 2014 12:09 pm    Post subject: Reply with quote

Nach Neustart mit o.g. fstab-optionen und login als root ist
/dev/sdb3 noch nicht auf /win4root_only gemountet.
deswegen auch das leere Verzeichnis.
Kann jetzt natürlich als root das Verzeichnis auch manuell mounten:
(weitere mount-optionen muss man angeblich bei einem vorhandenem Eintrag in der /etc/fstab nicht nochmal eingeben)
Code:
mount /dev/sdb3 /win4root_only

jetzt kann ich das Verzeichnis einsehen, leider werden aber durch dieses Kommando die Dateirechte auf
    drwxr-xr-x 11 root root 16384 1. Jan 1970 win4root_only
geändert
und User haben dadurch wieder zumindest Lese-Zugriff
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1183

PostPosted: Fri Oct 31, 2014 12:48 pm    Post subject: Reply with quote

wenn du obengenannte fstab optionen verwendest, musst du "noauto" entfernen, denn das verhindert dass die partition beim booten gemountet wird.
Back to top
View user's profile Send private message
oliver2104
Apprentice
Apprentice


Joined: 27 Jul 2004
Posts: 207
Location: Wien

PostPosted: Sun Nov 02, 2014 12:16 pm    Post subject: Reply with quote

Hab jetzt eine Lösung gefunden.
die fstab- bzw mount-optionen "file_mode" und "dir_mode"
sind für vfat-partitionen nicht geeignet.
Stattdessen muss "fmask" und "dmask" verwendet werden.
mit der /etc/fstab Zeile:
Code:
/dev/sdb3    /win4root_only vfat  rw,auto,owner,nodev,nosuid,noexec,uid=0,gid=0,fmask=177,dmask=077   0 0

funktioniert alles wie gewünscht. Hab aber wirklich lang gesucht.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum