Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Thinkpad keyboard does not work on newer kernels/initrds
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message

Joined: 04 Jan 2004
Posts: 1169
Location: Buchholz/GER

PostPosted: Sat Jun 06, 2015 1:38 pm    Post subject: Thinkpad keyboard does not work on newer kernels/initrds Reply with quote


I also discussed this problem in a longer german forums thread but we got no solution there. So I'll try here:

I have a problem with my external Thinkpad USB keyboard on my full encrypted Gentoo system (luks/lvm). I can't enter the luks passphrase in initrd. Another standard USB-keyboard works, but my Thinkpad USB keyboard doesn't.

When I connect a second standard USB keyboard to this system, I can enter the passphrase on the second keyboard and use the Thinkpads one later in terminal, KDE or whatever. So it only fails in initrd.

I create my kernel/initrd with latest genkernel. Entering the luks passphrase worked with older kernels (e.g. my actual 3.14.41 and also 3.17.8-gentoo-r1), but I does not work on newer kernels (like 3.18.9-gentoo and 4.0.4-gentoo).

If I search on google for that problem I found some similar problems on other distributions like Debian, etc.

I have no idea how to fix this issue ... any help would be appreciated.

Btw, there is a kernel module for this type of keyboard .. hid-lenovo.ko, but this module is only for extra keys (like Fn, Volumekeys, etc.). I tried without hid-lenovo, with hid-lenovo as a module and builtin ... all fails.

Some information:

non working Thinkpad USB keyboard: Bus 005 Device 003: ID 17ef:6009 Lenovo ThinkPad Keyboard with TrackPoint
working standard USB keyboard: Bus 002 Device 003: ID 04d9:1603 Holtek Semiconductor, Inc. Keyboard

[root@sorum:~]# emerge --info
Portage 2.2.20 (python 2.7.10-final-0, default/linux/amd64/13.0/desktop/kde, gcc-4.8.4, glibc-2.20-r2, 4.0.4-gentoo-stv-i7-rev-9e-intel x86_64)
System uname: Linux-4.0.4-gentoo-stv-i7-rev-9e-intel-x86_64-Intel-R-_Core-TM-_i7-3770K_CPU_@_3.50GHz-with-gentoo-2.2
KiB Mem:    31885840 total,  14341400 free
KiB Swap:      65532 total,     65532 free
Timestamp of repository gentoo: Sat, 06 Jun 2015 12:00:01 +0000
sh bash 4.3_p39
ld GNU ld (Gentoo 2.25 p1.2) 2.25
app-shells/bash:          4.3_p39::gentoo
dev-lang/perl:            5.20.2-r1::gentoo
dev-lang/python:          2.7.10::gentoo, 3.3.5-r1::gentoo
dev-util/cmake:           3.2.3::gentoo
dev-util/pkgconfig:       0.28-r3::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.16.4::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r1::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.12.6::gentoo, 1.13.4::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25-r1::gentoo
sys-devel/gcc:            4.8.4::gentoo, 4.9.2::gentoo
sys-devel/gcc-config:     1.8::gentoo
sys-devel/libtool:        2.4.6-r1::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.0::gentoo (virtual/os-headers)
sys-libs/glibc:           2.20-r2::gentoo

    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://
    priority: -1000

ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -march=corei7 -pipe"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0 /usr/share/themes/oxygen-gtk/gtk-3.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -march=corei7 -pipe"
EMERGE_DEFAULT_OPTS="--with-bdeps=y --quiet-build=y --autounmask=n"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="3dnow 3dnowext X a52 aac aalib acl acpi addressbook akonadi alsa amd64 apng autoipd avahi berkdb bidi branding bzip2 cairo calendar cdda cddb cdr cli consolekit cracklib crypt cryptsetup cups custom-optimization cxx dbus declarative designer device-mapper dhclient dhcpcd djbfft dri dts dvb dvbpsi dvbsetup dvd dvdnav dvdr ebook embedded emboss enca encode exif extensions extraengine extras faac faad fam fax fbcondecor ffmpeg firefox firefox3 flac fontconfig fortran gallium gdbm gflags gif glamor gmplayer gnutls google gpm gstreamer hddtemp hpijs iconv icq icu id3 id3tag idn ieee1394 jpeg json kde kipi lame laptop lastfm lastfmradio lcms libnotify lm_sensors logitech-mouse mad matroska mdnsresponder-compat mjpeg mmx mmxext mng modules mp2 mp3 mp3tunes mp4 mpd mpeg msn mtp multilib musicbrainz ncurses nfs nfsidmap nfsv3 nfsv4 nls nptl nsplugin nss ogg online-services opengl openmp oscar otr pam pango pcre pdf phonon pipelight plasma png podcast policykit postscript ppds ppp qt3support qt4 readline redeyes reiser4 reiserfs replytolist romio scanner sdl semantic-desktop session smime snmp spell sql sse sse2 sse3 ssl startup-notification svg taglib tcpd theora thinkpad threads thumbnail tiff tint2conf tordns truetype tv tv_check tv_combiner tv_pick_cgi tvtime udev udisks unicode upower usb uxa v4l v4l2 vaapi vcd vdr virtualbox vnc vorbis webkit wifi wxwidgets x264 xcb xcomposite xft xinerama xml xscreensaver xv xvid youtube zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" DRACUT_MODULES="crypt lvm mdraid" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev keyboard mouse virtualbox vmmouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="nvidia intel vesa virtualbox i915 i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message

Joined: 04 Jan 2004
Posts: 1169
Location: Buchholz/GER

PostPosted: Sat Jun 06, 2015 1:56 pm    Post subject: Reply with quote

some aditional info:

- working kernel config 3.14.41-gentoo
- non working kernel config 4.0.4-gentoo
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum