Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved]Problems getting KMS/Xorg to work
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
imp0s5ible
n00b
n00b


Joined: 16 Jul 2015
Posts: 9

PostPosted: Thu Jul 16, 2015 5:26 am    Post subject: [Solved]Problems getting KMS/Xorg to work Reply with quote

First time trying to install Gentoo on my Asus EEPC 1015PX.

I tried following this guide to set up Xorg but to no avail, when booting into my Gentoo install on my netbook GRUB works fine (it even displays at my native resolution) but as soon as I boot into the OS it switches to a lower resolution and refuses to start lightdm. What happens instead is I get the regular terminal prompt which disappears after about a second and instead what I get is a blinking cursor in the top left corner, however I can fix this by switching to another tty so I assume the blinking cursor thing was lightdm attempting to start or something.

When attempting to manually use the startx command I get the [KMS] drm report modesetting isn't supported error. Running X -configure returns that same error and also a segmentation fault at address 0x0.
I also checked this page but nothing seems to have helped.

I'm pretty sure I have everything checked/unchecked that they tell me to in these guides, but I'll be able to get my kernel .config file and full xorg logs in a while, but until then I'd be grateful if any of you have any ideas as to what the problem and possible solution could be. So far everything points to kernel modesetting not working, with the xorg error and the fact that the OS boots into a low resolution, but I'm out of ideas.

EDIT: Turns out Gentoo doesn't mount /boot by default, which I didn't know, so all the kernel configurations I've made were not actually applied. After properly mounting /boot and rebuilding the kernel, graphics work fine now.


Last edited by imp0s5ible on Sat Jul 18, 2015 4:04 am; edited 1 time in total
Back to top
View user's profile Send private message
Keruskerfuerst
Advocate
Advocate


Joined: 01 Feb 2006
Posts: 2288
Location: near Augsburg, Germany

PostPosted: Thu Jul 16, 2015 7:27 am    Post subject: Reply with quote

Anything unusual in the logs?
Back to top
View user's profile Send private message
imp0s5ible
n00b
n00b


Joined: 16 Jul 2015
Posts: 9

PostPosted: Thu Jul 16, 2015 8:08 am    Post subject: Reply with quote

Keruskerfuerst wrote:
Anything unusual in the logs?


Yes, I just looked through dmesg and I spotted the following:
Direct firmware load for radeon/PALM_pfp.bin failed with error -2

It turns out I didn't have that specific file in my CONFIG_EXTRA_FIRMWARE. After adding it, rebuilding the kernel and rebooting, the very same error still persists. I'm using full drive encryption and a dracut initramfs so that would prevent it from being accessed but shouldn't it be built into the kernel to begin with?
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2717

PostPosted: Thu Jul 16, 2015 8:19 am    Post subject: Re: Problems getting KMS/Xorg to work Reply with quote

imp0s5ible wrote:
When attempting to manually use the startx command I get the [KMS] drm report modesetting isn't supported error.

What is the graphics card? Please pastbin your output of # lspci -k. Important details are the pci number and the kernel driver in use.

After startx and Ctrl C, there should be /var/log/Xorg.0.log. Please pastebin this too.
Some of the modules related (WW) and (EE) from the log can be solved by creating a /etc/X11/xorg.conf.d/device.conf file.

Have you set the VIDEO_CARDS variable in /etc/portage/make.conf and the x11-drivers/xf86-video-<intel, nouveau, whatever> installed?
Back to top
View user's profile Send private message
imp0s5ible
n00b
n00b


Joined: 16 Jul 2015
Posts: 9

PostPosted: Thu Jul 16, 2015 3:28 pm    Post subject: Re: Problems getting KMS/Xorg to work Reply with quote

charles17 wrote:
imp0s5ible wrote:
When attempting to manually use the startx command I get the [KMS] drm report modesetting isn't supported error.

What is the graphics card? Please pastbin your output of # lspci -k. Important details are the pci number and the kernel driver in use.

After startx and Ctrl C, there should be /var/log/Xorg.0.log. Please pastebin this too.
Some of the modules related (WW) and (EE) from the log can be solved by creating a /etc/X11/xorg.conf.d/device.conf file.

Have you set the VIDEO_CARDS variable in /etc/portage/make.conf and the x11-drivers/xf86-video-<intel, nouveau, whatever> installed?


Sorry for the delay, here are some log files:
dmesg output
lspci output
Xorg.0.log

EDIT:
Forgot to link my kernel .config file and my portage make.conf.
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2717

PostPosted: Thu Jul 16, 2015 6:31 pm    Post subject: Re: Problems getting KMS/Xorg to work Reply with quote

imp0s5ible wrote:
Sorry for the delay, here are some log files:
dmesg output
lspci output

So according to lspci you have a Wrestler [Radeon HD 6290] at 00:01.0. You can get a more condensed output using
Code:
# lspci | grep -i '00:01.0\|radeon\|drm\|error'

Did you work through the radeon wiki page? Never had that kind of card, so I cannot help.

imp0s5ible wrote:
Xorg.0.log

EDIT:
Forgot to link my kernel .config file and my portage make.conf.

Regarding the make.conf you might also want to read https://www.gentoo.org/support/news-items/2015-01-28-cpu_flags_x86-introduction.html
Back to top
View user's profile Send private message
imp0s5ible
n00b
n00b


Joined: 16 Jul 2015
Posts: 9

PostPosted: Thu Jul 16, 2015 7:12 pm    Post subject: Re: Problems getting KMS/Xorg to work Reply with quote

charles17 wrote:

imp0s5ible wrote:
Sorry for the delay, here are some log files:

Did you work through the radeon wiki page? Never had that kind of card, so I cannot help.


Yes, I did work through all the steps needed to get my radeon card running, but as you can see in the dmesg apparently the kernel wants to load radeon/PALM_pfp.bin but fails, and I'm fairly certain that's what causes the problems in the first place, but I have no idea why it can't load that firmware even though it's supposedly built into the kernel and I did install radeon-ucode and the file is indeed there.

I'm fairly certain the problem is not with my X installation, at least not yet.

EDIT: I took a look at the CPU_FLAGS_X86 and used the cpuinfo2cpuflags script mentioned in your link to add the proper CPU_FLAGS_X86 to my make.conf and also copied them to my regular USE flags. I tried running emerge --update --deep --newuse @world afterwards but it only seemed to update one package. Is that alright or is there another command to rebuild all my packages to use my new settings? I'll try rebuilding the kernel and the firmware package again just in case, I'll report back with results.


Last edited by imp0s5ible on Thu Jul 16, 2015 7:33 pm; edited 1 time in total
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 3250
Location: Illinois, USA

PostPosted: Thu Jul 16, 2015 7:15 pm    Post subject: Re: Problems getting KMS/Xorg to work Reply with quote

[quote="imp0s5ible"][quote="charles17"]
imp0s5ible wrote:
but as you can see in the dmesg apparently the kernel wants to load radeon/PALM_pfp.bin but fails, and I'm fairly certain that's what causes the problems in the first place, but I have no idea why it can't load that driver even though it's supposedly built into the kernel and I did install radeon-ucode and the file is indeed there.

I'm fairly certain the problem is not with my X installation, at least not yet.


Did you enable the firmware in the kernel option? Have you emerged the latest version of the firmware? I think it's called "linux-firmware".
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Thu Jul 16, 2015 7:17 pm    Post subject: Reply with quote

So double check if the firmware is really in kernel. If only radeon driver is built into kernel firmware load will fail because / is not mounted when kernel loads. You can build radeon as module and it will load firmware from hard drive.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43994
Location: 56N 3W

PostPosted: Thu Jul 16, 2015 7:52 pm    Post subject: Reply with quote

imp0s5ible,

dmesg:
[    1.606503] radeon 0000:00:01.0: Direct firmware load for radeon/PALM_pfp.bin failed with error -2

So your driver is looking for PALM.

.config:
CONFIG_EXTRA_FIRMWARE="radeon/SUMO_pfp.bin"
CONFIG_EXTRA_FIRMWARE_DIR="/lib/firmware"
you are providing SUMO, which is not the same thing at all.

Lack of firmware mill not stop Xorg running but you will not have any 3D hardware acceleration, so this is not your immediate problem

Xorg.0.log:
[   567.644] (II) [KMS] drm report modesetting isn't supported.
THaths a showstopper.

Xorg.0.log:
[   567.615] Current Operating System: Linux IMPOSSIBLE-NET 4.0.5-gentoo #7 SMP Thu Jul 16 03:25:04 CEST 2015 x86_64
[   567.615] Kernel command line: BOOT_IMAGE=/vmlinuz-4.0.5-gentoo root=/dev/mapper/main-root ro radeon.modeset=1

You are running a kernel built today and its your 7th try at this kernel. You should not need the radeon.modeset=1 but it shoud be harmless.
dmesg:
[    1.602577] [drm] Initialized drm 1.1.0 20060810
[    1.602759] [drm] radeon kernel modesetting enabled.
[    1.604056] [drm] initializing kernel modesetting (PALM 0x1002:0x9807 0x1043:0x84E4).
so drm modesetting works.

Is this a self consistant set of files?
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
imp0s5ible
n00b
n00b


Joined: 16 Jul 2015
Posts: 9

PostPosted: Thu Jul 16, 2015 7:55 pm    Post subject: Reply with quote

Buffoon wrote:
So double check if the firmware is really in kernel. If only radeon driver is built into kernel firmware load will fail because / is not mounted when kernel loads. You can build radeon as module and it will load firmware from hard drive.


Device Drivers -> Generic Driver Options -> [*] Include in-kernel firmware blobs in kernel binary
is checked, so the firmware should be in the kernel. Firmware blobs directory is /lib/firmware and the External firmware blobs to build into the kernel binary variable is: "radeon/PALM_me.bin radeon/PALM_pfp.bin radeon/SUMO_rlc.bin radeon/SUMO_uvd.bin" and yet it fails to load radeon/PALM_pfp.bin.

Tony0945 wrote:
Did you enable the firmware in the kernel option? Have you emerged the latest version of the firmware? I think it's called "linux-firmware".


I have merged radeon-ucode. According to the handbook, linux-firmware is the same but contains other firmware for other cards (that I don't need). I don't know how successful I'd be with emerging that, seeing how radeon-ucode already contains the file that it needs, it just fails to load. It would be good to know what the error -2 means though, maybe that would help.
Back to top
View user's profile Send private message
imp0s5ible
n00b
n00b


Joined: 16 Jul 2015
Posts: 9

PostPosted: Thu Jul 16, 2015 8:15 pm    Post subject: Reply with quote

NeddySeagoon wrote:
imp0s5ible,

dmesg:
[    1.606503] radeon 0000:00:01.0: Direct firmware load for radeon/PALM_pfp.bin failed with error -2

So your driver is looking for PALM.

.config:
CONFIG_EXTRA_FIRMWARE="radeon/SUMO_pfp.bin"
CONFIG_EXTRA_FIRMWARE_DIR="/lib/firmware"
you are providing SUMO, which is not the same thing at all.

Lack of firmware mill not stop Xorg running but you will not have any 3D hardware acceleration, so this is not your immediate problem

Xorg.0.log:
[   567.644] (II) [KMS] drm report modesetting isn't supported.
THaths a showstopper.

Xorg.0.log:
[   567.615] Current Operating System: Linux IMPOSSIBLE-NET 4.0.5-gentoo #7 SMP Thu Jul 16 03:25:04 CEST 2015 x86_64
[   567.615] Kernel command line: BOOT_IMAGE=/vmlinuz-4.0.5-gentoo root=/dev/mapper/main-root ro radeon.modeset=1

You are running a kernel built today and its your 7th try at this kernel. You should not need the radeon.modeset=1 but it shoud be harmless.
dmesg:
[    1.602577] [drm] Initialized drm 1.1.0 20060810
[    1.602759] [drm] radeon kernel modesetting enabled.
[    1.604056] [drm] initializing kernel modesetting (PALM 0x1002:0x9807 0x1043:0x84E4).
so drm modesetting works.

Is this a self consistant set of files?


I updated my make.conf, dmesg output, Xorg.0.log and kernel .config files with some changes I made since then, they can all be reached at the same links I posted before. Those files should be consistent with each other. As you can see I now provide the correct firmware blobs, but the error persists, and xorg still won't load.

ls /bin/firmware/radeon | grep PALM shows that PALM_me.bin and PALM_pfp.bin both exist so that shouldn't be the problem either.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43994
Location: 56N 3W

PostPosted: Thu Jul 16, 2015 8:39 pm    Post subject: Reply with quote

[imp0s5ible,

code=".config"]CONFIG_EXTRA_FIRMWARE="radeon/PALM_me.bin radeon/PALM_pfp.bin radeon/SUMO_rlc.bin radeon/SUMO_uvd.bin"
CONFIG_EXTRA_FIRMWARE_DIR="/lib/firmware"[/code]

imp0s5ible wrote:
ls /bin/firmware/radeon | grep ...
ls /bin ?
You told the kernel /lib/firmware.
I'm not sure if CONFIG_EXTRA_FIRMWARE_DIR needs to have a trailing / or not.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
imp0s5ible
n00b
n00b


Joined: 16 Jul 2015
Posts: 9

PostPosted: Thu Jul 16, 2015 9:04 pm    Post subject: Reply with quote

NeddySeagoon wrote:
[imp0s5ible,

code=".config"]CONFIG_EXTRA_FIRMWARE="radeon/PALM_me.bin radeon/PALM_pfp.bin radeon/SUMO_rlc.bin radeon/SUMO_uvd.bin"
CONFIG_EXTRA_FIRMWARE_DIR="/lib/firmware"[/code]

imp0s5ible wrote:
ls /bin/firmware/radeon | grep ...
ls /bin ?
You told the kernel /lib/firmware.
I'm not sure if CONFIG_EXTRA_FIRMWARE_DIR needs to have a trailing / or not.


Sorry, I'm dumb, yes, I did mean /lib/firmware. Anyway I seem to have figured out the problem, which presents a new one. When I tried to do sudo mount /dev/sda1 /boot it executed without any output, which means the /boot partition wasn't properly mounted before, which of course meant that any kernel modifications I made never actually applied. I noticed this too when you pointed out that it was my 7th try with that kernel when it should have been way more than that. After manually mounting /boot and recompiling the kernel and rebooting, lightdm now starts and I can log in to a graphical interface.

The new problem presented is, of course, to fix the /boot partition not mounting properly.
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Thu Jul 16, 2015 10:32 pm    Post subject: Reply with quote

imp0s5ible wrote:
The new problem presented is, of course, to fix the /boot partition not mounting properly.


This is not a problem, this is default Gentoo setting. You can change it in fstab of course.
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 3250
Location: Illinois, USA

PostPosted: Thu Jul 16, 2015 10:40 pm    Post subject: Reply with quote

If you want /boot mounting automatically every time, set your /etc/fstab to this line copied verbatim from my /etc/fstab
Quote:

/dev/sda1 /boot ext2 auto,noatime 1 2


If your boot partition is not ext2, change that accordingly.

I used to set "noauto" to protect the partition, but finally realized that the boot partition is the easiest to rebuild (after swap).

Edit:
That's six fields
F1: /dev/sda1
F2: /boot
F3: ext2
F4: auto,noatime
F5: 1
F6: 2

After posting, I realized the verbatim line has the spaces compressed after posting. They are obvious when editting, but not when viewing
Back to top
View user's profile Send private message
imp0s5ible
n00b
n00b


Joined: 16 Jul 2015
Posts: 9

PostPosted: Sat Jul 18, 2015 4:02 am    Post subject: Reply with quote

Tony0945 wrote:
If you want /boot mounting automatically every time, set your /etc/fstab to this line copied verbatim from my /etc/fstab
Quote:

/dev/sda1 /boot ext2 auto,noatime 1 2


If your boot partition is not ext2, change that accordingly.

I used to set "noauto" to protect the partition, but finally realized that the boot partition is the easiest to rebuild (after swap).

Edit:
That's six fields
F1: /dev/sda1
F2: /boot
F3: ext2
F4: auto,noatime
F5: 1
F6: 2

After posting, I realized the verbatim line has the spaces compressed after posting. They are obvious when editting, but not when viewing


Alright, thanks for the help. Graphics works perfectly now, even direct rendering and hardware acceleration. Now to get a better looking lockscreen/screensaver.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum