Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Nouveau drivers (and others) not showing up in kernel config
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Quell
n00b
n00b


Joined: 13 Aug 2015
Posts: 2

PostPosted: Thu Aug 13, 2015 2:54 pm    Post subject: Nouveau drivers (and others) not showing up in kernel config Reply with quote

I recently installed the kernel sources with the 'deblob' USE flag on. Only about eight graphics drivers showed up under 'Direct Rendering Manager', so I emerged the kernel sources without the 'deblob' USE flag. Still, only eight drivers show up under DRM (mostly VM drivers).

All dependencies for the module 'nouveau' have been fulfilled, I just don't understand why it isn't showing up. Was there something else I should have done as I replaced the deblobbed kernel with the blobbed kernel? The kernel version is still the same.

Edit: Forgot to mention, this is a brand new install with kernel 4.0.5


Last edited by Quell on Thu Aug 13, 2015 3:46 pm; edited 1 time in total
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Thu Aug 13, 2015 3:15 pm    Post subject: Reply with quote

If you mean Xorg drivers then they are not part of the kernel.
Back to top
View user's profile Send private message
Quell
n00b
n00b


Joined: 13 Aug 2015
Posts: 2

PostPosted: Thu Aug 13, 2015 3:24 pm    Post subject: Reply with quote

Buffoon wrote:
If you mean Xorg drivers then they are not part of the kernel.

Sorry, I was unclear. I meant the KMS nouveau driver in the kernel. It is located in
Code:
 Device Drivers > Graphics Support > Direct Rendering Manager
It's not there, and neither are most other KMS drivers (Intel, ATI etc.).

I've re-activated nouveau DRM in the .config file generated by make menuconfig, but it still doesn't show up in the menu configuration
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 3184
Location: Illinois, USA

PostPosted: Thu Aug 13, 2015 5:16 pm    Post subject: Reply with quote

Good question! I just did a "make menuconfig" to try and find it in 4.1.5, but couldn't find it their either. I use RADEON so I haven't noticed it's disappearance.

I think it used to be under "experimental drivers" but I don't see that either.


Last edited by Tony0945 on Thu Aug 13, 2015 7:44 pm; edited 1 time in total
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Thu Aug 13, 2015 6:46 pm    Post subject: Reply with quote

It is there for me.
Code:
Device Drivers > Graphics Support > Direct Rendering Manager > Direct Rendering Manager (XFree86 4.1.0 and higher DRI support) >
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum