Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Video display doesn't load on Lenovo ThinkPad W520
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
dhinds
n00b
n00b


Joined: 05 Jul 2014
Posts: 13

PostPosted: Wed Oct 07, 2015 8:59 am    Post subject: Video display doesn't load on Lenovo ThinkPad W520 Reply with quote

I installed Gentoo with the Calculate Xfce v. 15 overlay on 3 separate partitions (/, /home and /swap). After rebooting the grub appears but the screen stays black after that.

Any suggestion to correct this will be appreciated.

TIA
Back to top
View user's profile Send private message
bookwood
Tux's lil' helper
Tux's lil' helper


Joined: 06 Oct 2005
Posts: 110
Location: Dortmund

PostPosted: Wed Oct 07, 2015 3:21 pm    Post subject: Reply with quote

I have the same laptop and use Gentoo on it. I had big problems to configure Xorg, because the nvidia card writes into the memory of the intel card. A very exotic solution to save power. Follow this guide:
https://wiki.gentoo.org/wiki/NVIDIA_Driver_with_Optimus_Laptops

Try at first to switch in bios to "discrete graphics"
I had also big problems with 2 eselect opengl switches. Now I have "eselect opengl nvidia" and "eselect qtgraphicssystem native", but I use KDE Plasma. XFCE runs fine before

I'm at work now. I will post my running xorg configuation when I'm at home.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44170
Location: 56N 3W

PostPosted: Wed Oct 07, 2015 3:51 pm    Post subject: Reply with quote

dhinds,

Make the intel graphics system work first. Thats quite conventional.
Add the nVidia graphics using the Optimus guide later.

By building on something that works, you can back out changes if you don't get it right first time.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
bookwood
Tux's lil' helper
Tux's lil' helper


Joined: 06 Oct 2005
Posts: 110
Location: Dortmund

PostPosted: Wed Oct 07, 2015 8:03 pm    Post subject: Reply with quote

Here is my w520 configuration. The configuration is not perfect, but works. I searched two weeks to find this settings. I hope it will help you.

Code:

eselect opengl list
Available OpenGL implementations:                                                                                                     
  [1]   nvidia *                                                                                                                     
  [2]   xorg-x11   


The next switch caused big problems with KDE when is switched to opengl. Perhaps not important to you, because you use xfce.
Code:

eselect qtgraphicssystem list
Available Qt Graphics Systems:
  [1]   native *
  [2]   opengl (experimental)
  [3]   raster (default)


/etc/portage/make.conf
Code:

# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-O2 -pipe -march=native -fomit-frame-pointer "
#CFLAGS="-O2 -pipe -march=native -ggdb "
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="X acpi alsa apng cairo clang cryptsetup cups dbus declarative
     device-mapper dhcp dhcp-tools dnssec firewalld gtk3 gudev gui icu idn
     ipv4 kde kde4 kdm lua lvm minizip mmx mng modemmanager nfs nfsdcld
     nfsexports nfsidmap nfsv4 nfsv41 nsplugin ogg opencl opengl parted pcap
     policykit postproc pulseaudio python qalculate qt3support qt4 qt5 script
     sdk sna spice sql sqlite sse sse2 svg systemd tftp threads udev usb
     usbredir uuid uvm virt-network vorbis webkit webserver wireshark-plugins
     xmp zeroconf -bindist -consolekit -nftrack -vdr"
PORTDIR="/usr/portage"
DISTDIR="${PORTDIR}/distfiles"
PKGDIR="${PORTDIR}/packages"
LINGUAS="de en"
INPUT_DEVICES="evdev synaptics "
MAKEOPTS="-j 4 "

VIDEO_CARDS="nvidia intel modesetting"
ALSA_CARDS="hda-intel"
GRUB_PLATFORMS="pc"


cd /etc/X11/xorg.conf.d/
10-xorg.conf
Code:

Section "ServerLayout"
     Identifier "layout"
     Screen 0 "nvidia" 0 0
     Inactive "intel"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    Option         "DPMS"
EndSection

Section "Device"
        Identifier  "nvidia"
        Driver      "nvidia"
        BusID       "PCI:1:0:0"
        Option "TripleBuffer" "True"
EndSection

Section "Screen"
        Identifier "nvidia"
        Device "nvidia"
        Monitor "Monitor0"
        DefaultDepth    24
        Option  "UseDisplayDevice" "none"
        SubSection      "Display"
                Depth       24
                Modes      "nvidia-auto-select"
        EndSubSection
#       Option "AllowEmptyInitialConfiguration"
EndSection

Section "Device"
        Identifier "intel"
        Driver  "modesetting"
        BusID   "PCI:0:2:0"
EndSection

Section "Screen"
        Identifier      "intel"
        Device          "intel"
        Monitor         "Monitor0"
EndSection



20-evdev.conf
Code:

#
# Catch-all evdev loader for udev-based systems
# We don't simply match on any device since that also adds accelerometers
# and other devices that we don't really want to use. The list below
# matches everything but joysticks.

Section "InputClass"
        Identifier "evdev pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option "xkb_layout" "de"
EndSection

Section "InputClass"
        Identifier "evdev touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev tablet catchall"
        MatchIsTablet "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev touchscreen catchall"
        MatchIsTouchscreen "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection


The next files are not so important and may differ
00-files.conf
Code:

Section "Files"
        ModulePath   "/usr/lib64/xorg/modules"
        FontPath     "/usr/share/fonts/misc/"
        FontPath     "/usr/share/fonts/TTF/"
        FontPath     "/usr/share/fonts/Type1/"
        FontPath     "/usr/share/fonts/freefont/"
        FontPath     "/usr/share/fonts/freefonts/"
        FontPath     "/usr/share/fonts/dejavu/"
        FontPath     "/usr/share/fonts/urw-fonts/"
        FontPath     "/usr/share/fonts/libertine/"
        FontPath     "/usr/share/fonts/texcm-ttf/"
        FontPath     "/usr/share/fonts/kanjistrokeorders/"
        FontPath     "/usr/share/fonts/mikachan-font-ttf/"
        FontPath     "/usr/share/fonts/ttf-bitstream-vera/"
EndSection
Back to top
View user's profile Send private message
dhinds
n00b
n00b


Joined: 05 Jul 2014
Posts: 13

PostPosted: Thu Oct 08, 2015 7:09 am    Post subject: These Responses Are A Big Help Reply with quote

I will follow up on these suggestions and report back asap. Thanks bookwood and NeddySeagoon.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum