Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Eigener Kernel für Raspberry Pi 2 bootet nicht
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
ConiKost
Veteran
Veteran


Joined: 11 Jan 2005
Posts: 1361

PostPosted: Fri Jan 01, 2016 9:24 pm    Post subject: Eigener Kernel für Raspberry Pi 2 bootet nicht Reply with quote

Hallo!
Ich habe mir einen Pi2 für meine Basteleien geholt, wobei ich ein Gentoo darauf installieren will.
Dazu habe ich, wie auch in der Dokumentation beschrieben, /boot mit FAT32 verstehen und auf / die passende Stage3 (arm7-hardfb) entpackt und grundlegend konfiguriert und eine passende Swap erzeugt.
Als Kernel habe ich zunächst einen fertigen aus Github https://github.com/raspberrypi/firmware geholt.

Damit bootet Gentoo und ist soweit benutzbar.

Allerdings ist mein Ziel, dass ich einen eigenen (kleineren) Kernel haben will. Dazu habe ich die sys-kernel/raspberrypi-sources emerged.
Leider scheitere ich mit der Aufgabe komplett.. auf x86/amd64-Systemen hatte ich da nie Probleme.
Es kommt immer wieder der Rainbow-Splash und das wars. Der Kernel von Github bootet dagegen sauber.

Um auszuschließen, dass evtl. meine eigene config fehlerhaft oder etwas fehlt, habe ich, wie in der Pi-Doku beschrieben, steht, einen default Build gemacht, wie hier beschrieben: https://www.raspberrypi.org/documentation/linux/kernel/building.md

Code:

KERNEL=kernel7
cd /usr/src/linux
make bcm2709_defconfig
make zImage modules dtbs
make modules_install
cp arch/arm/boot/dts/*.dtb /boot/
cp arch/arm/boot/dts/overlays/*.dtb* /boot/overlays/
cp arch/arm/boot/dts/overlays/README /boot/overlays/
scripts/mkknlimg arch/arm/boot/zImage /boot/$KERNEL.img


Auch das klappt nicht und ich lande am Ende wieder im Rainbow-Splash. Ich habe auch explizit auf dem Pi2 kompiliert, um mögliche Probleme mit meinem cross-Toolchain zu umgehen..
Jemand eine Idee, was ich hier grundlegend falsch mache? Mit dem Defaultbuild hätte es doch in jedem Fall klappen müssen?

[EDIT]
Hab mal meinen RS232-TTL Adapter an den Seriellen Port via GPIO rangehangen. Die einzige Meldung dort: "Uncompressing Linux... done, booting the kernel."
Back to top
View user's profile Send private message
Treborius
Guru
Guru


Joined: 18 Oct 2005
Posts: 584
Location: Berlin

PostPosted: Sun Jan 03, 2016 11:43 pm    Post subject: Reply with quote

hast Du mal ein diff von

sys-kernel/raspberrypi-sources und den sourcen von deren seite gemacht?

vielleicht vergisst das ebuild bestimmte essentielle patches...

Was klügeres fällt mir auch nicht ein, benutzte meine pi nichtmehr :(
_________________
Systems running gentoo :
Desktop, Laptop, ZOTAC AD-10 media-center, odroid-xu4 server / wLan-router
Back to top
View user's profile Send private message
ConiKost
Veteran
Veteran


Joined: 11 Jan 2005
Posts: 1361

PostPosted: Mon Jan 04, 2016 9:28 pm    Post subject: Reply with quote

Inzwischen gehe ich davon aus, dass mein Pi2 wohl defekt ist. Ich habe mir einen anderen Pi2 geliehen, dort bootet der Kernel mit meiner SD-Karte einwandfrei..
Back to top
View user's profile Send private message
tazinblack
Veteran
Veteran


Joined: 23 Jan 2005
Posts: 1133
Location: Baden / Germany

PostPosted: Sat Jan 09, 2016 6:50 pm    Post subject: Re: Eigener Kernel für Raspberry Pi 2 bootet nicht Reply with quote

ConiKost wrote:
Hallo!
... Ich habe auch explizit auf dem Pi2 kompiliert, um mögliche Probleme mit meinem cross-Toolchain zu umgehen...

Sorry, ist OT aber mich würde an dieser Stelle sehr interessieren, wie lange das dauert mit dem Raspberri Pi 2.
Ich überlege auch einen zu kaufen.
_________________
Gruß / Regards
tazinblack
_______________________________________________________
what's the point in being grown up if you can't be childish sometimes
Back to top
View user's profile Send private message
Treborius
Guru
Guru


Joined: 18 Oct 2005
Posts: 584
Location: Berlin

PostPosted: Mon Jan 11, 2016 4:36 pm    Post subject: Reply with quote

kernel mit viele modules lag bei mir um die 4h

aber ist ja egal ... die pi lag in der ecke und werkelte vor sich hin
_________________
Systems running gentoo :
Desktop, Laptop, ZOTAC AD-10 media-center, odroid-xu4 server / wLan-router
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum