Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Microsoft Mobile 3600 BT mouse segfaults on connect
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message

Joined: 12 Aug 2004
Posts: 13
Location: Bucharest, Romania

PostPosted: Tue Mar 29, 2016 7:18 am    Post subject: [SOLVED] Microsoft Mobile 3600 BT mouse segfaults on connect Reply with quote

I have a Microsoft Mobile 3600 for Bluetooth 4.0. It connects just fine to my Android phone, but on my two Gentoo boxes it doesn't work. Each has its own bluetooth 4.0 device (my laptop has an internal radio, while my desktop has a dongle). On both, however, whenever I try to connect, the bluetooth daemon crashes and the dmesg reads:
bluetoothd[4045]: segfault at 20 ip 0000556bd26169cc sp 00007ffdac9d3d90 error 4 in bluetoothd[556bd25d1000+10c000]

It happens either when I try to connect via bluetoothctl or via bluez.

emerge --info for the laptop:
Portage 2.2.26 (python 2.7.10-final-0, default/linux/amd64/13.0/desktop/kde, gcc-4.9.3, glibc-2.21-r2, 4.1.15-gentoo-r1 x86_64)
System uname: Linux-4.1.15-gentoo-r1-x86_64-Intel-R-_Core-TM-_i7-4712HQ_CPU_@_2.30GHz-with-gentoo-2.2
KiB Mem:    16334652 total,   1164488 free
KiB Swap:     524284 total,    524216 free
Timestamp of repository gentoo: Tue, 29 Mar 2016 06:15:01 +0000
sh bash 4.3_p42-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1                                                                                                                                             
app-shells/bash:          4.3_p42-r1::gentoo                                                                                                                                     
dev-java/java-config:     2.2.0::gentoo                                                                                                                                           
dev-lang/perl:            5.20.2::gentoo                                                                                                                                         
dev-lang/python:          2.7.10-r1::gentoo, 3.4.3-r1::gentoo                                                                                                                     
dev-util/cmake:           3.3.1-r1::gentoo                                                                                                                                       
dev-util/pkgconfig:       0.28-r2::gentoo                                                                                                                                         
sys-apps/baselayout:      2.2::gentoo                                                                                                                                             
sys-apps/openrc:          0.19.1::gentoo                                                                                                                                         
sys-apps/sandbox:         2.10-r1::gentoo                                                                                                                                         
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo                                                                                                                             
sys-devel/automake:       1.11.6-r1::gentoo, 1.14.1::gentoo, 1.15::gentoo                                                                                                         
sys-devel/binutils:       2.25.1-r1::gentoo                                                                                                                                       
sys-devel/gcc:            4.9.3::gentoo                                                                                                                                           
sys-devel/gcc-config:     1.7.3::gentoo                                                                                                                                           
sys-devel/libtool:        2.4.6::gentoo                                                                                                                                           
sys-devel/make:           4.1-r1::gentoo                                                                                                                                         
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)                                                                                                                       
sys-libs/glibc:           2.21-r2::gentoo                                                                                                                                         

    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://
    priority: -1000

CFLAGS="-O2 -pipe -march=core-avx2 -O2 -pipe"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=core-avx2 -O2 -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit corefonts cracklib crypt cryptsetup cups cxx dbus declarative device-mapper dlna dri dts dvd dvdr eap-sim emboss encode exif fam firefox flac fortran gdbm gif glamor gpm gtk iconv icu ipv6 java jpeg kde kipi lcms ldap libnotify mad mmx mmxext mng modules mp3 mp4 mpeg multilib ncurses nls nptl nsplugin ntfs ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds pulseaudio qt3support qt4 readline samba sdl seccomp semantic-desktop session spell sqlite sse sse2 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upnp upower usb vorbis wps wxwidgets x264 xattr xcb xcomposite xinerama xml xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="keyboard mouse evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="intel vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

Last edited by astroe on Mon Sep 26, 2016 6:40 am; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 22 Sep 2003
Posts: 42
Location: Utrecht, Holland

PostPosted: Wed Mar 30, 2016 6:59 pm    Post subject: same problem with MX anywhere 2 Reply with quote

I found this topic searching for a solution for the exact same problem.
Logitech MX anywhere 2 mouse here.
I compiled in al the modules under: Networking support -> Bluetooth subsystem support. (except Bluetooth self testing support and Export Bluetooth internals in debugfs)
When starting bluetoothctl everything is normal.
As soon I say scan on it finds the mouse and deletes the controler.
playstation 4 controler works fine.
Back to top
View user's profile Send private message

Joined: 29 Sep 2008
Posts: 33

PostPosted: Tue Apr 26, 2016 9:54 pm    Post subject: Reply with quote


I'm facing same problem with my Logitech MX Anywhere 2. Bluetoothd crashes instantly during connection attempt. No solution found at this moment. Using bluez-5.37, bluedevil-2.1.1
Back to top
View user's profile Send private message

Joined: 12 Aug 2004
Posts: 13
Location: Bucharest, Romania

PostPosted: Thu Jul 28, 2016 5:53 pm    Post subject: Reply with quote

FWIW, at bluez 5.39 and bluedevil 5.6.5 I get the same thing.
Back to top
View user's profile Send private message

Joined: 16 Sep 2005
Posts: 1381
Location: Montréal

PostPosted: Fri Jul 29, 2016 4:25 pm    Post subject: Reply with quote

No problem here with Bluez-5.39 and Blueman-2.0.4.

Bluez is compile with USE flags obex python_targets_python3_4 readline systemd udev

and Blueman with network nls policykit pulseaudio python_single_target_python2_7 python_targets_python2_7 python_targets_python3_4 USE flags.

The processor is Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz (-march=native), Amd64.

I connect H800 Logitech headset and Headrush 8003763.
Back to top
View user's profile Send private message

Joined: 12 Aug 2004
Posts: 13
Location: Bucharest, Romania

PostPosted: Mon Sep 26, 2016 6:40 am    Post subject: Reply with quote

It was an upstream problem with the actual hardware of the mouse. It was solved in bluez-5.41 (currently marked unstable, I emerged it after unmasking), and now my Microsoft mouse works. After getting it to connect, I also had to enable "User-space I/O driver support for HID subsystems" (CONFIG_UHID) in the kernel to get the mouse to be also recognized as an input device.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum