Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Résolu] problèmes de compilation
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Mouski
n00b
n00b


Joined: 25 Jun 2016
Posts: 21

PostPosted: Sat Jun 25, 2016 4:24 pm    Post subject: [Résolu] problèmes de compilation Reply with quote

Bonjour à tous,

Je vous expose rapidement le topo, car il est possible que ce soit lié. J'essaie d'installer une VM à base de Gentoo amd64 sur mon poste sous Archlinux, avec Virtualbox. Je n'ai aucun problème à installer le système de base, qui démarre parfaitement. Arrivé à l'installation d'un environnement bureautique, la compilation échoue sur un paquet. Lors d'un premier essai, sous Gentoo amd64 no-multilib, j'essaie d'installer le bureau Enlightenment, et environ la moitié des paquets compilent sans problème (sur un peu moins de 100), avant de tomber sur un paquet affichant un "emake failed" et des messages du style "recipe for target 'all-recursive' failed" mais pas une seule ligne contenant "error", donc je n'avais aucune idée pour régler mon problème. Au début, je tente de démasquer des versions plus récentes d'Enlightenment, mais je rencontre le même problème. J'ai fait quelques recherches sur le net, et j'en ai conclu sans pouvoir en être sûr que c'était parce que j'étais en no-multilib. Donc ni une, ni deux, je recommence à zéro en étant bien cette fois-ci en multilib. L'installation de base se passe encore une fois sans aucun problème, et cette fois-ci je décide d'installer xfce4. Rebelote, les mêmes problèmes, sauf que j'ai une ligne avec "error". Cette fois-ci j'ai pris soin de récupérer les logs.

Donc ici mon emerge --info :
https://bpaste.net/show/c734d9670e89

Le log du paquet qui échoue (xfce-base/libxfce4ui-4.12.1-r2::gentoo) :
https://bpaste.net/show/240b138de925

Voilà, merci d'avance pour les aiguillages.


Last edited by Mouski on Tue Jun 28, 2016 9:40 am; edited 2 times in total
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3098
Location: Paris

PostPosted: Sat Jun 25, 2016 6:46 pm    Post subject: Reply with quote

Je vois: "error: gdk/gdkx.h: No such file or directory"
Cela ressemble à un dépendance manquante (USE mal renseigné ou ebuild perfectible). Je te laisse chercher la suite :)

Tu peux retirer "Gentoo en invité" de ton titre, cela n'a aucun rapport avec la choucroute, et le remplacer par quelque chose de vraiment parlant ("problème de compilation" sous Gentoo.... enfin tu vois le soucis? ;))
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
Mouski
n00b
n00b


Joined: 25 Jun 2016
Posts: 21

PostPosted: Tue Jun 28, 2016 9:43 am    Post subject: Reply with quote

Bonjour,

Problème résolu, j'étais en profil simple, je suis passé au profil desktop de base. Je trouve ça quand même curieux car s'il s'agit du paquet gdk-pixbuf il était déjà compilé avant.

Enfin, c'est réglé pour Xfce, je vais voir pour Enlightenment.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum