Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Could not find the root block device in UUID=........
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43402
Location: 56N 3W

PostPosted: Tue Jul 26, 2016 8:39 pm    Post subject: Reply with quote

beetterfly,

Just change the kernel line in grub.cfg so that root points to the other mmc card.
You have root=/dev/mmcblk0p2 which looks correct.
Try root=/dev/mmcblk1p2 instead.

The drive or entire card is the /dev/mmcblk0, /dev/mmcblk1, ...
What comes after the numeral is the partition. You have partitions called rpmb, boot0, boot1 all on /dev/mmcblk0.
Well, parted thinks you do.

Much like /dev/sda, /dev/sdb ... refers to a whole drive and the partitions are numbered.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
beetterfly
n00b
n00b


Joined: 17 Jun 2016
Posts: 26

PostPosted: Wed Jul 27, 2016 3:47 pm    Post subject: Reply with quote

I tried, same result. even with your binary kerne, even with rootdelay=10l.
i'm gettin crazy
:evil:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Goto page Previous  1, 2, 3
Page 3 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum