Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Blocks & Slots
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1161
Location: Eppingen, Germany

PostPosted: Sun Oct 16, 2016 1:41 pm    Post subject: Blocks & Slots Reply with quote

Hallo zusammen,

ich versteh wieder was nicht... Auf emerge -auDNtv --backtrack=300 --verbose-conflicts world bekomme ich das hier:


Code:
[blocks B      ] media-gfx/graphicsmagick[imagemagick] ("media-gfx/graphicsmagick[imagemagick]" is blocking media-gfx/imagemagick-6.9.6.2)                                                                     
[blocks B      ] <kde-apps/kde4-l10n-16.08.1 ("<kde-apps/kde4-l10n-16.08.1" is blocking kde-apps/kde-l10n-16.08.1)                                                                                             
[blocks B      ] media-gfx/imagemagick ("media-gfx/imagemagick" is blocking media-gfx/graphicsmagick-1.3.25)                                                                                                   

Total: 260 packages (240 upgrades, 1 downgrade, 10 new, 5 in new slots, 4 reinstalls), Size of downloads: 865.997 KiB
Conflict: 6 blocks (3 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/libxcb:0

  (x11-libs/libxcb-1.12:0/1.12::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, installed) pulled in by
    x11-libs/libxcb:0/1.11.1= required by (lxqt-base/lxqt-config-0.10.0:0/0::gentoo, installed)
                   ^^^^^^^^^^                                                                                                     
    >=x11-libs/libxcb-1.9.1:0/1.11.1=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-0.4.0:0/0::gentoo, installed)                                                                                 
                           ^^^^^^^^^^                                                                                                                             
    x11-libs/libxcb:0/1.11.1=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-keysyms-0.4.0:0/0::gentoo, installed)                                                                                 
                   ^^^^^^^^^^                                                                                                                                     
    >=x11-libs/libxcb-1.9.1:0/1.11.1=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-image-0.4.0:0/0::gentoo, installed)                                                                           
                           ^^^^^^^^^^                                                                                                                                   
    x11-libs/libxcb:0/1.11.1= required by (x11-misc/pcmanfm-qt-0.10.0:0/0::gentoo, installed)
                   ^^^^^^^^^^                                                                                                   
    >=x11-libs/libxcb-1.9.1:0/1.11.1=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-wm-0.4.1-r1:0/0::gentoo, installed)                                                                           
                           ^^^^^^^^^^                                                                                                                                   
    >=x11-libs/libxcb-1.9.1:0/1.11.1=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-renderutil-0.3.9-r1:0/0::gentoo, installed)                                                                   
                           ^^^^^^^^^^                                                                                                                                           

x11-base/xorg-server:0

  (x11-base/xorg-server-1.18.4:0/1.18.4::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-base/xorg-server-1.18[udev] required by (x11-drivers/xf86-input-evdev-2.10.3:0/0::gentoo, ebuild scheduled for merge)
    ^^                     ^^^^                                                                                                                                                       

  (x11-base/xorg-server-1.17.4:0/1.17.4::gentoo, installed) pulled in by
    <x11-base/xorg-server-1.17.99:0/1.17.4= required by (x11-drivers/nvidia-drivers-340.96:0/340::gentoo, installed)
    ^                     ^^^^^^^^^^^^^^^^^                                                                                                                                                   
    x11-base/xorg-server:0/1.17.4= required by (x11-drivers/xf86-input-mouse-1.9.1:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                                                                           
    <x11-base/xorg-server-1.17.99:= required by (x11-drivers/nvidia-drivers-340.96:0/340::gentoo, installed)
    ^                     ^^^^^^^ ^                                                                                                                                                   
    x11-base/xorg-server:0/1.17.4= required by (x11-drivers/xf86-input-keyboard-1.8.1:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                                                                               

lxqt-base/liblxqt:0

  (lxqt-base/liblxqt-0.10.0:0/0::gentoo, installed) pulled in by
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-panel-0.10.0-r1:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                           
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-session-0.10.0:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                         
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-policykit-0.10.0:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                           
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-globalkeys-0.10.0:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                             
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-notificationd-0.10.0:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                               
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-runner-0.10.0:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                         
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-qtplugin-0.10.0:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                           
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-about-0.10.0:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                       
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-config-0.10.0:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                         

  (lxqt-base/liblxqt-0.11.0-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    ~lxqt-base/liblxqt-0.11.0 required by (lxqt-base/lxqt-admin-0.11.0:0/0::gentoo, ebuild scheduled for merge)
    ^                  ^^^^^^                                                                                                                                         
    ~lxqt-base/liblxqt-0.11.0 required by (lxqt-base/lxqt-sudo-0.11.0:0/0::gentoo, ebuild scheduled for merge)
    ^                  ^^^^^^                                                                                                                                       

media-gfx/imagemagick:0

  (media-gfx/imagemagick-6.9.6.2:0/6.9.6.2::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-gfx/imagemagick-6.9.4.6:0/6.9.4.6::gentoo, installed) pulled in by
    media-gfx/imagemagick:0/6.9.4.6= required by (media-gfx/uniconvertor-2.0_pre379-r1:0/0::gentoo, installed)
                         ^^^^^^^^^^^                                                                                                             
    >=media-gfx/imagemagick-5.5.7.14:0/6.9.4.6= required by (media-video/dvdauthor-0.7.1:0/0::gentoo, installed)
                                    ^^^^^^^^^^^                                                                                                     
    media-gfx/imagemagick:0/6.9.4.6= required by (media-video/transcode-1.1.7-r3:0/0::gentoo, installed)
                         ^^^^^^^^^^^                                                                                                       
    media-gfx/imagemagick:0/6.9.4.6= required by (media-libs/xine-lib-1.2.6-r1:1/1::gentoo, installed)
                         ^^^^^^^^^^^                                                                                                     


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-apps/kde4-l10n-16.04.3:4/4::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/kde4-l10n-4.8:4[aqua=,l10n_de(+)] (>=kde-apps/kde4-l10n-4.8:4[-aqua,l10n_de(+)]) required by (x11-misc/lightdm-kde-0.3.2.1-r1:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-4.4:4[aqua=,l10n_de(+)] (>=kde-apps/kde4-l10n-4.4:4[-aqua,l10n_de(+)]) required by (kde-misc/wacomtablet-2.1.0:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-4.4:4[aqua=,l10n_de(+)] (>=kde-apps/kde4-l10n-4.4:4[-aqua,l10n_de(+)]) required by (dev-vcs/kdesvn-1.7.0:4/4::gentoo, ebuild scheduled for merge)
    >=kde-apps/kde4-l10n-4.4:4[aqua=,l10n_de(+)] (>=kde-apps/kde4-l10n-4.4:4[-aqua,l10n_de(+)]) required by (kde-misc/krename-4.0.9-r3:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-16.04.3 required by (kde-apps/kdebase-runtime-meta-16.04.3:5/5::gentoo, ebuild scheduled for merge)
    >=kde-apps/kde4-l10n-4.4:4[aqua=,l10n_de(+)] (>=kde-apps/kde4-l10n-4.4:4[-aqua,l10n_de(+)]) required by (app-cdr/k3b-2.0.3-r2:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-4.4:4[aqua=,l10n_de(+)] (>=kde-apps/kde4-l10n-4.4:4[-aqua,l10n_de(+)]) required by (media-gfx/kuickshow-0.9.1-r2:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-4.13.1:4[aqua=,l10n_de(+)] (>=kde-apps/kde4-l10n-4.13.1:4[-aqua,l10n_de(+)]) required by (kde-misc/tellico-2.3.10:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-4.4:4[aqua=,l10n_de(+)] (>=kde-apps/kde4-l10n-4.4:4[-aqua,l10n_de(+)]) required by (app-text/kding-0.6-r3:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-4.4:4[aqua=,l10n_de(+)] (>=kde-apps/kde4-l10n-4.4:4[-aqua,l10n_de(+)]) required by (kde-misc/krusader-2.4.0_beta3-r2:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-4.4:4[aqua=,l10n_de(+)] (>=kde-apps/kde4-l10n-4.4:4[-aqua,l10n_de(+)]) required by (app-backup/kbackup-0.8-r1:4/4::gentoo, installed)

  (media-gfx/graphicsmagick-1.3.25:0/1.3::gentoo, ebuild scheduled for merge) pulled in by
    media-gfx/graphicsmagick[imagemagick] required by (app-emulation/playonlinux-4.2.4:0/0::gentoo, installed)
    media-gfx/graphicsmagick[imagemagick] required by (gnome-extra/libgsf-1.14.40:0/114::gentoo, ebuild scheduled for merge)
    media-gfx/graphicsmagick required by (media-libs/xine-lib-1.2.6-r1:1/1::gentoo, installed)

  (kde-apps/kde-l10n-16.08.1:5/5::gentoo, installed) pulled in by
    kde-apps/kde-l10n required by @selected
    >=kde-apps/kde-l10n-16.04.3 required by (kde-apps/kde4-l10n-16.04.3:4/4::gentoo, ebuild scheduled for merge)


Eigentlich war ich der Meinung, qt läuft beim updaten einfach mit. Wieso kommen da soviele Slots zusammen? Ich habe keine USE qt4 oder qt5 gesetzt in make.confoder package.use.
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4473

PostPosted: Sun Oct 16, 2016 2:41 pm    Post subject: Reply with quote

wiso meinst du das das problem mit den Qt paketen zu tun hätte?
In den ausgaben sehe ich null von Qt paketen
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3669
Location: Germany

PostPosted: Sun Oct 16, 2016 3:34 pm    Post subject: Reply with quote

Vermutlich sind das meiste nur Folgefehler vom
Code:
[blocks B      ] <kde-apps/kde4-l10n-16.08.1 ("<kde-apps/kde4-l10n-16.08.1" is blocking kde-apps/kde-l10n-16.08.1)
den portage nicht auflösen kann. (den Blocker würde ich als erstes versuchen aufzulösen, und dann weiter schauen)
Prüfe ob die geforderte >=kde-apps/kde4-l10n-16.08.1 Version (ist zZt testing) in deinen Keywords freigeschaltet ist, so das sie auch genutzt werden kann.
Schau mal was
Code:
emerge -av1 \>=kde-apps/kde4-l10n-16.08.1
dazu meint.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1161
Location: Eppingen, Germany

PostPosted: Sun Oct 16, 2016 5:06 pm    Post subject: Reply with quote

:oops: Bin betriebsblind... 3 Tage hatte ich dev-qt/* mehrfach in den slots hängen. Das scheint sich mit dem per-cleaner gelöst zu haben. Ehrlich, ich habe die Liste gar nicht mehr angeschaut.

Nur die Blocks waren plötzlich wieder da, die seit Freitag eigentlich weg waren.

kde-apps/kde4-l10n-16.08.1 muss ich keyworden, bin am testen, ob es jetzt geht.

uhai

Löst sich leider nicht komplett auf:
Code:
[blocks B      ] media-gfx/imagemagick ("media-gfx/imagemagick" is blocking media-gfx/graphicsmagick-1.3.25)                                                                                                   
[blocks B      ] media-gfx/graphicsmagick[imagemagick] ("media-gfx/graphicsmagick[imagemagick]" is blocking media-gfx/imagemagick-6.9.6.2)                                                                     

Total: 260 packages (241 upgrades, 10 new, 5 in new slots, 4 reinstalls), Size of downloads: 866.614 KiB
Conflict: 5 blocks (2 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/libxcb:0

  (x11-libs/libxcb-1.12:0/1.12::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, installed) pulled in by
    x11-libs/libxcb:0/1.11.1= required by (x11-misc/pcmanfm-qt-0.10.0:0/0::gentoo, installed)
                   ^^^^^^^^^^                                                                                                   
    >=x11-libs/libxcb-1.9.1:0/1.11.1=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-wm-0.4.1-r1:0/0::gentoo, installed)                                                                           
                           ^^^^^^^^^^                                                                                                                                   
    >=x11-libs/libxcb-1.9.1:0/1.11.1=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-renderutil-0.3.9-r1:0/0::gentoo, installed)                                                                   
                           ^^^^^^^^^^                                                                                                                                           
    >=x11-libs/libxcb-1.9.1:0/1.11.1=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-image-0.4.0:0/0::gentoo, installed)                                                                           
                           ^^^^^^^^^^                                                                                                                                   
    x11-libs/libxcb:0/1.11.1=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-keysyms-0.4.0:0/0::gentoo, installed)                                                                                 
                   ^^^^^^^^^^                                                                                                                                     
    x11-libs/libxcb:0/1.11.1= required by (lxqt-base/lxqt-config-0.10.0:0/0::gentoo, installed)
                   ^^^^^^^^^^                                                                                                     
    >=x11-libs/libxcb-1.9.1:0/1.11.1=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-0.4.0:0/0::gentoo, installed)                                                                                 
                           ^^^^^^^^^^                                                                                                                             

media-gfx/imagemagick:0

  (media-gfx/imagemagick-6.9.6.2:0/6.9.6.2::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-gfx/imagemagick-6.9.4.6:0/6.9.4.6::gentoo, installed) pulled in by
    media-gfx/imagemagick:0/6.9.4.6= required by (media-gfx/uniconvertor-2.0_pre379-r1:0/0::gentoo, installed)
                         ^^^^^^^^^^^                                                                                                             
    media-gfx/imagemagick:0/6.9.4.6= required by (media-libs/xine-lib-1.2.6-r1:1/1::gentoo, installed)
                         ^^^^^^^^^^^                                                                                                     
    >=media-gfx/imagemagick-5.5.7.14:0/6.9.4.6= required by (media-video/dvdauthor-0.7.1:0/0::gentoo, installed)
                                    ^^^^^^^^^^^                                                                                                     
    media-gfx/imagemagick:0/6.9.4.6= required by (media-video/transcode-1.1.7-r3:0/0::gentoo, installed)
                         ^^^^^^^^^^^                                                                                                       

x11-base/xorg-server:0

  (x11-base/xorg-server-1.18.4:0/1.18.4::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-base/xorg-server-1.18[udev] required by (x11-drivers/xf86-input-evdev-2.10.3:0/0::gentoo, ebuild scheduled for merge)
    ^^                     ^^^^                                                                                                                                                       

  (x11-base/xorg-server-1.17.4:0/1.17.4::gentoo, installed) pulled in by
    x11-base/xorg-server:0/1.17.4= required by (x11-drivers/xf86-input-mouse-1.9.1:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                                                                           
    <x11-base/xorg-server-1.17.99:= required by (x11-drivers/nvidia-drivers-340.96:0/340::gentoo, installed)
    ^                     ^^^^^^^ ^                                                                                                                                                   
    x11-base/xorg-server:0/1.17.4= required by (x11-drivers/xf86-input-keyboard-1.8.1:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                                                                               
    <x11-base/xorg-server-1.17.99:0/1.17.4= required by (x11-drivers/nvidia-drivers-340.96:0/340::gentoo, installed)
    ^                     ^^^^^^^^^^^^^^^^^                                                                                                                                                   

lxqt-base/liblxqt:0

  (lxqt-base/liblxqt-0.11.0-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    ~lxqt-base/liblxqt-0.11.0 required by (lxqt-base/lxqt-sudo-0.11.0:0/0::gentoo, ebuild scheduled for merge)
    ^                  ^^^^^^                                                                                                                                       
    ~lxqt-base/liblxqt-0.11.0 required by (lxqt-base/lxqt-admin-0.11.0:0/0::gentoo, ebuild scheduled for merge)
    ^                  ^^^^^^                                                                                                                                         

  (lxqt-base/liblxqt-0.10.0:0/0::gentoo, installed) pulled in by
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-session-0.10.0:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                         
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-about-0.10.0:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                       
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-runner-0.10.0:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                         
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-qtplugin-0.10.0:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                           
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-policykit-0.10.0:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                           
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-globalkeys-0.10.0:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                             
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-notificationd-0.10.0:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                               
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-panel-0.10.0-r1:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                           
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-config-0.10.0:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                         

app-pda/libimobiledevice:0

  (app-pda/libimobiledevice-1.2.0:0/6::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-pda/libimobiledevice-1.1.6:0/4::gentoo, installed) pulled in by
    >=app-pda/libimobiledevice-1.1.4:0/4= required by (app-pda/ifuse-1.1.3:0/0::gentoo, installed)
                                    ^^^^^                                                                                             


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (media-gfx/graphicsmagick-1.3.25:0/1.3::gentoo, ebuild scheduled for merge) pulled in by
    media-gfx/graphicsmagick[imagemagick] required by (gnome-extra/libgsf-1.14.40:0/114::gentoo, ebuild scheduled for merge)
    media-gfx/graphicsmagick[imagemagick] required by (app-emulation/playonlinux-4.2.4:0/0::gentoo, installed)
    media-gfx/graphicsmagick required by (media-libs/xine-lib-1.2.6-r1:1/1::gentoo, installed)


_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6293

PostPosted: Sun Oct 16, 2016 5:32 pm    Post subject: Reply with quote

Ein Block ist klar: Du musst das imagemagick-Useflag von graphicsmagick wegnehmen/ausschalten.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3669
Location: Germany

PostPosted: Sun Oct 16, 2016 6:04 pm    Post subject: Reply with quote

Code:
x11-base/xorg-server:0

  (x11-base/xorg-server-1.18.4:0/1.18.4::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-base/xorg-server-1.18[udev] required by (x11-drivers/xf86-input-evdev-2.10.3:0/0::gentoo, ebuild scheduled for merge)
    ^^                     ^^^^                                                                                                                                                       

  (x11-base/xorg-server-1.17.4:0/1.17.4::gentoo, installed) pulled in by
    x11-base/xorg-server:0/1.17.4= required by (x11-drivers/xf86-input-mouse-1.9.1:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                                                                           
    <x11-base/xorg-server-1.17.99:= required by (x11-drivers/nvidia-drivers-340.96:0/340::gentoo, installed)
    ^                     ^^^^^^^ ^                                                                                                                                                   
    x11-base/xorg-server:0/1.17.4= required by (x11-drivers/xf86-input-keyboard-1.8.1:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                                                                               
    <x11-base/xorg-server-1.17.99:0/1.17.4= required by (x11-drivers/nvidia-drivers-340.96:0/340::gentoo, installed)

Deine installierte nvidia-drivers-340.96 Version ist mit dem neuen stable xorg-server-1.18 nicht mehr kompatibel. Schalte dir alternativ zb die aktuellere
~x11-drivers/nvidia-drivers-340.98
Version frei, die ist dann auch mit xorg-server-1.18 kompatibel.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1161
Location: Eppingen, Germany

PostPosted: Sun Oct 16, 2016 6:13 pm    Post subject: Reply with quote

@mv:
Ein USE "imagemagick" habe ich entfernt und dann das bekommen:

Code:
[blocks B      ] media-gfx/imagemagick ("media-gfx/imagemagick" is blocking media-gfx/graphicsmagick-1.3.25)

Total: 260 packages (241 upgrades, 10 new, 5 in new slots, 4 reinstalls), Size of downloads: 866.195 KiB
Conflict: 4 blocks (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/libxcb:0

  (x11-libs/libxcb-1.12:0/1.12::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, installed) pulled in by
    >=x11-libs/libxcb-1.9.1:0/1.11.1=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-0.4.0:0/0::gentoo, installed)
                           ^^^^^^^^^^                                                                                                                             
    (and 6 more with the same problem)

x11-base/xorg-server:0

  (x11-base/xorg-server-1.18.4:0/1.18.4::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-base/xorg-server-1.18[udev] required by (x11-drivers/xf86-input-evdev-2.10.3:0/0::gentoo, ebuild scheduled for merge)
    ^^                     ^^^^                                                                                                                                                       

  (x11-base/xorg-server-1.17.4:0/1.17.4::gentoo, installed) pulled in by
    x11-base/xorg-server:0/1.17.4= required by (x11-drivers/xf86-input-mouse-1.9.1:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                                                                           
    <x11-base/xorg-server-1.17.99:= required by (x11-drivers/nvidia-drivers-340.96:0/340::gentoo, installed)
    ^                     ^^^^^^^ ^                                                                                                                                                   
    (and 2 more with the same problems)

media-gfx/imagemagick:0

  (media-gfx/imagemagick-6.9.6.2:0/6.9.6.2::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-gfx/imagemagick-6.9.4.6:0/6.9.4.6::gentoo, installed) pulled in by
    media-gfx/imagemagick:0/6.9.4.6= required by (media-video/transcode-1.1.7-r3:0/0::gentoo, installed)
                         ^^^^^^^^^^^                                                                                                       
    (and 3 more with the same problem)

lxqt-base/liblxqt:0

  (lxqt-base/liblxqt-0.11.0-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    ~lxqt-base/liblxqt-0.11.0 required by (lxqt-base/lxqt-admin-0.11.0:0/0::gentoo, ebuild scheduled for merge)
    ^                  ^^^^^^                                                                                                                                         
    (and 1 more with the same problem)

  (lxqt-base/liblxqt-0.10.0:0/0::gentoo, installed) pulled in by
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-runner-0.10.0:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                         
    (and 8 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (media-gfx/graphicsmagick-1.3.25:0/1.3::gentoo, ebuild scheduled for merge) pulled in by
    media-gfx/graphicsmagick required by (media-libs/xine-lib-1.2.6-r1:1/1::gentoo, installed)
    media-gfx/graphicsmagick[imagemagick] required by (gnome-extra/libgsf-1.14.40:0/114::gentoo, ebuild scheduled for merge)
    media-gfx/graphicsmagick[imagemagick] required by (app-emulation/playonlinux-4.2.4:0/0::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by app-emulation/playonlinux-4.2.4::gentoo
# required by @selected
# required by @world (argument)
>=media-gfx/graphicsmagick-1.3.25 imagemagick


Also wieder dazu? Wie kann ich sehen, wer graphicsmagick reinzieht? Eigentlich müsste imagemagick doch das gleiche können....

@Josef95:
Ich habe hier eine Nvidia Geforce 8400 laufen. Anscheinend unterstützt nvidia die nicht mehr mit den neueren Treibern. Daher habe ich auf 3.40 eingefroren.... Sollte ich evtl. mal die Hardware updaten?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3669
Location: Germany

PostPosted: Sun Oct 16, 2016 6:36 pm    Post subject: Reply with quote

uhai wrote:
@Josef95:
Ich habe hier eine Nvidia Geforce 8400 laufen. Anscheinend unterstützt nvidia die nicht mehr mit den neueren Treibern. Daher habe ich auf 3.40 eingefroren.

Hehe, die vorgeschlagene ~x11-drivers/nvidia-drivers-340.98 Version ist eine 340er Version.
340.98 ist zZt exakt die Version die dir laut der nvidia Homepage für deine Geforce 8400 vorgeschlagen wird - sollte also fein passen :)
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3669
Location: Germany

PostPosted: Sun Oct 16, 2016 6:49 pm    Post subject: Reply with quote

uhai wrote:
Wie kann ich sehen, wer graphicsmagick reinzieht? Eigentlich müsste imagemagick doch das gleiche können....

Schau in deiner emerge Ausgabe -->
Code:
  (media-gfx/graphicsmagick-1.3.25:0/1.3::gentoo, ebuild scheduled for merge) pulled in by
    media-gfx/graphicsmagick required by (media-libs/xine-lib-1.2.6-r1:1/1::gentoo, installed)
    media-gfx/graphicsmagick[imagemagick] required by (gnome-extra/libgsf-1.14.40:0/114::gentoo, ebuild scheduled for merge)
    media-gfx/graphicsmagick[imagemagick] required by (app-emulation/playonlinux-4.2.4:0/0::gentoo, installed)

Vermutlich ist dies aber nur eine irreführende Fehlermeldung, da zZt die Subslots noch nicht sauber mit aufgelöst werden können (ich hab in den ebuilds nachgesehen, und keines fordert zwingend graphicsmagick zu deinem schon installierten (aber noch nicht aktualisierten) imagemagick.
Eventuell hilft es auch zunächst temporär (wie in der emerge Ausgabe vorgeschlagen) media-gfx/graphicsmagick hart zu maskieren - dann wird es wahrscheinlich eine besser lesbare Fehlermeldung geben.

Vorschlag: Kümmere dich erst mal um den nvidia-drivers / xorg-server
und den lxqt Versionskonflikt. Und nimm dann bitte auch wieder die --backtrack=300 --verbose-conflicts Optionen mit hinzu.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1161
Location: Eppingen, Germany

PostPosted: Sun Oct 16, 2016 8:06 pm    Post subject: Reply with quote

Code:
[blocks B      ]  <x11-themes/gnome-themes-standard-3.20.2-r1 ("<x11-themes/gnome-themes-standard-3.20.2-r1" is blocking x11-themes/gtk-engines-adwaita-3.20.2)
[blocks B      ] media-video/nvidia-settings ("media-video/nvidia-settings" is blocking x11-drivers/nvidia-drivers-340.98)

Total: 258 packages (242 upgrades, 7 new, 5 in new slots, 4 reinstalls), Size of downloads: 928.487 KiB
Conflict: 4 blocks (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/libxcb:0

  (x11-libs/libxcb-1.12:0/1.12::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, installed) pulled in by
    >=x11-libs/libxcb-1.9.1:0/1.11.1=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-image-0.4.0:0/0::gentoo, installed)
                           ^^^^^^^^^^                                                                                                                                   
    >=x11-libs/libxcb-1.9.1:0/1.11.1=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-wm-0.4.1-r1:0/0::gentoo, installed)
                           ^^^^^^^^^^                                                                                                                                   
    x11-libs/libxcb:0/1.11.1=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-keysyms-0.4.0:0/0::gentoo, installed)
                   ^^^^^^^^^^                                                                                                                                     
    >=x11-libs/libxcb-1.9.1:0/1.11.1=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-0.4.0:0/0::gentoo, installed)
                           ^^^^^^^^^^                                                                                                                             
    x11-libs/libxcb:0/1.11.1= required by (x11-misc/pcmanfm-qt-0.10.0:0/0::gentoo, installed)
                   ^^^^^^^^^^                                                                                                   
    x11-libs/libxcb:0/1.11.1= required by (lxqt-base/lxqt-config-0.10.0:0/0::gentoo, installed)
                   ^^^^^^^^^^                                                                                                     
    >=x11-libs/libxcb-1.9.1:0/1.11.1=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-renderutil-0.3.9-r1:0/0::gentoo, installed)
                           ^^^^^^^^^^                                                                                                                                           

media-gfx/imagemagick:0

  (media-gfx/imagemagick-6.9.6.2:0/6.9.6.2::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-gfx/imagemagick-6.9.4.6:0/6.9.4.6::gentoo, installed) pulled in by
    >=media-gfx/imagemagick-5.5.7.14:0/6.9.4.6= required by (media-video/dvdauthor-0.7.1:0/0::gentoo, installed)
                                    ^^^^^^^^^^^                                                                                                     
    media-gfx/imagemagick:0/6.9.4.6= required by (media-gfx/uniconvertor-2.0_pre379-r1:0/0::gentoo, installed)
                         ^^^^^^^^^^^                                                                                                             
    media-gfx/imagemagick:0/6.9.4.6= required by (media-video/transcode-1.1.7-r3:0/0::gentoo, installed)
                         ^^^^^^^^^^^                                                                                                       
    media-gfx/imagemagick:0/6.9.4.6= required by (media-libs/xine-lib-1.2.6-r1:1/1::gentoo, installed)
                         ^^^^^^^^^^^                                                                                                     

x11-base/xorg-server:0

  (x11-base/xorg-server-1.18.4:0/1.18.4::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-base/xorg-server-1.18[udev] required by (x11-drivers/xf86-input-evdev-2.10.3:0/0::gentoo, ebuild scheduled for merge)
    ^^                     ^^^^                                                                                                                                                       

  (x11-base/xorg-server-1.17.4:0/1.17.4::gentoo, installed) pulled in by
    x11-base/xorg-server:0/1.17.4= required by (x11-drivers/xf86-input-keyboard-1.8.1:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                                                                               
    x11-base/xorg-server:0/1.17.4= required by (x11-drivers/xf86-input-mouse-1.9.1:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                                                                           

lxqt-base/liblxqt:0

  (lxqt-base/liblxqt-0.11.0-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    ~lxqt-base/liblxqt-0.11.0 required by (lxqt-base/lxqt-sudo-0.11.0:0/0::gentoo, ebuild scheduled for merge)
    ^                  ^^^^^^                                                                                                                                       
    ~lxqt-base/liblxqt-0.11.0 required by (lxqt-base/lxqt-admin-0.11.0:0/0::gentoo, ebuild scheduled for merge)
    ^                  ^^^^^^                                                                                                                                         

  (lxqt-base/liblxqt-0.10.0:0/0::gentoo, installed) pulled in by
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-qtplugin-0.10.0:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                           
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-runner-0.10.0:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                         
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-notificationd-0.10.0:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                               
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-policykit-0.10.0:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                           
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-panel-0.10.0-r1:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                           
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-globalkeys-0.10.0:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                             
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-about-0.10.0:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                       
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-session-0.10.0:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                         
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-config-0.10.0:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                         


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (media-video/nvidia-settings-340.58-r1:0/0::gentoo, installed) pulled in by
    media-video/nvidia-settings required by (app-admin/conky-1.9.0-r3:0/0::gentoo, installed)

  (x11-drivers/nvidia-drivers-340.98:0/340::gentoo, ebuild scheduled for merge) pulled in by
    x11-drivers/nvidia-drivers required by @selected
    x11-drivers/nvidia-drivers required by (x11-base/xorg-drivers-1.18-r1:0/0::gentoo, ebuild scheduled for merge)
    x11-drivers/nvidia-drivers:0/340 required by (media-video/nvidia-settings-340.58-r1:0/0::gentoo, installed)


Den gtk-themes Block hatte ich heute morgen schon mal weg.... warum kommt der jetzt wieder?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3669
Location: Germany

PostPosted: Sun Oct 16, 2016 8:53 pm    Post subject: Reply with quote

uhai wrote:
Code:
(media-video/nvidia-settings-340.58-r1:0/0::gentoo, installed) pulled in by
    media-video/nvidia-settings required by (app-admin/conky-1.9.0-r3:0/0::gentoo, installed)

Ja, =conky-1.9.0-r3 mit nvidia Useflag fordert noch strickt das separate media-video/nvidia-settings Paket, welches sich mit dem aktuellen nvidia-drivers-340.98 nicht mehr verträgt.
Die neueren nvidia-drivers bringen nun (mit USE=tools) ein eigenes nvidia-settings Tool mit (welches auch die neueren conky Versionen nutzen können).

Vorschlag:
Baue app-admin/conky mit USE=-nvidia
dann wird nvidia-settings nicht mehr benötigt (sofern du drauf verzichten kannst)
oder (sofern möglich)
nimm eine aktuellere app-admin/conky Version, die sind dann auch mit den neueren nvidia-drivers kompatibel.
Bei letzteren musst du die nvidia-drivers dann mit USE="static-libs tools" bauen, dann brauchst das blockierende separate nvidia-settings Paket nicht mehr.
Schau es dir am besten einfach mal in den ebuilds an,
zb via
Code:
less `equery w app-admin/conky-1.9.0-r3`
less `equery w app-admin/conky-1.10.5`
darin sind die Deps fein einsehbar :)
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1161
Location: Eppingen, Germany

PostPosted: Mon Oct 17, 2016 6:20 pm    Post subject: Reply with quote

Das hier verstehe ich auch nicht:

Code:
!!! All ebuilds that could satisfy ">=x11-base/xorg-drivers-1.18" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-base/xorg-drivers-1.18-r1::gentoo (masked by: )

(dependency required by "x11-base/xorg-server-1.18.4::gentoo[xorg]" [ebuild])
(dependency required by "x11-drivers/xf86-input-evdev-2.9.2::gentoo" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


weil:

Code:
 eix xorg-server
[U] x11-base/xorg-server
     Verfügbare Versionen:   1.12.4-r5(0/1.12.4) 1.12.4-r5(0/1.12.4)[1] 1.12.4-r7(0/1.12.4) 1.12.4-r7(0/1.12.4)[1] 1.15.2-r2(0/1.15.2) 1.15.2-r2(0/1.15.2)[1] 1.15.2-r4(0/1.15.2) 1.15.2-r4(0/1.15.2)[1] 1.16.4(0/1.16.1) 1.16.4(0/1.16.1)[1] 1.16.4-r5(0/1.16.1) 1.16.4-r5(0/1.16.1)[1] 1.17.4(0/1.17.4) 1.17.4(0/1.17.4)[1] ~1.18.0(0/1.18.0)[1] ~1.18.1(0/1.18.1)[1] ~1.18.2(0/1.18.2)[1] ~1.18.3(0/1.18.3)[1] 1.18.4(0/1.18.4)[1] {dmx doc glamor ipv6 kdrive libressl minimal nptl selinux static-libs +suid systemd tslib +udev unwind wayland xephyr xnest xorg xvfb}       
     Installierte Versionen: 1.17.4(10:07:46 16.04.2016)(doc glamor ipv6 nptl suid systemd udev xorg -dmx -kdrive -libressl -minimal -selinux -static-libs -tslib -unwind -wayland -xephyr -xnest -xvfb)                                                                                 
     Startseite:             http://xorg.freedesktop.org/
     Beschreibung:           X.Org X servers


xorg-server-1.18.4 ist nicht masked, also müsste portage den doch nehmen, oder?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6293

PostPosted: Mon Oct 17, 2016 6:50 pm    Post subject: Reply with quote

uhai wrote:
Also wieder dazu?

Nein. Die Meldungen kommen nur, weil Portage "falsch" versucht, einen Konflikt zu lösen: Die beiden Pakete, die angeblich media-gfx/graphicsmagick[imagemagick] brauchen, wären auch mit media-gfx/imagemagick zufrieden. Vielleicht reicht wirklich Dein --backtrack-Wert nicht aus; in jedem Fall ist der eigentliche Konflikt woanders.
Quote:
Eigentlich müsste imagemagick doch das gleiche können....

Leider nein: graphicsmagick emuliert nur die Binaries, aber einige Pakete greifen auf die zugrundeliegenden Bibliotheken von imagemagick zurück.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1161
Location: Eppingen, Germany

PostPosted: Mon Oct 17, 2016 6:57 pm    Post subject: Reply with quote

Mein backtrack=300 - 500 - dauert so schon lange, soll ich den noch höher setzen?

Im Moment hätte ich gerne den Block xorg-server weg und die Slots bereinigt...

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3669
Location: Germany

PostPosted: Mon Oct 17, 2016 7:36 pm    Post subject: Reply with quote

Hm, ist schwierig da du nicht dazugeschrieben hast zu welcher Variante mit dem nvidia-drivers nvidia-settings conky du dich entschieden hast :-/
Ich gehe mal von letzterer aus.
Falls ja, dann unmerge nvidia-settings am besten erst, und versuche dann zunächst ein
Code:
emerge -av1 x11-base/xorg-drivers x11-base/xorg-server @x11-module-rebuild app-admin/conky
durchzubringen.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1161
Location: Eppingen, Germany

PostPosted: Mon Oct 17, 2016 8:11 pm    Post subject: Reply with quote

conky-1.9.0-r3 mit -nvidia.

War das die letzte Variante?

Scheint so, das läuft jetzt.

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1161
Location: Eppingen, Germany

PostPosted: Tue Oct 18, 2016 5:55 pm    Post subject: Reply with quote

Nur noch die Slots:

Code:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/libxcb:0

  (x11-libs/libxcb-1.12:0/1.12::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, installed) pulled in by
    >=x11-libs/libxcb-1.9.1:0/1.11.1=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-0.4.0:0/0::gentoo, installed)
                           ^^^^^^^^^^                                                                                                                             
    >=x11-libs/libxcb-1.9.1:0/1.11.1=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-renderutil-0.3.9-r1:0/0::gentoo, installed)                                                                                                         
                           ^^^^^^^^^^                                                                                                                                           
    x11-libs/libxcb:0/1.11.1= required by (lxqt-base/lxqt-config-0.10.0:0/0::gentoo, installed)
                   ^^^^^^^^^^                                                                                                     
    >=x11-libs/libxcb-1.9.1:0/1.11.1=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-image-0.4.0:0/0::gentoo, installed)
                           ^^^^^^^^^^                                                                                                                                   
    >=x11-libs/libxcb-1.9.1:0/1.11.1=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-wm-0.4.1-r1:0/0::gentoo, installed)
                           ^^^^^^^^^^                                                                                                                                   
    x11-libs/libxcb:0/1.11.1=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-keysyms-0.4.0:0/0::gentoo, installed)
                   ^^^^^^^^^^                                                                                                                                     
    x11-libs/libxcb:0/1.11.1= required by (x11-misc/pcmanfm-qt-0.10.0:0/0::gentoo, installed)
                   ^^^^^^^^^^                                                                                                   

lxqt-base/liblxqt:0

  (lxqt-base/liblxqt-0.11.0-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    ~lxqt-base/liblxqt-0.11.0 required by (lxqt-base/lxqt-sudo-0.11.0:0/0::gentoo, ebuild scheduled for merge)
    ^                  ^^^^^^                                                                                                                                       
    ~lxqt-base/liblxqt-0.11.0 required by (lxqt-base/lxqt-admin-0.11.0:0/0::gentoo, ebuild scheduled for merge)
    ^                  ^^^^^^                                                                                                                                         

  (lxqt-base/liblxqt-0.10.0:0/0::gentoo, installed) pulled in by
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-globalkeys-0.10.0:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                             
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-runner-0.10.0:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                         
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-notificationd-0.10.0:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                               
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-config-0.10.0:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                         
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-panel-0.10.0-r1:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                           
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-session-0.10.0:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                         
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-qtplugin-0.10.0:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                           
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-policykit-0.10.0:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                           
    ~lxqt-base/liblxqt-0.10.0 required by (lxqt-base/lxqt-about-0.10.0:0/0::gentoo, installed)
    ^                  ^^^^^^                                                                                                                       

app-pda/libimobiledevice:0

  (app-pda/libimobiledevice-1.2.0:0/6::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-pda/libimobiledevice-1.1.6:0/4::gentoo, installed) pulled in by
    >=app-pda/libimobiledevice-1.1.4:0/4= required by (app-pda/ifuse-1.1.3:0/0::gentoo, installed)
                                    ^^^^^                                                         

Zur Schreibweise:
"app-pda/libimobiledevice-1.1.6:0/4" heißt Version 1.1.6 in Slot 0 von 4 möglichen (?) Ist damit Slot 0 belegt, so das die Version 1.1.6 keinen Platz findet? Und was ist "::gentoo"? Was markiert portage mit ^^^^? - liegt da der Hund begraben? In eckigen Klammern werden USE-Flags angezeigt. Heißt (-) dass das Use fehlt oder dass es entfernt werden soll? Und bedeutet "(no parents that aren't satisfied by other packages in this slot)" dass das neue Paket gar nicht zwingend benötigt wird? Die lxqt-base/* werden mit ~ und ^ begonnen. Was bedeutet der Hinweis?

Allerdings verstehe ich das nicht:

Das ebuild von x11-libs/xcb-util-0.4.0 fordert doch >=x11-libs/libxcb-1.9.1. Und x11-libs/libxcb-1.12 erfüllt die Bedingung. Also wo ist das Problem?

Code:
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

XORG_MODULE=/
XORG_BASE_INDIVIDUAL_URI=https://xcb.freedesktop.org/dist
XORG_DOC=doc
XORG_MULTILIB=yes
inherit xorg-2

EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/util"

DESCRIPTION="X C-language Bindings sample implementations"
HOMEPAGE="https://xcb.freedesktop.org/"

KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
IUSE="test"

RDEPEND=">=x11-libs/libxcb-1.9.1:=[${MULTILIB_USEDEP}]
        >=x11-proto/xproto-7.0.24:=[${MULTILIB_USEDEP}]"
DEPEND="${RDEPEND}
        >=dev-util/gperf-3.0.1
        test? ( >=dev-libs/check-0.9.11[${MULTILIB_USEDEP}] )"

PDEPEND="
        >=x11-libs/xcb-util-cursor-0.1.1:=[${MULTILIB_USEDEP}]
        >=x11-libs/xcb-util-image-${PV}:=[${MULTILIB_USEDEP}]
        >=x11-libs/xcb-util-keysyms-${PV}:=[${MULTILIB_USEDEP}]
        >=x11-libs/xcb-util-renderutil-0.3.9:=[${MULTILIB_USEDEP}]
        >=x11-libs/xcb-util-wm-${PV}:=[${MULTILIB_USEDEP}]
"

src_configure() {
        XORG_CONFIGURE_OPTIONS=(
                $(use_with doc doxygen)
        )
        xorg-2_src_configure

_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6293

PostPosted: Tue Oct 18, 2016 6:55 pm    Post subject: Reply with quote

Das libxcb-Problem wird sich vermutlich von selbst lösen, wenn die anderen Konflikte gelöst sind: Die Subslots passen nicht und bedeuten, dass portage nach dem libxcb-Upgrade eine ganze Reihe von Paketen neu emergen muss.

Das eigentliche Problem dürfte das lxqt-Zeugs sein: Anscheinend hast Du kxqt-sudo in der -0.11-Version demaskiert, die anderen nur in der 0.10-Version. Du brauchst aber anscheinend von allem die selbe Version.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1161
Location: Eppingen, Germany

PostPosted: Tue Oct 18, 2016 7:05 pm    Post subject: Reply with quote

Das habe ich in package.accept_keywords/lxqt:

Code:
dev-qt/*
lxqt-base/*
media-gfx/lximage-qt
x11-misc/obconf-qt
x11-misc/pcmanfm-qt
x11-misc/sddm


Damit wäre die jeweils aktuelle Version doch frei, oder nicht?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3669
Location: Germany

PostPosted: Wed Oct 19, 2016 3:03 pm    Post subject: Reply with quote

Vermutlich ist das neue lxqt 0.11 im Tree noch nicht wirklich komplett (lxqt-meta-0.11 ist zb noch nicht da).
Schau zb mal mit
Code:
eix -C lxqt-base

Und ja, passend die verfügbaren 0.10er Versionen freischalten sollte funktionieren.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1161
Location: Eppingen, Germany

PostPosted: Thu Oct 20, 2016 4:25 am    Post subject: Reply with quote

Stimmt, da sind vershciedene Versionsstände. Kann ich die lxqt-Pakete irgendwie übergehen?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3669
Location: Germany

PostPosted: Sat Oct 22, 2016 7:58 pm    Post subject: Reply with quote

Na, die paar Pakete mit passender Version in deiner package.accept_keywords/lxqt mit setzen ist doch wahrscheinlich am saubersten, und auch fix erledigt.
Oder anders herum gefragt, was spricht denn dagegen? :)
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1161
Location: Eppingen, Germany

PostPosted: Mon Oct 24, 2016 6:11 pm    Post subject: Reply with quote

anscheinend gibt es die 0.11 noch nicht für alle Pakete...

Meine package.accept_keywords/lxqt enthält schon alles, oder nicht?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6293

PostPosted: Tue Oct 25, 2016 7:04 am    Post subject: Reply with quote

uhai wrote:
anscheinend gibt es die 0.11 noch nicht für alle Pakete...

Was Du klären musst: Noch nicht, oder nicht mehr?
Ich halte Letzteres für wahrscheinlicher: Entweder wurde die Funktionalität von einem Paket in ein anderes übernommen, oder sie wurde entferrnt (was seit einigen Jahren bei etlichen Projekte traurige Mode geworden ist: gnome3, mplayer2, mpv, parted drängen sich da unangenehm in Erinnerung).
Wenn Du jemals upgraden willst, bleibt Dir nichts anderes übrig, als die entsprechenden "obsoleten" Pakete zu deinstallieren und aus dem world-File zu entfernen.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3669
Location: Germany

PostPosted: Sat Oct 29, 2016 3:39 pm    Post subject: Reply with quote

Heute Nachmittag gab es im Tree bezüglich lxqt-0.11 ein paar Anpassungen, Ergänzungen usw
auch lxqt-base/lxqt-meta-0.11.0 ist nun (hoffentlich mit passenden Deps) verfügbar :)

Vorschlag: Teste es mal nach einem frischen emerge --sync
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum