Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Plymouth or Fbsplash
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
DancesWithWords
Guru
Guru


Joined: 29 Jun 2002
Posts: 342
Location: ottawa, canada

PostPosted: Sat Oct 29, 2016 5:06 pm    Post subject: Plymouth or Fbsplash Reply with quote

I'm wonder does anyone have plymouth or Fbsplash working on a current kernel? I've got kernel 4.4.26 installed but I'm uncertain if either of the framebuffer software will work. The gentoo wiki is not much help as it is out of date with current kernels.

Do gentoo users even bother with framebuffer software anymore?

Help, suggestions and comments are welcome?

====
DWW
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22057
Location: here

PostPosted: Sun Oct 30, 2016 8:01 am    Post subject: Reply with quote

I use fbsplash but with kernel 4.7.10. What's your problem?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
DancesWithWords
Guru
Guru


Joined: 29 Jun 2002
Posts: 342
Location: ottawa, canada

PostPosted: Sun Oct 30, 2016 6:38 pm    Post subject: Reply with quote

fedeliallalinea wrote:
I use fbsplash but with kernel 4.7.10. What's your problem?


First of all when I use fbsplash and I go to test it using:splash_manager -c set --theme=natural_gentoo --tty=1
I get the error message: Failed to open the fbcon_decor control device.

This leads me to look for [*] Support for the Framebuffer Console Decorations in the kernel

Apparently that option has been taken out of the kernel I'm using.

CONFIG_FB=y
CONFIG_FIRMWARE_EDID=y
CONFIG_FB_CMDLINE=y
# CONFIG_FB_DDC is not set
CONFIG_FB_BOOT_VESA_SUPPORT=y
CONFIG_FB_CFB_FILLRECT=y
CONFIG_FB_CFB_COPYAREA=y
CONFIG_FB_CFB_IMAGEBLIT=y
# CONFIG_FB_CFB_REV_PIXELS_IN_BYTE is not set
CONFIG_FB_SYS_FILLRECT=m
CONFIG_FB_SYS_COPYAREA=m
CONFIG_FB_SYS_IMAGEBLIT=m
# CONFIG_FB_FOREIGN_ENDIAN is not set
CONFIG_FB_SYS_FOPS=m
# CONFIG_FB_SVGALIB is not set
# CONFIG_FB_MACMODES is not set
# CONFIG_FB_BACKLIGHT is not set
CONFIG_FB_MODE_HELPERS=y
CONFIG_FB_TILEBLITTING=y

#
# Frame buffer hardware drivers
#
# CONFIG_FB_CIRRUS is not set
# CONFIG_FB_PM2 is not set
# CONFIG_FB_CYBER2000 is not set
# CONFIG_FB_ARC is not set
# CONFIG_FB_ASILIANT is not set
# CONFIG_FB_IMSTT is not set
# CONFIG_FB_VGA16 is not set
CONFIG_FB_UVESA=m
CONFIG_FB_VESA=y
CONFIG_FB_EFI=y
# CONFIG_FB_N411 is not set
# CONFIG_FB_HGA is not set
# CONFIG_FB_OPENCORES is not set
# CONFIG_FB_S1D13XXX is not set
# CONFIG_FB_NVIDIA is not set
# CONFIG_FB_RIVA is not set
# CONFIG_FB_I740 is not set
# CONFIG_FB_LE80578 is not set
# CONFIG_FB_MATROX is not set
# CONFIG_FB_RADEON is not set
# CONFIG_FB_ATY128 is not set
# CONFIG_FB_ATY is not set
# CONFIG_FB_S3 is not set
# CONFIG_FB_SAVAGE is not set
# CONFIG_FB_SIS is not set
# CONFIG_FB_NEOMAGIC is not set
# CONFIG_FB_KYRO is not set
# CONFIG_FB_3DFX is not set
# CONFIG_FB_VOODOO1 is not set
# CONFIG_FB_VT8623 is not set
# CONFIG_FB_TRIDENT is not set
# CONFIG_FB_ARK is not set
# CONFIG_FB_PM3 is not set
# CONFIG_FB_CARMINE is not set
# CONFIG_FB_SMSCUFX is not set
# CONFIG_FB_UDL is not set
# CONFIG_FB_IBM_GXT4500 is not set
# CONFIG_FB_VIRTUAL is not set
# CONFIG_FB_METRONOME is not set
# CONFIG_FB_MB862XX is not set
# CONFIG_FB_BROADSHEET is not set
# CONFIG_FB_AUO_K190X is not set
# CONFIG_FB_SIMPLE is not set
# CONFIG_FB_SM712 is not set
CONFIG_BACKLIGHT_LCD_SUPPORT=y
# CONFIG_LCD_CLASS_DEVICE is not set
CONFIG_BACKLIGHT_CLASS_DEVICE=y
CONFIG_BACKLIGHT_GENERIC=y
# CONFIG_BACKLIGHT_APPLE is not set
# CONFIG_BACKLIGHT_PM8941_WLED is not set
# CONFIG_BACKLIGHT_SAHARA is not set
# CONFIG_BACKLIGHT_ADP8860 is not set
# CONFIG_BACKLIGHT_ADP8870 is not set
# CONFIG_BACKLIGHT_LM3639 is not set
# CONFIG_BACKLIGHT_LV5207LP is not set
# CONFIG_BACKLIGHT_BD6107 is not set
# CONFIG_VGASTATE is not set
CONFIG_HDMI=y

#
# Console display driver support
#
CONFIG_VGA_CONSOLE=y
CONFIG_VGACON_SOFT_SCROLLBACK=y
CONFIG_VGACON_SOFT_SCROLLBACK_SIZE=64
CONFIG_DUMMY_CONSOLE=y
CONFIG_DUMMY_CONSOLE_COLUMNS=80
CONFIG_DUMMY_CONSOLE_ROWS=25
CONFIG_FRAMEBUFFER_CONSOLE=y
CONFIG_FRAMEBUFFER_CONSOLE_DETECT_PRIMARY=y
# CONFIG_FRAMEBUFFER_CONSOLE_ROTATION is not set
# CONFIG_LOGO is not set
CONFIG_SOUND=y




Any suggestions?


=====
DWW


Last edited by DancesWithWords on Sun Oct 30, 2016 6:53 pm; edited 1 time in total
Back to top
View user's profile Send private message
otakugeek
n00b
n00b


Joined: 26 Jun 2014
Posts: 50

PostPosted: Sun Oct 30, 2016 6:44 pm    Post subject: Reply with quote

buildkernel is static I really don't like.

Plymouth has more powerful, more animation, more effcts and work with openrc.
Back to top
View user's profile Send private message
otakugeek
n00b
n00b


Joined: 26 Jun 2014
Posts: 50

PostPosted: Sun Oct 30, 2016 6:48 pm    Post subject: Reply with quote

look that : https://forums.gentoo.org/viewtopic-t-1039070-highlight-plymouth+theme.html
Back to top
View user's profile Send private message
unheatedgarage
n00b
n00b


Joined: 19 Sep 2016
Posts: 51

PostPosted: Sun Oct 30, 2016 8:29 pm    Post subject: Reply with quote

I'm running Plymouth and kernel 4.8.5 without issue--using systemd and genkernel-next.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22057
Location: here

PostPosted: Mon Oct 31, 2016 8:43 am    Post subject: Reply with quote

DancesWithWords wrote:
Any suggestions?

Try to remove CONFIG_FB_TILEBLITTING config and FB_CON_DECOR appear

Code:
Symbol: FB_CON_DECOR [=y]                             
   Type  : boolean                         
   Prompt: Support for the Framebuffer Console Decorations     Location:                                 
       -> Device Drivers                                                                               
         -> Graphics support                                                                                                         
           -> Console display driver support
             -> Framebuffer Console support (FRAMEBUFFER_CONSOLE [=y])             
     Defined at drivers/video/console/Kconfig:133                                       
     Depends on: HAS_IOMEM [=y] && VT [=y] && FRAMEBUFFER_CONSOLE [=y]=y && !FB_TILEBLITTING [=n]

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
DancesWithWords
Guru
Guru


Joined: 29 Jun 2002
Posts: 342
Location: ottawa, canada

PostPosted: Wed Nov 02, 2016 1:06 am    Post subject: Reply with quote

fedeliallalinea wrote:
DancesWithWords wrote:
Any suggestions?

Try to remove CONFIG_FB_TILEBLITTING config and FB_CON_DECOR appear

Code:
Symbol: FB_CON_DECOR [=y]                             
   Type  : boolean                         
   Prompt: Support for the Framebuffer Console Decorations     Location:                                 
       -> Device Drivers                                                                               
         -> Graphics support                                                                                                         
           -> Console display driver support
             -> Framebuffer Console support (FRAMEBUFFER_CONSOLE [=y])             
     Defined at drivers/video/console/Kconfig:133                                       
     Depends on: HAS_IOMEM [=y] && VT [=y] && FRAMEBUFFER_CONSOLE [=y]=y && !FB_TILEBLITTING [=n]


Well I've managed to make some small progress. However I've not getting access to any of the theme but the basic grey screen with 3 square dots. Any reason that should be so? And better yet what do I need to do to fix it.


=====
DWW
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22057
Location: here

PostPosted: Wed Nov 02, 2016 7:01 am    Post subject: Reply with quote

DancesWithWords wrote:
Well I've managed to make some small progress. However I've not getting access to any of the theme but the basic grey screen with 3 square dots. Any reason that should be so? And better yet what do I need to do to fix it.

If you try to test theme with command splash_manager -c set --theme=natural_gentoo --tty=1, the theme work or return a message error?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
DancesWithWords
Guru
Guru


Joined: 29 Jun 2002
Posts: 342
Location: ottawa, canada

PostPosted: Wed Nov 02, 2016 11:34 pm    Post subject: Reply with quote

fedeliallalinea wrote:
DancesWithWords wrote:
Well I've managed to make some small progress. However I've not getting access to any of the theme but the basic grey screen with 3 square dots. Any reason that should be so? And better yet what do I need to do to fix it.

If you try to test theme with command splash_manager -c set --theme=natural_gentoo --tty=1, the theme work or return a message error?


I believe that is for fbsplash and I'm presently testing plymouth, but for the record this did work.



Note: I just did some more reading and I've got plymouth up and running. I have noticed that once the boot up process is done and handed over to SDDM I've got no TTY1 decorations. Is this true of all the themes or specific to the theme spinfinity?


=====
DWW
Back to top
View user's profile Send private message
DancesWithWords
Guru
Guru


Joined: 29 Jun 2002
Posts: 342
Location: ottawa, canada

PostPosted: Thu Nov 03, 2016 11:24 pm    Post subject: Reply with quote

otakugeek wrote:
look that : https://forums.gentoo.org/viewtopic-t-1039070-highlight-plymouth+theme.html


I've got your gentoo theme up and running on my desktop. Thanks.


It does look that plymouth is not what I want for my server. As it has no X running I'd like the terminal to have a little pazz so I'm going to look at run fbsplash there or try anyways.


=====
DWW
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum