Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Why does my system want ~amd64 ncurses? [SOLVED?]
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2660

PostPosted: Mon Dec 05, 2016 11:55 pm    Post subject: Reply with quote

michi-monster wrote:
I have the same error and can not find a solution. The information in the thread I have read. Unfortunately no further. Can someone help me?

Are you using the complete graph?
Code:
$ emerge -uDUavt --with-bdeps=y --complete-graph @world
This should resolve them all. Rebuilds caused by dev-libs/icu are normal and should work without problems.
Back to top
View user's profile Send private message
michi-monster
Apprentice
Apprentice


Joined: 16 Aug 2016
Posts: 175
Location: Germany

PostPosted: Tue Dec 06, 2016 10:21 am    Post subject: Reply with quote

I try it. But i get an other error

Code:
talled)
                    ^^^^^
    sys-libs/ncurses:0/5= required by (dev-scheme/guile-1.8.8-r3:12/8::gentoo, nstalled)
                    ^^^^^
    sys-libs/ncurses:0/5= required by (app-text/hunspell-1.3.3:0/0::gentoo, insalled)
                    ^^^^^
    sys-libs/ncurses:0/5[cxx,gpm,unicode,abi_x86_64(-)] required by (sys-libs/nurses-5.9-r99:5/5::gentoo, installed)
                    ^^^^                               
    sys-libs/ncurses:0/5= required by (dev-lang/ruby-2.0.0_p648:2.0/2.0::gentoo installed)
                    ^^^^^
    >=sys-libs/ncurses-5.9-r3:0/5=[abi_x86_64(-)] required by (sys-devel/llvm-37.1-r3:0/3.7.1::gentoo, installed)
                             ^^^^^               
    >=sys-libs/ncurses-5.2:0/5= required by (dev-lang/python-3.4.5:3.4/3.4m::getoo, installed)
                          ^^^^^
    >=sys-libs/ncurses-5.2-r2:0/5= required by (sys-apps/texinfo-6.1:0/0::gento, installed)
                             ^^^^^
    >=sys-libs/ncurses-5.7-r7:0/5= required by (sys-process/psmisc-22.21-r3:0/0:gentoo, installed)
                             ^^^^^
    sys-libs/ncurses:0/5= required by (sys-apps/openrc-0.22.4:0/0::gentoo, instlled)
                    ^^^^^


!!! The following update(s) have been skipped due to unsatisfied dependencies
!!! triggered by backtracking:

sys-libs/ncurses:5

Nothing to merge; quitting.

localhost ~ #

_________________
www.edv-bildung.de
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2660

PostPosted: Tue Dec 06, 2016 11:52 am    Post subject: Reply with quote

Then try
Code:
# emerge -1avt  ncurses:0/6
The "-1" option means "do not register in @world"
Back to top
View user's profile Send private message
michi-monster
Apprentice
Apprentice


Joined: 16 Aug 2016
Posts: 175
Location: Germany

PostPosted: Tue Dec 06, 2016 12:15 pm    Post subject: Reply with quote

The same :(

Code:
localhost ~ # emerge -1avt  ncurses:0/6

 * IMPORTANT: 20 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild  rR    ] sys-process/procps-3.3.11-r3:0/5::gentoo  USE="kill ncurses nls systemd unicode -modern-top (-selinux) -static-libs {-test}" 0 KiB
[ebuild     U  ]  sys-libs/ncurses-6.0-r1:0/6::gentoo [5.9-r5:0/5::gentoo] USE="cxx gpm unicode -ada -debug -doc -minimal -profile -static-libs {-test%} -threads% -tinfo -trace" ABI_X86="(64) -32 (-x32)" 3059 KiB

Total: 2 packages (1 upgrade, 1 reinstall), Size of downloads: 3059 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-libs/ncurses:0

  (sys-libs/ncurses-6.0-r1:0/6::gentoo, ebuild scheduled for merge) pulled in by
    sys-libs/ncurses:0/6 (Argument)

  (sys-libs/ncurses-5.9-r5:0/5::gentoo, installed) pulled in by
    sys-libs/ncurses:0/5= required by (sys-devel/gettext-0.19.7:0/0::gentoo, installed)
                    ^^^^^                                                                                                 
    (and 24 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

_________________
www.edv-bildung.de
Back to top
View user's profile Send private message
Polynomial-C
Developer
Developer


Joined: 01 Jun 2003
Posts: 1423
Location: germany

PostPosted: Tue Dec 06, 2016 12:56 pm    Post subject: Reply with quote

Alright, here comes a last resort solution. Please try the other solutions suggested in this thread FIRST!

The dangerous step in this help is step 2. Enabling preserve-libs (step 1) won't do any harm to a Gentoo installation.

  1. Make sure you have preserve-libs enabled. (See our Wiki article about preserve-libs). If you don't want to enable it or don't know if it's really enabled, don't proceed! Otherwise you can break your whole Gentoo installation.
  2. Now run
    Code:
    emerge -uDav --with-bdeps=y --ignore-built-slot-operator-deps=y @world

  3. After that don't forget to run
    Code:
    emerge -av @preserved-rebuild


Now your system should be up-to-date again.

Really, this is nothing but a last resort solution. Please try any other possible solution first!


[edit]Added an explanation about preserve-libs[/edit]
_________________
The manual said "Requires Windows10 or better" so I installed GNU/Linux...

my portage overlay

Need a stage1 tarball? (Unofficial builds)


Last edited by Polynomial-C on Tue Dec 06, 2016 11:47 pm; edited 1 time in total
Back to top
View user's profile Send private message
altrent
n00b
n00b


Joined: 03 Mar 2004
Posts: 52

PostPosted: Tue Dec 06, 2016 2:44 pm    Post subject: Reply with quote

Same issue here. Not feeling brave enough to enable preserve-libs, so I just masked ncurses until this gets resolved...

Code:

$ cat /etc/portage/package.mask/miscellaneous
=sys-libs/ncurses-6.0-r1:0/6::gentoo
=sys-libs/ncurses-6.0:5/6::gentoo
=sys-libs/ncurses-5.9-r101:5::gentoo
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2660

PostPosted: Tue Dec 06, 2016 3:26 pm    Post subject: Reply with quote

michi-monster wrote:
The same :(

Sorry. Just checked again. What I really did was the other slot:
Code:
# emerge --oneshot --tree --verbose --ask ncurses:5/6
Then it gave me this.
Back to top
View user's profile Send private message
jonfr
Veteran
Veteran


Joined: 20 Jul 2003
Posts: 1006
Location: Iceland

PostPosted: Tue Dec 06, 2016 9:56 pm    Post subject: Reply with quote

charles17 wrote:
michi-monster wrote:
The same :(

Sorry. Just checked again. What I really did was the other slot:
Code:
# emerge --oneshot --tree --verbose --ask ncurses:5/6
Then it gave me this.


I got the same thing and a lot of broken thing. I'm currently running a 'emerge world -e' to fix everything that might be broken.
Back to top
View user's profile Send private message
luispa
Guru
Guru


Joined: 17 Mar 2006
Posts: 357
Location: España

PostPosted: Wed Dec 07, 2016 12:48 am    Post subject: Reply with quote

Had same issue, did what @charles17 mentioned and fixed the problem.

Code:
~ # emerge --oneshot --tree --verbose --ask ncurses:5/6

Then,

Code:
~ # emerge -DuvN system world


Thanks
Luis
Back to top
View user's profile Send private message
linuxale
n00b
n00b


Joined: 11 Jan 2006
Posts: 34

PostPosted: Sun Dec 18, 2016 10:29 pm    Post subject: Reply with quote

In my case I had to remove the old version and the reinstall with:
Code:

emerge --oneshot --tree --verbose --ask ncurses:5/6


No otherway to get it updated!

Does anybody know if this bug is tracked?

Cheers
Alessandro[/code]
Back to top
View user's profile Send private message
jamtat
Apprentice
Apprentice


Joined: 09 Aug 2003
Posts: 155

PostPosted: Fri Dec 23, 2016 8:45 pm    Post subject: Reply with quote

I'm confronting this issue as well but can't claim I understand it very well. So let me ask: would I be correct in assuming that there is at stake here, ultimately, some issue that the Gentoo devs need to sort?

I initially just used the --exclude ncurses switch suggested earlier, which allowed me to update other parts of the system. But of course that seems to just defer the problem to a later point. Rather than flailing around with some of the other suggested solutions in this thread--which seem not to work in all instances in any case--I decided the best course of action at the moment would be to adopt the masking suggested in this thread by altrent. Of course that approach presumes that the slot conflict problem results from some high-level brokeness that the devs will be fixing at some point--after which, I would undo the mask and upgrade ncurses along with the rest of the system. Anyway, the key question in all this is whether my assumption that the slot conflict is an issue the devs will be needing to sort, is a more or less correct one. Input on that, anyone?
Back to top
View user's profile Send private message
solamour
l33t
l33t


Joined: 21 Dec 2004
Posts: 638
Location: San Diego, CA

PostPosted: Tue Jan 31, 2017 5:00 pm    Post subject: Reply with quote

When I do "emerge -vDu world", I'm not able to proceed due to the following.
Code:
...

[blocks B      ] <sys-libs/ncurses-6:0 ("<sys-libs/ncurses-6:0" is blocking sys-libs/ncurses-5.9-r101)

...

  (sys-libs/ncurses-5.9-r101:5/5::gentoo, ebuild scheduled for merge) pulled in by
    sys-libs/ncurses required by @selected
    sys-libs/ncurses:5/5 required by (net-misc/dropbox-17.3.28:0/0::gentoo, ebuild scheduled for merge)


I've read every single post in this thread, but it's still not clear to me what I need to do to fix the problem. Would using "--emptytree" option help?
__
sol


Last edited by solamour on Tue Jan 31, 2017 8:09 pm; edited 1 time in total
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Tue Jan 31, 2017 5:59 pm    Post subject: Reply with quote

solamour ... try to update ncurses to the 0/6 slot (6.0-r1)

Code:
# emerge --oneshot --ask sys-libs/ncurses:0/6

If this fails then, as Polynomial-C suggested, try adding '--ignore-built-slot-operator-deps=y'.

Once ncurses is updated you can run 'emerge --ask @preserved-rebuild', and '--update @world'.

HTH & best ... khay
Back to top
View user's profile Send private message
solamour
l33t
l33t


Joined: 21 Dec 2004
Posts: 638
Location: San Diego, CA

PostPosted: Sat Feb 04, 2017 2:42 am    Post subject: Reply with quote

khayyam wrote:
try to update ncurses to the 0/6 slot (6.0-r1)

Code:
# emerge --oneshot --ask sys-libs/ncurses:0/6

If this fails then, as Polynomial-C suggested, try adding '--ignore-built-slot-operator-deps=y'.

Once ncurses is updated you can run 'emerge --ask @preserved-rebuild', and '--update @world'.


After updating ncurses, "emerge @preserved-rebuild" and "emerge -vu @world" went through OK. Another "emerge -vu @world" shows nothing to update. But "emerge -vDu @world" still shows "ncurses blocked" message and stops. Would it be worthwhile to try "--emptytree"?
__
sol
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Sat Feb 04, 2017 9:44 am    Post subject: Reply with quote

solamour wrote:
After updating ncurses, "emerge @preserved-rebuild" and "emerge -vu @world" went through OK. Another "emerge -vu @world" shows nothing to update. But "emerge -vDu @world" still shows "ncurses blocked" message and stops. Would it be worthwhile to try "--emptytree"?

solamour ... the exact error is generally preferable, I suspect you have something depending on another slot, or you need to do a '--depclean'. Please try the following:

Code:
# emerge --depclean --ask

... if ncurses is selected then select 'yes', and then run 'emerge @preserved-rebuild' again.

HTH & best ... khay
Back to top
View user's profile Send private message
solamour
l33t
l33t


Joined: 21 Dec 2004
Posts: 638
Location: San Diego, CA

PostPosted: Fri Feb 10, 2017 5:58 pm    Post subject: Reply with quote

I tried many different suggestions discussed here, but I kept getting "ncurses blocked" error message and couldn't proceed. I almost tried "--emptytree" as a last ditch effort (it's a big deal for me, because due to underpowered machine I have, it would take at least a week and a half to finish), but then I decided to check all the files in "/etc/portage/" once more.

Darned, there were a few packages with "~x86" in "/etc/portage/package.keywords", mostly old experimental ones that either became available since then (so I don't need "~x86" anymore, even though the stable version might not be the latest) or I just no longer need them at all. I commented out all "~x86" packages and removed them, and "ncurses blocked" message is gone. Thanks everyone for taking time to help.
__
sol
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page Previous  1, 2, 3
Page 3 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum