Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
(solved) freecad sci-libs/vtk media-video/nvidia-settings
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
artbody
Guru
Guru


Joined: 15 Sep 2006
Posts: 431
Location: LB

PostPosted: Mon Dec 12, 2016 11:18 pm    Post subject: (solved) freecad sci-libs/vtk media-video/nvidia-settings Reply with quote

emerge media-gfx/freecad

absolut fehlgeschlagen und warum ????

:oops: :cry: :twisted: :roll: :evil:

Code:
 * Messages for package x11-drivers/nvidia-drivers-340.93-r1:

 * ERROR: x11-drivers/nvidia-drivers-340.93-r1::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=x11-drivers/nvidia-drivers-340.93-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=x11-drivers/nvidia-drivers-340.93-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-340.93-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-340.93-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-drivers/nvidia-drivers-340.93-r1/work/kernel'
 * S: '/var/tmp/portage/x11-drivers/nvidia-drivers-340.93-r1/work/'

 * Messages for package sci-libs/vtk-6.1.0-r1:

 * emerge --keep-going: sci-libs/vtk-6.1.0-r1 dropped because it requires
 * media-video/nvidia-settings

 * Messages for package media-video/nvidia-settings-340.58:

 * emerge --keep-going: media-video/nvidia-settings-340.58 dropped because it
 * requires ~x11-drivers/nvidia-drivers-340.93, ~x11-drivers/nvidia-
 * drivers-340.93

 * Messages for package sci-libs/opencascade-6.9.0-r1:

 * emerge --keep-going: sci-libs/opencascade-6.9.0-r1 dropped because it
 * requires =sci-libs/vtk-6.1*[qt4]

 * Messages for package media-gfx/freecad-0.15.4671:

 * emerge --keep-going: media-gfx/freecad-0.15.4671 dropped because it
 * requires sci-libs/opencascade:6.9.0[vtk]

 * Messages for package dev-python/wxpython-3.0.2.0:

 * Gentoo uses the Multi-version method for SLOT'ing.
 * Developers, see this site for instructions on using
 * it with your apps:
 * http://wiki.wxpython.org/MultiVersionInstalls
 *
 * The following 5 packages have failed to build, install, or execute
 * postinst:
 *
 *  (x11-drivers/nvidia-drivers-340.93-r1:0/340::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/x11-drivers/nvidia-drivers-340.93-r1/temp/build.log'
 *  (sci-libs/vtk-6.1.0-r1:0/0::gentoo, ebuild scheduled for merge)
 *  (media-video/nvidia-settings-340.58:0/0::gentoo, ebuild scheduled for merge)
 *  (sci-libs/opencascade-6.9.0-r1:6.9.0/6.9.0::gentoo, ebuild scheduled for merge)
 *  (media-gfx/freecad-0.15.4671:0/0::gentoo, ebuild scheduled for merge)
 *

 * GNU info directory index is up-to-date.

 * IMPORTANT: 20 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


edit:
HARDWARE (Speicher) ware defekt
gelöst mit neuer Hardware
_________________
Never give up
WM : E16 layman -o https://raw.githubusercontent.com/mcclung/e16-overlay/master/repositories.xml -f -a e16-overlay
achim


Last edited by artbody on Fri Dec 16, 2016 8:04 pm; edited 1 time in total
Back to top
View user's profile Send private message
artbody
Guru
Guru


Joined: 15 Sep 2006
Posts: 431
Location: LB

PostPosted: Tue Dec 13, 2016 12:04 am    Post subject: sci-libs/vtk-6.1.0-r1 Reply with quote

Code:
Messages for package sci-libs/vtk-6.1.0-r1:

 * emerge --keep-going: sci-libs/vtk-6.1.0-r1 dropped because it requires
 * media-video/nvidia-settings


:oops:

Naja hier liegt das Übel

hab mal die Abhängigkeit von nvidia-settings aus dem ebuild entfern und versucht zu compilieren ABER das geht so einfach nicht, also mal ein echter Schuß in Ofen

Solangsam bekomme ich das Gefühl, daß Gentoo für normale Benutzer nicht mehr zu gebrauchen ist.
Warum ?
Weil das hätte so nie von den Devs freigegeben werden dürfen.
_________________
Never give up
WM : E16 layman -o https://raw.githubusercontent.com/mcclung/e16-overlay/master/repositories.xml -f -a e16-overlay
achim
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3710
Location: Germany

PostPosted: Tue Dec 13, 2016 1:14 am    Post subject: Reply with quote

Hehe nein, ich denke der Konflikt geht hier https://forums.gentoo.org/viewtopic-p-8002042.html#8002042
zwischen dem alten nvidia-drivers-340.93-r1 und dem inzwischen stable xorg-server-1.18.4 los.
Die alte Treiberversion ist mit dem neuen xorg-server nicht mehr kompatibel.

Vorschlag: Nutze die aktuelle nvidia-drivers-340.98 Version - die ist auch mit xorg-server-1.18 kompatibel.
Code:
echo "~x11-drivers/nvidia-drivers-340.98" >> /etc/portage/package.accept_keywords

Nutze die gewünschten nvidia-settings dann am besten aus dem neuen nvidia-drivers-340.98 Treiber-Paket,
indem du es mit tools Useflag baust
Code:
echo "x11-drivers/nvidia-drivers tools static-libs" >> /etc/portage/package.use
(das alte media-video/nvidia-settings Paket vorher bitte deinstallieren).
Mit dem aus den nvidia-drivers-340.98 schon mit enthaltenen nvidia-settings wird dann dann =sci-libs/vtk-6.1.0-r3 benötigt.
Code:
echo "=sci-libs/vtk-6.1.0-r3" >> /etc/portage/package.accept_keywords

Bau den neuen xorg-server mitsamt Treiber dann zb via
Code:
emerge -av1 xorg-server @x11-module-rebuild


Wenn das bauen auch fehlschlägt, dann poste bitte die "emerge --info" und die Fehlermeldung, das build.log (zb via Pastebin-Service).
Back to top
View user's profile Send private message
artbody
Guru
Guru


Joined: 15 Sep 2006
Posts: 431
Location: LB

PostPosted: Tue Dec 13, 2016 10:35 am    Post subject: Reply with quote

Danke erst mal

nvidia-drivers-300.98 war/ ist installiert

das Anfangsproblem gab mir keinen Hinweis auf vtk nvidia-settings abhängigkeit

Code:

Total: 38 packages (2 downgrades, 36 new), Size of downloads: 574.273 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-base/xorg-server:0

  (x11-base/xorg-server-1.17.4:0/1.17.4::gentoo, ebuild scheduled for merge) pulled in by
    <x11-base/xorg-server-1.17.99:= required by (x11-drivers/nvidia-drivers-340.93-r1:0/340::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^^^ ^                                                                                                                                                                       

  (x11-base/xorg-server-1.18.4:0/1.18.4::gentoo, installed) pulled in by
    >=x11-base/xorg-server-1.18[udev] required by (x11-drivers/xf86-input-evdev-2.10.3:0/0::gentoo, installed)
    ^^                     ^^^^                                                                                                                                     
    x11-base/xorg-server:0/1.18.4= required by (x11-drivers/xf86-input-evdev-2.10.3:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                                                                             
    >=x11-base/xorg-server-1.7:0/1.18.4=[-minimal] required by (x11-drivers/xf86-video-virtualbox-4.3.38:0/0::gentoo, installed)
                              ^^^^^^^^^^                                     


Soweit so gut
package use
Code:

#2016-12-13 for vrt nvidia-settings nvidia driver
x11-drivers/nvidia-drivers  tools static-libs


und ebuild vvtk-6.1.0-r1.ebuild
zeile 102
von
Code:
video_cards_nvidia? ( media-video/nvidia-settings )

Code:
video_cards_nvidia? ( || ( media-video/nvidia-settings x11-drivers/nvidia-drivers[tools,static-libs] ) )

geändert

emerge nvidia-drivers
emerge vtk

und funktioniert
_________________
Never give up
WM : E16 layman -o https://raw.githubusercontent.com/mcclung/e16-overlay/master/repositories.xml -f -a e16-overlay
achim
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3710
Location: Germany

PostPosted: Tue Dec 13, 2016 12:15 pm    Post subject: Reply with quote

Na prima,
aber ebuild editieren ist gar nicht nötig - nutze am besten die schon vorgeschlagene
=sci-libs/vtk-6.1.0-r3 Version, da ist der fix schon mit drin.
Ist auch schon (genau aus diesem Grund) zur neuen stable Version vorgeschlagen, siehe im Bug 595654
Back to top
View user's profile Send private message
artbody
Guru
Guru


Joined: 15 Sep 2006
Posts: 431
Location: LB

PostPosted: Sat Dec 17, 2016 12:22 pm    Post subject: Reply with quote

Danke Josef.95
Hab es jetzt in der package.accept-keywords passend eingetragen

Code:
x11-drivers/nvidia-drivers* ~amd64
#needet for vrt pulling in nvidia-settings nvidia driver
=sci-libs/vtk-6.1.0-r3 ~amd64

package.use :
Code:
x11-drivers/nvidia-drivers  tools static-libs

:D

war schon ne ganz fiese Geschichte mit der ursprünglichen Fehlermeldung
Code:
<x11-base/xorg-server-1.17.99:= required by (x11-drivers/nvidia-drivers...

auf den Verursacher :evil: zu kommen :lol:
Code:
equery d media-video/nvidia-settings
 * These packages depend on media-video/nvidia-settings:
sci-libs/vtk-6.1.0-r1 (video_cards_nvidia ? media-video/nvidia-settings)


Und x11-drivers/nvidia-drivers* ~amd64 den brauchts jetzt für die neue Grafikkarte weil die den nvidia-drivers-375.20-r1 will
_________________
Never give up
WM : E16 layman -o https://raw.githubusercontent.com/mcclung/e16-overlay/master/repositories.xml -f -a e16-overlay
achim
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum