Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
boost-build ist angeblich maskert, ist es aber nicht
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2033
Location: Heidelberg - Germany

PostPosted: Sat Jan 28, 2017 5:19 pm    Post subject: boost-build ist angeblich maskert, ist es aber nicht Reply with quote

Nach einem Worldupdate sehe ich folgendes:

Code:

!!! The following update has been skipped due to unsatisfied dependencies:

dev-libs/boost:0

!!! All ebuilds that could satisfy "=dev-util/boost-build-1.62*" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-util/boost-build-1.62.0-r1::gentoo (masked by: )

(dependency required by "dev-libs/boost-1.62.0-r1::gentoo" [ebuild])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


ein "emerge -pv =boost-build-1.62.0-r1" sagt mir aber:

Code:

Calculating dependencies... done!
[ebuild     U  ] dev-util/boost-build-1.62.0-r1::gentoo [1.56.0::gentoo] USE="-examples -python {-test}" PYTHON_TARGETS="python2_7" 82.533 KiB

Total: 1 package (1 upgrade), Size of downloads: 82.533 KiB


Warum, soll also boost-build nicht aufgelöst werden können?
_________________
Desktop AMD FX-4300 12GB RAM, Asus GF GTX 650. Sound RME Multiface + PCI + Cardbus, 2x RME Quadmic, 1x Behringer ADA8000 + ganz viele Modellflugzeuge, ein Tandem, Rennrad und DFXL ;)
2x IBM Thinkpad T60
Zotag Mag Mini Atom
Raspberry Pi 1 + 2 + Zero W
Back to top
View user's profile Send private message
LuxJux
Guru
Guru


Joined: 01 Mar 2016
Posts: 302

PostPosted: Sat Jan 28, 2017 8:13 pm    Post subject: Reply with quote

Soweit mir bekannt muß boost mit -j1 gebaut werden.
Vielleicht liegst ja wieder mal daran.
Back to top
View user's profile Send private message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2033
Location: Heidelberg - Germany

PostPosted: Sun Jan 29, 2017 9:28 am    Post subject: Reply with quote

LuxJux wrote:
Soweit mir bekannt muß boost mit -j1 gebaut werden.
Vielleicht liegst ja wieder mal daran.


Aber dann müßte es ja zumindest gebaut werden und dabei abbrechen. Er sagt aber, es wäre maskiert, müßte es aber als Abhängigkeit bauen.
_________________
Desktop AMD FX-4300 12GB RAM, Asus GF GTX 650. Sound RME Multiface + PCI + Cardbus, 2x RME Quadmic, 1x Behringer ADA8000 + ganz viele Modellflugzeuge, ein Tandem, Rennrad und DFXL ;)
2x IBM Thinkpad T60
Zotag Mag Mini Atom
Raspberry Pi 1 + 2 + Zero W
Back to top
View user's profile Send private message
sdoubleyou
n00b
n00b


Joined: 27 May 2016
Posts: 42

PostPosted: Sun Jan 29, 2017 10:24 am    Post subject: Reply with quote

Hatte das gleiche Problem auf meiner Plasma-Kiste. Auf meinem Notebook mit Profil "desktop" lief es sauber durch.

Auf dem Plasma-PC habe ich es mit der backtrack-Option auflösen können
Code:
emerge -avuDN --backtrack=3000 --jobs=3 world
Back to top
View user's profile Send private message
sdoubleyou
n00b
n00b


Joined: 27 May 2016
Posts: 42

PostPosted: Sun Jan 29, 2017 11:50 am    Post subject: Reply with quote

Habe hierzu gerade noch eine andere Info bekommen
https://bugs.gentoo.org/show_bug.cgi?id=554838
Back to top
View user's profile Send private message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2033
Location: Heidelberg - Germany

PostPosted: Sun Jan 29, 2017 2:30 pm    Post subject: Reply with quote

Das hat bei mir auch funktioniert. Der Prozess läuft noch. Der Update von boost hat einige rebuilds hervorgerufen.
_________________
Desktop AMD FX-4300 12GB RAM, Asus GF GTX 650. Sound RME Multiface + PCI + Cardbus, 2x RME Quadmic, 1x Behringer ADA8000 + ganz viele Modellflugzeuge, ein Tandem, Rennrad und DFXL ;)
2x IBM Thinkpad T60
Zotag Mag Mini Atom
Raspberry Pi 1 + 2 + Zero W
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum