Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Two finger scroll with touchpad
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
reichmyu
n00b
n00b


Joined: 19 Oct 2015
Posts: 17

PostPosted: Sat Feb 25, 2017 3:45 pm    Post subject: [Solved] Two finger scroll with touchpad Reply with quote

Hello everyone!

I am havin some problems trying to get vertical scroll with two fingers in Gentoo. I know that there are many threads about this in this forum but none of them helped me.

I tried with many configurations in xorg.conf.d but still it is not working.

Also:

- I have xf86-input-synaptics installed
- I compiled the kernel with support for synaptics touchpads
- However synclient says that synaptics driver is not loaded

Any ideas? :P


Last edited by reichmyu on Tue Feb 28, 2017 10:02 pm; edited 1 time in total
Back to top
View user's profile Send private message
fcl
n00b
n00b


Joined: 31 Dec 2016
Posts: 72

PostPosted: Sat Feb 25, 2017 4:09 pm    Post subject: Reply with quote

Hey! I'd recommend you to post your configs in /etc/X11/xorg.conf.d/ and your Xorg log (from /var/log/ or ~/.local/share/xorg/). Also, what do you have in make.conf as your INPUT_DEVICES?
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7195
Location: almost Mile High in the USA

PostPosted: Sat Feb 25, 2017 4:48 pm    Post subject: Reply with quote

As an aside, some touchpads do not support 2 finger scroll?

Also, most new installs should be using libinput versus synaptics, and your INPUT_DEVICES and configs would indeed be useful to know.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1704
Location: United Kingdom

PostPosted: Sat Feb 25, 2017 6:15 pm    Post subject: Re: Two finger scroll with touchpad Reply with quote

reichmyu,

I have two-finger scroll working with an ~amd64 installation, but I'm still using x11-base/xorg-server-1.17.4 because I am using the deprecated x11-drivers/ati-drivers-15.12-r1 (in a local overlay) with my Compal laptop's ATI Mobility Radeon HD 5650 GPU. Anyway, in case it's of any use to you, below is what I have installed and configured for X Windows:

Code:
# grep INPUT /etc/portage/make.conf
INPUT_DEVICES="synaptics evdev"

Code:
# grep x11 /etc/portage/package.mask/package.mask
>x11-base/xorg-server-1.17.4
>x11-base/xorg-drivers-1.17
>x11-drivers/xf86-input-evdev-2.9.2
>x11-drivers/xf86-input-synaptics-1.8.2

Code:
# eix -I xorg-server
[I] x11-base/xorg-server
     Available versions:  1.12.4-r7(0/1.12.4) 1.15.2-r4(0/1.15.2) [M]1.16.4-r5(0/1.16.1) 1.17.4(0/1.17.4) [m]1.18.4(0/1.18.4) [m](~)1.19.1(0/1.19.1) [m]**9999(0/9999) {debug dmx doc glamor ipv6 kdrive libressl minimal nptl selinux static-libs +suid systemd tslib +udev unwind wayland xephyr xnest xorg xvfb}
     Installed versions:  1.17.4(09:55:47 04/02/16)(glamor kdrive nptl suid udev xorg -dmx -doc -ipv6 -libressl -minimal -selinux -static-libs -systemd -tslib -unwind -wayland -xephyr -xnest -xvfb)
     Homepage:            https://www.x.org/wiki/
     Description:         X.Org X servers

Code:
# eix -I xorg-drivers
[I] x11-base/xorg-drivers
     Available versions:  1.12 1.15 [M]1.16 1.17 [m]1.18-r1 [m](~)1.19 [m]**9999 {INPUT_DEVICES="acecad aiptek elographics evdev fpit hyperpen joystick keyboard libinput mouse mutouch penmount synaptics tslib vmmouse void wacom" VIDEO_CARDS="amdgpu apm ark ast chips cirrus dummy epson fbdev fglrx freedreno geode glint i128 i740 i965 intel mach64 mga modesetting neomagic newport nouveau nv nvidia omap omapfb qxl r128 radeon radeonsi rendition s3 s3virge savage siliconmotion sis sisusb sunbw2 suncg14 suncg3 suncg6 sunffb sunleo suntcx tdfx tegra tga trident tseng v4l vesa via virtualbox vmware voodoo"}
     Installed versions:  1.17(17:31:48 25/02/17)(INPUT_DEVICES="evdev synaptics -acecad -aiptek -elographics -fpit -hyperpen -joystick -keyboard -libinput -mouse -mutouch -penmount -tslib -vmmouse -void -wacom" VIDEO_CARDS="-amdgpu -apm -ast -chips -cirrus -dummy -epson -fbdev -fglrx -freedreno -geode -glint -i128 -i740 -intel -mach64 -mga -neomagic -nouveau -nv -nvidia -omap -omapfb -qxl -r128 -radeon -radeonsi -rendition -s3 -s3virge -savage -siliconmotion -sisusb -sunbw2 -suncg14 -suncg3 -suncg6 -sunffb -sunleo -suntcx -tdfx -tegra -tga -trident -tseng -vesa -via -virtualbox -vmware -voodoo")
     Homepage:            https://www.gentoo.org/
     Description:         Meta package containing deps on all xorg drivers

Code:
# eix -I synaptics
[I] x11-drivers/xf86-input-synaptics
     Available versions:  1.8.2 [m]1.8.3 [m](~)1.9.0 {KERNEL="linux"}
     Installed versions:  1.8.2(00:31:35 24/02/17)(KERNEL="linux")
     Homepage:            https://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/
     Description:         Driver for Synaptics touchpads

Code:
# cat /etc/X11/xorg.conf.d/50-synaptics.conf
Section "InputClass"
    Identifier "touchpad catchall"
    Driver "synaptics"
    MatchIsTouchpad "on"
    MatchDevicePath "/dev/input/event*"
    Option "TapButton1" "1"
    Option "TapButton2" "2"
    Option "TapButton3" "3"
    Option "VertEdgeScroll" "on"
    Option "VertTwoFingerScroll" "on"
    Option "HorizEdgeScroll" "on"
    Option "HorizTwoFingerScroll" "on"
    Option "CircularScrolling" "on"
    Option "CircScrollTrigger" "0"
    Option "EmulateTwoFingerMinZ" "40"
    Option "EmulateTwoFingerMinW" "8"
    Option "CoastingSpeed" "0"
    Option "FingerLow" "35"
    Option "FingerHigh" "40"
EndSection

Section "InputClass"
    Identifier "touchpad ignore duplicates"
    MatchIsTouchpad "on"
    MatchDevicePath "/dev/input/mouse*"
    Option "Ignore" "on"
EndSection

_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7195
Location: almost Mile High in the USA

PostPosted: Sun Feb 26, 2017 7:48 pm    Post subject: Reply with quote

Speaking of libinput and my Synaptics touchpad, it seems that libinput turns off tap to click by default now, where it's on by default on the older Synaptics driver/Windows/other OS. I don't know why libinput is so much worse than other OS/older Synaptics driver... will have to play with it to see how it behaves; I just noticed that it doesn't work. 2 finger scrolling works on libinput just fine, however - on a touch pad that supports 2+touch.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
reichmyu
n00b
n00b


Joined: 19 Oct 2015
Posts: 17

PostPosted: Mon Feb 27, 2017 7:35 pm    Post subject: Reply with quote

Thanks for all the answers.

Now I am not using any config file for synaptics under /etc/X11/xorg.conf.d because the touchpad is working in the same way when using a config file and without it and I have evdev and synaptics as input devices in my make.conf

The touchpad does support two finger scroll because I have been using Arch before I moved to Gentoo and it worked there.

A Xorg log:
Code:
[     5.694]
X.Org X Server 1.18.4
Release Date: 2016-07-19
[     5.694] X Protocol Version 11, Revision 0
[     5.694] Build Operating System: Linux 4.9.6-gentoo-r1 x86_64 Gentoo
[     5.694] Current Operating System: Linux Gentoo 4.9.6-gentoo-r1 #2 SMP Sat Feb 25 16:23:44 -00 2017 x86_64
[     5.694] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.9.6-gentoo-r1 root=UUID=c47ab1a0-a65f-49e7-8643-a090dfca3786 ro
[     5.694] Build Date: 14 February 2017  09:56:10PM
[     5.694] 
[     5.694] Current version of pixman: 0.34.0
[     5.694]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[     5.694] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[     5.694] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Feb 27 20:27:39 2017
[     5.696] (==) Using config directory: "/etc/X11/xorg.conf.d"
[     5.696] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[     5.697] (==) No Layout section.  Using the first Screen section.
[     5.697] (==) No screen section available. Using defaults.
[     5.697] (**) |-->Screen "Default Screen Section" (0)
[     5.697] (**) |   |-->Monitor "<default monitor>"
[     5.697] (==) No device specified for screen "Default Screen Section".
   Using the first device section listed.
[     5.697] (**) |   |-->Device "Intel Graphics"
[     5.697] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[     5.697] (==) Automatically adding devices
[     5.697] (==) Automatically enabling devices
[     5.697] (==) Automatically adding GPU devices
[     5.697] (==) Max clients allowed: 256, resource mask: 0x1fffff
[     5.697] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[     5.697]    Entry deleted from font path.
[     5.697] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[     5.697]    Entry deleted from font path.
[     5.697] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[     5.697]    Entry deleted from font path.
[     5.698] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[     5.698]    Entry deleted from font path.
[     5.698]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[     5.698] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[     5.698]    Entry deleted from font path.
[     5.698]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[     5.698] (==) FontPath set to:
   /usr/share/fonts/misc/
[     5.698] (==) ModulePath set to "/usr/lib64/xorg/modules"
[     5.698] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[     5.698] (II) Loader magic: 0x811c80
[     5.698] (II) Module ABI versions:
[     5.698]    X.Org ANSI C Emulation: 0.4
[     5.698]    X.Org Video Driver: 20.0
[     5.698]    X.Org XInput driver : 22.1
[     5.698]    X.Org Server Extension : 9.0
[     5.698] (II) xfree86: Adding drm device (/dev/dri/card0)
[     5.706] (--) PCI:*(0:0:2:0) 8086:0a16:1043:131d rev 9, Mem @ 0xf7400000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64, BIOS @ 0x????????/131072
[     5.706] (--) PCI: (0:4:0:0) 10de:1140:1043:131d rev 161, Mem @ 0xf6000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @ 0x0000d000/128, BIOS @ 0x????????/524288
[     5.706] (II) LoadModule: "glx"
[     5.708] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[     5.715] (II) Module glx: vendor="X.Org Foundation"
[     5.715]    compiled for 1.18.4, module version = 1.0.0
[     5.715]    ABI class: X.Org Server Extension, version 9.0
[     5.715] (==) AIGLX enabled
[     5.715] (II) LoadModule: "intel"
[     5.716] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[     5.718] (II) Module intel: vendor="X.Org Foundation"
[     5.718]    compiled for 1.18.4, module version = 2.99.917
[     5.718]    Module class: X.Org Video Driver
[     5.718]    ABI class: X.Org Video Driver, version 20.0
[     5.718] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
   i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
   915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
   Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
   GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[     5.718] (II) intel: Driver for Intel(R) HD Graphics: 2000-6000
[     5.718] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100, 6100
[     5.718] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200, 6200, P6300
[     5.718] (++) using VT number 7

[     5.725] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20160919
[     5.726] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics 4400
[     5.726] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2, avx, avx2; using a maximum of 2 threads
[     5.726] (II) intel(0): Creating default Display subsection in Screen section
   "Default Screen Section" for depth/fbbpp 24/32
[     5.726] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[     5.726] (==) intel(0): RGB weight 888
[     5.726] (==) intel(0): Default visual is TrueColor
[     5.726] (**) intel(0): Option "TearFree" "true"
[     5.726] (II) intel(0): Output eDP1 has no monitor section
[     5.733] (--) intel(0): Found backlight control interface intel_backlight (type 'raw') for output eDP1
[     5.733] (II) intel(0): Enabled output eDP1
[     5.733] (II) intel(0): Output DP1 has no monitor section
[     5.733] (II) intel(0): Enabled output DP1
[     5.733] (II) intel(0): Output HDMI1 has no monitor section
[     5.733] (II) intel(0): Enabled output HDMI1
[     5.733] (--) intel(0): Using a maximum size of 256x256 for hardware cursors
[     5.733] (II) intel(0): Output VIRTUAL1 has no monitor section
[     5.733] (II) intel(0): Enabled output VIRTUAL1
[     5.733] (--) intel(0): Output eDP1 using initial mode 1366x768 on pipe 0
[     5.733] (**) intel(0): TearFree enabled
[     5.733] (==) intel(0): DPI set to (96, 96)
[     5.733] (II) Loading sub module "dri2"
[     5.733] (II) LoadModule: "dri2"
[     5.733] (II) Module "dri2" already built-in
[     5.733] (II) Loading sub module "present"
[     5.733] (II) LoadModule: "present"
[     5.733] (II) Module "present" already built-in
[     5.733] (==) Depth 24 pixmap format is 32 bpp
[     5.736] (II) intel(0): SNA initialized with Haswell (gen7.5, gt2) backend
[     5.736] (==) intel(0): Backing store enabled
[     5.736] (==) intel(0): Silken mouse enabled
[     5.736] (II) intel(0): HW Cursor enabled
[     5.736] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[     5.737] (==) intel(0): DPMS enabled
[     5.737] (==) intel(0): Display hotplug detection enabled
[     5.737] (II) intel(0): [DRI2] Setup complete
[     5.737] (II) intel(0): [DRI2]   DRI driver: i965
[     5.737] (II) intel(0): [DRI2]   VDPAU driver: va_gl
[     5.737] (II) intel(0): direct rendering: DRI2 enabled
[     5.737] (II) intel(0): hardware support for Present enabled
[     5.737] (--) RandR disabled
[     5.757] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[     5.757] (II) AIGLX: enabled GLX_ARB_create_context
[     5.757] (II) AIGLX: enabled GLX_ARB_create_context_profile
[     5.757] (II) AIGLX: enabled GLX_EXT_create_context_es{,2}_profile
[     5.757] (II) AIGLX: enabled GLX_INTEL_swap_event
[     5.757] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[     5.757] (II) AIGLX: enabled GLX_EXT_framebuffer_sRGB
[     5.757] (II) AIGLX: enabled GLX_ARB_fbconfig_float
[     5.757] (II) AIGLX: enabled GLX_EXT_fbconfig_packed_float
[     5.757] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[     5.757] (II) AIGLX: enabled GLX_ARB_create_context_robustness
[     5.757] (II) AIGLX: Loaded and initialized i965
[     5.757] (II) GLX: Initialized DRI2 GL provider for screen 0
[     5.759] (II) intel(0): switch to mode 1366x768@60.0 on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none
[     5.772] (II) intel(0): Setting screen physical size to 361 x 203
[     5.805] (II) config/udev: Adding input device Power Button (/dev/input/event2)
[     5.805] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[     5.805] (II) LoadModule: "evdev"
[     5.806] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[     5.808] (II) Module evdev: vendor="X.Org Foundation"
[     5.808]    compiled for 1.18.4, module version = 2.10.3
[     5.808]    Module class: X.Org XInput Driver
[     5.808]    ABI class: X.Org XInput driver, version 22.1
[     5.808] (II) Using input driver 'evdev' for 'Power Button'
[     5.808] (**) Power Button: always reports core events
[     5.808] (**) evdev: Power Button: Device: "/dev/input/event2"
[     5.808] (--) evdev: Power Button: Vendor 0 Product 0x1
[     5.808] (--) evdev: Power Button: Found keys
[     5.808] (II) evdev: Power Button: Configuring as keyboard
[     5.808] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input2/event2"
[     5.808] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[     5.808] (**) Option "xkb_rules" "evdev"
[     5.808] (II) config/udev: Adding input device Video Bus (/dev/input/event4)
[     5.808] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[     5.808] (II) Using input driver 'evdev' for 'Video Bus'
[     5.808] (**) Video Bus: always reports core events
[     5.808] (**) evdev: Video Bus: Device: "/dev/input/event4"
[     5.809] (--) evdev: Video Bus: Vendor 0 Product 0x6
[     5.809] (--) evdev: Video Bus: Found keys
[     5.809] (II) evdev: Video Bus: Configuring as keyboard
[     5.809] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:01/input/input4/event4"
[     5.809] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
[     5.809] (**) Option "xkb_rules" "evdev"
[     5.809] (II) config/udev: Adding input device Video Bus (/dev/input/event3)
[     5.809] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[     5.809] (II) Using input driver 'evdev' for 'Video Bus'
[     5.809] (**) Video Bus: always reports core events
[     5.809] (**) evdev: Video Bus: Device: "/dev/input/event3"
[     5.809] (--) evdev: Video Bus: Vendor 0 Product 0x6
[     5.809] (--) evdev: Video Bus: Found keys
[     5.809] (II) evdev: Video Bus: Configuring as keyboard
[     5.809] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:05/LNXVIDEO:00/input/input3/event3"
[     5.809] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 8)
[     5.809] (**) Option "xkb_rules" "evdev"
[     5.809] (II) config/udev: Adding input device Lid Switch (/dev/input/event0)
[     5.809] (II) No input driver specified, ignoring this device.
[     5.809] (II) This device may have been added with another device file.
[     5.809] (II) config/udev: Adding input device Sleep Button (/dev/input/event1)
[     5.809] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
[     5.809] (II) Using input driver 'evdev' for 'Sleep Button'
[     5.809] (**) Sleep Button: always reports core events
[     5.809] (**) evdev: Sleep Button: Device: "/dev/input/event1"
[     5.809] (--) evdev: Sleep Button: Vendor 0 Product 0x3
[     5.809] (--) evdev: Sleep Button: Found keys
[     5.809] (II) evdev: Sleep Button: Configuring as keyboard
[     5.809] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input1/event1"
[     5.809] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 9)
[     5.809] (**) Option "xkb_rules" "evdev"
[     5.810] (II) config/udev: Adding input device HDA Intel HDMI HDMI (/dev/input/event8)
[     5.810] (II) No input driver specified, ignoring this device.
[     5.810] (II) This device may have been added with another device file.
[     5.810] (II) config/udev: Adding input device HDA Intel PCH Mic (/dev/input/event6)
[     5.810] (II) No input driver specified, ignoring this device.
[     5.810] (II) This device may have been added with another device file.
[     5.810] (II) config/udev: Adding input device HDA Intel PCH Headphone (/dev/input/event7)
[     5.810] (II) No input driver specified, ignoring this device.
[     5.810] (II) This device may have been added with another device file.
[     5.810] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event5)
[     5.810] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[     5.810] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[     5.810] (**) AT Translated Set 2 keyboard: always reports core events
[     5.810] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event5"
[     5.810] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[     5.810] (--) evdev: AT Translated Set 2 keyboard: Found keys
[     5.810] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[     5.810] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input5/event5"
[     5.810] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 10)
[     5.810] (**) Option "xkb_rules" "evdev"
[     5.810] (II) config/udev: Adding input device PS/2 Generic Mouse (/dev/input/event9)
[     5.810] (**) PS/2 Generic Mouse: Applying InputClass "evdev pointer catchall"
[     5.810] (II) Using input driver 'evdev' for 'PS/2 Generic Mouse'
[     5.810] (**) PS/2 Generic Mouse: always reports core events
[     5.810] (**) evdev: PS/2 Generic Mouse: Device: "/dev/input/event9"
[     5.810] (--) evdev: PS/2 Generic Mouse: Vendor 0x2 Product 0x1
[     5.810] (--) evdev: PS/2 Generic Mouse: Found 3 mouse buttons
[     5.810] (--) evdev: PS/2 Generic Mouse: Found relative axes
[     5.810] (--) evdev: PS/2 Generic Mouse: Found x and y relative axes
[     5.810] (II) evdev: PS/2 Generic Mouse: Configuring as mouse
[     5.810] (**) evdev: PS/2 Generic Mouse: YAxisMapping: buttons 4 and 5
[     5.810] (**) evdev: PS/2 Generic Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[     5.810] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio4/input/input13/event9"
[     5.810] (II) XINPUT: Adding extended input device "PS/2 Generic Mouse" (type: MOUSE, id 11)
[     5.810] (II) evdev: PS/2 Generic Mouse: initialized for relative axes.
[     5.810] (**) PS/2 Generic Mouse: (accel) keeping acceleration scheme 1
[     5.810] (**) PS/2 Generic Mouse: (accel) acceleration profile 0
[     5.810] (**) PS/2 Generic Mouse: (accel) acceleration factor: 2.000
[     5.811] (**) PS/2 Generic Mouse: (accel) acceleration threshold: 4
[     5.811] (II) config/udev: Adding input device PS/2 Generic Mouse (/dev/input/mouse0)
[     5.811] (II) No input driver specified, ignoring this device.
[     5.811] (II) This device may have been added with another device file.
[     7.734] (II) intel(0): EDID vendor "AUO", prod id 18668
[     7.734] (II) intel(0): Printing DDC gathered Modelines:
[     7.734] (II) intel(0): Modeline "1366x768"x0.0   76.30  1366 1404 1426 1592  768 771 777 798 -hsync -vsync (47.9 kHz eP)
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1704
Location: United Kingdom

PostPosted: Mon Feb 27, 2017 8:03 pm    Post subject: Reply with quote

Well, your installation is certainly not loading the synaptics driver. Here is what my Xorg.0.log file looks like:

Code:
# grep -i synaptics /var/log/Xorg.0.log
[    45.677] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event5)
[    45.677] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[    45.677] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[    45.677] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "Default clickpad buttons"
[    45.677] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[    45.677] (II) LoadModule: "synaptics"
[    45.677] (II) Loading /usr/lib64/xorg/modules/input/synaptics_drv.so
[    45.693] (II) Module synaptics: vendor="X.Org Foundation"
[    45.693] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
[    45.693] (**) SynPS/2 Synaptics TouchPad: always reports core events
[    45.728] (--) synaptics: SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5772 (res 69)
[    45.728] (--) synaptics: SynPS/2 Synaptics TouchPad: y-axis range 1408 - 5086 (res 118)
[    45.728] (--) synaptics: SynPS/2 Synaptics TouchPad: pressure range 0 - 255
[    45.728] (--) synaptics: SynPS/2 Synaptics TouchPad: finger width range 0 - 15
[    45.728] (--) synaptics: SynPS/2 Synaptics TouchPad: buttons: left right
[    45.728] (--) synaptics: SynPS/2 Synaptics TouchPad: Vendor 0x2 Product 0x7
[    45.728] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[    45.728] (**) SynPS/2 Synaptics TouchPad: always reports core events
[    45.740] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD, id 15)
[    45.740] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 2.5
[    45.740] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MaxSpeed is now 1.75
[    45.740] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) AccelFactor is now 0.035
[    45.740] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
[    45.740] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 1
[    45.740] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
[    45.740] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
[    45.740] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[    45.740] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse0)
[    45.740] (**) SynPS/2 Synaptics TouchPad: Ignoring device from InputClass "touchpad ignore duplicates"

Have you double-checked that the driver is actually installed?:

Code:
# eix -I xorg-drivers
[I] x11-base/xorg-drivers
     Available versions:  1.12 1.15 1.17 [m]1.18-r1 [m](~)1.19 [m]**9999 {INPUT_DEVICES="acecad aiptek elographics evdev fpit hyperpen joystick keyboard libinput mouse mutouch penmount synaptics tslib vmmouse void wacom" VIDEO_CARDS="amdgpu apm ark ast chips cirrus dummy epson fbdev fglrx freedreno geode glint i128 i740 i965 intel mach64 mga modesetting neomagic newport nouveau nv nvidia omap omapfb qxl r128 radeon radeonsi rendition s3 s3virge savage siliconmotion sis sisusb sunbw2 suncg14 suncg3 suncg6 sunffb sunleo suntcx tdfx tegra tga trident tseng v4l vesa via virtualbox vmware voodoo"}
     Installed versions:  1.17(17:31:48 25/02/17)(INPUT_DEVICES="evdev synaptics -acecad -aiptek -elographics -fpit -hyperpen -joystick -keyboard -libinput -mouse -mutouch -penmount -tslib -vmmouse -void -wacom" VIDEO_CARDS="-amdgpu -apm -ast -chips -cirrus -dummy -epson -fbdev -fglrx -freedreno -geode -glint -i128 -i740 -intel -mach64 -mga -neomagic -nouveau -nv -nvidia -omap -omapfb -qxl -r128 -radeon -radeonsi -rendition -s3 -s3virge -savage -siliconmotion -sisusb -sunbw2 -suncg14 -suncg3 -suncg6 -sunffb -sunleo -suntcx -tdfx -tegra -tga -trident -tseng -vesa -via -virtualbox -vmware -voodoo")
     Homepage:            https://www.gentoo.org/
     Description:         Meta package containing deps on all xorg drivers

# eix -I synaptics
[I] x11-drivers/xf86-input-synaptics
     Available versions:  1.8.2 [m]1.8.3 [m](~)1.9.0 {KERNEL="linux"}
     Installed versions:  1.8.2(00:31:35 24/02/17)(KERNEL="linux")
     Homepage:            https://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/
     Description:         Driver for Synaptics touchpads

_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
reichmyu
n00b
n00b


Joined: 19 Oct 2015
Posts: 17

PostPosted: Tue Feb 28, 2017 7:52 pm    Post subject: Reply with quote

Fitzcarraldo wrote:
Well, your installation is certainly not loading the synaptics driver. Here is what my Xorg.0.log file looks like:

Code:
# grep -i synaptics /var/log/Xorg.0.log
[    45.677] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event5)
[    45.677] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[    45.677] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[    45.677] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "Default clickpad buttons"
[    45.677] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[    45.677] (II) LoadModule: "synaptics"
[    45.677] (II) Loading /usr/lib64/xorg/modules/input/synaptics_drv.so
[    45.693] (II) Module synaptics: vendor="X.Org Foundation"
[    45.693] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
[    45.693] (**) SynPS/2 Synaptics TouchPad: always reports core events
[    45.728] (--) synaptics: SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5772 (res 69)
[    45.728] (--) synaptics: SynPS/2 Synaptics TouchPad: y-axis range 1408 - 5086 (res 118)
[    45.728] (--) synaptics: SynPS/2 Synaptics TouchPad: pressure range 0 - 255
[    45.728] (--) synaptics: SynPS/2 Synaptics TouchPad: finger width range 0 - 15
[    45.728] (--) synaptics: SynPS/2 Synaptics TouchPad: buttons: left right
[    45.728] (--) synaptics: SynPS/2 Synaptics TouchPad: Vendor 0x2 Product 0x7
[    45.728] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[    45.728] (**) SynPS/2 Synaptics TouchPad: always reports core events
[    45.740] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD, id 15)
[    45.740] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 2.5
[    45.740] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MaxSpeed is now 1.75
[    45.740] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) AccelFactor is now 0.035
[    45.740] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
[    45.740] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 1
[    45.740] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
[    45.740] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
[    45.740] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[    45.740] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse0)
[    45.740] (**) SynPS/2 Synaptics TouchPad: Ignoring device from InputClass "touchpad ignore duplicates"

Have you double-checked that the driver is actually installed?:

Code:
# eix -I xorg-drivers
[I] x11-base/xorg-drivers
     Available versions:  1.12 1.15 1.17 [m]1.18-r1 [m](~)1.19 [m]**9999 {INPUT_DEVICES="acecad aiptek elographics evdev fpit hyperpen joystick keyboard libinput mouse mutouch penmount synaptics tslib vmmouse void wacom" VIDEO_CARDS="amdgpu apm ark ast chips cirrus dummy epson fbdev fglrx freedreno geode glint i128 i740 i965 intel mach64 mga modesetting neomagic newport nouveau nv nvidia omap omapfb qxl r128 radeon radeonsi rendition s3 s3virge savage siliconmotion sis sisusb sunbw2 suncg14 suncg3 suncg6 sunffb sunleo suntcx tdfx tegra tga trident tseng v4l vesa via virtualbox vmware voodoo"}
     Installed versions:  1.17(17:31:48 25/02/17)(INPUT_DEVICES="evdev synaptics -acecad -aiptek -elographics -fpit -hyperpen -joystick -keyboard -libinput -mouse -mutouch -penmount -tslib -vmmouse -void -wacom" VIDEO_CARDS="-amdgpu -apm -ast -chips -cirrus -dummy -epson -fbdev -fglrx -freedreno -geode -glint -i128 -i740 -intel -mach64 -mga -neomagic -nouveau -nv -nvidia -omap -omapfb -qxl -r128 -radeon -radeonsi -rendition -s3 -s3virge -savage -siliconmotion -sisusb -sunbw2 -suncg14 -suncg3 -suncg6 -sunffb -sunleo -suntcx -tdfx -tegra -tga -trident -tseng -vesa -via -virtualbox -vmware -voodoo")
     Homepage:            https://www.gentoo.org/
     Description:         Meta package containing deps on all xorg drivers

# eix -I synaptics
[I] x11-drivers/xf86-input-synaptics
     Available versions:  1.8.2 [m]1.8.3 [m](~)1.9.0 {KERNEL="linux"}
     Installed versions:  1.8.2(00:31:35 24/02/17)(KERNEL="linux")
     Homepage:            https://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/
     Description:         Driver for Synaptics touchpads



Both packages are installed and as you said the driver isn't loaded.
I also noticed that the output of xinput list shows that it is recognising the touchpad as a normal mouse. Then it may be a problem of kernel configuration (?)
Back to top
View user's profile Send private message
reichmyu
n00b
n00b


Joined: 19 Oct 2015
Posts: 17

PostPosted: Tue Feb 28, 2017 10:01 pm    Post subject: Reply with quote

Exactly, I didn't configure the kernel well :S

I used a kernel compiled using genkernel and now it is working well

Thank you all for the help :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum