Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
pci-e card setup for USB3? [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
cwc
Veteran
Veteran


Joined: 20 Mar 2006
Posts: 1112
Location: Tri-Cities, WA USA

PostPosted: Mon May 08, 2017 4:34 am    Post subject: pci-e card setup for USB3? [solved] Reply with quote

I a have an
Inateck PCI-E to USB 3.0 2-Port PCI Express Card

lspci
USB controller: Fresco Logic FL1100 USB 3.0 Host Controller (rev 10)

Kernel:
4.4.39-gentoo #3 SMP Thu Mar 2 20:59:52 PST 2017 x86_64 AMD FX(tm)-4350 Quad-Core Processor AuthenticAMD GNU/Linux

The card does not pick up any usb devices and I know it is powered up.

Please throw me a bone on this one.


Code:
03:00.0 USB controller: Fresco Logic FL1100 USB 3.0 Host Controller (rev 10) (prog-if 30 [XHCI])
   Subsystem: Fresco Logic FL1100 USB 3.0 Host Controller
   Flags: fast devsel, IRQ 25, NUMA node 0
   Memory at fe100000 (64-bit, non-prefetchable) [size=64K]
   Memory at fe111000 (64-bit, non-prefetchable) [size=4K]
   Memory at fe110000 (64-bit, non-prefetchable) [size=4K]
   Capabilities: [40] Power Management version 3
   Capabilities: [50] MSI: Enable- Count=1/8 Maskable- 64bit+
   Capabilities: [70] Express Endpoint, MSI 00
   Capabilities: [b0] MSI-X: Enable- Count=8 Masked-
   Capabilities: [100] Advanced Error Reporting


[Moderator edit: added [code] tags to preserve output layout. -Hu]
_________________
Without diversity there can be no evolution:)


Last edited by cwc on Fri May 12, 2017 12:06 pm; edited 2 times in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22176
Location: here

PostPosted: Mon May 08, 2017 7:40 am    Post subject: Reply with quote

It's a old post, but can help?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
cwc
Veteran
Veteran


Joined: 20 Mar 2006
Posts: 1112
Location: Tri-Cities, WA USA

PostPosted: Tue May 09, 2017 12:04 pm    Post subject: Reply with quote

I started my system with the sysrc and got the following:

03:00.0 USB controller: Fresco Logic Device 1100 (rev 10) (prog-if 30 [XHCI])
Subsystem: Fresco Logic Device 1100
Flags: bus master, fast devsel, latency 0, IRQ 47
Memory at fe100000 (64-bit, non-prefetchable) [size=64K]
Memory at fe111000 (64-bit, non-prefetchable) [size=4K]
Memory at fe110000 (64-bit, non-prefetchable) [size=4K]
Capabilities: [40] Power Management version 3
Capabilities: [50] MSI: Enable- Count=1/8 Maskable- 64bit+
Capabilities: [70] Express Endpoint, MSI 00
Capabilities: [b0] MSI-X: Enable+ Count=8 Masked-
Capabilities: [100] Advanced Error Reporting
Kernel driver in use: xhci_hcd

I was able to mount a usb from the usb 3.0 pci-e card using tty.
Now I need to figure out how to install the driver on my system.
_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
cwc
Veteran
Veteran


Joined: 20 Mar 2006
Posts: 1112
Location: Tri-Cities, WA USA

PostPosted: Fri May 12, 2017 12:06 pm    Post subject: Reply with quote

Got the card to work:

https://pastebin.com/buxjDfD4
_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum