Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Qemu Black Screen
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
anymay
n00b
n00b


Joined: 04 May 2017
Posts: 1

PostPosted: Thu May 04, 2017 10:51 pm    Post subject: Qemu Black Screen Reply with quote

Hello,
I am currently transitioning to Gentoo and am having difficulties getting vfio passthrough working. It seems to start but there is no video output. This issue is not experienced when ran from a chroot within ubuntu.

Kernel config: https://clbin.com/y3Y7N
Qemu script: https://clbin.com/DoiLO

Kernel command-line:
Code:
GRUB_CMDLINE_LINUX="intel_iommu=on vfio-pci.ids=01:00.0,01:00.1"
Back to top
View user's profile Send private message
zino
n00b
n00b


Joined: 14 Jan 2016
Posts: 21
Location: Switzerland

PostPosted: Tue May 16, 2017 3:28 pm    Post subject: Reply with quote

Check if adding

Code:
-display none -nographic


to the qemu command line makes any difference.

If that doesn't change anything, please tell us what kind of gpu you're trying to pass through and post the output of dmesg.

While going to your qemu script again, I noticed that you're using
Code:
x-vga=on
.

This is only necessary when you use seabios to boot a guest, but since you're booting with uefi you can set this parameter to off.


Last edited by zino on Tue May 16, 2017 3:53 pm; edited 1 time in total
Back to top
View user's profile Send private message
niceflower
Tux's lil' helper
Tux's lil' helper


Joined: 31 Mar 2017
Posts: 76

PostPosted: Tue May 16, 2017 3:42 pm    Post subject: Reply with quote

hello, i did not really read your thread, are you running qemu in gentoo host?
For me it worked by installed the qemu gentoo package with emerge, then when compile is done, run this argument within the /dir/ of .iso and VM image:

Code:
./GentooVM -enable-kvm -display gtk -cpu kvm64 -m 3G -boot d -cdrom live.iso

U need build in kvm module in kernel, and compile qemu with USE
Code:
gtk opengl glx kvm


source: https://wiki.gentoo.org/wiki/QEMU/Linux_guest
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5974

PostPosted: Tue May 16, 2017 5:18 pm    Post subject: Reply with quote

I can see what you're trying to do, but nothing in the info provided really jumps out as wrong.
Something quick you could try, if those suggestions zino posted don't help: if you still have that gentoo/ubuntu ISO around, see if qemu will boot it. That'd at least determine whether the problem's with windows, qemu or something else.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum