Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[3615Mavie] : Chroniques de geeks (tome 6)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 17, 18, 19  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Oupsman
Veteran
Veteran


Joined: 19 Jul 2004
Posts: 1042

PostPosted: Mon Jul 03, 2017 6:24 am    Post subject: Reply with quote

Démonstration :

Code:


root@xxxxxxxx:~# cat /usr/lib/systemd/system/factorio.service
[Unit]
Description=Factorio Server

[Service]
Type=simple
Userr=factorio
ExecStart=/opt/factorio/bin/x64/factorio --start-server /opt/factorio/OUPSFACTORY.zip

root@xxxxxx:~# systemctl status factorio
â factorio.service - Factorio Server
   Loaded: loaded (/usr/lib/systemd/system/factorio.service; static; vendor preset: enabled)
   Active: inactive (dead)

Jul 03 08:19:29 xxxx systemd[1]: [/usr/lib/systemd/system/factorio.service:6] Unknown lvalue 'Userr' in section 'Service'
Jul 03 08:19:36 xxxx systemd[1]: [/usr/lib/systemd/system/factorio.service:6] Unknown lvalue 'Userr' in section 'Service'

root@xxxxxx:~# ps -ef | grep factorio
root     17273     1 16 08:19 ?        00:00:03 /opt/factorio/bin/x64/factorio --start-server /opt/factorio/OUPSFACTORY.zip



La sécurité selon Lennart Poettering. C'est pas un bug, c'est une fonctionnalité. J'hésite entre rire et pleurer.
_________________
--
L'idéal de nouveauté semble avoir remplacé l'idéal de progrès. C'est bien triste.

----
Unix philosophy: "Do one thing and do it well."
systemd: "Try to do everything and do it wrong."
Back to top
View user's profile Send private message
helecho
Apprentice
Apprentice


Joined: 26 Dec 2016
Posts: 178

PostPosted: Mon Jul 03, 2017 11:07 am    Post subject: Reply with quote

Code:
root@xxxxxx:~# systemctl status factorio
    Loaded: loaded (/usr/lib/systemd/system/factorio.service; static; vendor preset: enabled) 
    Active: inactive (dead)


Je pense que systemd a détruit le service (processus) ! dead :P

Code:
root@xxxxxx:~# ps -ef | grep factorio
root     17273     1 16 08:19 ?        00:00:03 /opt/factorio/bin/x64/factorio --start-server /opt/factorio/OUPSFACTORY.zip


Toutefois, je n'ai pas appréhendé le résultat de la commande ps.
Back to top
View user's profile Send private message
Oupsman
Veteran
Veteran


Joined: 19 Jul 2004
Posts: 1042

PostPosted: Mon Jul 03, 2017 1:01 pm    Post subject: Reply with quote

la commande de restart n'apparait pas dans ma trace effectivement ...

Le ps indique que le processus factorio fonctionne en tant que l'utilisateur root ...
_________________
--
L'idéal de nouveauté semble avoir remplacé l'idéal de progrès. C'est bien triste.

----
Unix philosophy: "Do one thing and do it well."
systemd: "Try to do everything and do it wrong."
Back to top
View user's profile Send private message
k-root
Guru
Guru


Joined: 08 Jan 2005
Posts: 419

PostPosted: Wed Jul 05, 2017 7:11 pm    Post subject: Reply with quote

https://github.com/systemd/systemd/issues/6237 wrote:
there's 2 bugs - one is that it is still running as root and the other is that it doesn't support usernames starting with numbers.


http://i.imgur.com/6sJfdqM.jpg
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3027
Location: Paris

PostPosted: Mon Jul 31, 2017 2:30 pm    Post subject: Reply with quote

Oupsman wrote:
La sécurité selon Lennart Poettering. C'est pas un bug, c'est une fonctionnalité. J'hésite entre rire et pleurer.

Un petit follow-up.
A priori, il n'y a pas que nous que ça a fait rire: Systemd wins top gong for 'lamest vendor' in Pwnie security awards
_________________
-Gentoo hardened: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
helecho
Apprentice
Apprentice


Joined: 26 Dec 2016
Posts: 178

PostPosted: Fri Oct 06, 2017 8:10 am    Post subject: Installateur Gentoo Reply with quote

Je souhaiterais disposer d'un installateur Gentoo : mon but est d'automatiser l'installation. En effet, il est fastidieux d'adapter (ou de changer) souvent les caractéristiques de son système.

Brièvement, j'élaborerais un installateur soit en le concevant ou en adaptant un installateur existant.

Quelqu'un a-t'il déjà utilisé un installateur Gentoo ?

Références
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7217
Location: ~Brussels - Belgique

PostPosted: Fri Oct 06, 2017 8:21 am    Post subject: Reply with quote

Bonjour,

Il y a déjà eu une tentative d'installateur officiel Gentoo, et le projet a été abandonné.

Bonne chance ! ;)

Tentative abandonnée
https://wiki.gentoo.org/wiki/Project:Installer/Old

Nouvelle tentative
https://wiki.gentoo.org/wiki/Project:Installer
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
helecho
Apprentice
Apprentice


Joined: 26 Dec 2016
Posts: 178

PostPosted: Fri Oct 06, 2017 5:23 pm    Post subject: Automatisation d'une installation Reply with quote

Bonsoir !

J'ai eu connaissance de ce projet l'année dernière. Il me semble judicieux d'élaborer un installateur en mode texte pour simplifier le développement.
Autrement, l'interface graphique de l'installateur Gentoo permettrait éventuellement de présenter un système Gentoo.
En principe, l'utilisateur appréhende le déroulement de l'installation et adapte l'installateur si nécessaire (en le configurant).

J'avais déjà considéré les programmes sources stager et stage7 (anciennement quickstart). Subjectivement, stager me semblait abstrait.

N.B : Il faudrait que je teste les différentes approches.
  • https://wiki.gentoo.org/wiki/Project:RelEng_GRS

P.S : Merci Xavier !
Back to top
View user's profile Send private message
bdouxx
Tux's lil' helper
Tux's lil' helper


Joined: 28 Dec 2009
Posts: 114

PostPosted: Sat Oct 14, 2017 1:05 pm    Post subject: Reply with quote

salut


Avant de déclarer un bug sur systemd, j'aimerai juste savoir si d'autre personnes sont dans mon cas.

Dans le but de résoudre un problème réseau, j'ai modifié des fichiers de conf et mit en ~amd64 certains paquets. A défaut de résoudre mes problème, je ne peux plus que démarrer qu'en single-user car le démarrage normal freeze et j'en suis donc a analyser les traces de systemd.

mais quand je lance la commande
Code:
journalctl -x -b -1


j'ai dans mes log des truc dans le genre:

Code:

-- L'unité (unit) systemd-remount-fs.service a terminé son démarrage, avec le résultat RESULT.
-- L'unité (unit) systemd-random-seed.service a terminé son démarrage, avec le résultat RESULT.
-- L'unité (unit) jenkins.service a terminé son démarrage, avec le résultat RESULT.


il y a donc un problème lors du remplacement des variable dans le fichier d'internalionalisation /usr/lib/systemd/catalog/systemd.fr.catalog


Savez vous d'où cela peut il venir?

faut il mieux déclarer un bug chez gentoo ou chez systemd?
Code:

* sys-apps/systemd
     Available versions:  233-r4(0/2) (~)234-r4(0/2) (~)235(0/2) **9999(0/2)
     IUSE (all versions): acl apparmor audit build cryptsetup curl doc elfutils +gcrypt gnuefi http idn importd +kmod libidn2 +lz4 lzma nat pam policykit qrcode +seccomp selinux ssl sysv-utils test vanilla xkb ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"
     Installed versions:  Version:   235
                          Date:      22:58:15 13/10/2017
                          USE:       acl gcrypt kmod lz4 pam policykit seccomp ssl -apparmor -audit -build -cryptsetup -curl -elfutils -gnuefi -http -idn -importd -libidn2 -lzma -nat -qrcode -selinux -sysv-utils -test -vanilla -xkb ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32"
                          DEPEND:    >=sys-apps/util-linux-2.30:0/0=[abi_x86_32(-),abi_x86_64(-)] sys-libs/libcap:0/0=[abi_x86_32(-),abi_x86_64(-)] !<sys-libs/glibc-2.16 sys-apps/acl:0/0= >=dev-libs/libgcrypt-1.4.5:0/20=[abi_x86_32(-),abi_x86_64(-)] >=sys-apps/kmod-15:0/0= >=app-arch/lz4-0_p131:0/r131=[abi_x86_32(-),abi_x86_64(-)] virtual/pam:0/0=[abi_x86_32(-),abi_x86_64(-)] >=sys-libs/libseccomp-2.3.1:0/0= !<=app-emulation/emul-linux-x86-baselibs-20130224-r9 !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] app-arch/xz-utils:0 dev-util/gperf >=dev-util/intltool-0.50 >=sys-apps/coreutils-8.16 >=sys-kernel/linux-headers-3.11 virtual/pkgconfig app-text/docbook-xml-dtd:4.2 app-text/docbook-xml-dtd:4.5 app-text/docbook-xsl-stylesheets dev-libs/libxslt:0 || ( ( dev-lang/python:3.6 dev-python/lxml[python_targets_python3_6(-),python_single_target_python3_6(+)] ) ( dev-lang/python:3.5 dev-python/lxml[python_targets_python3_5(-),python_single_target_python3_5(+)] ) ( dev-lang/python:3.4 dev-python/lxml[python_targets_python3_4(-),python_single_target_python3_4(+)] ) ) >=dev-util/meson-0.40.0 >=dev-util/ninja-1.7.2 virtual/pkgconfig virtual/pkgconfig
                          RDEPEND:   >=sys-apps/util-linux-2.30:0/0=[abi_x86_32(-),abi_x86_64(-)] sys-libs/libcap:0/0=[abi_x86_32(-),abi_x86_64(-)] !<sys-libs/glibc-2.16 sys-apps/acl:0/0= >=dev-libs/libgcrypt-1.4.5:0/20=[abi_x86_32(-),abi_x86_64(-)] >=sys-apps/kmod-15:0/0= >=app-arch/lz4-0_p131:0/r131=[abi_x86_32(-),abi_x86_64(-)] virtual/pam:0/0=[abi_x86_32(-),abi_x86_64(-)] >=sys-libs/libseccomp-2.3.1:0/0= !<=app-emulation/emul-linux-x86-baselibs-20130224-r9 !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] >=sys-apps/baselayout-2.2 || ( sys-apps/util-linux[kill(-)] sys-process/procps[kill(+)] sys-apps/coreutils[kill(-)] ) !sys-auth/nss-myhostname !<sys-kernel/dracut-044 !sys-fs/eudev !sys-fs/udev
                          PDEPEND:   >=sys-apps/dbus-1.9.8[systemd] >=sys-apps/hwids-20150417[udev] >=sys-fs/udev-init-scripts-25 sys-auth/polkit sys-apps/gentoo-systemd-integration
                          EAPI:      6
                          (~)235(0/2)
     Homepage:            https://www.freedesktop.org/wiki/Software/systemd
     Find open bugs:      https://bugs.gentoo.org/buglist.cgi?quicksearch=sys-apps%2Fsystemd
     Description:         System and service manager for Linux
     License:             GPL-2 LGPL-2.1 MIT public-domain
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page Previous  1, 2, 3 ... 17, 18, 19
Page 19 of 19

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum