Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201801-09 ] WebkitGTK+
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2087

PostPosted: Mon Jan 08, 2018 7:26 am    Post subject: [ GLSA 201801-09 ] WebkitGTK+ Reply with quote

Gentoo Linux Security Advisory

Title: WebkitGTK+: Multiple vulnerabilities (GLSA 201801-09)
Severity: normal
Exploitable: remote
Date: 2018-01-07
Bug(s): #641752
ID: 201801-09

Synopsis

Multiple vulnerabilities have been found in WebkitGTK+, the worst
of which may lead to arbitrary code execution.


Background

WebKitGTK+ is a full-featured port of the WebKit rendering engine.

Affected Packages

Package: net-libs/webkit-gtk
Vulnerable: < 2.18.4
Unaffected: >= 2.18.4
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in WebkitGTK+. Please
review the referenced CVE Identifiers for details.


Impact

An attacker, by enticing a user to visit maliciously crafted web
content, may be able to execute arbitrary code or cause memory
corruption.


Workaround

There are no known workarounds at this time.

Resolution

All WebkitGTK+ users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=net-libs/webkit-gtk-2.18.4:4"
   


References


CVE-2017-13856


CVE-2017-13866


CVE-2017-13870


CVE-2017-7156


CVE-2017-7157


Last edited by GLSA on Mon Jan 15, 2018 4:17 am; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum