Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Spotify can't play local files
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
program666
n00b
n00b


Joined: 08 Jun 2014
Posts: 9

PostPosted: Fri Jun 12, 2015 8:51 pm    Post subject: Spotify can't play local files Reply with quote

Just installed Spotify for the first time and it just won't play any music from my library, but it will play the same local files on Windows. When emerging I got the warning:
Code:

 * Messages for package media-sound/spotify-0.9.17.1-r1:

 * If Spotify crashes after an upgrade its cache may be corrupt.
 * To remove the cache:
 * rm -rf ~/.cache/spotify
 *
 * you need to use the ld.bfd linker with openssl


And I don't even know what that last line mean but but I got the errors
Code:

/opt/spotify/spotify-client/spotify: /usr/lib64/libcrypto.so.1.0.0: no version information available (required by /opt/spotify/spotify-client/spotify)
/opt/spotify/spotify-client/spotify: /usr/lib64/libssl.so.1.0.0: no version information available (required by /opt/spotify/spotify-client/spotify)

that I read in some other thread that are harmless but I thought about mentioning them.

When I look for help for this problem one of the solutions is aways getting codecs in sketchy as hell sites, that only give you a ".exe" file when downloading, and people on the Spotify forums warning others to not install the adware that comes with, and I would want to avoid it if possible. But I tried other appointed solutions like deleting all my local library from Spotify and then re-importing, installing libquicktime, unmerging it from the system and emerging again and deleting the cache. You guys have any idea?


Last edited by program666 on Fri Jun 12, 2015 9:52 pm; edited 1 time in total
Back to top
View user's profile Send private message
program666
n00b
n00b


Joined: 08 Jun 2014
Posts: 9

PostPosted: Fri Jun 12, 2015 9:52 pm    Post subject: Reply with quote

I finally solved this after multiple hours on it, it seems that the problem is most likely a too recent version of ffmpeg, so you have to use an older version. The steps are as follow:
- Download the version 9 of the lib av here http://libav.org/download.html (tarbal http://libav.org/releases/libav-9.18.tar.gz)
- ./configure --enable-shared; make
- copy the .so files to the appropriated places like so
Code:

#from the libav directory, I chose to copy to them to the spotify-client directory to stay separated from the "official" libs installed via portage
cp libavcodec/libavcodec.so.54 libavformat/libavformat.so.54 /opt/spotify/spotify-client/
#spotify will not look for the libavutil on the same directory, only /lib64 or /usr/lib64, so
cp libavutil/libavutil.so.52 /usr/lib64/


That's it.
I used the version 9 ("plain 9") because the version 8 suggested on the original post where I got this solution from, credited below, wouldn't compile for some reason, that will be enough.

To find out what libraries spotify was looking for and in what place you can just run
Code:

strace spotify 2>&1 |grep open|grep lib


Full credits for this solution to this post on the spotify forums: https://community.spotify.com/t5/Help-Desktop-Linux-Mac-Windows/Solved-Linux-Spotify-0-9-4-no-Local-Files-reproduction-after/td-p/689438

Obs: I'm gonna remove the [SOLVED] tag that I had put up because this is more like a workaround and it would be nice to know a better more permanent solution, I mean, that libavutil file on the /usr/lib64 directory might cause problems to portage or something.
Back to top
View user's profile Send private message
<3
l33t
l33t


Joined: 21 Oct 2004
Posts: 876

PostPosted: Fri Jan 12, 2018 1:22 am    Post subject: Reply with quote

It's 2018 and I am having this issue, Does this solution still fix this problem. Also I am skeptical of installing old, outdated software outside of portage. Is anyone else having this problem still?
Back to top
View user's profile Send private message
bunder
Bodhisattva
Bodhisattva


Joined: 10 Apr 2004
Posts: 5356

PostPosted: Sat Jan 13, 2018 8:55 pm    Post subject: Reply with quote

I can't even add local tracks to spotify, it's a really old bug and they probably won't fix it.
Back to top
View user's profile Send private message
josephg
l33t
l33t


Joined: 10 Jan 2016
Posts: 641

PostPosted: Sat Jan 13, 2018 9:55 pm    Post subject: Reply with quote

libav-9 is still available on portage, if you want to try.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum