Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
PL2303 not recognized (present in kernel)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Oniryczny
Guru
Guru


Joined: 01 Dec 2011
Posts: 388
Location: Poland

PostPosted: Sat Mar 10, 2018 7:24 pm    Post subject: PL2303 not recognized (present in kernel) Reply with quote

Hello

I don't know what happened but plugging my USB serial PL2303 is not seen in system
Code:

$ cat /usr/src/linux/.config | grep SERIAL
# CONFIG_MOUSE_SERIAL is not set
# CONFIG_TABLET_SERIAL_WACOM4 is not set
# CONFIG_TOUCHSCREEN_EGALAX_SERIAL is not set
CONFIG_SERIAL_NONSTANDARD=y
CONFIG_SERIAL_EARLYCON=y
CONFIG_SERIAL_8250=y
CONFIG_SERIAL_8250_DEPRECATED_OPTIONS=y
CONFIG_SERIAL_8250_PNP=y
# CONFIG_SERIAL_8250_FINTEK is not set
CONFIG_SERIAL_8250_CONSOLE=y
CONFIG_SERIAL_8250_DMA=y
CONFIG_SERIAL_8250_PCI=y
CONFIG_SERIAL_8250_NR_UARTS=32
CONFIG_SERIAL_8250_RUNTIME_UARTS=4
CONFIG_SERIAL_8250_EXTENDED=y
CONFIG_SERIAL_8250_MANY_PORTS=y
CONFIG_SERIAL_8250_SHARE_IRQ=y
CONFIG_SERIAL_8250_DETECT_IRQ=y
CONFIG_SERIAL_8250_RSA=y
# CONFIG_SERIAL_8250_FSL is not set
# CONFIG_SERIAL_8250_DW is not set
CONFIG_SERIAL_8250_RT288X=y
CONFIG_SERIAL_8250_LPSS=y
CONFIG_SERIAL_8250_MID=y
# CONFIG_SERIAL_8250_MOXA is not set
# CONFIG_SERIAL_UARTLITE is not set
CONFIG_SERIAL_CORE=y
CONFIG_SERIAL_CORE_CONSOLE=y
# CONFIG_SERIAL_JSM is not set
# CONFIG_SERIAL_SCCNXP is not set
# CONFIG_SERIAL_SC16IS7XX is not set
# CONFIG_SERIAL_ALTERA_JTAGUART is not set
# CONFIG_SERIAL_ALTERA_UART is not set
# CONFIG_SERIAL_ARC is not set
# CONFIG_SERIAL_RP2 is not set
# CONFIG_SERIAL_FSL_LPUART is not set
# CONFIG_SND_SERIAL_U16550 is not set
CONFIG_USB_SERIAL=y
CONFIG_USB_SERIAL_CONSOLE=y
CONFIG_USB_SERIAL_GENERIC=y
# CONFIG_USB_SERIAL_SIMPLE is not set
# CONFIG_USB_SERIAL_AIRCABLE is not set
# CONFIG_USB_SERIAL_ARK3116 is not set
# CONFIG_USB_SERIAL_BELKIN is not set
# CONFIG_USB_SERIAL_CH341 is not set
# CONFIG_USB_SERIAL_WHITEHEAT is not set
# CONFIG_USB_SERIAL_DIGI_ACCELEPORT is not set
CONFIG_USB_SERIAL_CP210X=m
# CONFIG_USB_SERIAL_CYPRESS_M8 is not set
# CONFIG_USB_SERIAL_EMPEG is not set
CONFIG_USB_SERIAL_FTDI_SIO=m
# CONFIG_USB_SERIAL_VISOR is not set
# CONFIG_USB_SERIAL_IPAQ is not set
# CONFIG_USB_SERIAL_IR is not set
# CONFIG_USB_SERIAL_EDGEPORT is not set
# CONFIG_USB_SERIAL_EDGEPORT_TI is not set
# CONFIG_USB_SERIAL_F81232 is not set
# CONFIG_USB_SERIAL_GARMIN is not set
# CONFIG_USB_SERIAL_IPW is not set
# CONFIG_USB_SERIAL_IUU is not set
# CONFIG_USB_SERIAL_KEYSPAN_PDA is not set
# CONFIG_USB_SERIAL_KEYSPAN is not set
# CONFIG_USB_SERIAL_KLSI is not set
# CONFIG_USB_SERIAL_KOBIL_SCT is not set
# CONFIG_USB_SERIAL_MCT_U232 is not set
# CONFIG_USB_SERIAL_METRO is not set
CONFIG_USB_SERIAL_MOS7720=m
CONFIG_USB_SERIAL_MOS7840=m
CONFIG_USB_SERIAL_MXUPORT=m
# CONFIG_USB_SERIAL_NAVMAN is not set
CONFIG_USB_SERIAL_PL2303=m
# CONFIG_USB_SERIAL_OTI6858 is not set
# CONFIG_USB_SERIAL_QCAUX is not set
# CONFIG_USB_SERIAL_QUALCOMM is not set
# CONFIG_USB_SERIAL_SPCP8X5 is not set
# CONFIG_USB_SERIAL_SAFE is not set
# CONFIG_USB_SERIAL_SIERRAWIRELESS is not set
# CONFIG_USB_SERIAL_SYMBOL is not set
# CONFIG_USB_SERIAL_TI is not set
# CONFIG_USB_SERIAL_CYBERJACK is not set
# CONFIG_USB_SERIAL_XIRCOM is not set
CONFIG_USB_SERIAL_WWAN=m
CONFIG_USB_SERIAL_OPTION=m
# CONFIG_USB_SERIAL_OMNINET is not set
# CONFIG_USB_SERIAL_OPTICON is not set
# CONFIG_USB_SERIAL_XSENS_MT is not set
# CONFIG_USB_SERIAL_WISHBONE is not set
# CONFIG_USB_SERIAL_SSU100 is not set
# CONFIG_USB_SERIAL_QT2 is not set
# CONFIG_USB_SERIAL_DEBUG is not set
$

dmesg says nothing
_________________
cogito ergo sum
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44171
Location: 56N 3W

PostPosted: Sat Mar 10, 2018 7:30 pm    Post subject: Reply with quote

Oniryczny,

Is it in lsusb?
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Oniryczny
Guru
Guru


Joined: 01 Dec 2011
Posts: 388
Location: Poland

PostPosted: Sat Mar 10, 2018 7:54 pm    Post subject: Reply with quote

it is not.
Windows recognizes it and debian recognizes it too
Code:

Bus 005 Device 004: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port
Code:

[  244.972319] usb 5-4: pl2303 converter now attached to ttyUSB0

_________________
cogito ergo sum
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44171
Location: 56N 3W

PostPosted: Sat Mar 10, 2018 8:17 pm    Post subject: Reply with quote

Oniryczny,

That worked
Code:
 [  244.972319] usb 5-4: pl2303 converter now attached to ttyUSB0

I suppose that was from Gentoo and not Windows or Debian ?
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Oniryczny
Guru
Guru


Joined: 01 Dec 2011
Posts: 388
Location: Poland

PostPosted: Sat Mar 10, 2018 8:31 pm    Post subject: Reply with quote

it is from debian...
_________________
cogito ergo sum
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44171
Location: 56N 3W

PostPosted: Sat Mar 10, 2018 8:41 pm    Post subject: Reply with quote

Oniryczny,

We need to see it not working in Gentoo.
In Gentoo, does it appear in lsusb?

Does the module appear in
Code:
 $ lsmod
Module                  Size  Used by
isofs                  40960  0
udf                    86016  0
crc_itu_t              16384  1 udf
sata_sil               16384  0
fuse                   94208  2
pl2303                 20480  0
...


What happens when you
Code:
modprobe pl2303
?
Any on screen feedback or anything in dmesg?
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Oniryczny
Guru
Guru


Joined: 01 Dec 2011
Posts: 388
Location: Poland

PostPosted: Sat Mar 10, 2018 8:55 pm    Post subject: Reply with quote

Code:
$ lsmod
Module                  Size  Used by
fam15h_power            4503  0
k10temp                 3060  0
vhba                    8234  0
vboxpci                14318  0
vboxnetadp             18502  0
vboxnetflt             16580  0
vboxdrv               359825  3 vboxnetadp,vboxnetflt,vboxpci
$ LANG=C su -
Password:
# modprobe pl2303
# lsmod
Module                  Size  Used by
pl2303                  8944  0
fam15h_power            4503  0
k10temp                 3060  0
vhba                    8234  0
vboxpci                14318  0
vboxnetadp             18502  0
vboxnetflt             16580  0
vboxdrv               359825  3 vboxnetadp,vboxnetflt,vboxpci
#

dmesg says nothing when I plug it in

I got confused maybe it simply got broken after years using it :( :oops:


I don't have any other PL2303 converter but plugging FT232 works fine... :(
_________________
cogito ergo sum
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44171
Location: 56N 3W

PostPosted: Sat Mar 10, 2018 9:02 pm    Post subject: Reply with quote

Oniryczny,

Maybe the USB port you are connecting it to is faulty or overloaded?
Try other USB ports.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Oniryczny
Guru
Guru


Joined: 01 Dec 2011
Posts: 388
Location: Poland

PostPosted: Sat Mar 10, 2018 9:06 pm    Post subject: Reply with quote

tried that already
and connecting other USB thing into it (like mass storage) works

this converter is old and I am seriously confused it simply might died :(

I will check it on monday at work with my other gentoo installation and with second PL2303 device (like OBDII car connector)


I should appologize for making mess with another post if it may be broken :oops: :oops: :oops:
_________________
cogito ergo sum
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44171
Location: 56N 3W

PostPosted: Sat Mar 10, 2018 9:31 pm    Post subject: Reply with quote

Oniryczny,

My PL2303 is old too.
I only use it to connect to a serial console on my Raspberry Pi.

Diagnosing faulty hardware is a last ditch thing.
I like to try everything else first :)
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Oniryczny
Guru
Guru


Joined: 01 Dec 2011
Posts: 388
Location: Poland

PostPosted: Mon Mar 12, 2018 5:54 am    Post subject: Reply with quote

http://wstaw.org/w/4Oei/
tried to solder it because the USB plug was not stable but still there's something wrong
Code:

$ Pobrane/dmesg.perl | tail
[2018-03-12 06:50:28]  usb usb3-port5: attempt power cycle
[2018-03-12 06:50:29]  usb 3-5: new full-speed USB device number 80 using xhci_hcd
[2018-03-12 06:50:29]  usb 3-5: Device not responding to setup address.
[2018-03-12 06:50:29]  usb 3-5: Device not responding to setup address.
[2018-03-12 06:50:29]  usb 3-5: device not accepting address 80, error -71
[2018-03-12 06:50:30]  usb 3-5: new full-speed USB device number 81 using xhci_hcd
[2018-03-12 06:50:30]  usb 3-5: Device not responding to setup address.
[2018-03-12 06:50:30]  usb 3-5: Device not responding to setup address.
[2018-03-12 06:50:30]  usb 3-5: device not accepting address 81, error -71
[2018-03-12 06:50:30]  usb usb3-port5: unable to enumerate USB device
$

_________________
cogito ergo sum


Last edited by Oniryczny on Mon Mar 12, 2018 8:04 am; edited 2 times in total
Back to top
View user's profile Send private message
bunder
Bodhisattva
Bodhisattva


Joined: 10 Apr 2004
Posts: 5882

PostPosted: Mon Mar 12, 2018 7:14 am    Post subject: Reply with quote

I just bought one (pl2303-based avrisp mk ii) and it works fine... now if only I could solder my atmega pcb correctly... hot air station in the mail. 8)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum