Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
tmux clear buffer and numlock not working in tty
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
samuelbernardo
n00b
n00b


Joined: 30 Jan 2016
Posts: 15

PostPosted: Sun Mar 04, 2018 1:11 pm    Post subject: tmux clear buffer and numlock not working in tty Reply with quote

I'm using kernel 4.9.84-gentoox99 with profile default/linux/amd64/17.0.

I realize now that, using tmux on a tty, when pane becomes full of text and it goes to the top, buffer clearing is not working as expected. "clear" command also don't empty text inside pane, but puts the cursor on the top. Text is replaced as it goes writting, but becomes a real mess inappropriate for reading. For tmux in tty I've set $TERM=screen-256color. I'm using nvidia modules in UEFI. Numlock is also not working giving a bip after pressing it.

When using tty outside tmux everything works as expected. Anybody knows why that is happening in tmux-2.6?

thks
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 6937
Location: almost Mile High in the USA

PostPosted: Sun Mar 04, 2018 7:24 pm    Post subject: Reply with quote

What is your TERM outside and inside of tmux? What terminal emulator are you using?

Seems to 'WFM' ... I'm using xfce4-terminal (vte) with TERM="xterm-256color" outside and TERM="screen" inside.

What version of ncurses are you using?

The numlock problem is probably something else, what X11 windowmanager/environment are you using?
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
samuelbernardo
n00b
n00b


Joined: 30 Jan 2016
Posts: 15

PostPosted: Sun Mar 11, 2018 3:58 pm    Post subject: Reply with quote

Sorry the delay, but I forget to enable notifications for new posts.

eccerr0r wrote:
What is your TERM outside and inside of tmux? What terminal emulator are you using?


Inside tmux I'm using screen-256color.
Outside tmux I'm using xterm-256color.

Reviewing arch linux tmux documentation[1] I realise that it needs tmux-256color starting with 2.1 version. With that it seems to work as expected.

[1] https://wiki.archlinux.org/index.php/tmux#Setting_the_correct_term

eccerr0r wrote:

Seems to 'WFM' ... I'm using xfce4-terminal (vte) with TERM="xterm-256color" outside and TERM="screen" inside.

What version of ncurses are you using?


I've installed ncurses 5.9-r101 and 6.0-r1. Looking into tmux strings I confirm that it's linked with libncurses.so.6.


eccerr0r wrote:

The numlock problem is probably something else, what X11 windowmanager/environment are you using?


I'm using kde plasma 5.12.3 with sddm 0.17.0-r1. But I've no problem with numlock inside X. Only using tmux outside X (in tty) numlock don't work.

Thanks eccerr0r for your hints.

Cheers
Back to top
View user's profile Send private message
samuelbernardo
n00b
n00b


Joined: 30 Jan 2016
Posts: 15

PostPosted: Sun Mar 11, 2018 4:59 pm    Post subject: Reply with quote

Unfortunately it's not working tmux in tty (witrhout X) when forcing TERM=tmux-256color.

Outside tmux it works without any problem. clear works as expected.

When inside tmux clear command put the cursor on top of the screen but didn't clear the text in the screen buffer.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum