Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Kernel hangs when Intel SSD DC P3520 is installed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
chrisk2305
Tux's lil' helper
Tux's lil' helper


Joined: 05 Sep 2007
Posts: 88

PostPosted: Fri Jun 22, 2018 9:02 am    Post subject: Kernel hangs when Intel SSD DC P3520 is installed Reply with quote

Hi,

I have been struggling this whole week to get my system to run with a newly bought Intel SSD DC P3520 (only as Data disk).

I have an issues booting the Linux Kernel (4.14.50) when a Intel SSD DC P3520 is installed (in the x4 PCH Slot 7 - also tried the slots connected to the CPU directly - no difference). Mainboard is a Supermicro X11SSA-F. I also have an Intel SSD 6000p M.2 500gb as boot drive that works flawlessly.

During hardware initialization (so very early - just a second after the kernel loads) the system hangs. No error is shown though.

As soon as I remove the Intel SSD DC P3520 the system can boot fine. Always reproducible. SSD has the latest firmware.

Bios is also the latest on the board (R2.1a).

As the boot drive is also an NVMe disk I don't understand why it hangs. The SSD works fine in Windows (interestingly it shows me the SSD as SDHC in Windows and Kernel also hangs shortly after loading the sdhci driver - but this is maybe just coincidence).

Appreciate your help!

Thanks,
Christian

Edit: SystemRescueCD loads fine (Kernel 4.14.32)
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6316
Location: /usr/lib64/lv2

PostPosted: Fri Jun 22, 2018 7:10 pm    Post subject: Reply with quote

Run lspci and lsmod in sysresccd to see what hardware is reported and what drivers are being used, then chroot into your system from there and make sure the kernel option includes those drivers.
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
Oniryczny
Guru
Guru


Joined: 01 Dec 2011
Posts: 388
Location: Poland

PostPosted: Sat Jun 23, 2018 7:48 pm    Post subject: Reply with quote

is it always reported as SDHC in every PCI-E port?
are there any options to make it work in some other mode in the BIOS?
_________________
cogito ergo sum
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5878

PostPosted: Sun Jun 24, 2018 3:48 am    Post subject: Reply with quote

Describe how it hangs, does magic sysrq still work to reboot the machine? Could be a missing firmware file - sysresccd's dmesg would show it in that case.
Back to top
View user's profile Send private message
P.Kosunen
Guru
Guru


Joined: 21 Nov 2005
Posts: 309
Location: Finland

PostPosted: Mon Jun 25, 2018 4:11 pm    Post subject: Reply with quote

Maybe it messes drive order numbers, have you UUID or device names in bootloader and kernel boot options?
Back to top
View user's profile Send private message
Oniryczny
Guru
Guru


Joined: 01 Dec 2011
Posts: 388
Location: Poland

PostPosted: Fri Jun 29, 2018 3:02 pm    Post subject: Reply with quote

what about NVME in your kernel?
_________________
cogito ergo sum
Back to top
View user's profile Send private message
P.Kosunen
Guru
Guru


Joined: 21 Nov 2005
Posts: 309
Location: Finland

PostPosted: Sat Jun 30, 2018 11:30 am    Post subject: Reply with quote

Oniryczny wrote:
what about NVME in your kernel?


Should be good, 6000p has no Sata models:

chrisk2305 wrote:
I also have an Intel SSD 6000p M.2 500gb as boot drive that works flawlessly.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum