Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
app-misc/lirc and kernel 4.16
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
P.Kosunen
Guru
Guru


Joined: 21 Nov 2005
Posts: 309
Location: Finland

PostPosted: Sat Apr 14, 2018 10:20 am    Post subject: app-misc/lirc and kernel 4.16 Reply with quote

What has chanced in lirc with 4.16 kernel, CONFIG_IR_LIRC_CODEC is missing?

Code:
# grep LIRC linux-4.15.15-gentoo/.config
CONFIG_LIRC=m
CONFIG_IR_LIRC_CODEC=m


Code:
# grep LIRC linux-4.16.2-gentoo/.config
CONFIG_LIRC=y
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 14056

PostPosted: Sat Apr 14, 2018 5:03 pm    Post subject: Reply with quote

According to git, it was removed in media: lirc: lirc interface should not be a raw decoder.
Code:
$ git log --oneline -GIR_LIRC_CODEC v4.15..v4.16 -- '*Kconfig*'
a60d64b15c20 media: lirc: lirc interface should not be a raw decoder
Back to top
View user's profile Send private message
P.Kosunen
Guru
Guru


Joined: 21 Nov 2005
Posts: 309
Location: Finland

PostPosted: Sat Apr 21, 2018 3:44 pm    Post subject: Reply with quote

I sent message to lirc mailing list:
Quote:
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=a60d64b15c20d178ba3a9bc3a542492b4ddeea70

Kernel config option missing for lirc protocol might not be related to issue, syslog shows:
Apr 21 14:14:09 beebox lircd-0.11.0-devel[3075]: Notice: 'lirc' written to protocols file /sys/class/rc/rc0/protocols
Apr 21 14:14:09 beebox lircd-0.11.0-devel[3075]: Info: Initial device: /dev/lirc0
Apr 21 14:14:09 beebox lircd-0.11.0-devel[3075]: Info: [lirc] protocol is enabled

http://kosunen.fi/gentoo/lirc/

Dmesg and logs seem to be fine in both cases, with 4.16 kernel remote just is not working.

mode2 --driver default --device /dev/lirc0
mode2 --driver devinput --device /dev/lirc0
cat /dev/lirc0
cat /dev/input/event11
irw

These commands show no output when using remote with kernel 4.16 and lirc 0.10 or latest from git.


Lirc confs & system logs packed:
http://kosunen.fi/gentoo/lirc-confs-logs.tar.gz


How can i test if nuvoton-cir is working properly?
Back to top
View user's profile Send private message
Saundersx
Apprentice
Apprentice


Joined: 11 Apr 2005
Posts: 251

PostPosted: Thu May 03, 2018 8:12 am    Post subject: Reply with quote

Im in the same boat, just upgraded to 4.16.7 from 4.15 and lost lirc. I have a hauppauge dvb card that is only used as a remote now and cannot get it to receive anything.
Code:
$ ir-keytable
Found /sys/class/rc/rc0/ (/dev/input/event14) with:
        Name: cx88 IR (Hauppauge Nova-S-Plus
        Driver: cx88xx, table: rc-hauppauge
        lirc device: /dev/lirc0
        Supported protocols: lirc rc-5 rc-5-sz
        Enabled protocols: lirc rc-5
        bus: 1, vendor/product: 0070:9202, version: 0x0001
        Repeat delay = 500 ms, repeat period = 125 ms


this is definitely flakey
Code:
$ mode2 --driver devinput --list-devices
/dev/input/event14 [(null):(null)] ? ? version: ? serial: ?
/dev/input/by-path/pci-0000:04:06.2-event-ir -> ../event14
/dev/input/irremote -> event14


irw aside just doing "cat /dev/input/event14" returns nothing. Looking at dmesg everything loads fine. I'm at a loss at what the problem could be.
Back to top
View user's profile Send private message
mymatenige
n00b
n00b


Joined: 10 May 2018
Posts: 1

PostPosted: Thu May 10, 2018 7:13 pm    Post subject: Reply with quote

Hi,

I don't want to add a "me too" post, but I'm experiencing this as well. Has anyone identified a resolution or alternatively understand the cause?

Thanks,
Nige
Back to top
View user's profile Send private message
Saundersx
Apprentice
Apprentice


Joined: 11 Apr 2005
Posts: 251

PostPosted: Wed Jun 20, 2018 8:22 pm    Post subject: Reply with quote

Not fixed in 4.17.2 . Still not sure if this is an lirc issue or kernel one.
Back to top
View user's profile Send private message
Saundersx
Apprentice
Apprentice


Joined: 11 Apr 2005
Posts: 251

PostPosted: Wed Jun 27, 2018 9:54 pm    Post subject: Reply with quote

And fixed in 4.17.3 . I'm willing to bet it was this commit that fixed it.

Code:

commit b72cee00bc77e8cf07dcaa14e751b813342fe3f5
Author: Sean Young <sean@mess.org>
Date:   Thu May 24 05:47:17 2018 -0400

    media: rc: ensure input/lirc device can be opened after register
   
    commit d7832cd2a3c87eb6ae1e802c88b6fc56c5823f6d upstream.
   
    Since commit cb84343fced1 ("media: lirc: do not call close() or open() on
    unregistered devices") rc_open() will return -ENODEV if rcdev->registered
    is false. Ensure this is set before we register the input device and the
    lirc device, else we have a short window where the neither the lirc or
    input device can be opened.
   
    Fixes: cb84343fced1 ("media: lirc: do not call close() or open() on unregistered devices")
   
    Cc: stable@vger.kernel.org # v4.16+
    Signed-off-by: Sean Young <sean@mess.org>
    Signed-off-by: Mauro Carvalho Chehab <mchehab+samsung@kernel.org>
    Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Back to top
View user's profile Send private message
P.Kosunen
Guru
Guru


Joined: 21 Nov 2005
Posts: 309
Location: Finland

PostPosted: Sun Jul 01, 2018 2:53 pm    Post subject: Reply with quote

Saundersx wrote:
And fixed in 4.17.3 .

This kernel works also for me, had to enable LIRC user interface from menuconfig, option to compile as module was gone.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum