Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge of gentoo-sources fails due to dev-qt/qtcore tangle
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
nw_biohazard
Tux's lil' helper
Tux's lil' helper


Joined: 05 Aug 2008
Posts: 122

PostPosted: Mon Dec 03, 2018 2:10 am    Post subject: emerge of gentoo-sources fails due to dev-qt/qtcore tangle Reply with quote

I am struggling to build a new kernel due to apparent qtcore conflict issues. I have increased the amount of backtracking to attempt to deal with this. I keep getting prompted to add new keyword changes to package.accept_keywords but after about 7 cycles of this, I'm concerned something more serious is wrong.

Any help would be greatly appreciated!

Code:

# emerge --ask --update --deep --with-bdeps=y  --backtrack=100 --newuse sys-kernel/gentoo-sources

These are the packages that would be merged, in order:

Calculating dependencies... done!

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-qt/qtcore:5

  (dev-qt/qtcore-5.11.2-r1:5/5.11::gentoo, ebuild scheduled for merge) conflicts with
    ~dev-qt/qtcore-5.11.1 required by (dev-qt/qtsql-5.11.1-r1:5/5.11.1::gentoo, installed)
    ^              ^^^^^^
    ~dev-qt/qtcore-5.11.1 required by (dev-qt/qtdbus-5.11.1:5/5.11::gentoo, installed)
    ^              ^^^^^^
    ~dev-qt/qtcore-5.11.1 required by (dev-qt/qtxml-5.11.1:5/5.11::gentoo, installed)
    ^              ^^^^^^
    ~dev-qt/qtcore-5.11.1 required by (dev-qt/qdbus-5.11.1:5/5.11::gentoo, installed)
    ^              ^^^^^^
    ~dev-qt/qtcore-5.11.1 required by (dev-qt/qtpaths-5.11.1:5/5.11::gentoo, installed)
    ^              ^^^^^^
    ~dev-qt/qtcore-5.11.1 required by (dev-qt/qtconcurrent-5.11.1:5/5.11::gentoo, installed)
    ^              ^^^^^^


!!! The following update(s) have been skipped due to unsatisfied dependencies
!!! triggered by backtracking:

dev-qt/qtwidgets:5
dev-qt/qtgui:5
dev-qt/linguist-tools:5
dev-qt/qtx11extras:5
dev-qt/qtsvg:5
kde-plasma/polkit-kde-agent:5
dev-qt/qtdeclarative:5

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by app-crypt/gnupg-2.2.10::gentoo
# required by dev-vcs/git-2.19.2::gentoo[gpg]
# required by sys-auth/consolekit-9999::gentoo
# required by sys-auth/pambase-20150213-r2::gentoo[consolekit]
# required by sys-libs/pam-1.3.0-r2::gentoo
# required by sys-apps/util-linux-2.32-r4::gentoo[pam]
# required by x11-libs/libSM-1.2.3::gentoo[uuid]
# required by sys-apps/groff-1.22.3::gentoo[X]
# required by net-nds/openldap-2.4.45::gentoo
# required by net-misc/curl-7.61.1::gentoo[ldap]
# required by dev-util/cmake-3.9.6::gentoo
# required by dev-libs/libical-2.0.0-r3::gentoo
# required by net-wireless/bluez-5.50::gentoo
# required by dev-lang/python-2.7.15::gentoo[bluetooth]
# required by dev-python/certifi-2018.4.16::gentoo[python_targets_python2_7]
# required by dev-python/setuptools-36.7.2::gentoo
# required by dev-util/meson-0.47.1::gentoo
# required by x11-base/xorg-proto-2018.4::gentoo
# required by x11-libs/libICE-1.0.9-r2::gentoo
=app-crypt/pinentry-1.1.0-r3 ~amd64

Would you like to add these changes to your config files? [Yes/No]

 * In order to avoid wasting time, backtracking has terminated early
 * due to the above autounmask change(s). The --autounmask-backtrack=y
 * option can be used to force further backtracking, but there is no
 * guarantee that it will produce a solution.

!!! All ebuilds that could satisfy "dev-qt/qtwidgets:5" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-qt/qtwidgets-5.11.2::gentoo (masked by: backtracking: missing dependency)
- dev-qt/qtwidgets-5.11.1::gentoo (masked by: backtracking: missing dependency)
- dev-qt/qtwidgets-5.9.6-r1::gentoo (masked by: backtracking: missing dependency)

(dependency required by "app-crypt/pinentry-1.1.0-r3::gentoo[qt5]" [ebuild])
(dependency required by "app-crypt/gnupg-2.2.10::gentoo" [ebuild])
(dependency required by "dev-vcs/git-2.19.2::gentoo[gpg]" [ebuild])
(dependency required by "sys-auth/consolekit-9999::gentoo" [ebuild])
(dependency required by "sys-auth/pambase-20150213-r2::gentoo[consolekit]" [ebuild])
(dependency required by "sys-libs/pam-1.3.0-r2::gentoo" [installed])
(dependency required by "sys-apps/util-linux-2.32-r4::gentoo[pam]" [installed])
(dependency required by "x11-libs/libSM-1.2.3::gentoo[uuid]" [installed])
(dependency required by "sys-apps/groff-1.22.3::gentoo[X]" [installed])
(dependency required by "net-nds/openldap-2.4.45::gentoo" [installed])
(dependency required by "net-misc/curl-7.61.1::gentoo[ldap]" [installed])
(dependency required by "dev-util/cmake-3.9.6::gentoo" [installed])
(dependency required by "dev-libs/libical-2.0.0-r3::gentoo" [installed])
(dependency required by "net-wireless/bluez-5.50::gentoo" [installed])
(dependency required by "dev-lang/python-2.7.15::gentoo[bluetooth]" [installed])
(dependency required by "dev-python/certifi-2018.4.16::gentoo[python_targets_python2_7]" [installed])
(dependency required by "dev-python/setuptools-36.7.2::gentoo" [installed])
(dependency required by "dev-util/meson-0.47.1::gentoo" [installed])
(dependency required by "x11-base/xorg-proto-2018.4::gentoo" [installed])
(dependency required by "x11-libs/libICE-1.0.9-r2::gentoo" [installed])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Here is the output of emerge --info https://paste.pound-python.org/show/SQCIWwYYgpLJoGwhbBwN/
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1673

PostPosted: Mon Dec 03, 2018 2:48 am    Post subject: Reply with quote

As far as installing a newer kernel sources, you only need to do something like:
Code:
emerge -1a gentoo-sources


Portage will automatically will want the newest version of a package that meets dependencies, as far as the kernel, there isn't much than you need to worry about on that side.

As far as the conflicts, some of it comes with keywording unstable marked packages. In general, you should try to avoid any unstable package if you are running a stable branch system. This said, I suggest you really consider wipeing out the package.accept_keywords, and only use it if you really need it for something (if you keyworded glibc, DO LEAVE that entry, leave it as it is not freadly on downgrading).

As far as the --newuse option goes, I'd recommend you don't use that unless you are changing use flags globally. Note: The USE option in your make.conf applies to all packages as applicable, package.use is per package settings.

On qt, it is one of the more common causes of conflicts, as everything needs to be updated lock-step as a whole.

Side Note:
The --oneshot (-1) is recommended when you are install/reinstall a dependency, to avoid polluting your world file.
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 6936
Location: almost Mile High in the USA

PostPosted: Mon Dec 03, 2018 2:57 am    Post subject: Reply with quote

As I have never used "make xconfig" I never researched into the requirements for such other than I vaguely recall that it requires QT and hence it makes sense why gentoo-sources requires parts of qt to install.

My take:

Are you planning on updating the rest of the system? Likely you need to solve your qt issue later anyway, so you should update qt and the rest of your system first.

Else:

Try emerge --nodeps gentoo-sources . I think this is safe in this respect if you don't plan to use make xconfig. Normally I'd be against using this but the kernel sources is fairly close to being a leaf.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
nw_biohazard
Tux's lil' helper
Tux's lil' helper


Joined: 05 Aug 2008
Posts: 122

PostPosted: Mon Dec 03, 2018 4:05 am    Post subject: Reply with quote

I will try to tackle the qt upgrade issue first. I removed /etc/portage/package.accept_keywords and followed the advice on re-installing qt (https://wiki.gentoo.org/wiki/Qt/FAQ):

Code:

# export INSTALLED_QT_PACKAGES=$(eix --only-names -IC dev-qt)

# quickpkg ${INSTALLED_QT_PACKAGES}

# emerge -Ca ${INSTALLED_QT_PACKAGES}

Then removed a couple of packages from INSTALLED_QT_PACKAGES that no longer exist and tried to emerge the rest:
Code:

emerge -av1 dev-qt/designer dev-qt/qtcore dev-qt/qtdbus dev-qt/qtdeclarative dev-qt/qtgui dev-qt/qtmultimedia dev-qt/qtopengl dev-qt/qtscript dev-qt/qtsql dev-qt/qtsvg dev-qt/qttest dev-qt/qtwebkit dev-qt/qtxmlpatterns


Still have many conflicts:
Code:

# emerge -av1 dev-qt/designer dev-qt/qtcore dev-qt/qtdbus dev-qt/qtdeclarative dev-qt/qtgui dev-qt/qtmultimedia dev-qt/qtopengl dev-qt/qtscript dev-qt/qtsql dev-qt/qtsvg dev-qt/qttest dev-qt/qtwebkit dev-qt/qtxmlpatterns

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ~] dev-qt/qtcore-5.9.6-r1:5/5.9::gentoo  USE="icu -debug -systemd -test" 0 KiB
[ebuild  N     ] dev-qt/qtcore-5.11.1-r1:5/5.11::gentoo  USE="icu -debug -systemd -test" 0 KiB
[ebuild  N     ] dev-qt/qtdbus-5.9.6:5/5.9::gentoo  USE="-debug -test" 0 KiB
[ebuild     UD ] dev-qt/qtxml-5.9.6:5/5.9::gentoo [5.11.1:5/5.11::gentoo] USE="-debug -test" 0 KiB
[ebuild  N     ] dev-qt/qtdbus-5.11.1:5/5.11::gentoo  USE="-debug -test" 0 KiB
[ebuild     UD ] dev-qt/qtnetwork-5.9.6:5/5.9::gentoo [5.11.1:5/5.11::gentoo] USE="ssl -bindist -connman -debug -libproxy -libressl% -networkmanager -test" 0 KiB
[ebuild  N     ] dev-qt/qtsql-5.11.1-r1:5/5.11.1::gentoo  USE="mysql sqlite -debug -freetds -oci8 -odbc -postgres -test" 0 KiB
[ebuild  N     ] dev-qt/qttest-5.9.6:5/5.9::gentoo  USE="-debug -test" 0 KiB
[ebuild  N     ] dev-qt/qttest-5.11.1:5/5.11::gentoo  USE="-debug -test" 0 KiB
[ebuild  N     ] dev-qt/qtxmlpatterns-5.9.6:5/5.9::gentoo  USE="-debug -test" 0 KiB
[ebuild  N     ] dev-qt/qtxmlpatterns-5.11.1:5/5.11::gentoo  USE="-debug -test" 0 KiB
[ebuild  N     ] dev-qt/qtgui-5.9.6:5/5.9::gentoo  USE="dbus egl gif jpeg libinput png udev xcb -accessibility -debug -eglfs -evdev (-gles2) -ibus -test -tslib -tuio -vnc" 0 KiB
[ebuild  N     ] dev-qt/qtgui-5.11.1:5/5.11::gentoo  USE="dbus egl gif jpeg libinput png udev xcb -accessibility -debug -eglfs -evdev (-gles2) -ibus -test -tslib -tuio -vnc" 0 KiB
[ebuild   R    ] dev-qt/qtwidgets-5.9.6-r1:5/5.9::gentoo  USE="png xcb -debug (-gles2) -gtk -test" 0 KiB
[ebuild     U  ] dev-qt/qtwidgets-5.11.1:5/5.11::gentoo [5.9.6-r1:5/5.9::gentoo] USE="png xcb -debug (-gles2) -gtk -test" 0 KiB
[ebuild  N     ] dev-qt/qtsvg-5.11.1:5/5.11::gentoo  USE="-debug -test" 0 KiB
[ebuild  N     ] dev-qt/qtscript-5.11.1:5/5.11::gentoo  USE="jit scripttools -debug -test" 0 KiB
[ebuild  N     ] dev-qt/qtdeclarative-5.9.6:5/5.9::gentoo  USE="jit widgets xml -debug (-gles2) -localstorage -test" 0 KiB
[ebuild  N     ] dev-qt/qtdeclarative-5.11.1:5/5.11::gentoo  USE="jit widgets xml -debug (-gles2) -localstorage -test" 0 KiB
[ebuild  N     ] dev-qt/qtopengl-5.11.1:5/5.11::gentoo  USE="-debug (-gles2) -test" 0 KiB
[ebuild  N     ] dev-qt/qtmultimedia-5.11.1:5/5.11::gentoo  USE="alsa qml widgets -debug (-gles2) -gstreamer -openal -pulseaudio -test" 0 KiB
[ebuild  N     ] dev-qt/designer-5.9.6:5/5.9::gentoo  USE="declarative -debug -test -webkit" 0 KiB
[ebuild  N     ] dev-qt/qtwebkit-5.212.0_pre20180120:5/5.212::gentoo  USE="X gstreamer hyphen jit nsplugin opengl printsupport qml -geolocation (-gles2) -multimedia -orientation -webp" 0 KiB

Total: 23 packages (1 upgrade, 2 downgrades, 19 new, 1 reinstall), Size of downloads: 0 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtcore:5

  (dev-qt/qtcore-5.11.1-r1:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtcore-5.11.1:5 required by (kde-plasma/plasma-workspace-wallpapers-5.13.5:5/5::gentoo, installed)
    ^^              ^^^^^^^^
    ~dev-qt/qtcore-5.11.1 required by (dev-qt/qtsql-5.11.1-r1:5/5.11.1::gentoo, ebuild scheduled for merge)
    ^              ^^^^^^
    (and 16 more with the same problems)

  (dev-qt/qtcore-5.9.6-r1:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtcore-5.9.4:5/5.9= required by (kde-frameworks/kxmlgui-5.46.0:5/5.46::gentoo, installed)
                         ^^^^^^^
    ~dev-qt/qtcore-5.9.6 required by (dev-qt/qtgui-5.9.6:5/5.9::gentoo, ebuild scheduled for merge)
    ^              ^^^^^
    (and 21 more with the same problems)

dev-qt/qtgui:5

  (dev-qt/qtgui-5.11.1:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-5.11.1 required by (dev-qt/qtscript-5.11.1:5/5.11::gentoo, ebuild scheduled for merge)
    ^             ^^^^^^
    (and 5 more with the same problem)

  (dev-qt/qtgui-5.9.6:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtgui-5.9.1:5/5.9=[-gles2] required by (kde-plasma/kwin-5.12.5:5/5::gentoo, installed)
                        ^^^^^^^
    ~dev-qt/qtgui-5.9.6 required by (dev-qt/designer-5.9.6:5/5.9::gentoo, ebuild scheduled for merge)
    ^             ^^^^^
    >=dev-qt/qtgui-5.9.1:5/5.9=[dbus] required by (kde-plasma/plasma-integration-5.12.5:5/5::gentoo, installed)
                        ^^^^^^^
    (and 11 more with the same problems)

dev-qt/qtnetwork:5

  (dev-qt/qtnetwork-5.11.1:5/5.11::gentoo, installed) pulled in by
    ~dev-qt/qtnetwork-5.11.1 required by (dev-qt/qtxmlpatterns-5.11.1:5/5.11::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^^
    (and 2 more with the same problem)

  (dev-qt/qtnetwork-5.9.6:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtnetwork-5.9.6 required by (dev-qt/qtdeclarative-5.9.6:5/5.9::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^
    (and 3 more with the same problem)

dev-qt/qtwidgets:5

  (dev-qt/qtwidgets-5.11.1:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtwidgets-5.11.1 required by (dev-qt/qtsvg-5.11.1:5/5.11::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^^
    (and 4 more with the same problem)

  (dev-qt/qtwidgets-5.9.6-r1:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtwidgets-5.9.6 required by (dev-qt/qtwebengine-5.9.6-r1:5/5.9::gentoo, installed)
    ^                 ^^^^^
    (and 5 more with the same problem)

dev-qt/qtdeclarative:5

  (dev-qt/qtdeclarative-5.11.1:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdeclarative-5.11.1 required by (dev-qt/qtmultimedia-5.11.1:5/5.11::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^^

  (dev-qt/qtdeclarative-5.9.6:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtdeclarative-5.9.4:5/5.9= required by (kde-frameworks/qqc2-desktop-style-5.46.2:5/5.46::gentoo, installed)
                                ^^^^^^^
    >=dev-qt/qtdeclarative-5.9.4:5/5.9= required by (kde-frameworks/kirigami-5.46.0-r1:5/5.46::gentoo, installed)
                                ^^^^^^^
    >=dev-qt/qtdeclarative-5.9.4:5/5.9= required by (kde-frameworks/kdeclarative-5.46.0:5/5.46::gentoo, installed)
                                ^^^^^^^
    ~dev-qt/qtdeclarative-5.9.6[widgets] required by (dev-qt/designer-5.9.6:5/5.9::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^
    (and 11 more with the same problems)

dev-qt/qttest:5

  (dev-qt/qttest-5.11.1:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qttest-5.11.1 required by (dev-qt/qtdeclarative-5.11.1:5/5.11::gentoo, ebuild scheduled for merge)
    ^              ^^^^^^

  (dev-qt/qttest-5.9.6:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qttest-5.9.6 required by (dev-qt/qtdeclarative-5.9.6:5/5.9::gentoo, ebuild scheduled for merge)
    ^              ^^^^^

dev-qt/qtxmlpatterns:5

  (dev-qt/qtxmlpatterns-5.11.1:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtxmlpatterns-5.11.1 required by (dev-qt/qtdeclarative-5.11.1:5/5.11::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^^

  (dev-qt/qtxmlpatterns-5.9.6:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtxmlpatterns-5.9.6 required by (dev-qt/qtdeclarative-5.9.6:5/5.9::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^

dev-qt/qtdbus:5

  (dev-qt/qtdbus-5.11.1:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdbus-5.11.1 required by (dev-qt/qdbus-5.11.1:5/5.11::gentoo, installed)
    ^              ^^^^^^
    (and 1 more with the same problem)

  (dev-qt/qtdbus-5.9.6:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdbus-5.9.6 required by (dev-qt/qtgui-5.9.6:5/5.9::gentoo, ebuild scheduled for merge)
    ^              ^^^^^
    (and 1 more with the same problem)

dev-qt/qtxml:5

  (dev-qt/qtxml-5.9.6:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtxml-5.9.6 required by (dev-qt/linguist-tools-5.9.6:5/5.9::gentoo, installed)
    ^             ^^^^^
    (and 1 more with the same problem)

  (dev-qt/qtxml-5.11.1:5/5.11::gentoo, installed) pulled in by
    ~dev-qt/qtxml-5.11.1 required by (dev-qt/qdbus-5.11.1:5/5.11::gentoo, installed)
    ^             ^^^^^^

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

!!! The slot conflict(s) shown above involve package(s) which may need to
!!! be rebuilt in order to solve the conflict(s). However, the following
!!! package(s) cannot be rebuilt for the reason(s) shown:

  (kde-frameworks/kxmlgui-5.46.0:5/5.46::gentoo, installed): ebuild is masked or unavailable
  (kde-plasma/kwin-5.12.5:5/5::gentoo, installed): ebuild is masked or unavailable
  (kde-plasma/plasma-integration-5.12.5:5/5::gentoo, installed): ebuild is masked or unavailable
  (kde-frameworks/kdeclarative-5.46.0:5/5.46::gentoo, installed): ebuild is masked or unavailable
  (kde-frameworks/kirigami-5.46.0-r1:5/5.46::gentoo, installed): ebuild is masked or unavailable
  (kde-frameworks/qqc2-desktop-style-5.46.2:5/5.46::gentoo, installed): ebuild is masked or unavailable


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by dev-qt/qtsensors-5.9.6::gentoo
# required by kde-plasma/kwin-5.12.5::gentoo
# required by kde-plasma/plasma-desktop-5.12.5-r1::gentoo
# required by @selected
# required by @world (argument)
=dev-qt/qtcore-5.9.6-r1 ~amd64

Would you like to add these changes to your config files? [Yes/No] No

 * In order to avoid wasting time, backtracking has terminated early
 * due to the above autounmask change(s). The --autounmask-backtrack=y
 * option can be used to force further backtracking, but there is no
 * guarantee that it will produce a solution.
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 6936
Location: almost Mile High in the USA

PostPosted: Mon Dec 03, 2018 4:53 am    Post subject: Reply with quote

I wouldn't have hastily emerge -C (i.e., --unmerge) packages. This can cause some major breakages... Alas what's done has been done.

You still appear have a bunch of qt version specific packages installed that are influencing portage to keep with the old version.

Most of it seems to be KDE packages that are expecting 5.9 to be reinstalled. Without having your box at hand I'd suggest unmerging KDE packages as well, specifically these

(kde-frameworks/kxmlgui-5.46.0:5/5.46::gentoo, installed): ebuild is masked or unavailable
(kde-plasma/kwin-5.12.5:5/5::gentoo, installed): ebuild is masked or unavailable
(kde-plasma/plasma-integration-5.12.5:5/5::gentoo, installed): ebuild is masked or unavailable
(kde-frameworks/kdeclarative-5.46.0:5/5.46::gentoo, installed): ebuild is masked or unavailable
(kde-frameworks/kirigami-5.46.0-r1:5/5.46::gentoo, installed): ebuild is masked or unavailable
(kde-frameworks/qqc2-desktop-style-5.46.2:5/5.46::gentoo, installed): ebuild is masked or unavailable

I suspect these are dependencies of packages, perhaps unmerging these, since you already unmerged qt stuff, may be your next course of action. You may want to quickpkg these as well prior to unmerging.

Also since you unmerged qt, likely your kde is broken. You should do a @world upgrade as much as you can, what errors does this show if you attempt to update @world ?
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
Goverp
l33t
l33t


Joined: 07 Mar 2007
Posts: 614

PostPosted: Mon Dec 03, 2018 8:59 am    Post subject: Reply with quote

The kernel doesn't need KDE; gentoo-sources has no dependency on anything, certainly not KDE. You can optionally use KDE if you prefer the GUI in "make xconfig" over the ncurses one in "make nconfig". So, as previously recommended, "emerge gentoo-sources" will get you the latest version.

All the other excitement about KDE results from the "--update --deep --with-bdeps=y --backtrack=100 --newuse", which tells emerge to look for updates triggered by /etc/portage file changes. I've never seen that set of options applied when trying to emerge a named package instead of "@world"; I guess it's valid, but I guess it's a rare use-case. If you habitually try to apply updates to only one particular package, I think you'll end up with chaos; get bog-standard
Code:
emerge --update --deep --with-bdeps=y --newuse @world
working cleanly.
_________________
Greybeard
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 41726
Location: 56N 3W

PostPosted: Mon Dec 03, 2018 9:41 am    Post subject: Reply with quote

nw_biohazard,

Code:
# emerge --ask --update --deep --with-bdeps=y  --backtrack=100 --newuse sys-kernel/gentoo-sources


You are confusing several things.
Code:
--update --deep
may not be possible with a single package, so don't do that.
Code:
--backtrack=100
is harmless once you drop --update --deep.

Save --update --deep for @world updates, where portage will consider all installed packages.

-- Edit --

Goverp got there first
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
nw_biohazard
Tux's lil' helper
Tux's lil' helper


Joined: 05 Aug 2008
Posts: 122

PostPosted: Tue Dec 04, 2018 3:38 am    Post subject: Reply with quote

Thanks to all of you for the clues. The tail end of the log for running a @world update gives the following error (full log linked below):

Code:
emerge --update --deep --with-bdeps=y --newuse  @world


Code:

>>> Source configured.
>>> Compiling source in /var/tmp/portage/dev-qt/qtgui-5.11.1/work/qtbase-everywhere-src-5.11.1 ...
 * Running emake in src/tools/qvkgen
make -j3
x86_64-pc-linux-gnu-g++ -c -O2 -pipe -march=native -std=c++1z -fno-exceptions -Wall -W -Wvla -Wdate-time -Wshift-overflow=2 -Wduplicated-cond -Wno-stringop-overflow -D_REENTRANT -fPIC -DQT_NO_NARROWING_CONVERSIONS_IN_CONNECT -DQT_USE_QSTRINGBUILDER -DQT_NO_EXCEPTIONS -D_LARGEFILE64_SOURCE -D_LARGEFILE_SOURCE -DQT_NO_DEBUG -DQT_CORE_LIB -I. -isystem /usr/include/qt5 -isystem /usr/include/qt5/QtCore -I.moc -I../../../mkspecs/linux-g++ -o .obj/qvkgen.o qvkgen.cpp
x86_64-pc-linux-gnu-g++ -Wl,-O1 -Wl,--as-needed -Wl,--gc-sections -Wl,--enable-new-dtags -o ../../../bin/qvkgen .obj/qvkgen.o   -lQt5Core -lpthread
 * Running emake in src/gui
make -j3
/var/tmp/portage/dev-qt/qtgui-5.11.1/work/qtbase-everywhere-src-5.11.1/src/gui/qvkgen_wrapper.sh vulkan/vk.xml /var/tmp/portage/dev-qt/qtgui-5.11.1/work/qtbase-everywhere-src-5.11.1/header.LGPL vulkan/qvulkanfunctions
perl /var/tmp/portage/dev-qt/qtgui-5.11.1/work/qtbase-everywhere-src-5.11.1/mkspecs/features/data/unix/findclasslist.pl < QtGui.version.in > QtGui.version
/var/tmp/portage/dev-qt/qtgui-5.11.1/work/qtbase-everywhere-src-5.11.1/bin/qvkgen: error while loading shared libraries: libQt5Core.so.5: cannot open shared object file: No such file or directory
make: *** [Makefile:1793: vulkan/qvulkanfunctions.h] Error 127
make: *** Waiting for unfinished jobs....
 * ERROR: dev-qt/qtgui-5.11.1::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=dev-qt/qtgui-5.11.1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-qt/qtgui-5.11.1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-qt/qtgui-5.11.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-qt/qtgui-5.11.1/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-qt/qtgui-5.11.1/work/qtbase-everywhere-src-5.11.1/src/gui'
 * S: '/var/tmp/portage/dev-qt/qtgui-5.11.1/work/qtbase-everywhere-src-5.11.1'

>>> Failed to emerge dev-qt/qtgui-5.11.1, Log file:

>>>  '/var/tmp/portage/dev-qt/qtgui-5.11.1/temp/build.log'

 * Messages for package net-misc/networkmanager-1.14.4:

 * Could not find a Makefile in the kernel source directory.
 * Please ensure that /usr/src/linux points to a complete set of Linux sources
 * Was unable to determine your kernel .config
 * Please note that if CONFIG_SYSFS_DEPRECATED_V2 is set in your kernel .config, NetworkManager will not work correctly.
 * See https://bugs.gentoo.org/333639 for more info.

 * Messages for package sys-apps/busybox-1.29.3:

 * Could not locate user configfile, so we will save a default one
 * Your configuration for sys-apps/busybox-1.29.3 has been saved in
 * /etc/portage/savedconfig/sys-apps/busybox-1.29.3 for your editing pleasure.
 * You can edit these files by hand and remerge this package with
 * USE=savedconfig to customise the configuration.
 * You can rename this file/directory to one of the following for
 * its configuration to apply to multiple versions:
 * ${PORTAGE_CONFIGROOT}/etc/portage/savedconfig/
 * [${CTARGET}|${CHOST}|""]/${CATEGORY}/[${PF}|${P}|${PN}]

 * Messages for package dev-qt/qtgui-5.11.1:

 * ERROR: dev-qt/qtgui-5.11.1::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=dev-qt/qtgui-5.11.1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-qt/qtgui-5.11.1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-qt/qtgui-5.11.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-qt/qtgui-5.11.1/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-qt/qtgui-5.11.1/work/qtbase-everywhere-src-5.11.1/src/gui'
 * S: '/var/tmp/portage/dev-qt/qtgui-5.11.1/work/qtbase-everywhere-src-5.11.1'

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: dev-qt/qtdeclarative-5.9.6
 *  - /usr/lib64/libQt5QuickWidgets.so.5
 *  - /usr/lib64/libQt5QuickWidgets.so.5.9.6
 *      used by /usr/bin/artikulate_editor (kde-apps/artikulate-18.04.3)
 *      used by /usr/bin/kbreakout (kde-apps/kbreakout-18.04.3)
 *      used by /usr/bin/khangman (kde-apps/khangman-18.04.3)
 *      used by 12 other files
 *  - /usr/lib64/libQt5Quick.so.5
 *  - /usr/lib64/libQt5Quick.so.5.9.6
 *      used by /usr/bin/artikulate (kde-apps/artikulate-18.04.3)
 *      used by /usr/bin/artikulate_editor (kde-apps/artikulate-18.04.3)
 *      used by /usr/bin/kanagram (kde-apps/kanagram-18.04.3)
 *      used by 75 other files
 *  - /usr/lib64/libQt5Qml.so.5
 *  - /usr/lib64/libQt5Qml.so.5.9.6
 *      used by /usr/bin/artikulate (kde-apps/artikulate-18.04.3)
 *      used by /usr/bin/artikulate_editor (kde-apps/artikulate-18.04.3)
 *      used by /usr/bin/kalgebramobile (kde-apps/kalgebra-18.04.3)
 *      used by 120 other files
>>> package: dev-qt/qtgui-5.9.6
 *  - /usr/lib64/libQt5Gui.so.5
 *  - /usr/lib64/libQt5Gui.so.5.9.6
 *      used by /usr/bin/akonadi_agent_launcher (kde-apps/akonadi-18.04.3)
 *      used by /usr/bin/akonadi_agent_server (kde-apps/akonadi-18.04.3)
 *      used by /usr/bin/akonadi_control (kde-apps/akonadi-18.04.3)
 *      used by 765 other files
>>> package: dev-qt/qtmultimedia-5.9.6
 *  - /usr/lib64/libQt5Multimedia.so.5
 *  - /usr/lib64/libQt5Multimedia.so.5.9.6
 *      used by /usr/bin/ktuberling (kde-apps/ktuberling-18.04.3)
 *      used by /usr/bin/parley (kde-apps/parley-18.04.3)
 *      used by /usr/lib64/qt5/plugins/kwave/kwaveplugin_playback.so (kde-apps/kwave-18.04.3)
 *      used by /usr/lib64/qt5/plugins/kwave/kwaveplugin_record.so (kde-apps/kwave-18.04.3)
>>> package: dev-qt/qtopengl-5.9.6
 *  - /usr/lib64/libQt5OpenGL.so.5
 *  - /usr/lib64/libQt5OpenGL.so.5.9.6
 *      used by /usr/bin/ksudoku (kde-apps/ksudoku-18.04.3)
 *      used by /usr/bin/kubrick (kde-apps/kubrick-18.04.3)
 *      used by /usr/bin/step (kde-apps/step-18.04.3)
 *      used by 3 other files
>>> package: dev-qt/qtscript-5.9.6
 *  - /usr/lib64/libQt5Script.so.5
 *  - /usr/lib64/libQt5Script.so.5.9.6
 *      used by /usr/bin/kalzium (kde-apps/kalzium-18.04.3)
 *      used by /usr/bin/plasmashell (kde-plasma/plasma-workspace-5.12.5)
 *      used by /usr/bin/rocs (kde-apps/rocs-18.04.3)
 *      used by 8 other files
>>> package: dev-qt/qtsvg-5.9.6
 *  - /usr/lib64/libQt5Svg.so.5
 *  - /usr/lib64/libQt5Svg.so.5.9.6
 *      used by /usr/bin/blinken (kde-apps/blinken-18.04.3)
 *      used by /usr/bin/bovo (kde-apps/bovo-18.04.3)
 *      used by /usr/bin/granatier (kde-apps/granatier-18.04.3)
 *      used by 50 other files
>>> package: dev-qt/qtwebkit-5.212.0_pre20180120
 *  - /usr/lib64/libQt5WebKitWidgets.so.5
 *  - /usr/lib64/libQt5WebKitWidgets.so.5.212.0
 *      used by /usr/bin/rocs (kde-apps/rocs-18.04.3)
 *      used by /usr/bin/signon-ui (net-libs/signon-ui-0.15-r1)
 *      used by /usr/lib64/libKF5WebKit.so.5.46.0 (kde-frameworks/kdewebkit-5.46.0)
 *      used by 4 other files
 *  - /usr/lib64/libQt5WebKit.so.5
 *  - /usr/lib64/libQt5WebKit.so.5.212.0
 *      used by /usr/bin/signon-ui (net-libs/signon-ui-0.15-r1)
 *      used by /usr/lib64/libKF5WebKit.so.5.46.0 (kde-frameworks/kdewebkit-5.46.0)
 *      used by /usr/lib64/libmarblewidget-qt5.so.0.28.0 (kde-apps/marble-18.04.3)
 *      used by 3 other files
>>> package: kde-frameworks/kdeclarative-5.46.0
 *  - /usr/lib64/libKF5CalendarEvents.so.5
 *  - /usr/lib64/libKF5CalendarEvents.so.5.46.0
 *      used by /usr/lib64/qt5/plugins/plasmacalendarplugins/holidaysevents.so (kde-plasma/plasma-workspace-5.12.5)
 *      used by /usr/lib64/qt5/qml/org/kde/plasma/calendar/libcalendarplugin.so (kde-frameworks/plasma-5.46.0)
 *  - /usr/lib64/libKF5QuickAddons.so.5
 *  - /usr/lib64/libKF5QuickAddons.so.5.46.0
 *      used by /usr/bin/krunner (kde-plasma/plasma-workspace-5.12.5)
 *      used by /usr/bin/ksplashqml (kde-plasma/plasma-workspace-5.12.5)
 *      used by /usr/bin/lookandfeeltool (kde-plasma/plasma-desktop-5.12.5-r1)
 *      used by 12 other files
 *  - /usr/lib64/libKF5Declarative.so.5
 *  - /usr/lib64/libKF5Declarative.so.5.46.0
 *      used by /usr/bin/kanagram (kde-apps/kanagram-18.04.3)
 *      used by /usr/bin/khangman (kde-apps/khangman-18.04.3)
 *      used by /usr/bin/krunner (kde-plasma/plasma-workspace-5.12.5)
 *      used by 21 other files
>>> package: kde-frameworks/kxmlgui-5.46.0
 *  - /usr/lib64/libKF5XmlGui.so.5
 *  - /usr/lib64/libKF5XmlGui.so.5.46.0
 *      used by /usr/bin/ark (kde-apps/ark-18.04.3)
 *      used by /usr/bin/artikulate (kde-apps/artikulate-18.04.3)
 *      used by /usr/bin/artikulate_editor (kde-apps/artikulate-18.04.3)
 *      used by 269 other files
Use emerge @preserved-rebuild to rebuild packages using these libraries
 * After world updates, it is important to remove obsolete packages with
 * emerge --depclean. Refer to `man emerge` for more information.


Output of emerge --info =dev-qt/qtgui-5.11.1::gentoo https://paste.pound-python.org/show/ponD8kDdYY6e99dPM9Yg/
Output of emerge -pqv =dev-qt/qtgui-5.11.1::gentoohttps://paste.pound-python.org/show/xmJoHxpL2PNkXwKcmQJE/
The complete build log https://paste.pound-python.org/show/3nIltnzIMUFCqggzzj41/
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 6936
Location: almost Mile High in the USA

PostPosted: Tue Dec 04, 2018 5:54 am    Post subject: Reply with quote

Try re-emerging qtcore again...and what version does it merge?
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 20124
Location: here

PostPosted: Tue Dec 04, 2018 6:11 am    Post subject: Reply with quote

You have mixed qt version? You can post output of qlist -Iv dev-qt/* command?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
nw_biohazard
Tux's lil' helper
Tux's lil' helper


Joined: 05 Aug 2008
Posts: 122

PostPosted: Wed Dec 05, 2018 1:55 am    Post subject: Reply with quote

emerge -1 dev-qt/qtcore successful installs dev-qt/qtcore-5.11.1-r1::gentoo though it gives the following message at the end:
Code:

>>> Completed installing qtcore-5.11.1-r1 into /var/tmp/portage/dev-qt/qtcore-5.11.1-r1/image/

 * Final size of build directory: 382392 KiB (373.4 MiB)
 * Final size of installed tree:   24940 KiB ( 24.3 MiB)

 * The ebuild is installing to one or more unexpected paths:
 *
 *   /usr/share/doc/qt-5.11.1
 *
 * Please fix the ebuild to use correct FHS/Gentoo policy paths.
strip: x86_64-pc-linux-gnu-strip --strip-unneeded -R .comment -R .GCC.command.line -R .note.gnu.gold-version
   usr/lib64/libQt5Bootstrap.a
   usr/lib64/libQt5Core.so.5.11.1
   usr/lib64/qt5/bin/moc
   usr/lib64/qt5/bin/rcc
   usr/lib64/qt5/bin/qlalr
   usr/lib64/qt5/bin/qmake
ecompressdir: bzip2 -9 /usr/share/doc

>>> Installing (1 of 1) dev-qt/qtcore-5.11.1-r1::gentoo
 * Regenerating gentoo-qconfig.h
 * Updating QT_CONFIG in qconfig.pri
 * Updating QT.global_private in qmodule.pri
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: dev-qt/qtdeclarative-5.9.6
 *  - /usr/lib64/libQt5QuickWidgets.so.5
 *  - /usr/lib64/libQt5QuickWidgets.so.5.9.6
 *      used by /usr/bin/artikulate_editor (kde-apps/artikulate-18.04.3)
 *      used by /usr/bin/kbreakout (kde-apps/kbreakout-18.04.3)
 *      used by /usr/bin/khangman (kde-apps/khangman-18.04.3)
 *      used by 12 other files
 *  - /usr/lib64/libQt5Quick.so.5
 *  - /usr/lib64/libQt5Quick.so.5.9.6
 *      used by /usr/bin/artikulate (kde-apps/artikulate-18.04.3)
 *      used by /usr/bin/artikulate_editor (kde-apps/artikulate-18.04.3)
 *      used by /usr/bin/kanagram (kde-apps/kanagram-18.04.3)
 *      used by 75 other files
 *  - /usr/lib64/libQt5Qml.so.5
 *  - /usr/lib64/libQt5Qml.so.5.9.6
 *      used by /usr/bin/artikulate (kde-apps/artikulate-18.04.3)
 *      used by /usr/bin/artikulate_editor (kde-apps/artikulate-18.04.3)
 *      used by /usr/bin/kalgebramobile (kde-apps/kalgebra-18.04.3)
 *      used by 120 other files
>>> package: dev-qt/qtgui-5.9.6
 *  - /usr/lib64/libQt5Gui.so.5
 *  - /usr/lib64/libQt5Gui.so.5.9.6
 *      used by /usr/bin/akonadi_agent_launcher (kde-apps/akonadi-18.04.3)
 *      used by /usr/bin/akonadi_agent_server (kde-apps/akonadi-18.04.3)
 *      used by /usr/bin/akonadi_control (kde-apps/akonadi-18.04.3)
 *      used by 765 other files
>>> package: dev-qt/qtmultimedia-5.9.6
 *  - /usr/lib64/libQt5Multimedia.so.5
 *  - /usr/lib64/libQt5Multimedia.so.5.9.6
 *      used by /usr/bin/ktuberling (kde-apps/ktuberling-18.04.3)
 *      used by /usr/bin/parley (kde-apps/parley-18.04.3)
 *      used by /usr/lib64/qt5/plugins/kwave/kwaveplugin_playback.so (kde-apps/kwave-18.04.3)
 *      used by /usr/lib64/qt5/plugins/kwave/kwaveplugin_record.so (kde-apps/kwave-18.04.3)
>>> package: dev-qt/qtopengl-5.9.6
 *  - /usr/lib64/libQt5OpenGL.so.5
 *  - /usr/lib64/libQt5OpenGL.so.5.9.6
 *      used by /usr/bin/ksudoku (kde-apps/ksudoku-18.04.3)
 *      used by /usr/bin/kubrick (kde-apps/kubrick-18.04.3)
 *      used by /usr/bin/step (kde-apps/step-18.04.3)
 *      used by 3 other files
>>> package: dev-qt/qtscript-5.9.6
 *  - /usr/lib64/libQt5Script.so.5
 *  - /usr/lib64/libQt5Script.so.5.9.6
 *      used by /usr/bin/kalzium (kde-apps/kalzium-18.04.3)
 *      used by /usr/bin/plasmashell (kde-plasma/plasma-workspace-5.12.5)
 *      used by /usr/bin/rocs (kde-apps/rocs-18.04.3)
 *      used by 8 other files
>>> package: dev-qt/qtsvg-5.9.6
 *  - /usr/lib64/libQt5Svg.so.5
 *  - /usr/lib64/libQt5Svg.so.5.9.6
 *      used by /usr/bin/blinken (kde-apps/blinken-18.04.3)
 *      used by /usr/bin/bovo (kde-apps/bovo-18.04.3)
 *      used by /usr/bin/granatier (kde-apps/granatier-18.04.3)
 *      used by 50 other files
>>> package: dev-qt/qtwebkit-5.212.0_pre20180120
 *  - /usr/lib64/libQt5WebKitWidgets.so.5
 *  - /usr/lib64/libQt5WebKitWidgets.so.5.212.0
 *      used by /usr/bin/rocs (kde-apps/rocs-18.04.3)
 *      used by /usr/bin/signon-ui (net-libs/signon-ui-0.15-r1)
 *      used by /usr/lib64/libKF5WebKit.so.5.46.0 (kde-frameworks/kdewebkit-5.46.0)
 *      used by 4 other files
 *  - /usr/lib64/libQt5WebKit.so.5
 *  - /usr/lib64/libQt5WebKit.so.5.212.0
 *      used by /usr/bin/signon-ui (net-libs/signon-ui-0.15-r1)
 *      used by /usr/lib64/libKF5WebKit.so.5.46.0 (kde-frameworks/kdewebkit-5.46.0)
 *      used by /usr/lib64/libmarblewidget-qt5.so.0.28.0 (kde-apps/marble-18.04.3)
 *      used by 3 other files
>>> package: kde-frameworks/kdeclarative-5.46.0
 *  - /usr/lib64/libKF5CalendarEvents.so.5
 *  - /usr/lib64/libKF5CalendarEvents.so.5.46.0
 *      used by /usr/lib64/qt5/plugins/plasmacalendarplugins/holidaysevents.so (kde-plasma/plasma-workspace-5.12.5)
 *      used by /usr/lib64/qt5/qml/org/kde/plasma/calendar/libcalendarplugin.so (kde-frameworks/plasma-5.46.0)
 *  - /usr/lib64/libKF5QuickAddons.so.5
 *  - /usr/lib64/libKF5QuickAddons.so.5.46.0
 *      used by /usr/bin/krunner (kde-plasma/plasma-workspace-5.12.5)
 *      used by /usr/bin/ksplashqml (kde-plasma/plasma-workspace-5.12.5)
 *      used by /usr/bin/lookandfeeltool (kde-plasma/plasma-desktop-5.12.5-r1)
 *      used by 12 other files
 *  - /usr/lib64/libKF5Declarative.so.5
 *  - /usr/lib64/libKF5Declarative.so.5.46.0
 *      used by /usr/bin/kanagram (kde-apps/kanagram-18.04.3)
 *      used by /usr/bin/khangman (kde-apps/khangman-18.04.3)
 *      used by /usr/bin/krunner (kde-plasma/plasma-workspace-5.12.5)
 *      used by 21 other files
>>> package: kde-frameworks/kxmlgui-5.46.0
 *  - /usr/lib64/libKF5XmlGui.so.5
 *  - /usr/lib64/libKF5XmlGui.so.5.46.0
 *      used by /usr/bin/ark (kde-apps/ark-18.04.3)
 *      used by /usr/bin/artikulate (kde-apps/artikulate-18.04.3)
 *      used by /usr/bin/artikulate_editor (kde-apps/artikulate-18.04.3)
 *      used by 269 other files


It does seem that I have mixed versions. Not sure how that happened. Would you recommend removing the 5.9.6 versions and re-emerging them?
Code:

# qlist -Iv dev-qt/*
dev-qt/linguist-tools-5.9.6
dev-qt/qdbus-5.11.1
dev-qt/qtchooser-0_p20170803
dev-qt/qtconcurrent-5.11.1
dev-qt/qtcore-5.11.1-r1
dev-qt/qtdbus-5.11.1
dev-qt/qtgraphicaleffects-5.9.6
dev-qt/qtimageformats-5.9.6
dev-qt/qtnetwork-5.11.1
dev-qt/qtpaths-5.11.1
dev-qt/qtpositioning-5.9.6
dev-qt/qtprintsupport-5.9.6
dev-qt/qtquickcontrols-5.9.6
dev-qt/qtquickcontrols2-5.9.6
dev-qt/qtsensors-5.9.6
dev-qt/qtsql-5.11.1-r1
dev-qt/qttest-5.11.1
dev-qt/qttranslations-4.8.7
dev-qt/qtvirtualkeyboard-5.9.6
dev-qt/qtwayland-5.9.6
dev-qt/qtwebchannel-5.9.6
dev-qt/qtwebengine-5.9.6-r1
dev-qt/qtwidgets-5.9.6-r1
dev-qt/qtx11extras-5.9.6
dev-qt/qtxml-5.11.1
dev-qt/qtxmlpatterns-5.11.1
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 20124
Location: here

PostPosted: Wed Dec 05, 2018 6:44 am    Post subject: Reply with quote

nw_biohazard wrote:

It does seem that I have mixed versions. Not sure how that happened. Would you recommend removing the 5.9.6 versions and re-emerging them?
Code:

# qlist -Iv dev-qt/*
dev-qt/linguist-tools-5.9.6
dev-qt/qdbus-5.11.1
dev-qt/qtchooser-0_p20170803
dev-qt/qtconcurrent-5.11.1
dev-qt/qtcore-5.11.1-r1
dev-qt/qtdbus-5.11.1
dev-qt/qtgraphicaleffects-5.9.6
dev-qt/qtimageformats-5.9.6
dev-qt/qtnetwork-5.11.1
dev-qt/qtpaths-5.11.1
dev-qt/qtpositioning-5.9.6
dev-qt/qtprintsupport-5.9.6
dev-qt/qtquickcontrols-5.9.6
dev-qt/qtquickcontrols2-5.9.6
dev-qt/qtsensors-5.9.6
dev-qt/qtsql-5.11.1-r1
dev-qt/qttest-5.11.1
dev-qt/qttranslations-4.8.7
dev-qt/qtvirtualkeyboard-5.9.6
dev-qt/qtwayland-5.9.6
dev-qt/qtwebchannel-5.9.6
dev-qt/qtwebengine-5.9.6-r1
dev-qt/qtwidgets-5.9.6-r1
dev-qt/qtx11extras-5.9.6
dev-qt/qtxml-5.11.1
dev-qt/qtxmlpatterns-5.11.1

You need to choose what version of qt you want because you cannot mix qt version.
You can also try to update qt with command emerge -uD $(qlist -I dev-qt/*)
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
nw_biohazard
Tux's lil' helper
Tux's lil' helper


Joined: 05 Aug 2008
Posts: 122

PostPosted: Wed Dec 05, 2018 1:27 pm    Post subject: Reply with quote

Thanks. I ran emerge -uD $(qlist -I dev-qt/*). There seems to be a missing shared library:
Code:

/var/tmp/portage/dev-qt/qtgui-5.11.1/work/qtbase-everywhere-src-5.11.1/src/gui/qvkgen_wrapper.sh vulkan/vk.xml /var/tmp/portage/dev-qt/qtgui-5.11.1/work/qtbase-everywhere-src-5.11.1/header.LGPL vulkan/qvulkanfunctions
perl /var/tmp/portage/dev-qt/qtgui-5.11.1/work/qtbase-everywhere-src-5.11.1/mkspecs/features/data/unix/findclasslist.pl < QtGui.version.in > QtGui.version
/var/tmp/portage/dev-qt/qtgui-5.11.1/work/qtbase-everywhere-src-5.11.1/bin/qvkgen: error while loading shared libraries: libQt5Core.so.5: cannot open shared object file: No such file or directory
make: *** [Makefile:1793: vulkan/qvulkanfunctions.h] Error 127
make: *** Waiting for unfinished jobs....
 * ERROR: dev-qt/qtgui-5.11.1::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=dev-qt/qtgui-5.11.1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-qt/qtgui-5.11.1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-qt/qtgui-5.11.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-qt/qtgui-5.11.1/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-qt/qtgui-5.11.1/work/qtbase-everywhere-src-5.11.1/src/gui'
 * S: '/var/tmp/portage/dev-qt/qtgui-5.11.1/work/qtbase-everywhere-src-5.11.1'

>>> Failed to emerge dev-qt/qtgui-5.11.1, Log file:

>>>  '/var/tmp/portage/dev-qt/qtgui-5.11.1/temp/build.log'

 * Messages for package dev-qt/qtgui-5.11.1:

 * ERROR: dev-qt/qtgui-5.11.1::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=dev-qt/qtgui-5.11.1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-qt/qtgui-5.11.1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-qt/qtgui-5.11.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-qt/qtgui-5.11.1/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-qt/qtgui-5.11.1/work/qtbase-everywhere-src-5.11.1/src/gui'
 * S: '/var/tmp/portage/dev-qt/qtgui-5.11.1/work/qtbase-everywhere-src-5.11.1'


emerge --info =dev-qt/qtgui-5.11.1::gentoo https://paste.pound-python.org/show/O5rPTLezxmu4zAEfmE7J/
emerge -pqv =dev-qt/qtgui-5.11.1::gentoo https://paste.pound-python.org/show/uTQ2c34FbGXYZ48pZiNY/
build log: https://paste.pound-python.org/show/w9jzYcDImvvpmuMiE2kK/
build environment: https://paste.pound-python.org/show/qgeEzOhx5URh6uud2Sz3/

Not sure why libQt5Core.so.5 should be missing.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 20124
Location: here

PostPosted: Wed Dec 05, 2018 1:36 pm    Post subject: Reply with quote

Rebuild qtcore-5.11 first
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
nw_biohazard
Tux's lil' helper
Tux's lil' helper


Joined: 05 Aug 2008
Posts: 122

PostPosted: Thu Dec 06, 2018 2:41 am    Post subject: Reply with quote

No go trying to rebuild qtcore only:
Code:

# emerge -1uD qtcore
Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtcore:5

  (dev-qt/qtcore-5.11.1-r1:5/5.11::gentoo, installed) pulled in by
    ~dev-qt/qtcore-5.11.1 required by (dev-qt/qtdbus-5.11.1:5/5.11::gentoo, installed)
    ^              ^^^^^^
    (and 2 more with the same problem)

  (dev-qt/qtcore-5.11.2-r1:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/qtcore (Argument)
    ~dev-qt/qtcore-5.11.2 required by (dev-qt/qtdbus-5.11.2:5/5.11::gentoo, ebuild scheduled for merge)
    ^              ^^^^^^
    (and 2 more with the same problems)

dev-qt/qtgui:5

  (dev-qt/qtgui-5.11.1:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-qt/qtgui-5.11.2-r1:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-5.11.2[gles2=,png=,xcb?] required by (dev-qt/qtwidgets-5.11.2:5/5.11::gentoo, ebuild scheduled for merge)
    ^             ^^^^^^

dev-qt/qtdbus:5

  (dev-qt/qtdbus-5.11.1:5/5.11::gentoo, installed) pulled in by
    ~dev-qt/qtdbus-5.11.1 required by (dev-qt/qtgui-5.11.1:5/5.11::gentoo, ebuild scheduled for merge)
    ^              ^^^^^^

  (dev-qt/qtdbus-5.11.2:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdbus-5.11.2 required by (dev-qt/qtgui-5.11.2-r1:5/5.11::gentoo, ebuild scheduled for merge)
    ^              ^^^^^^

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by dev-qt/qtgui-5.11.2-r1::gentoo
# required by dev-qt/qtwidgets-5.11.2::gentoo
# required by kde-frameworks/kwindowsystem-5.52.0::gentoo
# required by kde-plasma/polkit-kde-agent-5.14.3::gentoo
# required by sys-auth/polkit-0.115-r1::gentoo[kde]
# required by sys-auth/polkit-qt-0.112.0_p20160416-r2::gentoo
=dev-qt/qtcore-5.11.2-r1 ~amd64
# required by sys-auth/polkit-qt-0.112.0_p20160416-r2::gentoo
# required by kde-plasma/polkit-kde-agent-5.14.3::gentoo
# required by sys-auth/polkit-0.115-r1::gentoo[kde]
# required by sys-auth/consolekit-1.2.1::gentoo
# required by sys-auth/pambase-20150213-r2::gentoo[consolekit]
# required by sys-libs/pam-1.3.0-r2::gentoo
# required by sys-apps/util-linux-2.32-r4::gentoo[pam]
# required by media-libs/fontconfig-2.13.0-r4::gentoo
# required by dev-qt/qtgui-5.11.1::gentoo
# required by kde-frameworks/kwindowsystem-5.52.0::gentoo
=dev-qt/qtwidgets-5.11.2 ~amd64
# required by dev-qt/qtgui-5.11.2-r1::gentoo[dbus]
# required by dev-qt/qtwidgets-5.11.2::gentoo
# required by kde-frameworks/kwindowsystem-5.52.0::gentoo
# required by kde-plasma/polkit-kde-agent-5.14.3::gentoo
# required by sys-auth/polkit-0.115-r1::gentoo[kde]
# required by sys-auth/polkit-qt-0.112.0_p20160416-r2::gentoo
=dev-qt/qtdbus-5.11.2 ~amd64
# required by dev-qt/qtwidgets-5.11.2::gentoo
# required by kde-frameworks/kwindowsystem-5.52.0::gentoo
# required by kde-plasma/polkit-kde-agent-5.14.3::gentoo
# required by sys-auth/polkit-0.115-r1::gentoo[kde]
# required by sys-auth/polkit-qt-0.112.0_p20160416-r2::gentoo
=dev-qt/qtgui-5.11.2-r1 ~amd64

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.

 * In order to avoid wasting time, backtracking has terminated early
 * due to the above autounmask change(s). The --autounmask-backtrack=y
 * option can be used to force further backtracking, but there is no
 * guarantee that it will produce a solution.

!!! All ebuilds that could satisfy "~dev-qt/qtwidgets-5.11.1[gles2=]" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-qt/qtwidgets-5.11.1::gentoo (masked by: backtracking: slot conflict)

(dependency required by "dev-qt/qtdeclarative-5.11.1::gentoo" [ebuild])
(dependency required by "dev-qt/linguist-tools-5.11.1::gentoo[qml]" [ebuild])
(dependency required by "kde-frameworks/kwindowsystem-5.52.0::gentoo[nls]" [ebuild])
(dependency required by "kde-plasma/polkit-kde-agent-5.14.3::gentoo" [ebuild])
(dependency required by "sys-auth/polkit-0.115-r1::gentoo[kde]" [ebuild])
(dependency required by "sys-auth/polkit-qt-0.112.0_p20160416-r2::gentoo" [installed])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


I could try adding the keyword changes that are listed as necessary but I was advised against that above.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 20124
Location: here

PostPosted: Thu Dec 06, 2018 6:48 am    Post subject: Reply with quote

Why your system want to install qt-5.11.2 that are masked?
Remove all qt entry, if exists, from package.accept_keywords and then post output of emerge --autounmask n -u qtcore command
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
nw_biohazard
Tux's lil' helper
Tux's lil' helper


Joined: 05 Aug 2008
Posts: 122

PostPosted: Thu Dec 06, 2018 1:27 pm    Post subject: Reply with quote

I have no /etc/package.accept_keywords file.
Code:
# emerge --autounmask n -u qtcore
Calculating dependencies... done!
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 2688
Location: Illinois, USA

PostPosted: Thu Dec 06, 2018 4:45 pm    Post subject: Reply with quote

nw_biohazard wrote:
I have no /etc/package.accept_keywords file.

That's /etc/portage/package.accept_keywords
Back to top
View user's profile Send private message
nw_biohazard
Tux's lil' helper
Tux's lil' helper


Joined: 05 Aug 2008
Posts: 122

PostPosted: Thu Dec 06, 2018 5:47 pm    Post subject: Reply with quote

Yes, sorry for the typo. No package.accept_keywords:

Code:
# ls /etc/portage
package.accept_keywords.save  package.mask    package.use      repos.conf
package.license               package.unmask  repo.postsync.d  savedconfig
#
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 20124
Location: here

PostPosted: Thu Dec 06, 2018 8:03 pm    Post subject: Reply with quote

You can post output of grep -r "dev-qt" /etc/portage/package.* command?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
nw_biohazard
Tux's lil' helper
Tux's lil' helper


Joined: 05 Aug 2008
Posts: 122

PostPosted: Fri Dec 07, 2018 1:18 am    Post subject: Reply with quote

Code:
# grep -r "dev-qt" /etc/portage/package.*
/etc/portage/package.accept_keywords.save:# required by dev-qt/qtdeclarative-5.5.1-r1::gentoo
/etc/portage/package.accept_keywords.save:# required by dev-qt/qtwidgets-5.9.6-r1::gentoo
/etc/portage/package.accept_keywords.save:# required by dev-qt/qtgui-5.9.6::gentoo
/etc/portage/package.accept_keywords.save:=dev-qt/qtcore-5.9.6-r1 ~amd64
/etc/portage/package.accept_keywords.save:=dev-qt/qtgui-5.11.2-r1 ~amd64
/etc/portage/package.accept_keywords.save:# required by dev-qt/qtgui-5.11.2-r1::gentoo[dbus]
/etc/portage/package.accept_keywords.save:=dev-qt/qtdbus-5.11.2 ~amd64
/etc/portage/package.accept_keywords.save:# required by dev-qt/qtgui-5.11.2-r1::gentoo
/etc/portage/package.accept_keywords.save:=dev-qt/qtcore-5.11.2-r1 ~amd64
/etc/portage/package.accept_keywords.save:=dev-qt/qtwidgets-5.11.2 ~amd64
/etc/portage/package.accept_keywords.save:# required by dev-qt/linguist-tools-5.11.2::gentoo[qml]
/etc/portage/package.accept_keywords.save:=dev-qt/qtdeclarative-5.11.2 ~amd64
/etc/portage/package.accept_keywords.save:# required by dev-qt/qtdeclarative-5.11.2::gentoo[xml]
/etc/portage/package.accept_keywords.save:# required by dev-qt/linguist-tools-5.11.2::gentoo[qml]
/etc/portage/package.accept_keywords.save:=dev-qt/qtnetwork-5.11.2 ~amd64
/etc/portage/package.accept_keywords.save:=dev-qt/linguist-tools-5.11.2 ~amd64
/etc/portage/package.accept_keywords.save:# required by dev-qt/qtdeclarative-5.11.2::gentoo[xml]
/etc/portage/package.accept_keywords.save:# required by dev-qt/linguist-tools-5.11.2::gentoo[qml]
/etc/portage/package.accept_keywords.save:=dev-qt/qtxmlpatterns-5.11.2 ~amd64
/etc/portage/package.accept_keywords.save:# required by dev-qt/linguist-tools-5.11.2::gentoo
/etc/portage/package.accept_keywords.save:=dev-qt/qtxml-5.11.2 ~amd64
/etc/portage/package.accept_keywords.save:# required by dev-qt/qtdeclarative-5.11.2::gentoo[-test]
/etc/portage/package.accept_keywords.save:# required by dev-qt/linguist-tools-5.11.2::gentoo[qml]
/etc/portage/package.accept_keywords.save:=dev-qt/qttest-5.11.2 ~amd64
/etc/portage/package.accept_keywords.save:=dev-qt/qtx11extras-5.11.2 ~amd64
/etc/portage/package.accept_keywords.save:=dev-qt/qtsvg-5.11.2 ~amd64
/etc/portage/package.use:# move x11-libs/qt-gui dev-qt/qtgui
/etc/portage/package.use:>=dev-qt/qtgui-4.8.1-r1 mng
/etc/portage/package.use:>=dev-qt/qtsql-4.8.5 mysql
/etc/portage/package.use:# required by dev-qt/qtcore-5.4.2::gentoo
/etc/portage/package.use:>=dev-qt/qtcore-5.5.1-r1 icu
/etc/portage/package.use:>=dev-qt/designer-4.8.6-r1:4 -phonon
/etc/portage/package.use:>=dev-qt/qtmultimedia-5.5.1-r2 qml
/etc/portage/package.use:>=dev-qt/qtscript-5.5.1-r1 scripttools
/etc/portage/package.use:# required by dev-qt/qtgui-5.6.1::gentoo
/etc/portage/package.use:# required by dev-qt/qtwebengine-5.11.1::gentoo
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 20124
Location: here

PostPosted: Fri Dec 07, 2018 6:50 am    Post subject: Reply with quote

You can post what now is installed in your system qlist -Iv dev-qt/*?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
nw_biohazard
Tux's lil' helper
Tux's lil' helper


Joined: 05 Aug 2008
Posts: 122

PostPosted: Fri Dec 07, 2018 1:10 pm    Post subject: Reply with quote

Code:
# qlist -Iv dev-qt/*
dev-qt/linguist-tools-5.9.6
dev-qt/qdbus-5.11.1
dev-qt/qtchooser-0_p20170803
dev-qt/qtconcurrent-5.11.1
dev-qt/qtcore-5.11.1-r1
dev-qt/qtdbus-5.11.1
dev-qt/qtgraphicaleffects-5.9.6
dev-qt/qtimageformats-5.9.6
dev-qt/qtnetwork-5.11.1
dev-qt/qtpaths-5.11.1
dev-qt/qtpositioning-5.9.6
dev-qt/qtprintsupport-5.9.6
dev-qt/qtquickcontrols-5.9.6
dev-qt/qtquickcontrols2-5.9.6
dev-qt/qtsensors-5.9.6
dev-qt/qtsql-5.11.1-r1
dev-qt/qttest-5.11.1
dev-qt/qttranslations-4.8.7
dev-qt/qtvirtualkeyboard-5.9.6
dev-qt/qtwayland-5.9.6
dev-qt/qtwebchannel-5.9.6
dev-qt/qtwebengine-5.9.6-r1
dev-qt/qtwidgets-5.9.6-r1
dev-qt/qtx11extras-5.9.6
dev-qt/qtxml-5.11.1
dev-qt/qtxmlpatterns-5.11.1
Back to top
View user's profile Send private message
nw_biohazard
Tux's lil' helper
Tux's lil' helper


Joined: 05 Aug 2008
Posts: 122

PostPosted: Sat Dec 08, 2018 3:36 am    Post subject: Reply with quote

According to this post (https://bbs.archlinux.org/viewtopic.php?id=232682) :

"Your problem is indeed the old kernel. Qt 5.10 uses the renameat2 system call which is only available since kernel 3.15"
Back to top
View user's profile Send private message
nw_biohazard
Tux's lil' helper
Tux's lil' helper


Joined: 05 Aug 2008
Posts: 122

PostPosted: Sat Dec 08, 2018 6:04 am    Post subject: Reply with quote

I tried adding
Code:
>=dev-qt/qtcore-5.10

to /etc/portage/package.mask.

Unfortunately, an @world update wants to update to dev-qt/qtcore-5.11.1-r1:
Code:

# emerge --update --deep --with-bdeps=y --newuse @world
Calculating dependencies... done!

The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by dev-qt/linguist-tools-5.11.1::gentoo
# required by kde-frameworks/kdesignerplugin-5.52.0::gentoo[nls]
# required by kde-frameworks/kdelibs4support-5.52.0::gentoo
# required by kde-plasma/plasma-desktop-5.14.3::gentoo
# required by kde-plasma/plasma-meta-5.14.3-r1::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=dev-qt/qtcore-5.11.1-r1

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.

 * In order to avoid wasting time, backtracking has terminated early
 * due to the above autounmask change(s). The --autounmask-backtrack=y
 * option can be used to force further backtracking, but there is no
 * guarantee that it will produce a solution.

emerge: there are no ebuilds to satisfy ">=dev-qt/qtcore-4.8.5:4".
(dependency required by "dev-python/PyQt4-4.12.1::gentoo" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


Is it possible that removing all of kde and re-installing would help?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum