Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Changing Profile during new installation
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
ROGA
n00b
n00b


Joined: 17 Feb 2018
Posts: 59
Location: Zurich, Switzerland

PostPosted: Sat Jan 05, 2019 12:45 pm    Post subject: [SOLVED] Changing Profile during new installation Reply with quote

Hi,

I ask myself, what's the correct way to change the system profile during installing a new stage-3 System.

After I chrooted and updated my environement (all necessary devices are mounted) the default profile is

Code:
[25] default/linux/amd64/17.0/systemd (stable)


Now I would like to change the profile to

Code:
[20] default/linux/amd64/17.0/desktop/plasma/systemd (stable)


Do I have now to rebuild the system-set with

Code:
emerge -av --update --deep --newuse  @world?


and if so, do I have to do further things?

regards,
Roland


Last edited by ROGA on Mon Jan 07, 2019 4:15 pm; edited 2 times in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22036
Location: here

PostPosted: Sat Jan 05, 2019 1:26 pm    Post subject: Re: Chaning Profile during new installation Reply with quote

ROGA wrote:
Now I would like to change the profile to

Code:
[20] default/linux/amd64/17.0/desktop/plasma/systemd (stable)


Do I have now to rebuild the system-set with

Code:
emerge -av --update --deep --newuse  @world?


and if so, do I have to do further things?

No this command is all you need because you not change init system
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ROGA
n00b
n00b


Joined: 17 Feb 2018
Posts: 59
Location: Zurich, Switzerland

PostPosted: Sat Jan 05, 2019 1:55 pm    Post subject: Reply with quote

fedeliallalinea,

thank for your reply.

I made a little misstake. I wrote "Do I have now to rebuild the @system set" but meant "Do I have now to rebuild the @world set". So, I tried to see, what's happen when I do both. And what I then saw, was not really clear for me. Both commands does exactly the same!


with @world
Code:
Total: 266 packages (23 upgrades, 223 new, 3 in new slots, 17 reinstalls), Size of downloads: 594217 KiB


with @system
Code:
Total: 266 packages (23 upgrades, 223 new, 3 in new slots, 17 reinstalls), Size of downloads: 594217 KiB



But more interesting was the fact that I had a conflict (in both cases) that I did not understand correctly.

Code:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.26.2:0/5.26::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.26* required by (virtual/perl-XSLoader-0.270.0:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                     
    (and 34 more with the same problem)

  (dev-lang/perl-5.24.3-r1:0/5.24::gentoo, installed) pulled in by
    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/Unicode-EastAsianWidth-1.330.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                     
    (and 20 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by dev-lang/spidermonkey-52.9.1_pre1::gentoo
# required by sys-auth/polkit-0.115-r2::gentoo
# required by gnome-extra/polkit-gnome-0.105-r1::gentoo
>=dev-lang/python-2.7.15:2.7 sqlite

Would you like to add these changes to your config files? [Yes/No]


Why occurs that? My system is still completely virgin in the current moment …

If anybody can explain me this behavior, this would be very nice :-)

regards,
Roland
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43395
Location: 56N 3W

PostPosted: Sat Jan 05, 2019 3:13 pm    Post subject: Reply with quote

ROGA,

If you have not yet explicitly emerged anything yot, your @world set is empty. As emerge @world includes @system too, both commands reduce to emerge @system.
Your world set is is /var/lib/portage/world. Feel free to look at it..

Your profile mostly changes USE flags. You can compare the USE settings by running
Code:
emerge --info
after selecting a profile.

Packages will only be rebuilt after a profile change if they are newer or are affected by a changed USE flag.
You can see that with the -v option to emerge. Changed USE flags are in green.

Code:
# required by dev-lang/spidermonkey-52.9.1_pre1::gentoo
# required by sys-auth/polkit-0.115-r2::gentoo
# required by gnome-extra/polkit-gnome-0.105-r1::gentoo
>=dev-lang/python-2.7.15:2.7 sqlite


The last line explains the problem. Your packages need dev-lang/python, in slot 2.7, to be built with sqlite support, which is currently disabled.
You can enable the sqlite USE flag in make.conf, so its used everywhere, or in /etc/portagelpackage.use, just for the one package.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
ROGA
n00b
n00b


Joined: 17 Feb 2018
Posts: 59
Location: Zurich, Switzerland

PostPosted: Sat Jan 05, 2019 9:58 pm    Post subject: Reply with quote

NeddySeagoon,

NeddySeagoon wrote:
As emerge @world includes @system too,

ok, thats new for me. I believed that both sets are on their own.

NeddySeagoon wrote:
both commands reduce to emerge @system.

Yes, I can follow, that makes sense. Now I understand, why both do the same thing.

NeddySeagoon wrote:
Your world set is is /var/lib/portage/world. Feel free to look at it..

I looked at it and it was ... empty as you said :-)

NeddySeagoon wrote:
Code:
# required by dev-lang/spidermonkey-52.9.1_pre1::gentoo
# required by sys-auth/polkit-0.115-r2::gentoo
# required by gnome-extra/polkit-gnome-0.105-r1::gentoo
>=dev-lang/python-2.7.15:2.7 sqlite


The last line explains the problem. Your packages need dev-lang/python, in slot 2.7, to be built with sqlite support, which is currently disabled.


You're right! It works, when I build the python package with use-flag "sqlite" set.

But what is with this conflict message below? I do not know what the problem should be here. But if I set python with the sqlite use flag, everything works fine. I see no connection.

Code:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.26.2:0/5.26::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.26* required by (virtual/perl-XSLoader-0.270.0:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                     
    (and 34 more with the same problem)

  (dev-lang/perl-5.24.3-r1:0/5.24::gentoo, installed) pulled in by
    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/Unicode-EastAsianWidth-1.330.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                     
    (and 20 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above


regards,
Roland
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43395
Location: 56N 3W

PostPosted: Sat Jan 05, 2019 10:36 pm    Post subject: Reply with quote

ROGA,

Aahh, perl. The problem is that some things want one version of perl and other thing another.
There is a tool for this, to do it all in the right order.

Code:
emerge perl-cleaner
perl-cleaner --all

_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
ROGA
n00b
n00b


Joined: 17 Feb 2018
Posts: 59
Location: Zurich, Switzerland

PostPosted: Sun Jan 06, 2019 10:11 am    Post subject: Reply with quote

NeddySeagoon,

thanks for your explanation.


NeddySeagoon wrote:
There is a tool for this, to do it all in the right order.

Code:
emerge perl-cleaner
perl-cleaner --all


But I think, it's not exactly what I asked for. (Sorry about this, my english is very bad) I try to ask again.

I changed the profile in my clean new stage-3 Installation. After that, I only had to make the following command:

Code:
emerge -av --update --newuse --deep @world


This command generates at the end of emerge two (error or conflict) messages (during the same emerge command), one with perl and one with python

Code:

Total: 266 packages (23 upgrades, 223 new, 3 in new slots, 17 reinstalls), Size of downloads: 594217 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.26.2:0/5.26::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.26* required by (virtual/perl-JSON-PP-2.274.0.200_rc:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                     
    (and 34 more with the same problem)

  (dev-lang/perl-5.24.3-r1:0/5.24::gentoo, installed) pulled in by
    dev-lang/perl:0/5.24= required by (dev-perl/TermReadKey-2.370.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                     
    (and 20 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.
For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by dev-lang/spidermonkey-52.9.1_pre1::gentoo
# required by sys-auth/polkit-0.115-r2::gentoo
# required by gnome-extra/polkit-gnome-0.105-r1::gentoo
>=dev-lang/python-2.7.15:2.7 sqlite

Would you like to add these changes to your config files? [Yes/No]


That one with python I understood (so far) but where is the connection between python and perl? When I add the use-flag "sqlite" to python, ALL works fine (no more conflicts with perl) , where is the connection to perl? I don't see a hint. Do you know, what I mean now? (or do I thinking to far)
_________________
regards,

Roland
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum