Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
tigervnc server works fine with DE plasma, but..
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Elleni
l33t
l33t


Joined: 23 May 2006
Posts: 939

PostPosted: Tue May 14, 2019 8:08 pm    Post subject: tigervnc server works fine with DE plasma, but.. Reply with quote

I'd like to use it with gnome too.

Wether I try to access normaly or to attach an established session issuing
Code:
x0vncserver -passwordfile ~/.vnc/passwd -display :0


I always get a black screen only.

Tried to attach to it with remmina or vncviewer - same thing.

The output of vncviewer hostname:0
Code:
TigerVNC-Betrachter (64-bit) Version 1.8.0
Erstellt auf: 2018-11-09 19:56
Copyright (C) 1999-2017 TigerVNC Team und viele andere (siehe README.txt)
Copyright (C) 2005 Klaus Franken, StrukturPunkt
Siehe http://www.tigervnc.org für Informationen über TigerVNC.

Tue May 14 22:01:35 2019
 DecodeManager: Detected 12 CPU core(s)
 DecodeManager: Creating 4 decoder thread(s)
 CConn:       verbunden mit Rechner hostname, Port 5900
 CConnection: Server supports RFB protocol version 3.8
 CConnection: Using RFB protocol version 3.8
 CConnection: Choosing security type VeNCrypt(19)
 CVeNCrypt:   Choosing security type TLSVnc (258)

Tue May 14 22:01:43 2019
 CConn:       Pixelformat depth 24 (32bpp) little-endian rgb888 wird verwendet
 CConn:       Tight-Verschlüsselung wird verwendet
 CConn:       Fortlaufende Aktualisierungen aktivieren


Please tell me, what information I could provide that helps solving this?

In xstartup file I have put:

Code:
start gnome-session &

instead of
Code:
startkde &
Back to top
View user's profile Send private message
dantrell
l33t
l33t


Joined: 01 Jun 2007
Posts: 619
Location: Earth

PostPosted: Wed May 15, 2019 10:46 pm    Post subject: Re: tigervnc server works fine with DE plasma, but.. Reply with quote

Elleni wrote:
I'd like to use it with gnome too.

I replied here (around the middle) but TL;DR:

Code:
gnome-session --disable-acceleration-check &

or (with GNOME Flashback):

Code:
gnome-session --session=gnome-flashback-metacity --disable-acceleration-check &

_________________
Dantrell B.
Back to top
View user's profile Send private message
Elleni
l33t
l33t


Joined: 23 May 2006
Posts: 939

PostPosted: Thu May 16, 2019 5:16 pm    Post subject: Reply with quote

I testet both, but unfortunatelly it does not work and always gets me black screen. I guess, I'll have to stay with plasma for the remote access. :?
Back to top
View user's profile Send private message
dantrell
l33t
l33t


Joined: 01 Jun 2007
Posts: 619
Location: Earth

PostPosted: Thu May 16, 2019 9:34 pm    Post subject: Reply with quote

Elleni wrote:
I testet both, but unfortunatelly it does not work and always gets me black screen. I guess, I'll have to stay with plasma for the remote access. :?

Just making sure, but you did install GNOME Flashback for the second one?

Elleni wrote:
Please tell me, what information I could provide that helps solving this?

Pass the debug flag and share the output:

Code:
gnome-session --debug --disable-acceleration-check &

Code:
gnome-session --debug --disable-acceleration-check --session=gnome-flashback-metacity &


And for good measure, maybe these too:

Code:
export XKL_XMODMAP_DISABLE=1
gnome-session --debug --disable-acceleration-check &

Code:
export XKL_XMODMAP_DISABLE=1
gnome-session --debug --disable-acceleration-check --session=gnome-flashback-metacity &

_________________
Dantrell B.
Back to top
View user's profile Send private message
Elleni
l33t
l33t


Joined: 23 May 2006
Posts: 939

PostPosted: Thu May 16, 2019 11:37 pm    Post subject: Reply with quote

Hey Dantrell :D

yes, I installed flashback mode before trying.

Also tried your suggestions always a black screen.

Here is what I found in /var/log/messages for
Code:
export XKL_XMODMAP_DISABLE=1
gnome-session --debug --disable-acceleration-check --session=gnome-flashback-metacity &

http://dpaste.com/2QSPWDJ

.vnc/xstartup file:
Code:
#!/bin/sh
export XKL_XMODMAP_DISABLE=1
gnome-session --debug --disable-acceleration-check --session=gnome-flashback-metacity &
#startkde &
#startxfce4 &
#startfluxbox &
#fvwm2 &
#icewm-session &
#startlxde &
#xfce4-panel &


I had also tried

startgnome-session...

and

start gnome-session...

I can start the other three variants tomorrow as its getting late here.

If I could find out howto set debug in x2goclient/x2goserver, I would love to test those too.

Thanks for looking into it - I really appreciate !

Btw. is there a way to start x0vncserver as openrc service? I only found a description launching it in console as user by issuing:
Code:
x0vncserver -passwordfile ~/.vnc/passwd -display :0
(So I ssh-ed in to launch as user)

I am asking as I realized that wobbling windows and cube in plasma are working if I connect to existing local x0vncserver session, while not when connecting to normal vncserver which does not attach to local session. I also read that accelerated DEs are only supported in x2go client/server wenn connecting to locally established Xsession.
Back to top
View user's profile Send private message
dantrell
l33t
l33t


Joined: 01 Jun 2007
Posts: 619
Location: Earth

PostPosted: Sat May 18, 2019 3:50 am    Post subject: Reply with quote

Elleni wrote:
http://dpaste.com/2QSPWDJ

I saw a couple issues but not sure how they relate to GNOME and VNC.

However, what stood out with GNOME Flashback was:

Code:
fill: *** Session is not runnable

which looked to be caused by:

Code:
WARNING: Unable to find required component 'gnome-panel'

I investigated and sure enough, I got a black screen. :twisted:

Looks like I forgot about GNOME Panel so I'll be rolling that out shortly.

Edit: I rolled out an update for GNOME Flashback that includes GNOME Panel (with elogind support). GNOME Applets is still missing, but that's not necessary to test things. I give it 50/50 on working out. :twisted:

Realistically though, figuring out (1) GNOME + VNC and (2) GNOME Flashback are probably their own mini-projects. Scouring the internet hasn't turned up anything useful and my own investigations haven't panned out.
_________________
Dantrell B.
Back to top
View user's profile Send private message
Elleni
l33t
l33t


Joined: 23 May 2006
Posts: 939

PostPosted: Thu May 30, 2019 7:24 pm    Post subject: Reply with quote

Hello dantrell :twisted:

we are making some progress here - just a littlebit - but better than nothing :)

I still cannot connect to the local session if gdm / gnome shell is locally started. Still getting black screen, but...

...if I choose gnome (not a local session) on the x2go-client and connect to x2go-server, I get an old-fashioned gnome-screen - see here

My final goal would be to access the local (accelerated gnome) session, and I see two possibilites to do this. Either by going through x2go-server/-client or by starting tigervnc like this:
Code:

x0vncserver -passwordfile ~/.vnc/passwd -display :0

and connecting to it through vnc client like remmina.

I still don't know how I could start x0vncserver through a service to add it to default runlevel though, at the moment I ssh to the client to execute above command as user for testing. But as said, not starting tigervnc at all and just use x2goclient and select local session works too.

But either way, I only get black windows there with gdm / gnome-shell autologin enabled in xdm.

For testing, I also edited .vnc/xstartup to the following again to connect to (non-local) session via vnc:

Code:
gnome-session --debug --disable-acceleration-check --session=gnome-flashback-metacity &


And tried to connect.

The corresponding debug log is here

dantrell wrote:
Realistically though, figuring out (1) GNOME + VNC and (2) GNOME Flashback are probably their own mini-projects. Scouring the internet hasn't turned up anything useful and my own investigations haven't panned out.


True

I tried to switch to sddm / plasma again to doublecheck. And indeed, by connecting to local session even the accelerated desktop (wobbling windows, switch workspace-> turning cube) is working, so why should that not work with gnome.

I read somewhere that accelerated desktops only work by attaching to local sessions; that would be fine for me, as I want to attach this box to tv and only connect to its local session to start a movie for ex.

Do you think, it's worth a try to temporary switch to official gnome without systemd profile that was recently announced and see, if it works there to maybe get an idea on howto fix?

Or maybe I should try this to see how it works - although its not in tree, it maybe worth a try?

Edit to add, that I found out, that conntection to the local session (plasma) works nice if a monitor is attached, which I did temporarily. But its painfully slow, if no monitor/mouse is attached to the remote box / x2goserver.

Edit to add that maybe this (workaround at the bottom of the page) can help you, dear dantrell to find out a way to make it work and then explain it to me :D

I wanted to try myself, but then I realized that there is no /usr/local/share/applications so I thought, ok I'll put the file in /usr/share/applications but then again /desktop/gnome/session did not exist either so I thought, maybe better ask dantrell
Back to top
View user's profile Send private message
dantrell
l33t
l33t


Joined: 01 Jun 2007
Posts: 619
Location: Earth

PostPosted: Sat Jun 01, 2019 7:42 am    Post subject: Reply with quote

Elleni wrote:
Hello dantrell :twisted:

Oh no. :o

Elleni wrote:
The corresponding debug log is here

Looks like this is because of backintime but that package isn't on my end I think?

Elleni wrote:
I tried to switch to sddm / plasma again to doublecheck. And indeed, by connecting to local session even the accelerated desktop (wobbling windows, switch workspace-> turning cube) is working, so why should that not work with gnome.

Because GNOME.

No really, if you are not starting GNOME on the setup upstream most expects it to be started on then it probably has a 1% chance of working out-of-the-box (if at all). GNOME Flashback might increase that chance to 50%. Either way, if you somehow get it working odds are there won't be hardware acceleration.

Elleni wrote:
Or maybe I should try this to see how it works - although its not in tree, it maybe worth a try?

Maybe. It really shouldn't be this complicated but it is what it is.

Elleni wrote:
Edit to add that maybe this (workaround at the bottom of the page) can help you, dear dantrell to find out a way to make it work and then explain it to me :D

I wanted to try myself, but then I realized that there is no /usr/local/share/applications so I thought, ok I'll put the file in /usr/share/applications but then again /desktop/gnome/session did not exist either so I thought, maybe better ask dantrell

Well, if those locations don't exist you can probably just create them (although you can probably just put them in ~bin and ~/.local/share/applications).

/desktop/gnome/session is a path for gconf/dconf but I'm not sure that specific path is still used.
_________________
Dantrell B.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum