Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Partly missing unicode characters?!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
hilfsbremser
n00b
n00b


Joined: 04 Jun 2004
Posts: 60
Location: Hamm

PostPosted: Mon May 20, 2019 12:12 pm    Post subject: Partly missing unicode characters?! Reply with quote

Dear guys,

I just did a fresh install of a Gentoo system and seem to be suffering from partially missing unicode characters in Gnome and the terminal.
This is an example from the console:

A screenshot from the gnome-terminal can be found here:

http://abload.de/image.php?img=screenshotfrom2019-055bk14.png

Locale is set to en_US.UTF-8. Visiting some UTF-8 test pages with firefox reveals some special characters working and some not.

Could somebody pint me into the right direction to correct this?

Regards

Flo
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2184
Location: Frankfurt, Germany

PostPosted: Tue May 21, 2019 9:40 am    Post subject: Reply with quote

Most probably, your font doesn't provide line drawing characters.
  • Which terminal do you use?
  • Which font do you use?
Install package 'media-fonts/source-pro' and switch the font of your terminal program to 'Source Code Pro'. Does that help?
Back to top
View user's profile Send private message
hilfsbremser
n00b
n00b


Joined: 04 Jun 2004
Posts: 60
Location: Hamm

PostPosted: Tue May 21, 2019 10:20 am    Post subject: Reply with quote

I am using gnome-terminal. But I realized that it does not only affect the terminal Also Thunderbird is missing these characters for example in the folder list if you have a collapsed sub-folder with unread messages in it...
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7412

PostPosted: Tue May 21, 2019 11:40 am    Post subject: Reply with quote

or maybe you're not using utf-8, ascii is a subset of it, so seeing proper ascii chars while no other utf8 chars doesn't mean your utf8 font is bad, just that maybe you're not using utf8 at all
you could look in forum for people asking help to configure utf8 for solve
Back to top
View user's profile Send private message
etnull
Guru
Guru


Joined: 26 Mar 2019
Posts: 338

PostPosted: Tue May 21, 2019 1:03 pm    Post subject: Reply with quote

Make sure you chose the locale properly, maybe you did some mistake:
Code:
   nano -w /etc/locale.gen
uncomment
en_US.UTF-8 UTF-8
   locale-gen
   eselect locale list
   eselect locale set *num*
   env-update && source /etc/profile

Try setting icu flag in make.conf, and emerge -avuDN, emerge @preserved-rebuild, I don't know if this is related but that's what I would try on your place.
Try different terminals, try setting different popular font for your terminal, if nothing works try emerging x11-base/xorg-x11 instead of xorg-server.


Last edited by etnull on Thu Dec 26, 2019 1:20 am; edited 1 time in total
Back to top
View user's profile Send private message
Banana
Guru
Guru


Joined: 21 May 2004
Posts: 521
Location: Germany

PostPosted: Tue May 21, 2019 1:34 pm    Post subject: Reply with quote

I know that this is old info but here is a good resource abut utf-8 and gentoo
https://wiki.gentoo.org/wiki/UTF-8
_________________
My personal space
Back to top
View user's profile Send private message
rogerx
Tux's lil' helper
Tux's lil' helper


Joined: 06 Apr 2004
Posts: 117

PostPosted: Thu Dec 26, 2019 12:39 am    Post subject: Reply with quote

$ LC_ALL=en_US.utf8 urxvt

Then execute your "xinput list", should now see "carriage return arrows" and beginning brackets. The previously mentioned UTF-8 environment chars were replaced with a question mark char within the ascii/iso8859 environment. The question mark is usually the default for non-printable chars.

If the above works for you, then it is likely your locale is set to C (eg. LC_ALL=C), similar to my setup, or the to setup that was the default prior to employing unicode.

As for me, I strongly prefer C/ANSI/ISO8859 chars over UTF-8/UTF-16 chars, as they cannot be easily or readily typed on a US keyboard! A good example of this is trying to delete or rename files with UTF-8/UTF-16 chars. There is a workaround by setting the individual LC_* variables, but it's tedious or error prone in my opinion. See: https://wiki.gentoo.org/wiki/UTF-8

As for me, I stick to LANG="C" within /etc/02locale! The Internet browsers, Seamonkey/Firefox/Chrome, do still display unicode chars without problems; while keeping my terminal and filesystem free of non-typable chars. All of my text files still default to C/ANSI as well.
_________________
Roger
http://rogerx.freeshell.org/
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2184
Location: Frankfurt, Germany

PostPosted: Thu Dec 26, 2019 12:52 am    Post subject: Reply with quote

rogerx wrote:
As for me, I stick to LANG="C" within /etc/02locale!

This might work -- as long as you use only the English language and as long as you live in the USA. :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum