Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gelöst: Umstieg auf 17.1 - dev-libs/mpfr
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
henry
Tux's lil' helper
Tux's lil' helper


Joined: 09 Aug 2002
Posts: 79

PostPosted: Tue Jun 11, 2019 2:28 pm    Post subject: gelöst: Umstieg auf 17.1 - dev-libs/mpfr Reply with quote

Hallo Freunde,

kann mir hier jemand weiter helfen?
Nach Anleitung auf 17.1 umgestiegen.
nach : emerge -pvu world kommt folgende Meldung:

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-libs/mpfr:0

(dev-libs/mpfr-4.0.1:0/6::gentoo, ebuild scheduled for merge) conflicts with
dev-libs/mpfr:0/4= required by (dev-libs/libbytesize-1.4:0/0::gentoo, installed)
^^^^^
>=dev-libs/mpfr-2.4.2:0/4= required by (sys-devel/gcc-8.3.0-r1:8.3.0/8.3.0::gentoo, installed)
^^^^^
dev-libs/mpfr:0/4= required by (dev-libs/rasqal-0.9.33:0/0::gentoo, installed)
^^^^^
<dev-libs/mpfr-4.0.0 required by (dev-libs/mpc-1.0.3:0/0::gentoo, installed)


#emerge -pv mpfr

[ebuild R ] dev-libs/mpfr-3.1.6:0/4::gentoo USE="-static-libs" ABI_X86="32 (64) (-x32)" 0 KiB

Ich weiss noch nicht wie ich das löse.
Bin für jede Idee dankbar.

73 Henry


Last edited by henry on Wed Jun 12, 2019 6:09 am; edited 1 time in total
Back to top
View user's profile Send private message
mike155
Veteran
Veteran


Joined: 17 Sep 2010
Posts: 1190
Location: Frankfurt, Germany

PostPosted: Wed Jun 12, 2019 12:16 am    Post subject: Reply with quote

Bitte umrande Ausgaben in Zukunft in [ code] .. [ /code]-Tags (ohne Leerzeichen). Sie sind dann wesentlich einfacher zu lesen. Einerseits werden Code-Blöcke mit einem Monospace-Font dargestellt, andererseits bleiben Einrückungen erhalten.

Zu dem eigentlichen Problem:
  • Emerge will dev-libs/mpfr-4.0.1 installieren...
  • ... und das geht nicht, weil dev-libs/mpc-1.0.3 eine Version < 4.0.0 will

Es gibt folgende alternative Lösungsmöglichkeiten:
  1. Warum will Emerge dev-libs/mpfr-4.0.1 installieren? Version 4 ist doch noch unstable? Hast Du einen Eintrag für mpfr in /etc/portage/packages.keywords oder /etc/portage/packages.accept_keywords? Wenn ja, dann könntest Du diesen entfernen.

  2. Du könntest dev-libs/mpc-1.0.3 auf 1.0.3-r2 upgraden. Dieser Ebuild hat kein Problem mehr mit der 4er Version von dev-libs/mpfr.

    Dazu kannst Du folgende Zeile an /etc/portage/package.accept_keywords hinzufügen:
    Code:
    =dev-libs/mpc-1.0.3* ~amd64

    Und dann aufrufen:
    Code:
    emerge --update --deep --oneshot -av dev-libs/mpc

Back to top
View user's profile Send private message
henry
Tux's lil' helper
Tux's lil' helper


Joined: 09 Aug 2002
Posts: 79

PostPosted: Wed Jun 12, 2019 6:11 am    Post subject: Reply with quote

Hallo Mike155,

danke für die Hilfe.

Ich habe mich für 2. entschieden und wieder was dazu gelernt.

73 Henry
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3661
Location: Hamburg

PostPosted: Wed Jun 12, 2019 8:21 pm    Post subject: Reply with quote

mike155 wrote:
Dazu kannst Du folgende Zeile an /etc/portage/package.accept_keywords hinzufügen:
Code:
=dev-libs/mpc-1.0.3* ~amd64
Ich bevorzuge
Code:
~dev-libs/mpc-1.0.3
Back to top
View user's profile Send private message
mike155
Veteran
Veteran


Joined: 17 Sep 2010
Posts: 1190
Location: Frankfurt, Germany

PostPosted: Wed Jun 12, 2019 11:10 pm    Post subject: Reply with quote

toralf wrote:
Ich bevorzuge
Code:
~dev-libs/mpc-1.0.3

Guter Vorschlag! Das geht natürlich auch und es ist kürzer.

Laut dieser Seite funktioniert die Tilde-Schreibweise aber nur für -r# package revisions.

Ich habe häufiger den Fall, dass ich auch Punkt-Versionen freigeben möchte. Beispielsweise möchte ich alle unstable Versionen von Qt 5.12 freigeben (also 5.12.2, 5.12.3, 5.12.4, usw.), nicht aber 5.13. Das bekomme ich mit der Sternchen-Schreibweise gut hin:
Code:
=dev-qt/qtcore-5.12*
=dev-qt/qtdbus-5.12*
...

Mit der Sternchen-Schreibweise könnte auch alle unstable Qt 5-Versionen freigeben (aber nicht Qt 4 oder 6):
Code:
=dev-qt/qtcore-5*
=dev-qt/qtdbus-5*
...
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4456

PostPosted: Thu Jun 13, 2019 6:50 am    Post subject: Reply with quote

mike155 wrote:

[/code]
Mit der Sternchen-Schreibweise könnte auch alle unstable Qt 5-Versionen freigeben (aber nicht Qt 4 oder 6):
Code:
=dev-qt/qtcore-5*
=dev-qt/qtdbus-5*
...

Jetzt wirds offtopic:
Bei Qt funktioniert auch das hier, da die haupt versionen (4,5,6) in slots sind
Code:
dev-qt/qtcore:5
dev-qt/qtdbus:5
...

_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3612
Location: Germany

PostPosted: Thu Jun 13, 2019 8:31 am    Post subject: Reply with quote

Jo, bei Qt würde ich auch eher die Slots und Subslots nutzen, also zb:
Code:
dev-qt/*:5/5.12.3::gentoo
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Thu Jun 13, 2019 4:16 pm    Post subject: Reply with quote

Josef.95 wrote:
Jo, bei Qt würde ich auch eher die Slots und Subslots nutzen, also zb:
Code:
dev-qt/*:5/5.12.3::gentoo

In 5/5.12.3 liegt aber nur qtsql, der Rest ist 5/5.12
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3612
Location: Germany

PostPosted: Thu Jun 13, 2019 6:05 pm    Post subject: Reply with quote

franzf wrote:
Josef.95 wrote:
Jo, bei Qt würde ich auch eher die Slots und Subslots nutzen, also zb:
Code:
dev-qt/*:5/5.12.3::gentoo

In 5/5.12.3 liegt aber nur qtsql, der Rest ist 5/5.12

Huch ja, in der tat, das ist neu.
Schade, bisher konnte man sich auf die Subslots recht gut verlassen :-/

/edit
Huh ja, hier hab ich mich tatsächlich geirrt -- die letzten Qt Versionen hatten stets nur einen zweistelligen Subslot (zb 5/5.12) -- einzig bei qtsql wurde er vor ein paar Monaten auf dreistellig erweitert. Sorry, war mein Fehler :-/
@franzf, danke fürs drauf aufmerksam machen :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum