Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
First Time Installing Gentoo - SDDM WIll Not Start.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
WillianRLD
n00b
n00b


Joined: 08 Jul 2019
Posts: 1
Location: Brasil

PostPosted: Mon Jul 08, 2019 9:10 pm    Post subject: First Time Installing Gentoo - SDDM WIll Not Start. Reply with quote

I have successfully installed Gentoo on my system with Plasma 5 and using Systemd as init system (as I'm coming from arch linux, and am more familiar with Systemd).

After installing everything I did the usual: systemctl enable sddm. Command runs and symlink is successfully created.

But after the restart, SDDM won't launch -- it simply hangs at "Reached target Graphical Interface" and stops there.

I know I must be doing a mistake somewhere...

Will I have better luck using OpenRC instead of Systemd?

My system is a Core i5-7400 with a Radeon RX 570 GPU. Xf86-video-amdgpu, xorg-server and wayland are all installed.
_________________
A realidade pode ser bem mais estranha e fascinante do que a Ficção.
Back to top
View user's profile Send private message
Etal
Veteran
Veteran


Joined: 15 Jul 2005
Posts: 1692

PostPosted: Fri Jul 12, 2019 1:00 am    Post subject: Reply with quote

Hi WillianRLD,

Can you log in if you switch to a different tty (e.g. Ctrl+Alt+F2)? If so, first step would be to check systemctl status sddm

Have you tried starting X without SDDM on your new install?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum