Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
realtek r8169 Link Up/Down problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
DeIM
Apprentice
Apprentice


Joined: 11 Apr 2006
Posts: 288

PostPosted: Fri Jul 26, 2019 4:22 pm    Post subject: realtek r8169 Link Up/Down problem Reply with quote

I'm facing this problem with integrated network card:
Code:
...
[421396.563718] r8169 0000:02:00.0 enp2s0: Link is Down
[421401.810122] r8169 0000:02:00.0 enp2s0: Link is Up - 1Gbps/Full - flow control rx/tx
[421405.032102] r8169 0000:02:00.0 enp2s0: Link is Down
[421408.537382] r8169 0000:02:00.0 enp2s0: Link is Up - 1Gbps/Full - flow control rx/tx
[421409.473932] r8169 0000:02:00.0 enp2s0: Link is Down
[421417.053729] r8169 0000:02:00.0 enp2s0: Link is Up - 1Gbps/Full - flow control rx/tx
[421419.474641] r8169 0000:02:00.0 enp2s0: Link is Down
[421423.379920] r8169 0000:02:00.0 enp2s0: Link is Up - 1Gbps/Full - flow control rx/tx
[421425.453701] r8169 0000:02:00.0 enp2s0: Link is Down
[427572.600396] r8169 0000:02:00.0 enp2s0: Link is Up - 1Gbps/Full - flow control rx/tx


it sometime disconnects at all and the LED on board and on switch doesn't light at all.
Other connections on switch are OK.
May it be something with driver?
Using kernel: 4.19.44-gentoo
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 6481

PostPosted: Fri Jul 26, 2019 5:36 pm    Post subject: Reply with quote

More likely to be the cable. They can degrade over time.
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 4524
Location: Dallas area

PostPosted: Fri Jul 26, 2019 5:39 pm    Post subject: Reply with quote

I was having problems with one of my computers on the router lately,
turns out that when I unplugged another port I tapped the cable just enough that it was getting an intermittent connection.
I unplugged it and plugged it back in properly -- no more problem :lol:
_________________
PRIME x570-pro, 3700x, RX 550 & 560
Acer E5-575 (laptop), i3-7100u - i965
---both---
5.5.18 zen kernel, gcc 9.3.0, profile 17.1 (no-pie & modified) amd64-no-multilib, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
bunder
Bodhisattva
Bodhisattva


Joined: 10 Apr 2004
Posts: 5910

PostPosted: Fri Jul 26, 2019 8:42 pm    Post subject: Reply with quote

the cable on my laptop sometimes comes loose, despite being still clicked into the jack. some cables and jacks are just weaksauce. :?
_________________
Neddyseagoon wrote:
The problem with leaving is that you can only do it once and it reduces your influence.

banned from #gentoo since sept 2017
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum