Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Try add wine-d3d9 support
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
Rafix0111
n00b
n00b


Joined: 11 Aug 2019
Posts: 13

PostPosted: Wed Aug 14, 2019 6:10 pm    Post subject: Try add wine-d3d9 support Reply with quote

When I try install wine d3d9 support for DirectX games get this:
Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy "media-libs/mesa[d3d9,egl,
  abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
  abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,
  abi_s390_32(-)?,abi_s390_64(-)?]" has unmet requirements.
- media-libs/mesa-19.0.8::gentoo USE="classic d3d9 dri3 egl gallium gbm gles2 llvm wayland -debug -gles1 (-libglvnd) -lm_sensors -opencl -osmesa -pax_kernel -pic (-selinux) -test -unwind -vaapi -valgrind -vdpau -vulkan -xa -xvmc" ABI_X86="32 (64) (-x32)" VIDEO_CARDS="radeon (-freedreno) -i915 -i965 (-imx) -intel -nouveau -r100 -r200 -r300 -r600 -radeonsi (-vc4) -virgl (-vivante) -vmware"

  The following REQUIRED_USE flag constraints are unsatisfied:
    d3d9? ( any-of ( video_cards_r300 video_cards_r600 video_cards_radeonsi video_cards_nouveau video_cards_vmware ) )

  The above constraints are a subset of the following complete expression:
    d3d9? ( dri3 any-of ( video_cards_r300 video_cards_r600 video_cards_radeonsi video_cards_nouveau video_cards_vmware ) ) gles1? ( egl ) gles2? ( egl ) vulkan? ( dri3 any-of ( video_cards_i965 video_cards_radeonsi ) video_cards_radeonsi? ( llvm ) ) wayland? ( egl gbm ) video_cards_freedreno? ( gallium ) video_cards_intel? ( classic ) video_cards_i915? ( any-of ( classic gallium ) ) video_cards_i965? ( classic ) video_cards_imx? ( gallium video_cards_vivante ) video_cards_nouveau? ( any-of ( classic gallium ) ) video_cards_radeon? ( any-of ( classic gallium ) gallium? ( x86? ( llvm ) amd64? ( llvm ) ) ) video_cards_r100? ( classic ) video_cards_r200? ( classic ) video_cards_r300? ( gallium x86? ( llvm ) amd64? ( llvm ) ) video_cards_r600? ( gallium ) video_cards_radeonsi? ( gallium llvm ) video_cards_vc4? ( gallium ) video_cards_virgl? ( gallium ) video_cards_vivante? ( gallium gbm ) video_cards_vmware? ( gallium )

(dependency required by "app-emulation/wine-d3d9-4.1::gentoo" [ebuild])
(dependency required by "wine-d3d9" [argument])

I have radeon HD3450. My question is Does my video card not support D3D9 or do I need to install additional drivers?

Broke long lines to make the forum layout behave.Chiitoo
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5963

PostPosted: Wed Aug 14, 2019 6:16 pm    Post subject: Reply with quote

Code:
  The following REQUIRED_USE flag constraints are unsatisfied:
    d3d9? ( any-of ( video_cards_r300 video_cards_r600 video_cards_radeonsi video_cards_nouveau video_cards_vmware ) )

d3d9 supports those video cards, you have none of them enabled
Back to top
View user's profile Send private message
Rafix0111
n00b
n00b


Joined: 11 Aug 2019
Posts: 13

PostPosted: Wed Aug 14, 2019 6:32 pm    Post subject: Reply with quote

Which should be enabled for my video card and whether the choice will affect the current driver?
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5963

PostPosted: Wed Aug 14, 2019 6:34 pm    Post subject: Reply with quote

See wiki
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum