Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED - WORKAROUND] DaVinci Resolve - new Qt5 installer issues
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Marcih
Apprentice
Apprentice


Joined: 19 Feb 2018
Posts: 159

PostPosted: Tue Sep 10, 2019 9:38 am    Post subject: DaVinci Resolve 16 - new installer issues Reply with quote

I know this is on the fence between Multimedia and Unsupported Sofware, mods please move it to the appropriate forum section if need be.

I'm having issues with the new Qt5-based GUI Resolve installer introduced in the 16 release. The old shell script used for versions up to 15 works fine; the new installer runs fine but when it comes to the actual install phase, the progress bar immediately jumps to 100% with the heading changing to "Aborted".
With no logs that I know of to look through for possible missing packages and no official list of deps, I'm hoping someone else has run into this problem too or maybe it does work for others and they can give me a hand in solving it.

I'm posting this here and not on the Blackmagic forums because Gentoo is not an officially supported distro and I don't know how much help the people there could be. Thanks for all the tips.
_________________
Bones McCracker wrote:
It wouldn't be so bad, if it didn't suck.


Last edited by Marcih on Sun Sep 15, 2019 5:21 pm; edited 3 times in total
Back to top
View user's profile Send private message
PeGa!
Tux's lil' helper
Tux's lil' helper


Joined: 13 May 2005
Posts: 104
Location: Capital Federal, Buenos Aires, Argentina

PostPosted: Sun Sep 15, 2019 1:45 pm    Post subject: Reply with quote

Hello Marcih,

Did you see similar behavior posted in the Blackmagic forums? I've tinkered with Resolve in the past, and I hacked my way through with Blackmagic posts, Google and lots of patience.

One thing that comes to my head right now -- try the installation with strace. I know is awful, but trust me it allowed me to make it work.

Hope that helps.
_________________
If it moves, it needs an ebuild.

Adopt an unanswered post.
Back to top
View user's profile Send private message
Marcih
Apprentice
Apprentice


Joined: 19 Feb 2018
Posts: 159

PostPosted: Sun Sep 15, 2019 5:20 pm    Post subject: Reply with quote

PeGa! wrote:
Hello Marcih,

Did you see similar behavior posted in the Blackmagic forums? I've tinkered with Resolve in the past, and I hacked my way through with Blackmagic posts, Google and lots of patience.

One thing that comes to my head right now -- try the installation with strace. I know is awful, but trust me it allowed me to make it work.

Hope that helps.
Hi PeGA!,

thanks for responding, I've forgotten about the issue and just went on using the version I had installed. :D
I have been scouring the Linux issues megathread on the Blackmagic forums, people do seem to have issues but 0 to do with the installer. I've tried using strace which revealed no additional info. Another thing I did was go back in the versions and I discovered that the new installer was introduced in the 15 release already, somewhere between 15.1.2 (the version I've been using up until now with the .sh installer) and 15.3.2 (the last 15 release).

Fortunately I've been able to find a workaround: I've gone back and re-read the installation instructions PDF included in the ZIP archive. It states that you can either use the GUI installer or a CLI installer; the GUI installer is launched by double-clicking (or just launching it regularly from the command line, ./DaVinci_Resolve_16.0_Linux.run) while the CLI installer is called by running sudo ./DaVinci_Resolve_16.0_Linux.run -i from the command line. Since the old .sh installer worked for me, I tried the CLI version of the new installer. Lo and behold, it worked. I should've Read The Fine Manual I suppose.

There's obviously something wrong since the Qt5 installer seems to be working for everyone but me (I'll blame it on the devs ignoring all the bug reports from people not using CentOS, the only distro they officially support ;)) but since I'll be closing the thread since I've gotten it working. Thanks for the nudge to get me to look into it again!
_________________
Bones McCracker wrote:
It wouldn't be so bad, if it didn't suck.
Back to top
View user's profile Send private message
Chiitoo
Administrator
Administrator


Joined: 28 Feb 2010
Posts: 1804
Location: Here and Away Again

PostPosted: Mon Sep 16, 2019 12:30 pm    Post subject: Reply with quote

Moved from Multimedia to Unsupported Software.

Since the software discussed here is, at this time, not available via the official Gentoo repository, it is indeed a better fit for the topic.
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum