Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] alpine>=2.22 doesn't save password
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
ups
n00b
n00b


Joined: 06 Sep 2018
Posts: 14

PostPosted: Mon Jun 29, 2020 11:45 am    Post subject: [SOLVED] alpine>=2.22 doesn't save password Reply with quote

After upgrade to 2.22 (in 2.23 problem persists) alpine doesn't store password between sessions anymore.
The file .pinepwd is present with proper permissions, and it is modified by by alpine although in new session it asks for password again.
No USE flags have been changed between upgrades, the package is compiled with "passfile" flag.

Code:
$ eix alpine
[I] mail-client/alpine
     Available versions:  2.00-r7[1] ~2.21.1-r1[1] 2.22 ~2.22-r1 2.23 {+chappa debug doc ipv6 kerberos ldap libressl nls onlyalpine pam passfile smime spell ssl threads}
     Installed versions:  2.23(09:48:07 PM 06/27/2020)(chappa ipv6 ldap nls passfile spell ssl -doc -kerberos -libressl -onlyalpine -smime -threads)
     Homepage:            http://alpine.x10host.com/alpine/ https://repo.or.cz/alpine.git/
     Description:         An easy to use text-based based mail and news client

[1] "mv" /var/lib/layman/mv


Any idea?


Last edited by ups on Tue Jun 30, 2020 11:41 am; edited 1 time in total
Back to top
View user's profile Send private message
saellaven
Guru
Guru


Joined: 23 Jul 2006
Posts: 561

PostPosted: Mon Jun 29, 2020 12:25 pm    Post subject: Reply with quote

I'm having the same issue... I haven't had a chance to file a bug or investigate it myself yet, though I see that password management was in the changelog for 2.22.

In the meantime, I've remained on 2.21.1-r1
_________________
Ryzen 3700X, Asus Prime X570-Pro, 32 GB DDR4 3200, GeForce 1050 Ti
openrc-0.17, ~vanilla-sources, ~nvidia-drivers, gcc-9.2.0
Back to top
View user's profile Send private message
cboldt
l33t
l33t


Joined: 24 Aug 2005
Posts: 889

PostPosted: Mon Jun 29, 2020 11:37 pm    Post subject: Reply with quote

If you haven't already, try this. I don't recall when I did this, but I am running alpine-2.22 and no need to repeat password.

Code:
Remove Master Password from mail reader `alpine`
================================================
cd ~/.alpine-smime/.pwd
mv MasterPassword.key MasterPassword.key.orig
openssl rsa -in MasterPassword.key.orig -out MasterPassword.key
Back to top
View user's profile Send private message
saellaven
Guru
Guru


Joined: 23 Jul 2006
Posts: 561

PostPosted: Tue Jun 30, 2020 12:19 am    Post subject: Reply with quote

cboldt wrote:
If you haven't already, try this. I don't recall when I did this, but I am running alpine-2.22 and no need to repeat password.

Code:
Remove Master Password from mail reader `alpine`
================================================
cd ~/.alpine-smime/.pwd
mv MasterPassword.key MasterPassword.key.orig
openssl rsa -in MasterPassword.key.orig -out MasterPassword.key


Thanks... this pointed me in the right direction.

I had the passfile useflag set, but not the smime useflag, and, after adding smime, I was asked to add a master password, and the passwords are now usable.

That said, now I have the new headache of needing to verify my master password every time I send an email. I already have a password to log into my system, I don't need another layer of passwords to protect me or else I'd just input my SMTP server password with every message.

Edit: now if I do the step you describe, the master password is gone and alpine is usable again. Thanks again.
_________________
Ryzen 3700X, Asus Prime X570-Pro, 32 GB DDR4 3200, GeForce 1050 Ti
openrc-0.17, ~vanilla-sources, ~nvidia-drivers, gcc-9.2.0
Back to top
View user's profile Send private message
cboldt
l33t
l33t


Joined: 24 Aug 2005
Posts: 889

PostPosted: Tue Jun 30, 2020 10:38 am    Post subject: Reply with quote

I didn't think to mention the USE settings, at least the extent they differ from default. Thanks for pointing that out.

Not all of these USE settings are necessary to get rid of the annoying "repeat your password" behavior, the systems on my tlocal network have the following USE settings. In /etc/portage/package.use/package.use ...

Code:
mail-client/alpine                      passfile smime threads
Back to top
View user's profile Send private message
ups
n00b
n00b


Joined: 06 Sep 2018
Posts: 14

PostPosted: Tue Jun 30, 2020 11:41 am    Post subject: Reply with quote

Indeed adding smime USE flag and encrypting private key solves the problem.
Thanks you all.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum