Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
diff between running firefox normally and safe mode [solved
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5530

PostPosted: Thu Sep 10, 2020 8:53 pm    Post subject: diff between running firefox normally and safe mode [solved Reply with quote

Greetings,

today a strange issue arose, I'm unable to view netflix streams via the website.
yesterday I was able to.

the only way to view it is vi safemode.
I wonder if there is a way to display the diffs between normal and safe mode?

here are the upgrades from yesterdaty and today:
Code:

     Wed Sep  9 19:09:35 2020 >>> dev-libs/re2-0.2020.06.01
     Wed Sep  9 19:09:46 2020 >>> net-vpn/wireguard-tools-1.0.20200827
     Wed Sep  9 19:09:50 2020 >>> app-arch/snappy-1.1.8
     Wed Sep  9 19:09:59 2020 >>> net-misc/youtube-dl-2020.09.06
     Wed Sep  9 19:10:08 2020 >>> kde-plasma/systemsettings-5.19.5
     Wed Sep  9 19:10:18 2020 >>> kde-plasma/kinfocenter-5.19.5
     Wed Sep  9 19:10:30 2020 >>> kde-plasma/kscreen-5.19.5
     Wed Sep  9 19:11:15 2020 >>> kde-plasma/powerdevil-5.19.5
     Wed Sep  9 19:14:14 2020 >>> app-editors/okteta-0.26.4
     Wed Sep  9 19:14:26 2020 >>> kde-plasma/plasma-desktop-5.19.5
     Wed Sep  9 19:24:01 2020 >>> media-video/transcode-1.1.7-r5
     Wed Sep  9 19:28:56 2020 >>> kde-apps/k3b-20.08.1
     Thu Sep 10 18:25:09 2020 >>> dev-libs/re2-0.2020.06.01
     Thu Sep 10 18:25:46 2020 >>> net-misc/curl-7.72.0
     Thu Sep 10 18:26:27 2020 >>> net-fs/nfs-utils-2.5.1
     Thu Sep 10 18:26:34 2020 >>> app-crypt/gnupg-2.2.20-r1
     Thu Sep 10 18:26:50 2020 >>> app-arch/snappy-1.1.8
     Thu Sep 10 18:27:34 2020 >>> dev-db/mysql-connector-c-8.0.21-r2
     Thu Sep 10 18:31:10 2020 >>> net-fs/samba-4.12.6
     Thu Sep 10 18:31:16 2020 >>> net-print/cups-filters-1.27.4
     Thu Sep 10 18:34:09 2020 >>> net-im/skypeforlinux-8.64.0.80
     Thu Sep 10 18:36:09 2020 >>> sys-kernel/gentoo-sources-5.8.8
     Thu Sep 10 18:36:19 2020 >>> app-admin/sudo-1.9.2
     Thu Sep 10 18:36:41 2020 >>> dev-vcs/git-2.28.0
     Thu Sep 10 18:41:00 2020 >>> net-vpn/strongswan-5.8.4
     Thu Sep 10 18:41:45 2020 >>> www-plugins/adobe-flash-32.0.0.433
     Thu Sep 10 18:51:35 2020 >>> net-mail/mailutils-3.10
     Thu Sep 10 19:29:20 2020 >>> media-tv/kodi-19.0_alpha1_p20200909


just to remove firefox upgrade of the question. the last firefox upgrade was at Sep 7th.

thought?
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein


Last edited by DaggyStyle on Sat Sep 12, 2020 4:11 pm; edited 1 time in total
Back to top
View user's profile Send private message
VinzC
Watchman
Watchman


Joined: 17 Apr 2004
Posts: 5069
Location: Dark side of the mood

PostPosted: Fri Sep 11, 2020 7:11 am    Post subject: Reply with quote

Have you checked [all the] proprietary codecs are allowed in Firefox? I know there are USE flags with Firefox that control DRM, mandatory for viewing certain video streams.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
1739!
Back to top
View user's profile Send private message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5530

PostPosted: Fri Sep 11, 2020 9:07 am    Post subject: Reply with quote

here is what I have:
Code:

=================================================================
                        Package Settings
=================================================================

www-client/firefox-80.0.1-r1::gentoo was built with the following:
USE="dbus geckodriver gmp-autoupdate lto openh264 screenshot system-av1 system-harfbuzz system-icu system-jpeg system-libevent system-libvpx system-webp -bindist -clang -custom-cflags -custom-optimization -debug -eme-free -hardened -hwaccel -jack -pgo -pulseaudio -screencast (-selinux) -test -wayland -wifi" ABI_X86="(64)" CPU_FLAGS_X86="avx2" L10N="he -ach -af -an -ar -ast -az -be -bg -bn -br -bs -ca -cak -cs -cy -da -de -dsb -el -en-CA -en-GB -eo -es-AR -es-CL -es-ES -es-MX -et -eu -fa -ff -fi -fr -fy -ga -gd -gl -gn -gu -hi -hr -hsb -hu -hy -ia -id -is -it -ja -ka -kab -kk -km -kn -ko -lij -lt -lv -mk -mr -ms -my -nb -nl -nn -oc -pa -pl -pt-BR -pt-PT -rm -ro -ru -si -sk -sl -son -sq -sr -sv -ta -te -th -tr -uk -ur -uz -vi -xh -zh-CN -zh-TW"
CFLAGS="-pipe -march=native -mtune=native"
CXXFLAGS="-pipe -march=native -mtune=native -flifetime-dse=1"
FEATURES="protect-owned sfperms binpkg-dostrip ebuild-locks distlocks news sandbox strict qa-unresolved-soname-deps merge-sync unmerge-logs fixlafiles preserve-libs userpriv binpkg-logs binpkg-docompress clean-logs unmerge-orphans pid-sandbox usersandbox multilib-strict usersync unknown-features-warn network-sandbox collision-protect config-protect-if-modified ipc-sandbox parallel-fetch assume-digests"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,-rpath=/usr/lib64/firefox,--enable-new-dtags -Wl,--compress-debug-sections=zlib"


still afaik, safe mode shouldn't enable codecs normal mode isn't enabling
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
VinzC
Watchman
Watchman


Joined: 17 Apr 2004
Posts: 5069
Location: Dark side of the mood

PostPosted: Fri Sep 11, 2020 1:54 pm    Post subject: Reply with quote

Well, I don't have the explanation for your particular issue but I could swear EME aka Encrypted Media Extensions (eme-free in this case and I know Mozilla has/had a special implementation for these) are required for DRM'ed contents such as Netflix. You might try to enable it, just out of curiosity and try again.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
1739!
Back to top
View user's profile Send private message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5530

PostPosted: Fri Sep 11, 2020 3:50 pm    Post subject: Reply with quote

VinzC wrote:
Well, I don't have the explanation for your particular issue but I could swear EME aka Encrypted Media Extensions (eme-free in this case and I know Mozilla has/had a special implementation for these) are required for DRM'ed contents such as Netflix. You might try to enable it, just out of curiosity and try again.

not sure I follow, are you suggesting to enable eme-free? if I understand correctly, this disables DRM which is needed for widevine lib must have
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5530

PostPosted: Fri Sep 11, 2020 8:30 pm    Post subject: Reply with quote

the plot thickens, seems like a facebook video has it's audio distorted in normal mode while is it ok in safe mode...
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 18542

PostPosted: Fri Sep 11, 2020 8:59 pm    Post subject: Reply with quote

Do you have add-ons / extensions set to auto-update, and does safe mode disable any of them?
_________________
Your lips move, but I can't hear what you're saying.
Back to top
View user's profile Send private message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5530

PostPosted: Fri Sep 11, 2020 9:46 pm    Post subject: Reply with quote

widevine and h264 are auto updated, both are enabled on safe mode
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5530

PostPosted: Sat Sep 12, 2020 4:11 pm    Post subject: Reply with quote

looks like it was one of the extensions I had, I've disabled them all and the problem went away, when I tried to find the right one, I've ended with all extensions enabled and the issues working,

so I think it is fixed...
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
VinzC
Watchman
Watchman


Joined: 17 Apr 2004
Posts: 5069
Location: Dark side of the mood

PostPosted: Tue Sep 15, 2020 7:39 am    Post subject: Reply with quote

VinzC wrote:
Well, I don't have the explanation for your particular issue but I could swear EME aka Encrypted Media Extensions (eme-free in this case and I know Mozilla has/had a special implementation for these) are required for DRM'ed contents such as Netflix. You might try to enable it, just out of curiosity and try again.

DaggyStyle wrote:
not sure I follow, are you suggesting to enable eme-free? if I understand correctly, this disables DRM which is needed for widevine lib must have

That's what I was indeed suggesting. My understanding was wrong, obviously, based on what I saw before. A while ago that USE flag was eme, now eme-free (which I wrongly interpreted as a "free" version of encrypted media extensions) has the exact, opposite effect... :oops: :roll:

So, sorry for the noise.

DaggyStyle wrote:
looks like it was one of the extensions I had, I've disabled them all and the problem went away, when I tried to find the right one, I've ended with all extensions enabled and the issues working,

so I think it is fixed...

That's somehow reassuring as it follows the old scheme: if something goes wrong with Firefox but in safe mode then it's probably an extension that's responsible for the mess... I thought of it but don't know why I didn't suggest that in the first place, go figure... :oops:

Glad you solved your issue though.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
1739!
Back to top
View user's profile Send private message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5530

PostPosted: Wed Sep 16, 2020 6:08 am    Post subject: Reply with quote

that's ok. I'm still unable to determine what was the issue exactly...

now that it works, it doesn't matter much.
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum