Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Cannot Update New Gentoo
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5  Next  
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 268
Location: USA, California

PostPosted: Wed Sep 17, 2014 2:35 am    Post subject: Reply with quote

I mounted all my partitions except boot, all the files in the / dir where there, I already deleted the stage3. I
Code:
ls -l /mnt/gentoo/bin/bash
and got
Code:
-rwxr-xr-x 1 root root 741992 Sep 11 03:17 /mnt/gentoo/bin/bash

I nano'd it but it was all giberish. So my files seem to be there.
Should I just do a whole new fresh install of Gentoo then? Or do I need to copy the dirs from the live disc?
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7552
Location: Goose Creek SC

PostPosted: Wed Sep 17, 2014 2:59 am    Post subject: Reply with quote

you say "all the files in the / dir where there" which I hear as, ' you ran "ls /mnt/gentoo" and the directory structure was present.'
gibberish from "nano /mnt/gentoo/bin/bash" would be expected, it's a binary file.
attempt to boot the installed gentoo. After the normal messaging do you see a login prompt? If so, login as root.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 268
Location: USA, California

PostPosted: Wed Sep 17, 2014 3:21 am    Post subject: Reply with quote

Yes, all the files/folders are present.
When the system loads, I get the login prompt. I had set up my user account right after I installed Gentoo; so I can login to both, but with either account, bash isn't working.
Even in root the errors persist.
Thanks again for working with me on this. I really appreciate it.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7552
Location: Goose Creek SC

PostPosted: Wed Sep 17, 2014 3:59 am    Post subject: Reply with quote

after login as root, run:
Code:
ls -l /bin/bash
post the output, or if you have wgetpaste,
Code:
ls -al /bin/bash | wgetpaste -s gists

_________________
Defund the FCC.
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 268
Location: USA, California

PostPosted: Wed Sep 17, 2014 4:13 am    Post subject: Reply with quote

Code:
ls -al /bin/bash | wgetpaste -s gists

https://gist.github.com/8472630c944b48cac441
Is that how it is supposed to look?
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7552
Location: Goose Creek SC

PostPosted: Wed Sep 17, 2014 4:23 am    Post subject: Reply with quote

letter perfect; this is getting crazy
run
Code:
whoami
expected is root pls post every letter of any other response
Code:
echo "moose"
expected is moose
_________________
Defund the FCC.


Last edited by DONAHUE on Wed Sep 17, 2014 4:29 am; edited 1 time in total
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 268
Location: USA, California

PostPosted: Wed Sep 17, 2014 4:25 am    Post subject: Reply with quote

You got that right! lol :)

it says "root"
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7552
Location: Goose Creek SC

PostPosted: Wed Sep 17, 2014 4:30 am    Post subject: Reply with quote

Code:
echo "moose"
expected is moose

Code:
ls -l /usr/bin/emerge
expected to resemble lrwxrwxrwx 1 root root 25 Apr 4 02:14 /usr/bin/emerge -> ../lib/portage/bin/emerge permissions and path are critical
_________________
Defund the FCC.


Last edited by DONAHUE on Wed Sep 17, 2014 4:36 am; edited 1 time in total
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 268
Location: USA, California

PostPosted: Wed Sep 17, 2014 4:34 am    Post subject: Reply with quote

Now I wonder if you are just messing with me? :D lol

Code:
echo "moose"
gives
Code:
moose
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7552
Location: Goose Creek SC

PostPosted: Wed Sep 17, 2014 4:38 am    Post subject: Reply with quote

echo is a bash command, wgetpaste used bash and environment, so bash works
Code:
ls -l /usr/bin/emerge
expected to resemble lrwxrwxrwx 1 root root 25 Apr 4 02:14 /usr/bin/emerge -> ../lib/portage/bin/emerge permissions and path are critical
AND
Code:
ls -l /usr/lib64/portage/bin/emerge

-rwxr-xr-x 1 root root 2278 Apr 4 02:14 /usr/lib64/portage/bin/emerge
Code:
ls -l /usr/lib/portage/bin/emerge

-rwxr-xr-x 1 root root 2278 Apr 4 02:14 /usr/lib/portage/bin/emerge
_________________
Defund the FCC.


Last edited by DONAHUE on Wed Sep 17, 2014 4:44 am; edited 1 time in total
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 268
Location: USA, California

PostPosted: Wed Sep 17, 2014 4:43 am    Post subject: Reply with quote

Is that what it is supposed to look like, or just what you where expecting, because of my "clear" and "nano" errors?
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7552
Location: Goose Creek SC

PostPosted: Wed Sep 17, 2014 4:46 am    Post subject: Reply with quote

what it should look like
note two more, same criteria
also critical owner group
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 268
Location: USA, California

PostPosted: Wed Sep 17, 2014 4:55 am    Post subject: Reply with quote

So, is that a bug then or just a corruption in those commands that are giving me problems?
Is it beyond help?
Oh... I missed your edit.

Code:
ls -l /usr/lib64/portage/bin/emerge

-rwxr-xr-x 1 root root 2278 Sep 10 2:27 /usr/lib64/portage/bin/emerge

Code:
ls -l /usr/lib/portage/bin/emerge

-rwxr-xr-x 1 root root 2278 Sep 10 2:27 /usr/lib/portage/bin/emerge
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7552
Location: Goose Creek SC

PostPosted: Wed Sep 17, 2014 5:08 am    Post subject: Reply with quote

try a simple command
Code:
nano /etc/fstab
look right?

you got
lrwxrwxrwx 1 root root 25 Apr 4 02:14 /usr/bin/emerge -> ../lib/portage/bin/emerge
doesn't matter
_________________
Defund the FCC.


Last edited by DONAHUE on Wed Sep 17, 2014 5:13 am; edited 1 time in total
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 268
Location: USA, California

PostPosted: Wed Sep 17, 2014 5:12 am    Post subject: Reply with quote

Same error as before
Code:
nano /etc/fstab

"Error opening terminal: linux."


Could this be a soulution?
http://www.terabyteunlimited.com/kb/article.php?id=454
Nope!


Last edited by Tefrem34 on Wed Sep 17, 2014 5:27 am; edited 1 time in total
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7552
Location: Goose Creek SC

PostPosted: Wed Sep 17, 2014 5:26 am    Post subject: Reply with quote

Code:
ls -l /usr/share/terminfo/
expect
Quote:
1 3 5 7 9 A c e f h j l m n o P Q s u w X
2 4 6 8 a b d E g i k L M N p q r t v x z
if not
Code:
emerge ncurses
but ?
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 268
Location: USA, California

PostPosted: Wed Sep 17, 2014 5:31 am    Post subject: Reply with quote

Code:
ls -l /usr/share/terminfo/

Quote:
total 8
drwxr-xr-x 2 root root 4096 Sep 16 22:29 l
drwxr-xr-x 2 root root 4096 Sep 16 22:31 x
because I just tried that link fix. :(

emerge will not get past the circular dependencies.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7552
Location: Goose Creek SC

PostPosted: Wed Sep 17, 2014 6:15 am    Post subject: Reply with quote

Hail Mary!

for linux terminal
Code:
ln -s /etc/terminfo/l/linux /usr/share/terminfo/l/linux
nano /etc/fstab


for x terminal
Code:
/etc/terminfo/x/xterm  /usr/share/terminfo/x/xterm
/etc/terminfo/x/xterm-color  /usr/share/terminfo/x/xterm-color
/etc/terminfo/x/xterm-xfree86  /usr/share/terminfo/x/xterm-xfree86
emerge -1 ncurses

_________________
Defund the FCC.
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 268
Location: USA, California

PostPosted: Wed Sep 17, 2014 6:53 am    Post subject: Reply with quote

no for the first one. :( "nano /etc/fstab" "Error opening terminal: linux
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 268
Location: USA, California

PostPosted: Wed Sep 17, 2014 6:07 pm    Post subject: Reply with quote

I really appreciate your help and persistence in trying to make this work for me.
But I am so frustrated with this that I think I am going to start over from scratch and re-install Gentoo tomorrow.
The things that I am worried about are the gcc or cflags and making sure that I have the right ones. Mainly, I can't understand/figure out which modules are the ones that I need in the /etc/conf.d/modules.
I will to use the make.conf guide that you shared, and I am sure that will help, as well as the other tips/instructions.
Thanks again! :D
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7552
Location: Goose Creek SC

PostPosted: Wed Sep 17, 2014 7:13 pm    Post subject: Reply with quote

Code:
emerge -C gpm
rc-update del gpm default
/etc/init.d/gpm stop
/etc/init.d/gpm zap
USE="-gpm" emerge -1 ncurses


Strange that I have used gpm on every system since 2006 and that the gpm use flag is in the profile.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 268
Location: USA, California

PostPosted: Wed Sep 17, 2014 10:32 pm    Post subject: Reply with quote

Well, I did a new install. I was able to get some things right this time. My native screen resolution in grub and in the tty1 is as it should be. Previously, it was huge and distorted. I have a working internet connection on boot. And, my bash commands, such as nano and clear, are working.

However, when I used
Code:
emerge --sync
and it did its thing, I was given a prompt to
Code:
emerge --oneshot portage
which then gave me the dreaded
Quote:
Error: circular dependencies: (sys-libs/ncurses-5.9-r3: :gentoo, ebuild scheduled for merge) depends on (sys-libs/gpm-1.20.7-r2: :gentoo, ebuild scheduled for merge) (buildtime) (sys-libs/ncurses-5.9-r3: :gentoo, ebuild scheduled for merge) (buildtime)
Could this command be contributing to my issue? Is there a way to regress to the previous portage image?

I noticed that the forum has been down quite a few times. Is it server issues, or just maintenance?

After I posted this I read your comment.
I did the first commands but gpm is not installed or on the system, so they did nothing. But the last command is running right now.
It is done. At the end of the message
Quote:
Package 'sys-libs/ncurses-5.9-r3' merged despite file collisions.

Should I try the
Code:
emerge -avuND world
now?
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7552
Location: Goose Creek SC

PostPosted: Wed Sep 17, 2014 10:53 pm    Post subject: Reply with quote

hammer it.
Code:
echo "sys-libs/ncurses -gpm"  >> /etc/portage/package.use
echo "sys-libs/gpm"  >> /etc/portage/package.mask
emerge -C gpm
emerge -1 ncurses

_________________
Defund the FCC.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7552
Location: Goose Creek SC

PostPosted: Wed Sep 17, 2014 10:57 pm    Post subject: Reply with quote

Code:
emerge portage
first, then
Code:
emerge -uNDav world


BTW: here I get
Quote:
emerge -av gpm ncurses

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] sys-libs/ncurses-5.9-r3:5 USE="cxx gpm unicode -ada -debug -doc -minimal -profile -static-libs -tinfo -trace" ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild R ] sys-libs/gpm-1.20.7-r2 USE="(-selinux) -static-libs" ABI_X86="(64) (-32) (-x32)" 0 kB

Total: 2 packages (2 reinstalls), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No]
I have a gnome profile; you have kde; I do not have a LINGUAS line in make.conf; other than gpm versus -gpm how do our use flags compare?
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 268
Location: USA, California

PostPosted: Wed Sep 17, 2014 11:41 pm    Post subject: Reply with quote

Okay...
I
Code:
emerge portage
still getting the same circular dependenceis error, but now I have a message below:
Quote:
The following mask changes are necessary to proceed: (see "package.umask" in the protage(5) man page for more details)
# required by www-client/links-2.8-r1[gpm,-livecd]
# required by x11-misc/xdg-utils-1.1.0_rc2
# required by net-print/cups-1.7.5[X]
# required by dev-qt/qtgui-4.8.5-r3[cups]
# required by dev-util/cmake-2.8.12.2-r1[qt4]
# required by media-gfx/graphite2-1.2.4-r1
# required by x11-libs/pango-1.36.5
# required by x11-libs/gtk+-3.12.2
# required by app-text/ghostscript-gpl-9.10-rZ[gtk]
# required by net-print/cups-filters-1.0.53
# /etc/portage/package.mask:
=sys-libs/gpm-1.20.7-r2


I will have to chroot into my system to wgetpaste if you need more.
Code:
nano -w /etc/portage/make.conf

Quote:
CFLAGS="-march=native -O2 -pipe"
CXXFLAGS=${CFLAGS}"
CHOST="x86_64-pc-linux-gnu"
MAKEOPTS="-j8"
LINGUAS="en_US en"
USE="mmx sse sse2"
INPUT_DEVICES="endev"
VIDEO_CARDS="nvidia"
PORTDIR="/usr/portage"
DISTDIR="${PORTDIR}/distfiles"
PKGDIR=${PORTDIR}/packages'
ACCEPT_LICENSE="* @EULA"

SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"

GENTOO_MIRRORS="http://gentoo.osuosl.org/"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Goto page Previous  1, 2, 3, 4, 5  Next
Page 2 of 5

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum