Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
fglrx drivers on a hybrid system, modprobe fails
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
justinh_tx
n00b
n00b


Joined: 19 Sep 2014
Posts: 2

PostPosted: Fri Sep 19, 2014 9:08 pm    Post subject: fglrx drivers on a hybrid system, modprobe fails Reply with quote

I'm trying to get a Gentoo desktop running on a Macmini5,2 (Core i5/AMD 6630M) and I'm having trouble getting the proprietary graphics driver to work. X works fine with the open radeon driver, but when I try to startx with fglrx I get:

modprobe: ERROR: could not insert 'fglrx': Exec format error

Xorg.0.log:
Code:
[  1359.218]
X.Org X Server 1.15.0
Release Date: 2013-12-27
[  1359.218] X Protocol Version 11, Revision 0
[  1359.218] Build Operating System: Linux 3.14.14-gentoo x86_64 Gentoo
[  1359.218] Current Operating System: Linux macmini 3.14.14-gentoo #2 SMP Mon Sep 8 00:33:06 CDT 2014 x86_64
[  1359.218] Kernel command line: root=/dev/sda4 \vmlinuz-3.14.14-gentoo
[  1359.218] Build Date: 09 September 2014  10:09:14AM
[  1359.218] 
[  1359.218] Current version of pixman: 0.32.4
[  1359.218]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[  1359.218] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  1359.218] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Sep 19 15:54:04 2014
[  1359.218] (==) Using config file: "/etc/X11/xorg.conf"
[  1359.218] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  1359.218] (==) ServerLayout "aticonfig Layout"
[  1359.218] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
[  1359.218] (**) |   |-->Monitor "aticonfig-Monitor[0]-0"
[  1359.218] (**) |   |-->Device "aticonfig-Device[0]-0"
[  1359.218] (==) Automatically adding devices
[  1359.218] (==) Automatically enabling devices
[  1359.218] (==) Automatically adding GPU devices
[  1359.218] (==) FontPath set to:
   /usr/share/fonts/misc/,
   /usr/share/fonts/TTF/,
   /usr/share/fonts/OTF/,
   /usr/share/fonts/Type1/,
   /usr/share/fonts/100dpi/,
   /usr/share/fonts/75dpi/
[  1359.218] (==) ModulePath set to "/usr/lib64/xorg/modules"
[  1359.218] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[  1359.219] (II) Loader magic: 0x807c60
[  1359.219] (II) Module ABI versions:
[  1359.219]    X.Org ANSI C Emulation: 0.4
[  1359.219]    X.Org Video Driver: 15.0
[  1359.219]    X.Org XInput driver : 20.0
[  1359.219]    X.Org Server Extension : 8.0
[  1359.219] (II) xfree86: Adding drm device (/dev/dri/card0)
[  1359.220] (--) PCI: (0:0:2:0) 8086:0126:106b:00f0 rev 9, Mem @ 0xa8000000/4194304, 0xa0000000/134217728, I/O @ 0x00003000/64
[  1359.220] (--) PCI:*(0:1:0:0) 1002:6741:106b:00e8 rev 0, Mem @ 0x90000000/268435456, 0xa8800000/131072, I/O @ 0x00002000/256, BIOS @ 0x????????/131072
[  1359.220] Initializing built-in extension Generic Event Extension
[  1359.220] Initializing built-in extension SHAPE
[  1359.220] Initializing built-in extension MIT-SHM
[  1359.220] Initializing built-in extension XInputExtension
[  1359.220] Initializing built-in extension XTEST
[  1359.220] Initializing built-in extension BIG-REQUESTS
[  1359.220] Initializing built-in extension SYNC
[  1359.220] Initializing built-in extension XKEYBOARD
[  1359.220] Initializing built-in extension XC-MISC
[  1359.220] Initializing built-in extension XINERAMA
[  1359.220] Initializing built-in extension XFIXES
[  1359.220] Initializing built-in extension RENDER
[  1359.220] Initializing built-in extension RANDR
[  1359.221] Initializing built-in extension COMPOSITE
[  1359.221] Initializing built-in extension DAMAGE
[  1359.221] Initializing built-in extension MIT-SCREEN-SAVER
[  1359.221] Initializing built-in extension DOUBLE-BUFFER
[  1359.221] Initializing built-in extension RECORD
[  1359.221] Initializing built-in extension DPMS
[  1359.221] Initializing built-in extension Present
[  1359.221] Initializing built-in extension DRI3
[  1359.221] Initializing built-in extension X-Resource
[  1359.221] Initializing built-in extension XVideo
[  1359.221] Initializing built-in extension XVideo-MotionCompensation
[  1359.221] Initializing built-in extension XFree86-VidModeExtension
[  1359.221] Initializing built-in extension XFree86-DGA
[  1359.221] Initializing built-in extension XFree86-DRI
[  1359.221] Initializing built-in extension DRI2
[  1359.221] (II) "glx" will be loaded by default.
[  1359.221] (II) LoadModule: "glx"
[  1359.221] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[  1359.221] (II) Module glx: vendor="Advanced Micro Devices, Inc."
[  1359.221]    compiled for 6.9.0, module version = 1.0.0
[  1359.221] Loading extension GLX
[  1359.221] (II) LoadModule: "fglrx"
[  1359.221] (II) Loading /usr/lib64/xorg/modules/drivers/fglrx_drv.so
[  1359.235] (II) Module fglrx: vendor="FireGL - AMD Technologies Inc."
[  1359.235]    compiled for 1.4.99.906, module version = 14.20.7
[  1359.235]    Module class: X.Org Video Driver
[  1359.235] (II) Loading sub module "fglrxdrm"
[  1359.235] (II) LoadModule: "fglrxdrm"
[  1359.235] (II) Loading /usr/lib64/xorg/modules/linux/libfglrxdrm.so
[  1359.236] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[  1359.236]    compiled for 1.4.99.906, module version = 14.20.7
[  1359.236] (II) AMD Proprietary Linux Driver Version Identifier:14.20.7
[  1359.236] (II) AMD Proprietary Linux Driver Release Identifier: UNSUPPORTED-14.20                   
[  1359.236] (II) AMD Proprietary Linux Driver Build Date: May 29 2014 10:25:55
[  1359.236] (--) using VT number 7

[  1359.240] (WW) Falling back to old probe method for fglrx
[  1359.249] (II) Loading PCS database from /etc/ati/amdpcsdb /etc/ati/amdpcsdb.default
[  1359.253] ukiDynamicMajor: failed to open /proc/ati/major
[  1359.253] ukiDynamicMajor: failed to open /proc/ati/major
[  1359.255] (--) Chipset Supported AMD Graphics Processor (0x6741) found
[  1359.255] (WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found
[  1359.255] (II) fglrx(0): pEnt->device->identifier=0xc6b1a0
[  1359.256] (II) fglrx(0): === [xdl_xs115_atiddxPreInit] === begin
[  1359.256] (II) Loading sub module "vgahw"
[  1359.256] (II) LoadModule: "vgahw"
[  1359.256] (II) Loading /usr/lib64/xorg/modules/libvgahw.so
[  1359.256] (II) Module vgahw: vendor="X.Org Foundation"
[  1359.256]    compiled for 1.15.0, module version = 0.1.0
[  1359.256]    ABI class: X.Org Video Driver, version 15.0
[  1359.257] (**) fglrx(0): Depth 24, (--) framebuffer bpp 32
[  1359.257] (II) fglrx(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
[  1359.257] (==) fglrx(0): Default visual is TrueColor
[  1359.257] (**) fglrx(0): Option "DPMS" "true"
[  1359.257] (==) fglrx(0): RGB weight 888
[  1359.257] (II) fglrx(0): Using 8 bits per RGB
[  1359.257] (==) fglrx(0): Buffer Tiling is ON
[  1359.257] (II) Loading sub module "fglrxdrm"
[  1359.257] (II) LoadModule: "fglrxdrm"
[  1359.257] (II) Loading /usr/lib64/xorg/modules/linux/libfglrxdrm.so
[  1359.257] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[  1359.257]    compiled for 1.4.99.906, module version = 14.20.7
[  1359.261] ukiDynamicMajor: failed to open /proc/ati/major
[  1359.261] ukiDynamicMajor: failed to open /proc/ati/major
[  1359.261] (**) fglrx(0): NoAccel = NO
[  1359.261] (**) fglrx(0): AMD 2D Acceleration Architecture enabled
[  1359.261] (--) fglrx(0): Chipset: "AMD Radeon 6600M and 6700M Series" (Chipset = 0x6741)
[  1359.261] (--) fglrx(0): (PciSubVendor = 0x106b, PciSubDevice = 0x00e8)
[  1359.261] (==) fglrx(0): board vendor info: third party graphics adapter - NOT original AMD
[  1359.261] (--) fglrx(0): Linear framebuffer (phys) at 0x90000000
[  1359.261] (--) fglrx(0): MMIO registers at 0xa8800000
[  1359.261] (--) fglrx(0): I/O port at 0x00002000
[  1359.261] (==) fglrx(0): ROM-BIOS at 0x000c0000
[  1359.263] (EE) fglrx(0): V_BIOS address 0x43420 out of range
[  1359.263] (II) fglrx(0): Invalid ATI BIOS from int10, the adapter is not VGA-enabled
[  1359.263] (EE) fglrx(0): Invalid video BIOS signature!
[  1359.263] (EE) fglrx(0): GetBIOSParameter failed
[  1359.263] (EE) fglrx(0): PreInitAdapter failed
[  1359.263] (EE) fglrx(0): PreInit failed
[  1359.263] (II) fglrx(0): === [xdl_xs115_atiddxPreInit] === end
[  1359.265] (II) UnloadModule: "fglrx"
[  1359.265] (II) UnloadSubModule: "fglrxdrm"
[  1359.265] (II) Unloading fglrxdrm
[  1359.265] (II) UnloadSubModule: "vgahw"
[  1359.265] (II) Unloading vgahw
[  1359.265] (II) UnloadSubModule: "fglrxdrm"
[  1359.265] (EE) Screen(s) found, but none have a usable configuration.
[  1359.265] (EE)
Fatal server error:
[  1359.265] (EE) no screens found(EE)
[  1359.265] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[  1359.265] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  1359.265] (EE)
[  1359.274] (EE) Server terminated with error (1). Closing log file.


This line seems to be saying something too:
[ 1359.263] (II) fglrx(0): Invalid ATI BIOS from int10, the adapter is not VGA-enabled

This was after running 'aticonfig --px-dgpu' so I think it should be using the discrete card.

Is this just a case of driver version/kernel version incompatibility? The AMD website does mention that the beta drivers are only supposed to work up to kernel 3.13. I'm on 3.14.14 and am using x11-drivers/ati-drivers-14.6_beta2, although I was not having any luck with the stable drivers either.

Any help would be greatly appreciated.
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Sat Sep 20, 2014 6:59 pm    Post subject: Reply with quote

Quote:
s this just a case of driver version/kernel version incompatibility? The AMD website does mention that the beta drivers are only supposed to work up to kernel 3.13. I'm on 3.14.14 and am using x11-drivers/ati-drivers-14.6_beta2, although I was not having any luck with the stable drivers either.


well thats usual for binary drivers. version of gpu has to fit xorg-server has to fit kernel !! thats essential. first step is amd to check what they recommend.

you also check gentoo wiki about how to configure your gpu, there is one for nvidia, there should be one for amd too.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum