Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Help me with GTX 480 & nouveau, please!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Kollin
Veteran
Veteran


Joined: 25 Feb 2006
Posts: 1137
Location: Sofia/Bulgaria

PostPosted: Sat Sep 20, 2014 11:37 am    Post subject: Help me with GTX 480 & nouveau, please! Reply with quote

Hello,
I recently upgraded my system with gtx 480. I'm using nouveau (compiled in kernel with kms and msi enabled in grub.cfg) and i want to keep it that way.

Code:
0b:00.0 VGA compatible controller: NVIDIA Corporation GF100 [GeForce GTX 480] (rev a3) (prog-if 00 [VGA controller])
        Subsystem: ASUSTeK Computer Inc. Device 8349
        Flags: bus master, fast devsel, latency 0, IRQ 46
        Memory at f8000000 (32-bit, non-prefetchable) [size=32M]
        Memory at d8000000 (64-bit, prefetchable) [size=128M]
        Memory at e4000000 (64-bit, prefetchable) [size=64M]
        I/O ports at 9c00 [size=128]
        Expansion ROM at fbf00000 [disabled] [size=512K]
        Capabilities: [60] Power Management version 3
        Capabilities: [68] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [78] Express Endpoint, MSI 00
        Capabilities: [b4] Vendor Specific Information: Len=14 <?>
        Capabilities: [100] Virtual Channel
        Capabilities: [128] Power Budgeting <?>
        Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
        Kernel driver in use: nouveau
        Kernel modules: nvidia


Console (framebuffer) is ok no problem there, kdm login screen is ok but when time comes kwin to take over, picture freezes on the last image of kdm splash screen(but the hard drive and system sounds are showing me that kde is still loading - only the picture freezes). ctl+alt+f1 works but very slooowly - takes 10-15 sec. to switch.
The only way to see kde is to login in failsafe mode or with opengl disabled (xrender enabled in system settings), and still there are artifacts like those:
http://img.photobucket.com/albums/v623/Kollin/Public/kdm0_zpse4a724de.png
http://img.photobucket.com/albums/v623/Kollin/Public/kdm1_zpsf7fea4fa.png

dmesg:
http://pastebin.com/raw.php?i=tnJJcSeu

Xorg.0.log:
http://pastebin.com/raw.php?i=fiaMn90M

eselect mesa list:
Code:

64bit i915 (Intel 915, 945)
64bit i965 (Intel GMA 965, G/Q3x, G/Q4x, HD)
64bit r300 (Radeon R300-R500)
64bit r600 (Radeon R600-R700, Evergreen, Northern Islands)
64bit sw (Software renderer)
  [1]   classic
  [2]   gallium *
32bit i915 (Intel 915, 945)
  [1]   classic
  [2]   gallium *
32bit i965 (Intel GMA 965, G/Q3x, G/Q4x, HD)
  [1]   classic *
32bit r300 (Radeon R300-R500)
  [1]   gallium *
32bit r600 (Radeon R600-R700, Evergreen, Northern Islands)
  [1]   gallium *
32bit sw (Software renderer)
  [1]   classic
  [2]   gallium *


eselect opengl list
Code:

Available OpenGL implementations:
  [1]   xorg-x11 *


nvidia-drivers are removed and blacklisted.
Currently there is no xorg.conf.
_________________
"Dear Enemy: may the Lord hate you and all your kind, may you be turned orange in hue, and may your head fall off at an awkward moment."
"Linux is like a wigwam - no windows, no gates, apache inside..."


Last edited by Kollin on Sat Sep 20, 2014 5:13 pm; edited 1 time in total
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Sat Sep 20, 2014 4:05 pm    Post subject: Reply with quote

Please add the word noveau to your title of this topic, thanks

off topic: i am pretty sure your hardware runs with nvidia-drivers, but i never hassled with open source as the features are limited as i checked a year ago.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43195
Location: 56N 3W

PostPosted: Sat Sep 20, 2014 4:25 pm    Post subject: Reply with quote

Kollin,

Code:
        Kernel driver in use: nouveau
        Kernel modules: nvidia
suggesnts that you have both nouveau and the nVida binaly blob installed.
You really don't want to do that.

What does your /var/log/Xorg.0.log show?
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Kollin
Veteran
Veteran


Joined: 25 Feb 2006
Posts: 1137
Location: Sofia/Bulgaria

PostPosted: Sat Sep 20, 2014 4:41 pm    Post subject: Reply with quote

NeddySeagoon wrote:
Kollin,

Code:
        Kernel driver in use: nouveau
        Kernel modules: nvidia
suggesnts that you have both nouveau and the nVida binaly blob installed.
You really don't want to do that.

What does your /var/log/Xorg.0.log show?


xorg.0.log is attached in my first post (pastebin), thank you! ;)
_________________
"Dear Enemy: may the Lord hate you and all your kind, may you be turned orange in hue, and may your head fall off at an awkward moment."
"Linux is like a wigwam - no windows, no gates, apache inside..."
Back to top
View user's profile Send private message
Kollin
Veteran
Veteran


Joined: 25 Feb 2006
Posts: 1137
Location: Sofia/Bulgaria

PostPosted: Sat Sep 20, 2014 4:52 pm    Post subject: Reply with quote

lsmod
Code:
~ # lsmod
Module                  Size  Used by
bnep                   10517  2
vboxpci                11832  0
vboxnetflt             15384  0
vboxnetadp             17680  0
vboxdrv               335705  3 vboxnetadp,vboxnetflt,vboxpci
rt2800usb              16295  0
rt2x00usb              10766  1 rt2800usb
rt2800lib              75555  1 rt2800usb
rt2x00lib              41302  3 rt2x00usb,rt2800lib,rt2800usb
crc_ccitt               1557  1 rt2800lib
usbnet                 23993  0
mii                     4647  1 usbnet
snd_hda_codec_analog    10169  1
snd_hda_codec_generic    53435  1 snd_hda_codec_analog
snd_hda_codec_hdmi     36912  4
snd_hda_intel          20605  0
snd_hda_controller     17668  1 snd_hda_intel
snd_hda_codec         107505  5 snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_intel,snd_hda_controller,
snd_hda_codec_analog
snd_hwdep               6410  1 snd_hda_codec
snd_pcm                88291  4 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_controller
k8temp                  3822  0
i2c_nforce2             5219  0
snd_timer              19835  1 snd_pcm
snd                    65928  8 snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_hda_codec_generic,snd_h
da_codec,snd_hda_intel,snd_hda_codec_analog
soundcore               6435  2 snd,snd_hda_codec

_________________
"Dear Enemy: may the Lord hate you and all your kind, may you be turned orange in hue, and may your head fall off at an awkward moment."
"Linux is like a wigwam - no windows, no gates, apache inside..."
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Sat Sep 20, 2014 7:15 pm    Post subject: Reply with quote

do you have video cars set in your /etc/make.conf to noveau and removed nvidia there?
eselect set to nouveau too?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43195
Location: 56N 3W

PostPosted: Sat Sep 20, 2014 7:54 pm    Post subject: Reply with quote

Kollin,

Sorry for missing your link.
That all looks good. Xorg is using nouveau and nvidia is not listed in lsmod.

-- Edit --

Hmm dmesg is not so good.
Code:
[    0.241006] NO_HZ FULL will not work with unstable sched clock
It looks like the kernel took evasive action, so it may not be related to your problem.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Kollin
Veteran
Veteran


Joined: 25 Feb 2006
Posts: 1137
Location: Sofia/Bulgaria

PostPosted: Sun Sep 21, 2014 6:32 am    Post subject: Reply with quote

:arrow: And now, after running for a while, dmesg is full of those errors:

Code:
[31881.673008] nouveau E[X[25524]] failed to idle channel 0
xcccc0000 [X[25524]]
[31896.673009] nouveau E[X[25524]] failed to idle channel 0
xcccc0000 [X[25524]]
[31896.673363] nouveau E[   PFIFO][0000:0b:00.0] SCHED_ERRO
R [ UNK0d ]
[31898.673403] nouveau E[   PFIFO][0000:0b:00.0] channel 2
[X[25524]] kick timeout
[31898.673436] nouveau E[   PFIFO][0000:0b:00.0] SCHED_ERRO
R [ UNK0d ]
[31900.673013] nouveau E[   PFIFO][0000:0b:00.0] runlist up
date timeout
[31900.673026] nouveau W[   PFIFO][0000:0b:00.0] INTR 0x000
00001: 0x00000003
[31900.826812] nouveau E[   PFIFO][0000:0b:00.0] SCHED_ERRO
R [ UNK0d ]
[31902.826015] nouveau E[   PFIFO][0000:0b:00.0] runlist up
date timeout
[31902.845548] nouveau E[   PFIFO][0000:0b:00.0] SCHED_ERRO
R [ UNK0d ]
[31904.845015] nouveau E[   PFIFO][0000:0b:00.0] runlist up
date timeout
[31921.857558] nouveau E[   PDISP][0000:0b:00.0] INVALID_HA
NDLE [] chid 1 mthd 0x0094 data 0xcafe0000
[31984.321766] nouveau E[   PDISP][0000:0b:00.0] INVALID_HA
NDLE [] chid 1 mthd 0x0094 data 0xcafe0000
[31999.343015] nouveau E[X[25571]] failed to idle channel 0
xcccc0001 [X[25571]]
[32014.343012] nouveau E[X[25571]] failed to idle channel 0
xcccc0001 [X[25571]]
[32016.343149] nouveau E[   PFIFO][0000:0b:00.0] channel 3
[X[25571]] kick timeout
[32016.343177] nouveau E[   PFIFO][0000:0b:00.0] SCHED_ERRO
R [ UNK0d ]
[32018.343022] nouveau E[   PFIFO][0000:0b:00.0] runlist up
date timeout
[32033.343018] nouveau E[X[25571]] failed to idle channel 0
xcccc0000 [X[25571]]
[32048.343014] nouveau E[X[25571]] failed to idle channel 0
xcccc0000 [X[25571]]
[32048.343351] nouveau E[   PFIFO][0000:0b:00.0] SCHED_ERRO
R [ UNK0d ]
[32050.343409] nouveau E[   PFIFO][0000:0b:00.0] channel 2
[X[25571]] kick timeout
[32050.343433] nouveau E[   PFIFO][0000:0b:00.0] SCHED_ERRO
R [ UNK0d ]
[32052.343022] nouveau E[   PFIFO][0000:0b:00.0] runlist up
date timeout
[32052.343031] nouveau W[   PFIFO][0000:0b:00.0] INTR 0x000
00001: 0x00000003


Xorg.0.log:
Code:

[ 31967.310] nouveau_exa_upload_to_screen:384 - falling bac
k to memcpy ignores tiling
[ 31982.310] nouveau_exa_upload_to_screen:384 - falling bac
k to memcpy ignores tiling
[ 31982.310] nouveau_exa_upload_to_screen:384 - falling bac
k to memcpy ignores tiling
[ 31982.310] nouveau_exa_upload_to_screen:384 - falling bac
k to memcpy ignores tiling
[ 31982.310] nouveau_exa_download_from_screen:299 - falling
back to memcpy ignores tiling
[ 31982.310] (EE)
[ 31982.310] (EE) Backtrace:
[ 31982.310] (EE) 0: /usr/bin/X (xorg_backtrace+0x48) [0x59
4db8]
[ 31982.310] (EE) 1: /usr/bin/X (0x400000+0x198c49) [0x598c
49]
[ 31982.310] (EE) 2: /lib64/libpthread.so.0 (0x7f635a9d1000
+0x10230) [0x7f635a9e1230]
[ 31982.310] (EE) 3: /lib64/libc.so.6 (0x7f6359619000+0x917
c0) [0x7f63596aa7c0]
[ 31982.310] (EE) 4: /usr/lib64/xorg/modules/libexa.so (0x7
f635605f000+0x5676) [0x7f6356064676]
[ 31982.310] (EE) 5: /usr/lib64/xorg/modules/libexa.so (0x7
f635605f000+0x5b1b) [0x7f6356064b1b]
[ 31982.310] (EE) 6: /usr/lib64/xorg/modules/libexa.so (0x7
f635605f000+0x829d) [0x7f635606729d]
[ 31982.310] (EE) 7: /usr/lib64/xorg/modules/libexa.so (0x7
f635605f000+0x122ca) [0x7f63560712ca]
[ 31982.310] (EE) 8: /usr/lib64/xorg/modules/libexa.so (0x7
f635605f000+0xecd6) [0x7f635606dcd6]
[ 31982.310] (EE) 9: /usr/bin/X (0x400000+0x11bd91) [0x51bd
91]
[ 31982.310] (EE) 10: /usr/bin/X (0x400000+0x111b4a) [0x511
b4a]
[ 31982.311] (EE) 11: /usr/bin/X (0x400000+0x3656e) [0x4365
6e]
[ 31982.311] (EE) 12: /usr/bin/X (0x400000+0x3a6ba) [0x43a6

@tw4|124 Yes videocatds line in make.conf is set to nouveau and eslect is using xorg!
Code:
felis ~ #  eselect opengl list
Available OpenGL implementations:
[1]   xorg-x11 *

There is no nouveau opengl target for eselect. ;)
_________________
"Dear Enemy: may the Lord hate you and all your kind, may you be turned orange in hue, and may your head fall off at an awkward moment."
"Linux is like a wigwam - no windows, no gates, apache inside..."
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43195
Location: 56N 3W

PostPosted: Sun Sep 21, 2014 10:54 am    Post subject: Reply with quote

Kollin,

Maybe that is related to your kernel issue above. Rebuild your kernel without the NO_HZ FULL option.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Sun Sep 21, 2014 10:54 am    Post subject: Reply with quote

Nouveau is not only buggy but also a changing target.

So, I highly suggest you to report this to either the nouveau mailing lists. It could be both a kernel bug and / or a bug in the drivers. In my experience, also, half of the bugs go away if you USE="-vdpau" and recompile everything that needs to be recompiled, but that might not apply to you, I don't know.

That, of course, means your cpu will be busier.

Also, there's no need to be *that* paranoid about nvidia being installed alongside. They both can perfectly coexist, you just need to blacklist either module, and make sure that xorg.conf and eselect opengl matches with whatever module you are using at the moment. Nothing else.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Sun Sep 21, 2014 12:02 pm    Post subject: Reply with quote

Hi, how do you blacklist a module?
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Sun Sep 21, 2014 1:19 pm    Post subject: Reply with quote

You just put lines like this in /etc/modprobe.d

Code:
blacklist nvidia
#blacklist nouveau


Then you comment/uncomment one or the other. Just like in sh scripts, the '#' character at the beginning of a given line means that line is a comment and not to be interpreted.

If /etc/modprobe.d/ is a directory (it is in gentoo) then you can add the lines in any file inside that directory. If you installed the nvidia driver you probably have a file called nvidia.conf or something like that in there, so you can put those lines inside that file.

EDITED: of course, all the above assumes you compiled nouveau as module. Else, nvidia won't work even if you blacklist nouveau for abvoius reasons.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Kollin
Veteran
Veteran


Joined: 25 Feb 2006
Posts: 1137
Location: Sofia/Bulgaria

PostPosted: Tue Sep 23, 2014 8:48 am    Post subject: Reply with quote

Quote:
dmesg | grep -i nvrm
[ 10.143177] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 343.13 Thu Jul 31 19:06:44 PDT 2014
[ 17.725001] NVRM: GPU at PCI:0000:0b:00: GPU-748c7215-0e11-303d-468b-b98459f038ea
[ 17.725017] NVRM: Xid (PCI:0000:0b:00): 44, Ch 00000000, engmask 00000101, intr 10000000
[ 33.723849] NVRM: GPU at PCI:0000:0b:00: GPU-748c7215-0e11-303d-468b-b98459f038ea
[ 33.723856] NVRM: Xid (PCI:0000:0b:00): 44, Ch 00000000, engmask 00000101, intr 10000000
[ 41.742052] NVRM: Xid (PCI:0000:0b:00): 8, Channel 00000001
[ 44.244528] NVRM: os_schedule: Attempted to yield the CPU while in atomic or interrupt context
[ 345.913166] NVRM: GPU at PCI:0000:0b:00: GPU-748c7215-0e11-303d-468b-b98459f038ea
[ 345.913173] NVRM: Xid (PCI:0000:0b:00): 44, Ch 00000000, engmask 00000101, intr 10000000
[ 353.930051] NVRM: Xid (PCI:0000:0b:00): 8, Channel 00000001
[ 356.432510] NVRM: os_schedule: Attempted to yield the CPU while in atomic or interrupt context
[25670.867841] NVRM: GPU at PCI:0000:0b:00: GPU-748c7215-0e11-303d-468b-b98459f038ea
[25670.867849] NVRM: Xid (PCI:0000:0b:00): 44, Ch 00000000, engmask 00000101, intr 10000000
[25807.925823] NVRM: GPU at PCI:0000:0b:00: GPU-748c7215-0e11-303d-468b-b98459f038ea
[25807.925832] NVRM: Xid (PCI:0000:0b:00): 44, Ch 00000000, engmask 00000101, intr 10000000
[25855.595938] NVRM: GPU at PCI:0000:0b:00: GPU-748c7215-0e11-303d-468b-b98459f038ea
[25855.595944] NVRM: Xid (PCI:0000:0b:00): 44, Ch 00000000, engmask 00000101, intr 10000000
[26155.538146] NVRM: GPU at PCI:0000:0b:00: GPU-748c7215-0e11-303d-468b-b98459f038ea
[26155.538155] NVRM: Xid (PCI:0000:0b:00): 44, Ch 00000000, engmask 00000101, intr 10000000


Installed nvidia-drivers and got the beauty from above...My conclusion is faulty hrdware.
What do you think?
_________________
"Dear Enemy: may the Lord hate you and all your kind, may you be turned orange in hue, and may your head fall off at an awkward moment."
"Linux is like a wigwam - no windows, no gates, apache inside..."
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Tue Sep 23, 2014 8:55 am    Post subject: Reply with quote

Ugh, seen that before.

It's hard to say if it's quirky hardware or a problem with the drivers. I'd say probably a combination of both, this is to be expected from time to time with nVidia cards in Linux unfortunately, and there's not much you can do about it, other than trying different kernels and driver versions and hope that any arbitrary combo will work for the time being.

That is, unless someone who knows better has another idea :cry:
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Kollin
Veteran
Veteran


Joined: 25 Feb 2006
Posts: 1137
Location: Sofia/Bulgaria

PostPosted: Tue Sep 23, 2014 11:42 am    Post subject: Reply with quote

Thank you!
_________________
"Dear Enemy: may the Lord hate you and all your kind, may you be turned orange in hue, and may your head fall off at an awkward moment."
"Linux is like a wigwam - no windows, no gates, apache inside..."
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3947
Location: Dallas area

PostPosted: Tue Sep 23, 2014 11:50 am    Post subject: Reply with quote

If you google that "yeild" message, you'll see lots of people having problems.
In some cases it was hardware, but in other cases it seems to have been the drivers or some interaction between drivers and kernel.
_________________
Asus m5a99fx, FX 8320 - nouveau, oss4, rx550 for qemu passthrough
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
5.0.13 zen kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum