Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201409-10 ] Bash: Code Injection (Updated fix for GLSA 201409-09)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2226

PostPosted: Thu Sep 25, 2014 4:26 pm    Post subject: [ GLSA 201409-10 ] Bash: Code Injection (Updated fix for GLS Reply with quote

Gentoo Linux Security Advisory

Title: Bash: Code Injection (Updated fix for GLSA 201409-09) (GLSA 201409-10)
Severity: high
Exploitable: local, remote
Date: September 25, 2014
Updated: October 04, 2014
Bug(s): #523592
ID: 201409-10

Synopsis

A parsing flaw related to functions and environments in Bash could
allow attackers to inject code. The unaffected packages listed in GLSA
201409-09 had an incomplete fix.


Background

Bash is the standard GNU Bourne Again SHell.

Affected Packages

Package: app-shells/bash
Vulnerable: < 4.2_p48-r1
Unaffected: >= 3.1_p18-r1 < 3.2
Unaffected: >= 3.2_p52-r1 < 3.3
Unaffected: >= 4.0_p39-r1 < 4.1
Unaffected: >= 4.1_p12-r1 < 4.2
Unaffected: >= 4.2_p48-r1
Architectures: All supported architectures


Description

Stephane Chazelas reported that Bash incorrectly handles function
definitions, allowing attackers to inject arbitrary code (CVE-2014-6271).
Gentoo Linux informed about this issue in GLSA 201409-09.
Tavis Ormandy reported that the patch for CVE-2014-6271 was incomplete.
As such, this GLSA supersedes GLSA 201409-09.


Impact

A remote attacker could exploit this vulnerability to execute arbitrary
commands even in restricted environments.


Workaround

There is no known workaround at this time.

Resolution

All Bash 3.1 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=app-shells/bash-3.1_p18-r1:3.1"
   
All Bash 3.2 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=app-shells/bash-3.2_p52-r1:3.2"
   
All Bash 4.0 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=app-shells/bash-4.0_p39-r1:4.0"
   
All Bash 4.1 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=app-shells/bash-4.1_p12-r1:4.1"
   
All Bash 4.2 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=app-shells/bash-4.2_p48-r1"
   


References

CVE-2014-7169


Last edited by GLSA on Sun Oct 05, 2014 4:34 am; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum