Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No Direct Rendering with Nvidia GTX 970 [Solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
PhoenixKnight
n00b
n00b


Joined: 09 Sep 2008
Posts: 18
Location: Chicago

PostPosted: Fri Sep 26, 2014 7:26 am    Post subject: No Direct Rendering with Nvidia GTX 970 [Solved] Reply with quote

I just installed an Nvidia GTX 970, but I've been unable to get Direct Rendering to work.
Code:
adam@gentoobox ~ $ glxinfo | grep rendering
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)


I'm using the latest nvidia-drivers
Code:
adam@gentoobox ~ $ eix nvidia-drivers
[I] x11-drivers/nvidia-drivers
     Available versions:  96.43.23^msd 173.14.39^msd 304.123^msd 331.89^msd 334.21-r3^msd 337.25^msd 340.32-r1^msd (~)343.13-r1^msd (~)343.22^msd (~)343.22-r2^msd {+X acpi custom-cflags gtk multilib pax_kernel (+)tools uvm KERNEL="FreeBSD linux"}
     Installed versions:  343.22-r2^msd(01:41:55 09/26/14)(X acpi multilib tools -pax_kernel -uvm KERNEL="linux -FreeBSD")
     Homepage:            http://www.nvidia.com/
     Description:         NVIDIA Accelerated Graphics Driver


Here is my xorg.conf file:
Quote:
Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib64/xorg/modules"
FontPath "/usr/share/fonts/misc/"
FontPath "/usr/share/fonts/TTF/"
FontPath "/usr/share/fonts/OTF/"
FontPath "/usr/share/fonts/Type1/"
FontPath "/usr/share/fonts/100dpi/"
FontPath "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
Load "glx"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
EndSection

Section "Device"
Identifier "Card0"
Driver "nvidia"
BusID "PCI:3:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection


And here is the output of /var/log/Xorg.0.log

Quote:
[ 17.413]
X.Org X Server 1.14.5
Release Date: 2013-12-12
[ 17.413] X Protocol Version 11, Revision 0
[ 17.413] Build Operating System: Linux 3.14.3-ck x86_64 Gentoo
[ 17.413] Current Operating System: Linux gentoobox 3.14.3-ck #20 SMP PREEMPT Fri Sep 26 01:36:25 CDT 2014 x86_64
[ 17.413] Kernel command line: root=/dev/ram0 real_root=/dev/mapper/vg_system-lv_root
[ 17.413] Build Date: 21 May 2014 07:31:19PM
[ 17.413]
[ 17.413] Current version of pixman: 0.32.4
[ 17.413] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 17.413] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 17.413] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Sep 26 01:44:06 2014
[ 17.415] (==) Using config file: "/etc/X11/xorg.conf"
[ 17.415] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 17.416] (==) ServerLayout "X.org Configured"
[ 17.416] (**) |-->Screen "Screen0" (0)
[ 17.416] (**) | |-->Monitor "Monitor0"
[ 17.416] (**) | |-->Device "Card0"
[ 17.416] (**) |-->Input Device "Mouse0"
[ 17.416] (**) |-->Input Device "Keyboard0"
[ 17.416] (==) Automatically adding devices
[ 17.416] (==) Automatically enabling devices
[ 17.416] (==) Automatically adding GPU devices
[ 17.418] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[ 17.418] Entry deleted from font path.
[ 17.418] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[ 17.418] Entry deleted from font path.
[ 17.418] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[ 17.418] Entry deleted from font path.
[ 17.419] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[ 17.419] Entry deleted from font path.
[ 17.419] (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[ 17.419] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[ 17.419] Entry deleted from font path.
[ 17.419] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[ 17.419] Entry deleted from font path.
[ 17.419] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[ 17.419] Entry deleted from font path.
[ 17.419] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[ 17.419] Entry deleted from font path.
[ 17.419] (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[ 17.419] (**) FontPath set to:
/usr/share/fonts/misc/,
/usr/share/fonts/100dpi/,
/usr/share/fonts/misc/,
/usr/share/fonts/100dpi/
[ 17.419] (**) ModulePath set to "/usr/lib64/xorg/modules"
[ 17.419] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[ 17.419] (WW) Disabling Mouse0
[ 17.419] (WW) Disabling Keyboard0
[ 17.419] (II) Loader magic: 0x7febe0
[ 17.419] (II) Module ABI versions:
[ 17.419] X.Org ANSI C Emulation: 0.4
[ 17.419] X.Org Video Driver: 14.1
[ 17.419] X.Org XInput driver : 19.1
[ 17.419] X.Org Server Extension : 7.0
[ 17.420] (--) PCI:*(0:3:0:0) 10de:13c2:3842:0972 rev 161, Mem @ 0xfa000000/16777216, 0xd0000000/268435456, 0xce000000/33554432, I/O @ 0x0000bc00/128, BIOS @ 0x????????/524288
[ 17.421] Initializing built-in extension Generic Event Extension
[ 17.421] Initializing built-in extension SHAPE
[ 17.421] Initializing built-in extension MIT-SHM
[ 17.421] Initializing built-in extension XInputExtension
[ 17.421] Initializing built-in extension XTEST
[ 17.421] Initializing built-in extension BIG-REQUESTS
[ 17.421] Initializing built-in extension SYNC
[ 17.421] Initializing built-in extension XKEYBOARD
[ 17.421] Initializing built-in extension XC-MISC
[ 17.421] Initializing built-in extension XINERAMA
[ 17.421] Initializing built-in extension XFIXES
[ 17.421] Initializing built-in extension RENDER
[ 17.421] Initializing built-in extension RANDR
[ 17.421] Initializing built-in extension COMPOSITE
[ 17.421] Initializing built-in extension DAMAGE
[ 17.421] Initializing built-in extension MIT-SCREEN-SAVER
[ 17.421] Initializing built-in extension DOUBLE-BUFFER
[ 17.421] Initializing built-in extension RECORD
[ 17.421] Initializing built-in extension DPMS
[ 17.421] Initializing built-in extension X-Resource
[ 17.421] Initializing built-in extension XVideo
[ 17.421] Initializing built-in extension XVideo-MotionCompensation
[ 17.421] Initializing built-in extension XFree86-VidModeExtension
[ 17.421] Initializing built-in extension XFree86-DGA
[ 17.421] Initializing built-in extension XFree86-DRI
[ 17.421] Initializing built-in extension DRI2
[ 17.424] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[ 17.424] (II) LoadModule: "glx"
[ 17.424] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[ 17.611] (II) Module glx: vendor="NVIDIA Corporation"
[ 17.611] compiled for 4.0.2, module version = 1.0.0
[ 17.611] Module class: X.Org Server Extension
[ 17.611] (II) NVIDIA GLX Module 343.22 Thu Sep 11 15:55:13 PDT 2014
[ 17.612] Loading extension GLX
[ 17.612] (II) LoadModule: "nvidia"
[ 17.612] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[ 17.619] (II) Module nvidia: vendor="NVIDIA Corporation"
[ 17.619] compiled for 4.0.2, module version = 1.0.0
[ 17.619] Module class: X.Org Video Driver
[ 17.620] (II) NVIDIA dlloader X Driver 343.22 Thu Sep 11 15:34:47 PDT 2014
[ 17.620] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 17.620] (++) using VT number 7

[ 17.626] (II) Loading sub module "fb"
[ 17.626] (II) LoadModule: "fb"
[ 17.626] (II) Loading /usr/lib64/xorg/modules/libfb.so
[ 17.627] (II) Module fb: vendor="X.Org Foundation"
[ 17.627] compiled for 1.14.5, module version = 1.0.0
[ 17.627] ABI class: X.Org ANSI C Emulation, version 0.4
[ 17.627] (II) Loading sub module "wfb"
[ 17.627] (II) LoadModule: "wfb"
[ 17.627] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[ 17.628] (II) Module wfb: vendor="X.Org Foundation"
[ 17.628] compiled for 1.14.5, module version = 1.0.0
[ 17.628] ABI class: X.Org ANSI C Emulation, version 0.4
[ 17.628] (II) Loading sub module "ramdac"
[ 17.628] (II) LoadModule: "ramdac"
[ 17.628] (II) Module "ramdac" already built-in
[ 17.630] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[ 17.630] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[ 17.630] (==) NVIDIA(0): RGB weight 888
[ 17.630] (==) NVIDIA(0): Default visual is TrueColor
[ 17.630] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[ 17.631] (**) NVIDIA(0): Enabling 2D acceleration
[ 18.187] (II) NVIDIA(0): Display (Samsung SyncMaster (DFP-4)) does not support NVIDIA
[ 18.187] (II) NVIDIA(0): 3D Vision stereo.
[ 18.262] (II) NVIDIA(0): NVIDIA GPU GeForce GTX 970 (GM204-A) at PCI:3:0:0 (GPU-0)
[ 18.262] (--) NVIDIA(0): Memory: 4194304 kBytes
[ 18.262] (--) NVIDIA(0): VideoBIOS: 84.04.1f.00.70
[ 18.262] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[ 18.271] (--) NVIDIA(0): Valid display device(s) on GeForce GTX 970 at PCI:3:0:0
[ 18.271] (--) NVIDIA(0): CRT-0
[ 18.271] (--) NVIDIA(0): DFP-0
[ 18.271] (--) NVIDIA(0): DFP-1
[ 18.271] (--) NVIDIA(0): DFP-2
[ 18.271] (--) NVIDIA(0): DFP-3
[ 18.271] (--) NVIDIA(0): Samsung SyncMaster (DFP-4) (boot, connected)
[ 18.271] (--) NVIDIA(0): DFP-5
[ 18.271] (--) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
[ 18.271] (--) NVIDIA(0): DFP-0: Internal TMDS
[ 18.271] (--) NVIDIA(GPU-0): DFP-0: 330.0 MHz maximum pixel clock
[ 18.271] (--) NVIDIA(0): DFP-1: Internal TMDS
[ 18.271] (--) NVIDIA(GPU-0): DFP-1: 330.0 MHz maximum pixel clock
[ 18.271] (--) NVIDIA(0): DFP-2: Internal DisplayPort
[ 18.271] (--) NVIDIA(GPU-0): DFP-2: 960.0 MHz maximum pixel clock
[ 18.271] (--) NVIDIA(0): DFP-3: Internal TMDS
[ 18.271] (--) NVIDIA(GPU-0): DFP-3: 330.0 MHz maximum pixel clock
[ 18.271] (--) NVIDIA(0): Samsung SyncMaster (DFP-4): Internal TMDS
[ 18.271] (--) NVIDIA(GPU-0): Samsung SyncMaster (DFP-4): 330.0 MHz maximum pixel clock
[ 18.271] (--) NVIDIA(0): DFP-5: External LVDS
[ 18.271] (--) NVIDIA(GPU-0): DFP-5: 165.0 MHz maximum pixel clock
[ 18.271] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[ 18.271] (**) NVIDIA(0): device Samsung SyncMaster (DFP-4) (Using EDID frequencies
[ 18.271] (**) NVIDIA(0): has been enabled on all display devices.)
[ 18.272] (==) NVIDIA(0):
[ 18.272] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[ 18.272] (==) NVIDIA(0): will be used as the requested mode.
[ 18.272] (==) NVIDIA(0):
[ 18.273] (II) NVIDIA(0): Validated MetaModes:
[ 18.273] (II) NVIDIA(0): "DFP-4:nvidia-auto-select"
[ 18.273] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1200
[ 18.297] (--) NVIDIA(0): DPI set to (93, 95); computed from "UseEdidDpi" X config
[ 18.297] (--) NVIDIA(0): option
[ 18.297] (--) Depth 24 pixmap format is 32 bpp
[ 18.297] (II) NVIDIA: Using 3072.00 MB of virtual memory for indirect memory
[ 18.297] (II) NVIDIA: access.
[ 18.309] (II) NVIDIA(0): Setting mode "DFP-4:nvidia-auto-select"
[ 18.356] Loading extension NV-GLX
[ 18.372] (==) NVIDIA(0): Disabling shared memory pixmaps
[ 18.372] (==) NVIDIA(0): Backing store disabled
[ 18.372] (==) NVIDIA(0): Silken mouse enabled
[ 18.372] (==) NVIDIA(0): DPMS enabled
[ 18.372] Loading extension NV-CONTROL
[ 18.372] Loading extension XINERAMA
[ 18.372] (II) Loading sub module "dri2"
[ 18.372] (II) LoadModule: "dri2"
[ 18.372] (II) Module "dri2" already built-in
[ 18.372] (II) NVIDIA(0): [DRI2] Setup complete
[ 18.372] (II) NVIDIA(0): [DRI2] VDPAU driver: nvidia
[ 18.372] (--) RandR disabled
[ 18.376] (II) Initializing extension GLX
[ 18.454] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[ 18.454] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[ 18.454] (II) LoadModule: "evdev"
[ 18.454] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[ 18.455] (II) Module evdev: vendor="X.Org Foundation"
[ 18.455] compiled for 1.14.5, module version = 2.8.2
[ 18.455] Module class: X.Org XInput Driver
[ 18.455] ABI class: X.Org XInput driver, version 19.1
[ 18.455] (II) Using input driver 'evdev' for 'Power Button'
[ 18.455] (**) Power Button: always reports core events
[ 18.455] (**) evdev: Power Button: Device: "/dev/input/event1"
[ 18.455] (--) evdev: Power Button: Vendor 0 Product 0x1
[ 18.455] (--) evdev: Power Button: Found keys
[ 18.455] (II) evdev: Power Button: Configuring as keyboard
[ 18.455] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input1/event1"
[ 18.455] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[ 18.455] (**) Option "xkb_rules" "evdev"
[ 18.455] (**) Option "xkb_model" "pc104"
[ 18.455] (**) Option "xkb_layout" "us"
[ 18.471] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[ 18.471] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[ 18.471] (II) Using input driver 'evdev' for 'Power Button'
[ 18.471] (**) Power Button: always reports core events
[ 18.471] (**) evdev: Power Button: Device: "/dev/input/event0"
[ 18.471] (--) evdev: Power Button: Vendor 0 Product 0x1
[ 18.471] (--) evdev: Power Button: Found keys
[ 18.471] (II) evdev: Power Button: Configuring as keyboard
[ 18.471] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input0/event0"
[ 18.471] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 7)
[ 18.471] (**) Option "xkb_rules" "evdev"
[ 18.471] (**) Option "xkb_model" "pc104"
[ 18.471] (**) Option "xkb_layout" "us"
[ 18.471] (II) config/udev: Adding input device daskeyboard (/dev/input/event5)
[ 18.471] (**) daskeyboard: Applying InputClass "evdev keyboard catchall"
[ 18.471] (II) Using input driver 'evdev' for 'daskeyboard'
[ 18.471] (**) daskeyboard: always reports core events
[ 18.471] (**) evdev: daskeyboard: Device: "/dev/input/event5"
[ 18.471] (--) evdev: daskeyboard: Vendor 0x4d9 Product 0x2013
[ 18.471] (--) evdev: daskeyboard: Found keys
[ 18.471] (II) evdev: daskeyboard: Configuring as keyboard
[ 18.471] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.1/usb7/7-2/7-2:1.0/0003:04D9:2013.0005/input/input8/event5"
[ 18.471] (II) XINPUT: Adding extended input device "daskeyboard" (type: KEYBOARD, id 8)
[ 18.471] (**) Option "xkb_rules" "evdev"
[ 18.471] (**) Option "xkb_model" "pc104"
[ 18.471] (**) Option "xkb_layout" "us"
[ 18.472] (II) config/udev: Adding input device daskeyboard (/dev/input/event6)
[ 18.472] (**) daskeyboard: Applying InputClass "evdev keyboard catchall"
[ 18.472] (II) Using input driver 'evdev' for 'daskeyboard'
[ 18.472] (**) daskeyboard: always reports core events
[ 18.472] (**) evdev: daskeyboard: Device: "/dev/input/event6"
[ 18.472] (--) evdev: daskeyboard: Vendor 0x4d9 Product 0x2013
[ 18.472] (--) evdev: daskeyboard: Found keys
[ 18.472] (II) evdev: daskeyboard: Configuring as keyboard
[ 18.472] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.1/usb7/7-2/7-2:1.1/0003:04D9:2013.0006/input/input9/event6"
[ 18.472] (II) XINPUT: Adding extended input device "daskeyboard" (type: KEYBOARD, id 9)
[ 18.472] (**) Option "xkb_rules" "evdev"
[ 18.472] (**) Option "xkb_model" "pc104"
[ 18.472] (**) Option "xkb_layout" "us"
[ 18.472] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event2)
[ 18.472] (**) Logitech USB Receiver: Applying InputClass "evdev pointer catchall"
[ 18.472] (II) Using input driver 'evdev' for 'Logitech USB Receiver'
[ 18.472] (**) Logitech USB Receiver: always reports core events
[ 18.472] (**) evdev: Logitech USB Receiver: Device: "/dev/input/event2"
[ 18.472] (--) evdev: Logitech USB Receiver: Vendor 0x46d Product 0xc526
[ 18.472] (--) evdev: Logitech USB Receiver: Found 20 mouse buttons
[ 18.472] (--) evdev: Logitech USB Receiver: Found scroll wheel(s)
[ 18.472] (--) evdev: Logitech USB Receiver: Found relative axes
[ 18.472] (--) evdev: Logitech USB Receiver: Found x and y relative axes
[ 18.472] (II) evdev: Logitech USB Receiver: Configuring as mouse
[ 18.472] (II) evdev: Logitech USB Receiver: Adding scrollwheel support
[ 18.472] (**) evdev: Logitech USB Receiver: YAxisMapping: buttons 4 and 5
[ 18.472] (**) evdev: Logitech USB Receiver: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[ 18.472] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.7/usb2/2-1/2-1.1/2-1.1:1.0/0003:046D:C526.0002/input/input5/event2"
[ 18.472] (II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: MOUSE, id 10)
[ 18.472] (II) evdev: Logitech USB Receiver: initialized for relative axes.
[ 18.472] (**) Logitech USB Receiver: (accel) keeping acceleration scheme 1
[ 18.472] (**) Logitech USB Receiver: (accel) acceleration profile 0
[ 18.472] (**) Logitech USB Receiver: (accel) acceleration factor: 2.000
[ 18.472] (**) Logitech USB Receiver: (accel) acceleration threshold: 4
[ 18.473] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/mouse0)
[ 18.473] (II) No input driver specified, ignoring this device.
[ 18.473] (II) This device may have been added with another device file.
[ 18.473] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event3)
[ 18.473] (**) Logitech USB Receiver: Applying InputClass "evdev keyboard catchall"
[ 18.473] (II) Using input driver 'evdev' for 'Logitech USB Receiver'
[ 18.473] (**) Logitech USB Receiver: always reports core events
[ 18.473] (**) evdev: Logitech USB Receiver: Device: "/dev/input/event3"
[ 18.473] (--) evdev: Logitech USB Receiver: Vendor 0x46d Product 0xc526
[ 18.473] (--) evdev: Logitech USB Receiver: Found 1 mouse buttons
[ 18.473] (--) evdev: Logitech USB Receiver: Found scroll wheel(s)
[ 18.473] (--) evdev: Logitech USB Receiver: Found relative axes
[ 18.473] (II) evdev: Logitech USB Receiver: Forcing relative x/y axes to exist.
[ 18.473] (--) evdev: Logitech USB Receiver: Found absolute axes
[ 18.473] (II) evdev: Logitech USB Receiver: Forcing absolute x/y axes to exist.
[ 18.473] (--) evdev: Logitech USB Receiver: Found keys
[ 18.473] (II) evdev: Logitech USB Receiver: Configuring as mouse
[ 18.473] (II) evdev: Logitech USB Receiver: Configuring as keyboard
[ 18.473] (II) evdev: Logitech USB Receiver: Adding scrollwheel support
[ 18.473] (**) evdev: Logitech USB Receiver: YAxisMapping: buttons 4 and 5
[ 18.473] (**) evdev: Logitech USB Receiver: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[ 18.473] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.7/usb2/2-1/2-1.1/2-1.1:1.1/0003:046D:C526.0003/input/input6/event3"
[ 18.473] (II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: KEYBOARD, id 11)
[ 18.473] (**) Option "xkb_rules" "evdev"
[ 18.473] (**) Option "xkb_model" "pc104"
[ 18.473] (**) Option "xkb_layout" "us"
[ 18.473] (II) evdev: Logitech USB Receiver: initialized for relative axes.
[ 18.473] (WW) evdev: Logitech USB Receiver: ignoring absolute axes.
[ 18.473] (**) Logitech USB Receiver: (accel) keeping acceleration scheme 1
[ 18.473] (**) Logitech USB Receiver: (accel) acceleration profile 0
[ 18.473] (**) Logitech USB Receiver: (accel) acceleration factor: 2.000
[ 18.473] (**) Logitech USB Receiver: (accel) acceleration threshold: 4
[ 18.473] (II) config/udev: Adding input device GreenAsia Inc. USB Joystick (/dev/input/event4)
[ 18.473] (II) No input driver specified, ignoring this device.
[ 18.473] (II) This device may have been added with another device file.
[ 18.473] (II) config/udev: Adding input device GreenAsia Inc. USB Joystick (/dev/input/js0)
[ 18.473] (II) No input driver specified, ignoring this device.
[ 18.473] (II) This device may have been added with another device file.
[ 27.925] (II) NVIDIA(GPU-0): Display (Samsung SyncMaster (DFP-4)) does not support NVIDIA
[ 27.925] (II) NVIDIA(GPU-0): 3D Vision stereo.
[ 38.276] (II) NVIDIA(GPU-0): Display (Samsung SyncMaster (DFP-4)) does not support NVIDIA
[ 38.276] (II) NVIDIA(GPU-0): 3D Vision stereo.
[ 114.049] (II) NVIDIA(GPU-0): Display (Samsung SyncMaster (DFP-4)) does not support NVIDIA
[ 114.049] (II) NVIDIA(GPU-0): 3D Vision stereo.
[ 134.905] (II) NVIDIA(GPU-0): Display (Samsung SyncMaster (DFP-4)) does not support NVIDIA
[ 134.905] (II) NVIDIA(GPU-0): 3D Vision stereo.


Last edited by PhoenixKnight on Fri Sep 26, 2014 3:03 pm; edited 1 time in total
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Fri Sep 26, 2014 7:30 am    Post subject: Reply with quote

A starting point is to check nviida homepage => section gpu drivers => section which gnu linux 32 or 64 bit => which card => which driver is recommended.

than check google for your card and if it has issues.

than try different kernels with different gpu drivers (but mainly that driver nvidia homepage suggests)

update your bios maybe?

there is also a nivida-driver howto on the gentoo-wiki. please compare your kernel settings and other settings there with your setup and than report back what you did so far. thank you

Quote:
[ 17.626] (II) Loading sub module "fb"


do you use framebuffer? i am not sure if that is a good idea, i may be wrong.

ouput of
Code:
localhost roman # eselect opengl show

Code:
localhost roman # eselect opengl list

please
Back to top
View user's profile Send private message
PhoenixKnight
n00b
n00b


Joined: 09 Sep 2008
Posts: 18
Location: Chicago

PostPosted: Fri Sep 26, 2014 7:43 am    Post subject: Reply with quote

I'm using the exact drivers that are recommended on nvidia's homepage.

A Google search doesn't reveal any Linux issues that I can see.

The open source drivers available in the kernel do not yet support the GTX 970 or GTX 980 cards. According to Nvidia's website, the proprietary drivers that I have installed do support it.

My motherboard's BIOS is completely up-to-date.

My kernel settings properly match what is shown in the nvidia-driver howto on gentoo wiki. All other settings match what is shown on the wiki.
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Fri Sep 26, 2014 8:04 am    Post subject: Reply with quote

PhoenixKnight wrote:


The open source drivers available in the kernel do not yet support the GTX 970 or GTX 980 cards. According to Nvidia's website, the proprietary drivers that I have installed do support it.



well even my 9800m gts is not well supported by the open source drviers. so your card won*t be, nothing surprising.

have you checked the eselect command i proved earlier?

have you checked your make.conf to add the video section about nvidia?

output of ... please
Code:
localhost roman # grep nvidia /etc/make.conf
     ntfsdecrypt ntfsprogs nut nuv nvcontrol nvidia odk openal opencl
VIDEO_CARDS="nvidia"
localhost roman #


did you make a clean kernel / fresh kernel. => new name => build => boot => build nvidia drivers => eselect nvidia drivers => xorg-server newest => ... most of the issues i have read about nvidia is caused by that. Regarding that your card is quite fresh it could be something else though... => changing the kernel / xorg-server does also sometimes help
Back to top
View user's profile Send private message
PhoenixKnight
n00b
n00b


Joined: 09 Sep 2008
Posts: 18
Location: Chicago

PostPosted: Fri Sep 26, 2014 2:19 pm    Post subject: Reply with quote

I already have opengl and opencl set to use nvidia.

[code]adam@gentoobox ~ $ eselect opengl list
Available OpenGL implementations:
[1] nvidia *
[2] xorg-x11
adam@gentoobox ~ $ eselect opencl list
Available OpenCL implementations:
[1] nvidia *
adam@gentoobox ~ $ /code]

And I added nvidia to /etc/portage/make.conf

[code]adam@gentoobox ~ $ grep nvidia /etc/portage/make.conf
VIDEO_CARDS="nvidia"
adam@gentoobox ~ $[/code]

I reinstalled xorg-server, xorg-drivers, opengl, and mesa after changing /etc/portage/make.conf.
Back to top
View user's profile Send private message
PhoenixKnight
n00b
n00b


Joined: 09 Sep 2008
Posts: 18
Location: Chicago

PostPosted: Fri Sep 26, 2014 3:03 pm    Post subject: Reply with quote

I was able to solve the problem by completely removing the nvidia drivers and reinstalling them.

Code:
adam@gentoobox ~ $sudo /etc/init.d/xdm stop
adam@gentoobox ~ $sudo emerge --unmerge nvidia-drivers
adam@gentoobox ~ $sudo modprobe -r nvidia
adam@gentoobox ~ $sudo emerge nvidia-drivers
adam@gentoobox ~ $sudo reboot
Back to top
View user's profile Send private message
solarseed
n00b
n00b


Joined: 24 Jan 2015
Posts: 1

PostPosted: Sat Jan 24, 2015 5:22 pm    Post subject: Reemerging the nvidia-drivers does not work for me. Reply with quote

Reemerging the Driver, sadly did not work for me.

What is the Hardware Vendor of your Graphicscard?

I use [b]Zotac[/b] NVidia Geforce GTX 970 4G OC GPU...

I did not have had any Problems getting X and kdm to work with my former [b]MSI[/b] ATI R9 270X 4G OC.

In both Cases I did try to pull the Gentoo Wiki to Help for Information and setting up X ... but with the Nvidia GTX 970 I failed.

A Reply to this [Solved] Topic would be appreciated.

Regards

Philip aka solarseed

P.S.: I do know, that Nvidia and FGLRX can not even be compared. Just wrote it down, so you can see, that I am not completely lost with Gentoo LINUX.

P.P.S.: I am sorry that I can not provide further Information on the System. It's because I am on a different Machine right now. Further Information might follow in P.P.P.S. !

(And i did not try #nvidia layman Overlay. Because you seem to have been using the Standard Gentoo-Sources Drivers...)

EDIT:

P.P.P.S.: New Status: [Unsolved] ... Because I just noticed, that NVidia proprietary Drivers can not even be built when nvidiafb is compiled into the Kernel.

Will provide further Information, as soon as wgetpaste ist emerged!!
_________________
The "G" in Gentoo stands for: Good Choice, The "E" stands for: Enormously Powerfull, The "N" stands for: Nothing Else, The "T" stands for: TTY, Both "O's" stand for: Overwhelming Overlord!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum